Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: GLX en ET  (gelezen 2290 keer)

Offline Ivan1986

  • Lid
  • Steunpunt: Nee
GLX en ET
« Gepost op: 2007/02/08, 10:22:57 »
hey weer eens,

ik heb aajn probleem... ik heb et (spel) ge├»nstaleerd en als ik opstart geeft hij een foutmelding.... de eerste keer was er iets met  een fout genaamd 11 ofzo... maar dat zou komen door men grafishe kaart die ik nog nie had ge├»nstaleerd ....dat heb ik dan gedaan.... en kwam dan deze fout tegen:
(men scherm versprong ook naar 640*400 en ik moest dus met de muis bewegen en zag maar ene stukje van het scherm)

----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 800x600
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Couldn't get a visual
...WARNING: could not set the given mode (4)
Initializing OpenGL display
...setting mode 3: 640 480
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 640x480
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Couldn't get a visual
...WARNING: could not set the given mode (3)
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Sys_Error: GLimp_Init() - could not load OpenGL subsystem

ivan@IvanPC:~$





kan er iemand me helpen?
dat er iets mis is met glx zie ik ook maar hoe los ik het op...
alvast bedankt...
Ivan

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
GLX en ET
« Reactie #1 Gepost op: 2007/02/08, 10:29:20 »
wat doet glxgears in de terminal?
of: glxgears -printfps?

heb je direct rendering? glxinfo|grep direct  in de terminal

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
GLX en ET
« Reactie #2 Gepost op: 2007/02/08, 10:32:13 »
en wat is je graf. kaart:
lspci|grep VGA  in de terminal.

Offline Ivan1986

  • Lid
  • Steunpunt: Nee
GLX en ET
« Reactie #3 Gepost op: 2007/02/08, 10:43:12 »
glxgears:

Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual

glxgears-printfps:

bash: glxgears-printfps: command not found

Grafische kaart

04:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600 GT] (rev a2)

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
GLX en ET
« Reactie #4 Gepost op: 2007/02/08, 10:50:12 »
Citaat van: Ivan1986
glxgears:

Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual

glxgears-printfps:

bash: glxgears-printfps: command not found

Grafische kaart

04:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600 GT] (rev a2)
ok: heb je direct rendering? glxinfo|grep direct  in de terminal

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
GLX en ET
« Reactie #5 Gepost op: 2007/02/08, 10:52:31 »
ik denk dat je de juiste drivers moet installen:

sudo apt-get install nvidia-glx
daarna:
sudo nvidia-xconfig
en herstarten./rebooten!

restricted modules: sudo apt-get install linux-restricted-modules-`uname -r`
( uname-r in de terminal geeft je kernel aan)

wanneer X niet meer opstart:Herstel dan X met
sudo dpkg-reconfigure xserver-xorg  en kies bij alles default ,behalve bij de graf.drivers, kies dan nvidia.

Offline Ivan1986

  • Lid
  • Steunpunt: Nee
GLX en ET
« Reactie #6 Gepost op: 2007/02/08, 10:57:20 »
ivan@IvanPC:~$ glxinfo|grep direct
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".

da is al da en dan ga ik nu nog is proberen de nvidia driver te instaleren (ik dacht dat die er op stond ma ik zal nog wel eens doen voor de zekerheid

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
GLX en ET
« Reactie #7 Gepost op: 2007/02/08, 10:59:15 »
Prima instructie van Leon!
Mocht je je meer thuis voelen in de grafische installatiemethode, installeer dan nvidia-glx in Systeem - Beheer - Synaptic pakketbeheer. Zoekterm: nvidia-glx  Aanvinken en druk op knop toepassen. Daarna in terminal: sudo gedit /etc/X11/xorg.conf   en vervang in de section Device, de vermelding "nv" door "nvidia". Daarna herstarten.

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
GLX en ET
« Reactie #8 Gepost op: 2007/02/08, 10:59:19 »
Citaat van: Ivan1986
ivan@IvanPC:~$ glxinfo|grep direct
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".

da is al da en dan ga ik nu nog is proberen de nvidia driver te instaleren (ik dacht dat die er op stond ma ik zal nog wel eens doen voor de zekerheid
idd zie boven! :) item#6 en#8

Offline Ivan1986

  • Lid
  • Steunpunt: Nee
GLX en ET
« Reactie #9 Gepost op: 2007/02/08, 11:14:06 »
euh der is toch iets vreemds hoor.....
ik heb dus niet via de terminal gedaan...
Nvidia glx staat al op men pc maar als ik de file open doe is die leeg zeer vreemd eigenlijk....  :s

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
GLX en ET
« Reactie #10 Gepost op: 2007/02/08, 11:20:56 »
Citaat van: Ivan1986
euh der is toch iets vreemds hoor.....
ik heb dus niet via de terminal gedaan...
Nvidia glx staat al op men pc maar als ik de file open doe is die leeg zeer vreemd eigenlijk....  :s
bedoel je: /etc/X11/xorg.conf ? is die leeg?

Offline Ivan1986

  • Lid
  • Steunpunt: Nee
GLX en ET
« Reactie #11 Gepost op: 2007/02/08, 11:24:05 »
ja die is leeg

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
GLX en ET
« Reactie #12 Gepost op: 2007/02/08, 11:27:23 »
heb je eerder bij het installeren automatix en/of easybuntu gebruikt om progs te installen?

Offline Ivan1986

  • Lid
  • Steunpunt: Nee
GLX en ET
« Reactie #13 Gepost op: 2007/02/08, 11:31:45 »
euh ja voor die grafische kaart de eerste keer te instaleren heb ik een engelstaligr tutorial gebruikt van ubunut zelf maar ik weet niet of alles juist was wat ik toen deed :s

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
GLX en ET
« Reactie #14 Gepost op: 2007/02/08, 11:38:24 »
Citaat van: Ivan1986
euh ja voor die grafische kaart de eerste keer te instaleren heb ik een engelstaligr tutorial gebruikt van ubunut zelf maar ik weet niet of alles juist was wat ik toen deed :s
dit is zooo jammer. het is zo simpel om het op de "ubuntu" manier te doen,
al die scripts gaan hun eigen gang! waar ze alles installeren blijft vaak volstrekt onduidelijk. een schoolvoorbeeld dit.
nu is alle logica zoek. ik zou je graag willen helpen. maar waar moet ik beginnen? iemand anders??

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
GLX en ET
« Reactie #15 Gepost op: 2007/02/08, 12:28:59 »
Weet je zeker dat je xorg.conf leeg is? (geen typefouten gemaakt?)
Als je dit kopieert en plakt in een terminal kan je de inhoud van het bestand controleren.
gedit /etc/X11/xorg.conf

Is die inderdaad leeg, dan kan je een nieuwe aan laten maken met het volgende commando:
sudo dpkg-reconfigure xserver-xorg

In de schermen die nu volgen moet je een aantal keuzes maken over je configuratie.
De standaard keuzes die al ingevuld zijn, zijn meestal prima.

Er is een grote kans dat je na het uitvoeren van dit commando een aantal dingen opnieuw in moet stellen, zoals de resolutie van je beeldscherm enz.

Als je verder nog vragen hebt, dan horen we dat graag :)

Offline Ivan1986

  • Lid
  • Steunpunt: Nee
GLX en ET
« Reactie #16 Gepost op: 2007/02/08, 12:52:16 »
dank danku danku danku   echt waar het werkt.... enkel nog zoeken wrm punkbuster niet wilt ge enabled worden en dan werkt hij wss beter dan onder Windows zaalig

ondertussen werkt het als ik het uitvoer als sudo ... maar dat kan niet de bedoeling zijn.... nu nog geluid ...ooit komt alles inorde :D

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
GLX en ET
« Reactie #17 Gepost op: 2007/02/08, 14:38:23 »
Geluid:
installeer eens alsamixergui
Gewoon, via Systeem - Beheer - Synaptic pakketbeheer
Zoekterm: alsamixergui
aanvinken en druk op knop Toepassen

na installatie: zet eens een paar schuifjes open (niet allemaal tegelijk, en geen enkele voor 100 %).

Groet, Pjotr.

Offline Ivan1986

  • Lid
  • Steunpunt: Nee
GLX en ET
« Reactie #18 Gepost op: 2007/02/09, 18:16:42 »
da heb ik dus ne keer gedaan he, maar het helpt ni
ik moet wel zeggen dat ik een speciale kaart heb met vele uitgangen ik ga seffes is kijken dat er tovallig geen driver voor bestaat....