Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Opgelost] NFS client mount traag bij opstarten Ubuntu 11.10; Bug ?  (gelezen 1249 keer)

Offline wowo

  • Lid
  • Steunpunt: Ja
Ik maak gebruik van een NAS-server.
Heb daarom op al mijn Ubuntu pc's veel netwerk shares naar deze server die ik altijd automatisch laat mounten in Ubuntu.

Het automatisch mounten bij opstarten is in Ubuntu 11.10 echter heel traag:
Pas na ongeveer 1 minuut verschijnen de netwerk shares in de persoonlijke map (Nautilus).

In vorige versies van Ubuntu waren de netwerk shares direct beschikbaar na opstarten.
In Ubuntu 11.10 moet ik nu altijd 1 minuut wachten voordat ik gebruik kan maken van al mijn zaken die op mijn NAS-server staan.

Weet iemand een oplossing hoe het mounten weer snel te krijgen ?
Het lijkt erop dat het mounten pas nu gaat starten nadat al het andere is opgestart.
Is deze bug bekend ?
« Laatst bewerkt op: 2011/11/23, 15:27:58 door wowo »
Desktop Ubuntu 14.04 LTS
Tablet Ubuntu Touch 15.04 (OTA-11); BQ Aquaris M10 FHD

Offline rja

  • Lid
  • Steunpunt: Nee
Re: NFS client mount traag bij opstarten Ubuntu 11.10; Bug ?
« Reactie #1 Gepost op: 2011/11/18, 13:51:46 »
Vaak heeft zo'n vertraging met DNS problemen te maken.

pingen naar die nas server gaat wel snel ?


Offline wowo

  • Lid
  • Steunpunt: Ja
Re: NFS client mount traag bij opstarten Ubuntu 11.10; Bug ?
« Reactie #2 Gepost op: 2011/11/18, 16:29:35 »
Vaak heeft zo'n vertraging met DNS problemen te maken.
pingen naar die nas server gaat wel snel ?

Pingen gaat snel (ongeveer 0,1 ms) zelfs voordat de netwerkverbindingen te voorschijn komen in nautilus.

Er is dus wel direct contact mogelijk met de NAS-server maar het mounten door fstab gebeurt nu pas na een bepaalde tijd ??

Nogmaals in oudere versies nooit problemen gehad.
Heb ook even getest hoe het gaat met het automatisch mounten van samba shares in Ubuntu 11.10, maar dat gaat gewoon wel snel.

Ik wil echter met nfs doorgaan.
Iemand nog idee├źn ? 
Desktop Ubuntu 14.04 LTS
Tablet Ubuntu Touch 15.04 (OTA-11); BQ Aquaris M10 FHD

Offline wowo

  • Lid
  • Steunpunt: Ja
Re: NFS client mount traag bij opstarten Ubuntu 11.10; Bug ?
« Reactie #3 Gepost op: 2011/11/23, 15:27:34 »
Ik heb een oplossing gevonden.
Voeg in fstab ook het volgende toe: nfsvers=3

Als voorbeeld:
192.168.1.130:/pictures /media/NAS-pictures nfs ro,hard,intr 0 0  Deze mount pas na ongeveer 1 minuut.

192.168.1.130:/pictures /media/NAS-pictures nfs ro,nfsvers=3,hard,intr 0 0 Deze mount direct  :D

Misschien dat het volgende een verklaring kan zijn  ??????:
Mijn NAS-server werkt met nfs3.
Ubuntu 11.10 probeert als default een mount in de nfs4 structuur te maken en pas na een aantal malen proberen (wat 1 ongeveer 1 minuut duurt) wordt een nfs3 verbinding gemaakt.
Desktop Ubuntu 14.04 LTS
Tablet Ubuntu Touch 15.04 (OTA-11); BQ Aquaris M10 FHD

Offline Sputnikc

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] NFS client mount traag bij opstarten Ubuntu 11.10; Bug ?
« Reactie #4 Gepost op: 2011/11/25, 19:16:36 »
Hi,
Ik heb me speciaal geregistreerd hier om je even te bedanken om deze info te posten.
'k had hetzelfde probleem na de upgrade en te weinig tijd om er wat naar te zoeken op de pc zelf. Even gegoogled en ik kwam op deze thread.

Werkt perfect hier ook, in combinatie met een wat oudere debian nfs-server (versie 3 ook )

Bij deze : bedankt om je eigen oplossing te delen.. :)