Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Updates!?  (gelezen 1534 keer)

Offline Nanostylez

  • Lid
  • Steunpunt: Nee
Updates!?
« Gepost op: 2011/11/17, 12:04:44 »
Ik wou vandaag mijn ubuntu laten zoeken naar updates. Hiervoor had ik al geupdates en werkte het prima. Nu krijg ik steeds de volgende error:

"Het methodestuurprogramma /usr/lib/apt/methods/htt kon niet gevonden worden.Het methodestuurprogramma /usr/lib/apt/methods/htt kon niet gevonden worden."

Hoe los ik dit op?

Offline AntonSteen

  • Lid
  • Steunpunt: Nee
Re: Updates!?
« Reactie #1 Gepost op: 2011/11/17, 12:16:59 »
Verplaatst op verzoek, excuses
« Laatst bewerkt op: 2011/11/17, 13:21:57 door AntonSteen »

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Re: Updates!?
« Reactie #2 Gepost op: 2011/11/17, 13:01:56 »
@AntonSteen: je kaapt Nanostylez' draadje, met een probleem dat vermoedelijk totaal anders is....

Begin eens een eigen draadje voor je probleem?  :)

Offline overdenkamp

  • Lid
  • Steunpunt: Nee
Re: Updates!?
« Reactie #3 Gepost op: 2011/11/17, 19:14:14 »
Klein vermoeden: Je hebt zelf softwarebronnen toegevoegd, en daar htt getyped in plaats van http. Heb je aparte softwarebronnen toegevoegd via Systeem > Beheer > Pakketbronnen of handmatig in /etc/sources.list?

Wat is de inhoud van je sources.list? Doe eens in een terminal:cat /etc/sources.listen plak de output hier tussen [ code ]-tags...

Offline Nardon

  • Lid
  • Steunpunt: Nee
Re: Updates!?
« Reactie #4 Gepost op: 2011/11/18, 08:29:38 »
Kleine maar vrij belangrijke correctie, de locatie van de sources.list is:
cat /etc/apt/sources.list

:P

Offline Nanostylez

  • Lid
  • Steunpunt: Nee
Re: Updates!?
« Reactie #5 Gepost op: 2011/11/18, 09:18:43 »
Klein vermoeden: Je hebt zelf softwarebronnen toegevoegd, en daar htt getyped in plaats van http. Heb je aparte softwarebronnen toegevoegd via Systeem > Beheer > Pakketbronnen of handmatig in /etc/sources.list?

Wat is de inhoud van je sources.list? Doe eens in een terminal:cat /etc/sources.listen plak de output hier tussen [ code ]-tags...

# deb cdrom:[Ubuntu 10.04.2 LTS _Lucid Lynx_ - Release i386 (20110211.1)]/ lucid main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://nl.archive.ubuntu.com/ubuntu/ lucid main restricted multiverse
deb-src http://nl.archive.ubuntu.com/ubuntu/ lucid main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://nl.archive.ubuntu.com/ubuntu/ lucid-updates main restricted multiverse
deb-src http://nl.archive.ubuntu.com/ubuntu/ lucid-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://nl.archive.ubuntu.com/ubuntu/ lucid universe
deb-src http://nl.archive.ubuntu.com/ubuntu/ lucid universe
deb http://nl.archive.ubuntu.com/ubuntu/ lucid-updates universe
deb-src http://nl.archive.ubuntu.com/ubuntu/ lucid-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://nl.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
# deb-src http://nl.archive.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu lucid partner
deb-src http://archive.canonical.com/ubuntu lucid partner

deb http://security.ubuntu.com/ubuntu lucid-security main restricted multiverse
deb-src http://security.ubuntu.com/ubuntu lucid-security main restricted
deb http://security.ubuntu.com/ubuntu lucid-security universe
deb-src http://security.ubuntu.com/ubuntu lucid-security universe
deb htt://archive.canonical.com/ lucid partner


Offline Progger

  • Lid
  • Steunpunt: Nee
Re: Updates!?
« Reactie #6 Gepost op: 2011/11/18, 09:53:30 »
Citaat
deb http://security.ubuntu.com/ubuntu lucid-security main restricted multiverse
deb-src http://security.ubuntu.com/ubuntu lucid-security main restricted
deb http://security.ubuntu.com/ubuntu lucid-security universe
deb-src http://security.ubuntu.com/ubuntu lucid-security universe
deb htt://archive.canonical.com/ lucid partner

Het klein vermoeden van overdenkamp klopt dus, de schuldige in dit geval is het vetgedrukte hierboven in je list. Even corrigeren en het zou opgelost moeten zijn.  ;)
Laptop MSI U123 (160 GB) 1 GB ramMint Cinnamon 18 LTS
Laptop Toshiba Tecra  (80GB) 2 GB ram Fedora 24
Dell Latitude D600 Pentium M 1400MHz 512MB ram
Bouwjaar 2003 met Debian 8 (Jessie)

Offline Nanostylez

  • Lid
  • Steunpunt: Nee
Re: Updates!?
« Reactie #7 Gepost op: 2011/11/18, 09:54:21 »
Ik ben nog nieuw met ubuntu, hoe moet dit precies? :$

Offline Progger

  • Lid
  • Steunpunt: Nee
Re: Updates!?
« Reactie #8 Gepost op: 2011/11/18, 09:58:57 »
Open een terminal en typ:

sudo gedit /etc/apt/sources.list

Druk op Enter,
Geef je wachtwoord

Het bestandje wordt nu geopend in gedit mét rootrechten, nu kan je die bewuste regel aanpassen, het bestandje opslaan, en dat is alles.  :D
Laptop MSI U123 (160 GB) 1 GB ramMint Cinnamon 18 LTS
Laptop Toshiba Tecra  (80GB) 2 GB ram Fedora 24
Dell Latitude D600 Pentium M 1400MHz 512MB ram
Bouwjaar 2003 met Debian 8 (Jessie)

Offline Nanostylez

  • Lid
  • Steunpunt: Nee
Re: Updates!?
« Reactie #9 Gepost op: 2011/11/18, 10:15:10 »
Ik krijg nu dit:

W: GPG error: http://ppa.launchpad.net lucid Release: De volgende ondertekeningen konden niet geverifieerd worden omdat de publieke sleutel niet beschikbaar is: NO_PUBKEY B725097B3ACC3965
Ik heb dit geprobeerd:

gpg --keyserver pgpkeys.mit.edu --recv-key  B725097B3ACC3965  
gpg -a --export B725097B3ACC3965 | sudo apt-key add -

Maar dan krijg ik dit:

gpg --keyserver pgpkeys-mit.edu --recv-key B725097B3ACC3965
gpg: requesting key 3ACC3965 from hkp server pgpkeys-mit.edu
gpgkeys: HTTP fetch error 6: Couldn't resolve host 'pgpkeys-mit.edu'
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0


« Laatst bewerkt op: 2011/11/18, 10:43:44 door Nanostylez »

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Re: Updates!?
« Reactie #10 Gepost op: 2011/11/18, 10:44:15 »
Heb je een PPA geactiveerd?

Enfin, ruim de boel eens netjes op, en zorg aldus voor een schone bronnenlijst (uiteraard, in jouw geval, alleen de instructies voor 10.04 toepassen en niet voor 11.10):
http://sites.google.com/site/computertip/bronnen

Pats, boem, klaar.  :)

Offline overdenkamp

  • Lid
  • Steunpunt: Nee
Re: Updates!?
« Reactie #11 Gepost op: 2011/11/18, 16:33:54 »
Als je een PPA wil toevoegen kun je dat beter grafisch doen: http://www.omgubuntu.co.uk/how-to-add-a-ppa-to-software-sources-in-ubuntu/

Verwijder wel eerst je oude ppa zonder sleutel, dit zou een bestandje in de map /etc/apt/sources.list.d moeten zijn. Omdat je hier ook administratorrechten voor nodig hebt kun je eerst even een bestandsbeheerder openen met gksudo nautilus in de terminal.