Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Atheros wlan op Asus Z83T  (gelezen 1070 keer)

rinuxl

  • Gast
Atheros wlan op Asus Z83T
« Gepost op: 2007/02/07, 22:04:44 »
Ik heb een nieuwe laptop gekocht, maar die moet natuurlijk onder Linux draaien en niet onder windows. Nu zit er een atheros wlan in. Omdat madwifi standaard in Ubuntu zit, had ik gedacht, dat hij dit zo wel zou herkennen. Dus niet. lspci geeft het volgende:
01:00.0 Ethernet controller: Atheros Communications, Inc. Unknown device 001c (rev 01)
inderdaad, bij iwconfig vind ik dus niets terug:
lo        no wireless extensions.

eth0      no wireless extensions.

sit0      no wireless extensions.

De Z83T schijnt een uitgeklede versie te zijn van de A7T.
Iemand een idee, hoe ik dit aan kan pakken?

getyours-it

  • Gast
Atheros wlan op Asus Z83T
« Reactie #1 Gepost op: 2007/02/09, 22:44:14 »
Het lijkt er op dat het bij linux de omgekeerde wereld is eerst kijken of je hardware ondersteund wordt dan pas aanschaffen.

Maar dat maakt het wel leuker dan windows waar ik overigens ook weinig slechts op aan te merken heb

Offline ubuntu_demon

  • Lid
    • http://twitter.com/thuphaer
  • Steunpunt: Nee
Atheros wlan op Asus Z83T
« Reactie #2 Gepost op: 2007/02/22, 12:49:41 »
Ik denk dat je als eerste even je router het beste even op onbeveiligd kunt instellen. Dat is het makkelijkste om werkend te krijgen. Dan kun je als het eenmaal werkt de beveiliging gaan instellen.

Installeer eerst de restricted modules. Kijk even wat voor kernel je draait :
$uname -r

Als dit eindigt op 386 :
$sudo aptitude install linux-686

Als dit eindigt op 686 :
$sudo aptitude install linux-386

Als dit eindigt op generic :
$sudo aptitude install linux-generic

Daarna even een reboot.

Je kunt nu proberen te spelen met system->administration->networking

Maar het zou kunnen dat je eerst de goede module moet modproben (en als je de goede hebt gevonden kun je hem later in je /etc/modules zetten).

Om een lijstje modules te krijgen die je kunt inladen kun je hier kijken :
$ locate madwifi | grep ko

Ik vermoed dat je sowieso de module ath_pci nodig hebt. (als dit niet werkt kun je er wat meer proberen of wat googlen)

$ sudo modprobe ath_pci
$ sudo modprobe wlan_scan_sta
$ sudo depmod
$ sudo /etc/init.d/networking restart

als dat geen error geeft zou je een nieuwe wireless device moeten zien in :
$ iwconfig

Nu hoef je hem alleen nog maar in je /etc/network/interfaces te zetten met de hand of met de gui (system->administration->networking).

Met de hand werkt het zo :

$ gksudo gedit /etc/network/interfaces

Als ath0 je interface is moet je dit toevoegen :

auto ath0
iface ath0 inet dhcp
En dan (als hij ath0 heet) :
$sudo ifup ath0

Als je nou na een tijdje klooien je onbeveiligde verbinding helemaal niet aan de praat krijgt kun je proberen de nieuwste madwifi drivers te gebruiken. Dit is wat ingewikkelder.

Info over dit laatste :
https://help.ubuntu.com/community/WifiDocs/Driver/Madwifi
http://madwifi.org/wiki/UserDocs/Distro/Ubuntu

succes!

PS :
als je wilt scannen op accesspoints met je favo tool of met iwlist ath0 scan dan heb je waarschijnlijk een van de modules nodig met het woord "scan" erin. En dat is waarschijnlijk wlan_scan_sta


En niet vergeten om alle gevonden modules (waarschijnlijk ath_pci en wlan_scan_sta) aan het einde van je /etc/modules te zetten (in deze volgorde) :
$gksudo gedit /etc/modules
ath_pci
wlan_scan_sta
PS2 :
als je dapper gebruikt dan kun je kiezen tussen : ath_pci of (new_ath_pci en new_wlan_scan_sta). Dapper heeft dus geen wlan_scan_sta. De new is een nieuwere driver zoals de naam al zegt.