Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] acpi=off voor installatie en opstarten.  (gelezen 9068 keer)

Offline Jeffcoboy

  • Lid
  • Steunpunt: Nee
[OPGELOST] acpi=off voor installatie en opstarten.
« Gepost op: 2011/11/11, 11:35:55 »
Hallo.

Ik heb alweer een vraagje dat ik graag zou opgelost zien.
Ik heb hier nog een best oude pc waar Linux Mint 11 echt onwaarschijnlijk stabiel en snel op draait.
Nu bij de komst van Ubuntu 11.10 was ik erg nieuwsgierig en ik had even geprobeerd. Nu bij het installeren gaat het al mis.
Als ik bij het bootmenu voor Ubuntu installeren kies, dan krijg ik vanalles te zien van kernel panic enzo. Nu kreeg ik hier de tip dat ik acpi=off moest gebruiken. OK dat werkte perfect, ik kon installeren, en helaas moest ik bij het opstarten ook acpi=off gebruiken. Is er hier ergens een oplossing voor, want ik vind het best irritant dat mijn pc dan niet vanzelf afsluit, dus ik moet steeds bij het afsluiten nog op de knop duwen.

Ik heb dit bij Xubuntu 11.10 en Lubuntu 11.10.
Nu bij de nieuwe Mint 12 die ik zo graag zou gebruiken, komt dat probleem ook voor.
Kortom, alles wat op de nieuwe kernel draait, werkt niet optimaal.


Is hier een oplossing voor, of kan ik een goedwerkend ubuntu/mint systeem op de nieuwe kernel vergeten.

Alvast bedankt!
« Laatst bewerkt op: 2012/04/30, 12:00:14 door Jeffcoboy »
Een trotse linux-beginner!

Offline VuurVosje

  • Lid
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #1 Gepost op: 2011/11/11, 13:51:00 »
Bij mij werkt acpi_osi=linux

Zie Common kernel options:
https://help.ubuntu.com/community/BootOptions#Common_Kernel_Options

VV
« Laatst bewerkt op: 2011/11/11, 13:52:55 door VuurVosje »

Offline donpedroII

  • Lid
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #2 Gepost op: 2011/11/11, 14:23:42 »
Hierbij moet je de het Defaultfile, wat grub gebruikt tijdens de update-grub, aanpassen.

Kijk eens hier voor meer info
https://help.ubuntu.com/community/Grub2#Configuring_GRUB_2  (/etc/default/grub file)

De regel wat je dan moet aanpassen is deze: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noacpi"
De noacpi moet je toevoegen.
Hierna doe je in de Terminal sudo update-grubzodat grub deze default kan wegschrijven in het grub.cfg file.
« Laatst bewerkt op: 2011/11/11, 14:29:36 door donpedroII »

Offline Jeffcoboy

  • Lid
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #3 Gepost op: 2011/11/11, 14:38:51 »
donpedroII hoe ik grub moet aanpassen kan ik ook wel. Mijn vraag was of ik het kon oplossen zonder die parameter te gebruiken

VuurVosje kan jij je pc dan automatisch afsluiten als je die parameter gebruikt? Ik ga dat straks eens proberen. Goede link trouwens...
Een trotse linux-beginner!

Offline Jeffcoboy

  • Lid
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #4 Gepost op: 2011/11/11, 17:37:27 »
Helaas, die parameter werkt niet, en de parameters van acpi in de link van jou werken ook niet. Enkel acpi=off wil werken.

Spijtig.. Als iemand nog iets weet...
Een trotse linux-beginner!

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #5 Gepost op: 2011/11/11, 17:43:54 »
ACPI is de standaard die o.a. voor powermanagement zorgt. Als je die hardhandig uitschakelt, dan werkt het uitschakelen van de PC niet meer nee. En alle energiebesparende instellingen, bij laptops de accu-informatie enz. werken dan ook niet meer.

Ik zou in ieder geval nog even de andere opties van https://help.ubuntu.com/community/BootOptions#Common_Kernel_Options nog even proberen.

Werkt dat niet, dan moet je even googlen op het merk en type van je moederbord in combinatie met zoektermen als linux of ubuntu.

Offline Jeffcoboy

  • Lid
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #6 Gepost op: 2011/11/11, 18:26:50 »
Helaas, enkel acpi=off werkt. Over mijn moederbord met Ubuntu vind ik niets. Het is pas vanaf versie 11.10 dat er problemen zijn.
Een trotse linux-beginner!

Offline HarzG

  • Lid
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #7 Gepost op: 2011/11/13, 11:28:30 »
1. Had je acpi=force geprobeerd?
2. Je kan misschien beter op moederbord-type en Linux (i.p.v. Ubuntu) zoeken, daar is dan meteen te zien of er een algemeen probleem met de 3.x-kernel voor je moederbord is.
Xubuntu 16.04; siduction-15.1.0 Xfce

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #8 Gepost op: 2011/11/13, 20:36:42 »
Ik heb hier nog een best oude pc (…) Helaas, enkel acpi=off werkt. (..) Het is pas vanaf versie 11.10 dat er problemen zijn.
Die kans heb je inderdaad bij oude PC's. Zie bijvoorbeeld op askubuntu.com Trouble with Plymouth and Suspend/Hibernate on a Dell Optiplex GX520. Of op het Engelstalige Ubuntu forum deze thread kernel_thread_helper and acpi=off. Verder zou het ook nog een bug kunnen zijn only boot with acpi=off.
Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline Jeffcoboy

  • Lid
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #9 Gepost op: 2011/11/14, 07:39:45 »
Ik ga vandaag jou links eens bekijken jolo.

HarzG acpi=forve heb ik ook geprobeerd, dat werkt helaas ook niet.
Een trotse linux-beginner!

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #10 Gepost op: 2011/11/14, 14:22:01 »
Jeffcoboy,

Als het blijkt dat je 'oude' moederbord niet overweg kan met de ACPI van de huidige kernel, om welke reden ook.
Kan je een paar mogelijkheden overwegen...
- Kijks eens of er een BIOS-update bestaat en installeren.
- Met kernel 3.1.x proberen of hiermee het probleem is opgelost.
- Het moelijkst, een aangepaste DSDT laden via initrd.img

Meer info oa:
http://wiki.osx86project.org/wiki/index.php/DSDT
MvG,
MauRice
Registered Linux user: 473556

Offline lord4163

  • Lid
    • Simpelbuntu
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #11 Gepost op: 2011/11/14, 21:16:07 »
Grappig, ik heb het zelfde probleem met Kubuntu  :|. Draait super met acpi off nu, maar al druk ik op afsluiten sluit hij niet af, de harde schijf gaat uit en de bolletjes stoppen en dan moet ik ook de knop indrukken.
Meer weten over Ubuntu? Bezoek mijn site dan eens:
Simpelbuntu


Offline Jeffcoboy

  • Lid
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #12 Gepost op: 2011/11/15, 17:17:27 »
Het gaat om de Intel D865GLC Desktop Board met Pentium 4 HT processor.
MauRice2.

De BIOS versie is up to date. Is het mogelijk om gnome 3 op een oudere kernel te draaien, en hoe doe ik dat dan juist?
Die aangepaste DSDT. Is dit echt zo moeilijk, en is de kans groot dat het probleem is opgelost.

Lord4163. Als jij het opgelost krijgt, hoor ik het graag... :)
Een trotse linux-beginner!

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #13 Gepost op: 2011/11/15, 18:58:47 »
Jeffcoboy,

Voor zover mij bekend heeft de kernel niet veel te doen met Gnome 3, de VGA-kaart die is belangrijker.
Het zal best mogelijk zijn om op U 11.04 of Mint 11, Gnome 3 te installeren.
Hoe en welke PPA je hiervoor nodig heb... ??

Een initrd.img met aangepaste DSDT maken.. Moeilijk, het vraag wel kennis van zaken.
Ik heb het lang geleden maar EEN keer toegpast. En bij de eerste kernel-update was het zelfs niet meer nodig.
Dus een kernel-update kan wonderen doen.
MvG,
MauRice
Registered Linux user: 473556

Offline Jeffcoboy

  • Lid
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #14 Gepost op: 2011/11/15, 19:07:40 »
Zijn er dan al nieuwere kernels dan die van 11.10?
Een trotse linux-beginner!

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #15 Gepost op: 2011/11/15, 19:34:17 »
Jeffcoboy,

Als ik me niet vergist, heb ik overlaatst een kleine kernel-update zien passeren.
Voor de laatste stabiele 3.1.1 zal je ook een PPA moeten gebruiken, denk ik.
MvG,
MauRice
Registered Linux user: 473556

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #16 Gepost op: 2011/11/15, 20:49:10 »
Of een kernel update hier gaat helpen, is nog niet zeker. Ik vond hierover eveneens met een Intel D865GLC moederbord, deze bugmelding met openSuse 12.1 RC 2 https://bugzilla.novell.com/show_bug.cgi?id=730183 Deze heeft kernel 3.1. Daarin staat dat je als wordkaround in het BIOS, hyper threading kunt uitschakelen.

Hoofd PC september 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Ubuntu 14.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM
Test pc's AthlonXP 1700+ PC 1,5 GB RAM nVidia 7600GS en Dual P3 1000 MHz 1 GB RAM X1650Pro

Offline Jeffcoboy

  • Lid
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #17 Gepost op: 2011/11/15, 21:12:37 »
jolo. OK dit werkt. Ik heb Hyper Threading in de BIOS uitgeschakeld, en het systeem startte perfect op. En afsluiten lukt dan ook automatisch.
Nu is mijn systeem dus wel bijna de helft trager. Is hier een oplossing voor, en bestaat er een parameter dat HT enkel uitgeschakeld word, want Windows 7 draait in dualboot, en daar zou ik liefst wel HT gebruiken.

@lord4163, misschien toch ook een tip voor jou!
Een trotse linux-beginner!

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #18 Gepost op: 2011/11/15, 21:38:31 »
Jeffcoboy,

Bij de vorige versie van GRUB, was het voldoende om noht als boot-optie mee te geven.
Bij GRUB2, helaas kan zo 123(45) niet vinden.

En andere mogelijkheid is naast de generic-kernel ook de server-kernel en/of generic-pae-kernel te installeren.
Deze hebben net iets andere parameters gekregen bij het compileren.
Baat het niet, ze zijn ook zo weer de-geinstalleerd.
MvG,
MauRice
Registered Linux user: 473556

Offline Jeffcoboy

  • Lid
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #19 Gepost op: 2011/11/15, 21:45:13 »
Dus als ik die installeer, moet ik dan bij het opstarten nog iets ingeven?
Een trotse linux-beginner!

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #20 Gepost op: 2011/11/15, 21:56:22 »
Dus als ik die installeer, moet ik dan bij het opstarten nog iets ingeven?
Jeffcoboy,

Neen , niet echt, anders heeft het geen resultaat die je wenst, ACPI en HT aan + normaal kunnen afsluiten.
Alleen snel bij het opstarten op de linker-shift-toest om in het GRUB-menu te komen zodat je kan kiezen met welke 'kernel-smaak': generic, generic-pae of server je wilt opstarten.
Op deze manier kan je er achter komen of je met die andere smaak-versie wel het goede resultaat heb.
Het is en blijf de 'try and error' methode.
MvG,
MauRice
Registered Linux user: 473556

Offline Jeffcoboy

  • Lid
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #21 Gepost op: 2011/11/15, 21:59:02 »
OK. Dat gaat wel iets voor morgen worden. Ik laat nog iets weten.

alvast nu al heel hard bedankt!
Een trotse linux-beginner!

Offline Jeffcoboy

  • Lid
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #22 Gepost op: 2011/11/16, 14:35:36 »
Helaas verandert er met de generic-pea/server kernel niets.
Een trotse linux-beginner!

Online koos4401

  • Lid
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #23 Gepost op: 2011/11/16, 15:59:11 »
Jeffrey schreef:
Citaat
Helaas verandert er met de generic-pea/server kernel niets.
Dat geloof ik wel. pae-kernels zijn alleen nuttig als je met een 32-bits systeem méér dan 3,2 GB RAM-geheugen aan wilt kunnen spreken. Ik heb nergens gelezen dat dát jouw probleem is. Ik heb dan ook geen idee van de achtergrond van het advies van Maurice2
Op 27-okt-2009 om 08.20 GMT geregistreerd als gebruiker nr.: 498523

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: acpi=off voor installatie en opstarten.
« Reactie #24 Gepost op: 2011/11/16, 17:41:17 »
Jeffcoboy,

Helaas, dat de pae-kernel soelaas bracht, was de kans zeer gering. Maar wie nie waagt.....
De server-kernel, die is wel gecompileerd voor multi-processoren, maar ook hier helaas....

En de boot-optie noht, weliswaar nog van de vorige versie van GRUB, gaf dat wel de benodigde resultaat?
MvG,
MauRice
Registered Linux user: 473556