Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Opgelost] nvidia drivers verwijderen uit kubuntu  (gelezen 1350 keer)

Offline Mathijs050

  • Lid
  • Steunpunt: Nee
[Opgelost] nvidia drivers verwijderen uit kubuntu
« Gepost op: 2011/11/03, 22:25:09 »
Ik heb onlangs Xubuntu op mijn laptop geïnstalleerd en dat werkte fantastisch! Werkte, want ik heb door een stomme fout de hele handel in de soep laten lopen.
Ik heb nvidia drivers d.m.v. een commandline in de terminal geïnstalleerd, terwijl mijn Dell laptop een ATI kaart heeft. Gevolg, ik kan niet meer opstarten. Het beeld komt niet verder dan een heel vaag logo van Kubuntu en verder niets.
Ik kan wel in het Grub menu komen, maar nu is de grote vraag hoe ik de drivers weer laat verdwijnen zodat mijn laptop weer gewoon kan opstarten. Ik heb al een aantal commando's geprobeerd in de herstelmodus, maar niks werkt.
Hulp wordt zeeeeer op prijs gesteld!
Mathijs
« Laatst bewerkt op: 2011/11/07, 18:24:35 door Mathijs050 »

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: nvidia drivers verwijderen uit kubuntu
« Reactie #1 Gepost op: 2011/11/03, 22:45:26 »
Probeer het volgende commando eens in herstelmodus.
apt-get remove nvidia-current

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: nvidia drivers verwijderen uit kubuntu
« Reactie #2 Gepost op: 2011/11/03, 23:04:09 »
Als je in recovery mode (herstelmodus) opstart dan zou je tot aan het bureaublad moeten kunnen opstarten omdat hij de vesa driver gebruikt. De vesa driver is een algemene driver.
Dus als je in dat kleine menu komt gewoon op enter drukken.

Gaat dat?

Offline Mathijs050

  • Lid
  • Steunpunt: Nee
Re: nvidia drivers verwijderen uit kubuntu
« Reactie #3 Gepost op: 2011/11/04, 15:23:38 »
Fieuw :)
Het is gelukt om de boel weer aan de praat te krijgen. Ik heb in het xorg.conf het woord nvidia veranderd in vesa en nu start de hele handel weer op. Alleen heb ik nu hele grote letters en iconen, dus ik moet nog iets aanpassen in de scherminstellingen.
En hopelijk blijft het allemaal werken want ik heb nog niet weer opnieuw opgestart...

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: nvidia drivers verwijderen uit kubuntu
« Reactie #4 Gepost op: 2011/11/04, 19:02:19 »
Staan er drivers aangegeven onder "Stuurprogramma's"?
Zo ja selecteer dan best de aanbevolen driver en activeer die. Ga dan naar de xorg.conf en hernoem die naar xorg.conf.old of xorg.conf.backup of iets dergelijks.
Start dan weer op.

Kijk ook even via Synaptic of er nog drivers die te maken hebben met nvidia (nv, nouveau, e.d.) nog geïsntalleerd staan en vink die aan en kies voor volledige verwijdering.

Staan er geen drivers in dan kan je eventueel ook de xorg.conf hernoemen en opnieuw opstarten.
Normaal gezien is er geen xorg.conf bestand aanwezig, enkel als je niet vrije drivers installeerd, dan word er wel een xorg.conf aangemaakt.


Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: nvidia drivers verwijderen uit kubuntu
« Reactie #5 Gepost op: 2011/11/04, 19:18:15 »
Fieuw :)
Het is gelukt om de boel weer aan de praat te krijgen. Ik heb in het xorg.conf het woord nvidia veranderd in vesa en nu start de hele handel weer op. Alleen heb ik nu hele grote letters en iconen, dus ik moet nog iets aanpassen in de scherminstellingen.
En hopelijk blijft het allemaal werken want ik heb nog niet weer opnieuw opgestart...
Mathijs050,

Wat ook help is die /etc/X11/xorg.conf hernoemen bv /etc/X11/xorg.conf.old zodat het lijkt dat je er geen heb.
Ubuntu zal zelf dan de juiste driver gebruiken.
Andere mogelijkheid: De driver "nvidia" of "vesa" veranderen in "ati".
Je moet wel even opletten of er geen extra typische regels voor nvidia er tussen zit.
Deze even op commentaar zetten door een # ervoor te zetten.
MvG,
MauRice
Registered Linux user: 473556

Offline Mathijs050

  • Lid
  • Steunpunt: Nee
Re: nvidia drivers verwijderen uit kubuntu
« Reactie #6 Gepost op: 2011/11/05, 15:16:39 »
Hartelijk dank voor alle hulp! Ik heb inderdaad het woord "vesa" veranderd in "ati" en een # gezet voor nvidia die als vendor cooperation nog stond aangemerkt. Daarna opnieuw opgestart: geen battery check meer en het beeldscherm weer helemaal normaal!
Dus dit kan als een succesvol opgelost topic worden aangemerkt! Hoe doe ik dat trouwens, melden dat het probleem is opgelost?
« Laatst bewerkt op: 2011/11/05, 15:20:05 door Mathijs050 »