Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Onveilige Java 6u26 in Ubuntuversies voorafgaand aan Oneiric: hulp gevraagd  (gelezen 2665 keer)

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Als je een oudere Ubuntuversie draait dan Oneiric, en je hebt gekozen voor Oracle (Sun) Java JRE (geïnstalleerd vanuit de Partner-pakketbron), dan is je Java onveilig: https://bugs.launchpad.net/ubuntu/+source/sun-java6/+bug/884252

Wie helpt even mee om deze foutmelding te bevestigen? Dat kan door te klikken op: "This bug affects me" (groene letters, linksboven). Hoe meer bevestigingen, des te sneller de actie. Zo leert de ervaring...

Alvast bedankt.  :)
« Laatst bewerkt op: 2011/10/31, 16:04:40 door Pjotr »

Offline Joris Donders

  • Lid
  • Steunpunt: Nee
Re: Onveilige Java 6u26 in Ubuntuversies voor Oneiric: hulp gevraagd
« Reactie #1 Gepost op: 2011/10/31, 16:05:55 »
Bevestigd op launchpad ! ;)

Het rare is dat ik van de Ferramroberto nog steeds geen antwoord heb gekregen  >:( (vakantie ? )
Gubuntu 17.04 wegens verdwijnen Unity binnenkort

Offline Vistaus

  • Lid
    • vistaus
  • Steunpunt: Nee
Re: Onveilige Java 6u26 in Ubuntuversies voor Oneiric: hulp gevraagd
« Reactie #2 Gepost op: 2011/10/31, 16:06:56 »
Ook in 10.04 is sun-java verwijderd uit Partner, dus daar moet je sowieso geen updates van verwachten.

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Re: Onveilige Java 6u26 in Ubuntuversies voor Oneiric: hulp gevraagd
« Reactie #3 Gepost op: 2011/10/31, 16:07:44 »
Ook in 10.04 is sun-java verwijderd uit Partner, dus daar moet je sowieso geen updates van verwachten.

Niet waar. Zojuist nog gecontroleerd.

Offline Joris Donders

  • Lid
  • Steunpunt: Nee
ow dat is dan slecht nieuws eigenlijk Vistaus ....

Dan moeten we die beheerder van de ppa (zie hierboven) nog even aanporren ..... ! ;)
Gubuntu 17.04 wegens verdwijnen Unity binnenkort

Offline Vistaus

  • Lid
    • vistaus
  • Steunpunt: Nee
Ook in 10.04 is sun-java verwijderd uit Partner, dus daar moet je sowieso geen updates van verwachten.

Niet waar. Zojuist nog gecontroleerd.

Wel waar. Zojuist nog gecontroleerd. Krijg de melding dat het pakket niet meer beschikbaar is.
« Laatst bewerkt op: 2011/10/31, 16:10:49 door Vistaus »

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Ook in 10.04 is sun-java verwijderd uit Partner, dus daar moet je sowieso geen updates van verwachten.

Niet waar. Zojuist nog gecontroleerd.

Wel waar. Zojuist nog gecontroleerd.
Ook Update Updates meld dat sun-java verwijderd is uit 10.04 Partner.

Kletskoek. Zie bijgaande schermafdruk.

Offline Vistaus

  • Lid
    • vistaus
  • Steunpunt: Nee
Op mijn 10.04 kreeg ik van apt-get zojuist de melding dat het pakket niet meer beschikbaar is.

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Op mijn 10.04 kreeg ik van apt-get zojuist de melding dat het pakket niet meer beschikbaar is.

Jij hebt altijd wat bijzonders met je systemen, simpelweg omdat je er zoveel aan knutselt, dat ze een algemeenheidswaarde hebben van 0,0001 %. Dat zegt dus helemaal niks en zaait verwarring.

Bij mij gaat het om een standaardsysteem van 10.04 LTS.

Offline Vistaus

  • Lid
    • vistaus
  • Steunpunt: Nee
Hou nou toch eens je grote mond dicht man. Ik heb je vorige keer al gezegd dat ik niet knutsel op mijn hoofdPC en schoollaptop. Ik heb geen enkele PPA toegevoegd behalve Medibuntu.

vistausss@vistausss-lenovo:~$ sudo apt-get install sun-java6-jre
Pakketlijsten worden ingelezen... Klaar
Boom van afhankelijkheden wordt opgebouwd       
Statusinformatie wordt gelezen... Klaar 
Pakket sun-java6-jre is niet beschikbaar, hoewel er naar verwezen wordt door
een ander pakket. Mogelijk betekent dit dat het pakket ontbreekt,
verouderd is, of enkel beschikbaar is van een andere bron

E: Pakket 'sun-java6-jre' heeft geen installatie-kandidaat
vistausss@vistausss-lenovo:~$

Op 10.04 die melding.

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Ik geloof er niks van, dat jij niet geknutseld hebt. Maar dan ook helemaal nul komma niks. Dit is al de zoveelste keer, dat je verwarring loopt te zaaien met niet-standaard-systemen. Eerlijk gezegd dacht ik al, toen ik dit draadje opende: dadelijk komt Vistaus weer met een verhaal dat 't niet zo is, om dat 't bij hem anders is.... En jawel hoor, verdomd als het niet waar is.

Ziehier mijn terminalmelding:
pjotr@thuiscomputer:~$ sudo apt-get install sun-java6-jre
[sudo] password for pjotr:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
De status informatie wordt gelezen... Klaar
De volgende pakketten zijn automatisch geïnstalleerd en zijn niet langer nodig:
  libvpx0
U kunt deze verwijderen via 'apt-get autoremove'.
De volgende extra pakketten zullen geïnstalleerd worden:
  sun-java6-bin
Voorgestelde pakketten:
  sun-java6-plugin ia32-sun-java6-plugin sun-java6-fonts ttf-kochi-gothic
  ttf-sazanami-gothic ttf-kochi-mincho ttf-sazanami-mincho ttf-arphic-uming
De volgende NIEUWE pakketten zullen geïnstalleerd worden:
  sun-java6-bin sun-java6-jre
0 pakketten opgewaardeerd, 2 pakketten nieuw geïnstalleerd, 0 te verwijderen en 0 niet opgewaardeerd.
Er moeten 36,5MB aan archieven opgehaald worden.
Door deze operatie zal er 104MB extra schijfruimte gebruikt worden.
Wilt u doorgaan [J/n]?

Offline Vistaus

  • Lid
    • vistaus
  • Steunpunt: Nee
Jammer dat je me niet geloofd Pjotr. Ben erg teleurgesteld daarin :(
Waarom zou ik gaan knutselen op een systeem wat ik voor school nodig heb? Ik heb vorige week al een paar dagen zonder OS gezeten en daar ben ik flink voor op mijn vingers getikt op school. Daarom dat ik maar niet meer knutsel aan mijn systeem. Heb dus een keurige dual-boot van 11.10 en 10.04 met alleen Medibuntu toegevoegd.

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Heb je de Partner-bron aanstaan? Want daar zit-ie in. Zie mijn startbericht.

Offline Vistaus

  • Lid
    • vistaus
  • Steunpunt: Nee
Heb je de Partner-bron aanstaan? Want daar zit-ie in. Zie mijn startbericht.

Ja, die staat aan.

Offline Pjotr

  • Lid
    • Makkelijke Linuxtips
  • Steunpunt: Nee
Nou, dan is 't bij jou dus weer eens anders.... voor de zoveelste keer.  XD

Offline Vistaus

  • Lid
    • vistaus
  • Steunpunt: Nee
Kennelijk ja. Kan iemand anders dit bevestigen of ...?

Offline Timo

  • Forumteam
    • timo.diedering
  • Steunpunt: Nee
*tiempjuuh is bezig een stikkie te maken met ubuntu 10.04

Offline overdenkamp

  • Lid
  • Steunpunt: Nee
http://archive.canonical.com/dists/lucid/partner/binary-i386/Packages.bz2

Even zoeken (Ctrl+F) op Sun:Package: sun-java6-jre
Source: sun-java6
Priority: optional
Section: java
Installed-Size: 14316
Maintainer: Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
Architecture: all
Version: 6.26-1lucid1
Recommends: gsfonts-x11
Replaces: ia32-sun-java6-bin, sun-java6-bin
Suggests: sun-java6-plugin | ia32-sun-java6-plugin, sun-java6-fonts, ttf-baekmuk | ttf-unfonts | ttf-unfonts-core, ttf-kochi-gothic | ttf-sazanami-gothic, ttf-kochi-mincho | ttf-sazanami-mincho, ttf-arphic-uming
Provides: java-runtime, java-runtime-headless, java-virtual-machine, java2-runtime, java2-runtime-headless, java5-runtime, java5-runtime-headless, java6-runtime, java6-runtime-headless
Depends: java-common (>= 0.24), locales, sun-java6-bin (>= 6.26-1lucid1) | ia32-sun-java6-bin (>= 6.26-1lucid1)
Conflicts: j2se-common
Pre-Depends: debconf (>= 0.5) | debconf-2.0
Filename: pool/partner/s/sun-java6/sun-java6-jre_6.26-1lucid1_all.deb
Size: 6370878
MD5sum: 61a78a417c17e0f589aa992dff8d9c4b
SHA1: 187bcbed84ce425fe51ac6415f479e38f5a32e31
Description: Sun Java(TM) Runtime Environment (JRE) 6 (architecture independent files)
 The Sun Java Platform Standard Edition Runtime Environment (JRE) 6
 contains the Java virtual machine, runtime class libraries, and
 Java application launcher that are necessary to run programs written
 in the Java progamming language. It is not a development environment and
 doesn't contain development tools such as compilers or debuggers.
 For development tools, see the Java Development Kit JDK(TM) 6
 (package sun-java6-jdk).
 .
 NOTE: You must accept Sun's EULA prior to successfully installing
 this package
 .
 This package contains architecture independent files.

Edit: zou zo eigenlijk ook niet geloven dat ze daar bij een LTS-versie zo mee ophouden, zijn simpelweg te veel mensen van afhankelijk...

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Lucid 64-bits:
johan@desktop:~$ apt-cache policy sun-java6-jre
sun-java6-jre:
  Installed: 6.26-1lucid1
  Candidate: 6.26-1lucid1
  Version table:
 *** 6.26-1lucid1 0
        500 http://archive.canonical.com/ubuntu/ lucid/partner Packages
        100 /var/lib/dpkg/status
Vlak daarvoor een sudo apt-get update gedaan, zodat de informatie vers is.

Offline erik1984

  • Lid
    • erik1984
  • Steunpunt: Nee
Pjotr en Vistaus: vergelijk anders eens jullie sources.list

Offline Prosper

  • Lid
  • Steunpunt: Nee
Draadje gesloten en laatste drie berichten verwijderd.
Overleg binnen moderatorteam
Omwille van de besparingen hebben ze het licht aan het eind van de tunnel ook uitgedaan...