Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: 11.10 Geen geluid koptelefoon laptop  (gelezen 5550 keer)

Offline 10o

  • Lid
  • Steunpunt: Nee
11.10 Geen geluid koptelefoon laptop
« Gepost op: 2011/10/19, 09:09:55 »
Het geluid op de koptelefoon (Sony Vaio laptop) is in 11.10 bijna onhoorbaar... Geen van de standaard geluidsinstellingen hebben effect.
Kinderziekte?  ^-^
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: 11.10 Geen geluid koptelefoon laptop
« Reactie #1 Gepost op: 2011/10/19, 10:35:55 »
Hallo

Een Sony Vaio; en welke dan?
belangrijker; wat geeft
aplay -l  (l is kleine letter L )
in een terminal,
misschien dat er een optie moet worden toegevoegd.

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: 11.10 Geen geluid koptelefoon laptop
« Reactie #2 Gepost op: 2011/10/19, 10:43:17 »
Type Vaio zie m'n footer (2e regel).
Output aplay -l
**** Lijst van PLAYBACK hardware-apparaten ****
kaart 0: PCH [HDA Intel PCH], apparaat 0: ALC275 Analog [ALC275 Analog]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0
kaart 0: PCH [HDA Intel PCH], apparaat 1: ALC275 Digital [ALC275 Digital]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0
kaart 1: NVidia [HDA NVidia], apparaat 3: HDMI 0 [HDMI 0]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0
kaart 1: NVidia [HDA NVidia], apparaat 7: HDMI 0 [HDMI 0]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0
kaart 1: NVidia [HDA NVidia], apparaat 8: HDMI 0 [HDMI 0]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0
kaart 1: NVidia [HDA NVidia], apparaat 9: HDMI 0 [HDMI 0]
  Sub-apparaten: 1/1
  Sub-apparaat #0: subdevice #0
Ps. in 11.04 geen problemen. Zie wel dezelfde problemen gerapporteerd in 11.10 op diverse laptops. Nog geen oplossing tegen gekomen.
« Laatst bewerkt op: 2011/10/19, 10:46:13 door 10o »
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: 11.10 Geen geluid koptelefoon laptop
« Reactie #3 Gepost op: 2011/10/19, 20:35:31 »
Hallo

Nou ook maar eens 11.10 ergens bij opgeplant, om te zien of de opties voor de alc275 in het HD-Audio-Models txt bestandje (stond nl. niet vermeldt in 10.04 dat ik nog steeds op mijn productie machines gebruik)
Wat blijkt; kent ie niet ???.
Ik heb alleen wat suggesties; misschien loont het om de linux-backports-modules-alsa-oneiric-generic
te installeren. Daarna rebooten en mixersettings controleren.

Je zou voor de gein (en op de gok) de opties vaio sony of auto proberen in je
alsa-base.conf in de bij te voegen regel
options snd_hda_intel model=.....
(je moet root zijn om die te kunnen bewerken dus;
gksudo gedit /etc/modprobe.d/alsa-base.conf)
en tussen elke optie verandering door; rebooten, mixersettings controleren.

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: 11.10 Geen geluid koptelefoon laptop
« Reactie #4 Gepost op: 2011/10/19, 21:39:11 »
Veel geprobeerd wat niet hielp in /etc/modprobe.d/alsa-base.conf zoals:
  • options snd-hda-intel model=vaio enable=1 index=0 position_fix=1 probe_mask=1 (zie hier)
  • options snd-hda-intel model=vaio
Maar de toevoeging
  • options snd-hda-intel model=auto
leek even te helpen, maar alleen als ik vanaf het begin af aan de koptelefoon erin had.
Eruit en er weer terug in gaf wederom hetzelfde probleem...

Ps. correctie: de tweede keer met "auto" optie, werkte helemaal niet meer.  ???
« Laatst bewerkt op: 2011/10/19, 21:42:15 door 10o »
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: 11.10 Geen geluid koptelefoon laptop
« Reactie #5 Gepost op: 2011/10/19, 21:46:50 »
Ik heb alleen wat suggesties; misschien loont het om de linux-backports-modules-alsa-oneiric-generic
te installeren. Daarna rebooten en mixersettings controleren.
sudo apt-get install linux-backports-modules-alsa-oneiric-generic
[sudo] password for 10o:
Pakketlijsten worden ingelezen... Klaar
Boom van afhankelijkheden wordt opgebouwd      
Statusinformatie wordt gelezen... Klaar  
E: Kan pakket linux-backports-modules-alsa-oneiric-generic niet vinden
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: 11.10 Geen geluid koptelefoon laptop
« Reactie #6 Gepost op: 2011/10/19, 21:51:01 »
Hallo,

Zoek eens op linux-backports in synaptic, misschien dat intussen dat pakket van naam is veranderd, dat
oneiric bijv. heb ik maar even aangenomen; vroegah heette dat altijd karmic/lucid etc. dus ik dacht...

Installeer ook eens pavucontrol, daarmee valt wat meer te controleren qua mixer/apparaat settings.

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: 11.10 Geen geluid koptelefoon laptop
« Reactie #7 Gepost op: 2011/10/19, 22:01:42 »
Thanks Gerrit!
Met pavucontrol zie je dat er iets helemaal mis gaat onder motorkap...
Zodra ik de koptelefoon erin stop, springt de uitvoerpoort naar "Analoge koptelefoon" en valt het geluid weg (ook op de koptelefoon), terwijl het volume op 100% staat.
Pas als ik in pavucontrol handmatig switch naar "Analog Speakers" krijg ik weer controle over het koptelefoon volume. Zonder deze handmatige (dubbelzinnige) tussenkomst middels pavucontrol blijft het dus fout lopen.
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: 11.10 Geen geluid koptelefoon laptop
« Reactie #8 Gepost op: 2011/10/19, 22:12:42 »
Hallo,

hmmmm. dat is typisch, het geeft aan dat er iets mis gaat icm. het zogenaamde
jack-sensing, dat wordt nogal eens op verschillende wijzen opgelost door de fabrikant.
Misschien dat je met het timmer houten alsamixer gebeuren hetzelfde kunt bewerkstelligen,
maar dan blijvend?

en hoe heet dat backports pakket nu eigenlijk ?

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: 11.10 Geen geluid koptelefoon laptop
« Reactie #9 Gepost op: 2011/10/20, 07:51:22 »
en hoe heet dat backports pakket nu eigenlijk ?
Is niet meer?
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline mrGee

  • Lid
  • Steunpunt: Nee
Re: 11.10 Geen geluid koptelefoon laptop
« Reactie #10 Gepost op: 2011/10/20, 11:05:55 »
Hallo

Net even gecontroleerd; inderdaad weg.
Kijk dan of je met alsamixer zaken om kunt buigen.

Groeten Gerrit
-- = >  simplify if you can   -- = >

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: 11.10 Geen geluid koptelefoon laptop
« Reactie #11 Gepost op: 2011/10/20, 14:50:51 »
Hoi Gerrit, ook met alsamixer gaat het speakervolume meteen dicht als ik de koptelefoon erin stop. Alleen als ik die steeds weer handmatig omhoog schroef heb ik geluid op de koptelefoon... Geen structurele oplossing helaas.
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: 11.10 Geen geluid koptelefoon laptop
« Reactie #12 Gepost op: 2011/10/20, 15:22:44 »
Met Xubuntu had ik een soortgelijk probleem, alleen deden daar de speakers het niet meer, wanneer een hoofdtelefoon aangesloten was geweest.
Het verwijderen (uitvinken) van de aparte instellingen van Hoofdtelefoon en speakers was de oplossing, er is alleen een master volume regelaar geconfigureerd.
Is dit in Ubuntu ook niet mogelijk bij de opties van de volume regelaar ?
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: 11.10 Geen geluid koptelefoon laptop
« Reactie #13 Gepost op: 2011/10/20, 15:49:36 »
Met Xubuntu had ik een soortgelijk probleem, alleen deden daar de speakers het niet meer, wanneer een hoofdtelefoon aangesloten was geweest.
Het verwijderen (uitvinken) van de aparte instellingen van Hoofdtelefoon en speakers was de oplossing, er is alleen een master volume regelaar geconfigureerd.
Is dit in Ubuntu ook niet mogelijk bij de opties van de volume regelaar ?
Volgens mij kan dat niet afzonderlijk aan-/uitgeschakeld worden...
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: 11.10 Geen geluid koptelefoon laptop
« Reactie #14 Gepost op: 2011/10/20, 16:15:48 »
Volgens mij kan dat niet afzonderlijk aan-/uitgeschakeld worden...
Linker muistoets geeft geen menu met onderin geluisdsinstellingen?
Dan is het mogelijk een ander probleem ....... (of een andere oplossing).
OpenStandaard evangelist, OpenSource promotor, OpenData liefhebber.
Xubuntu gebruiker en voorstander (XFCE).
In Nederland bekend als een dwarsligger.

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: 11.10 Geen geluid koptelefoon laptop
« Reactie #15 Gepost op: 2011/10/20, 16:19:18 »
Volgens mij kan dat niet afzonderlijk aan-/uitgeschakeld worden...
Linker muistoets geeft geen menu met onderin geluisdsinstellingen?
Dan is het mogelijk een ander probleem ....... (of een andere oplossing).
In de geluidsinstellingen komen lukt wel via het geluidsmenu, maar een instelling om hoofdtelefoon danwel speakers uit te schakelen zie ik niet voorhanden.
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: 11.10 Geen geluid koptelefoon laptop
« Reactie #16 Gepost op: 2011/10/20, 16:26:12 »
Dit is een bekend probleem met deze chip, heb ik zlef ook. Connector in Geluidsinstellingen op "koptelefoon" zetten, elke keer handmatig de speaker unmuten en open zetten in alsamixer.

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: 11.10 Geen geluid koptelefoon laptop
« Reactie #17 Gepost op: 2011/10/20, 16:31:16 »
Dit is een bekend probleem met deze chip, heb ik zlef ook. Connector in Geluidsinstellingen op "koptelefoon" zetten, elke keer handmatig de speaker unmuten en open zetten in alsamixer.
Hoe/waar kom ik erachter of iets een "bekend" probleem is? Op fora ben ik het wel tegengekomen, maar hoe kom ik er op overzichtelijke wijze achter welke problemen ik met welke hardware kan verwachten i.c.m. de nieuwe kernel?
In 11.04 werkte alles prima, dus bij mij was het geen bekend probleem.  ;)
Had jij in 11.04 ook al dit probleem?
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: 11.10 Geen geluid koptelefoon laptop
« Reactie #18 Gepost op: 2012/01/01, 19:40:38 »
Op te lossen door bij ieder switch tussen koptelefoon en speakers handmatig in te stellen
Geluidsinstellingen > Uitvoer > Kies analoge speakers.

Met dit pakketje https://code.launchpad.net/~ubuntu-audio-dev/+archive/alsa-daily/+packages is dat eindelijk overbodig. Het was een behoorlijk irritant gemis als je vaak switcht. Zie verder https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: 11.10 Geen geluid koptelefoon laptop
« Reactie #19 Gepost op: 2012/01/01, 21:53:25 »
Op te lossen door bij ieder switch tussen koptelefoon en speakers handmatig in te stellen
Geluidsinstellingen > Uitvoer > Kies analoge speakers.

Met dit pakketje https://code.launchpad.net/~ubuntu-audio-dev/+archive/alsa-daily/+packages is dat eindelijk overbodig. Het was een behoorlijk irritant gemis als je vaak switcht. Zie verder https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS
Heeft op mijn laptop helaas niet geholpen, VT1708S Analog.. :(