Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] Problemen met scannen  (gelezen 1704 keer)

Offline Cheap Applications

  • Lid
  • Steunpunt: Nee
[OPGELOST] Problemen met scannen
« Gepost op: 2011/09/30, 18:55:44 »
Dag dames en heren,
Ik heb een scanner die normaal werkt (HP ScanJet 5300C, primitief, maar hij doet het nog XD)
Maar het probleem is: hij werkt niet altijd. Vaak werkt hij na een herstart of de stekker er opnieuw insteken wel. Maar om elke keer opnieuw op te moeten starten of de stekker opnieuw erin te steken (die achter mijn PC kast zit) als hij het niet doet...

Ik heb gelezen in de Ubuntu documentatie dat een mogelijk probleem kan zijn dat de driver soms niet automatisch geladen word.
Maar oplossing erbij zetten ho maar :D

Ik zou graag weten hoe ik dit probleem kan fixen. Simple-Scan geeft de melding: Scannen is mislukt, Geen scanners beschikbaar. Sluit een scanner aan om dit programma te gebruiken. En als wortel geeft hij hetzelfde probleem.
Ik zie wel dat de scanner aan staat (hij geeft licht en zit te brommen).

Iemand die mij kan helpen?
« Laatst bewerkt op: 2011/10/02, 10:59:55 door Cheap Applications »
Desktop:
Processor: Intel® Core™2 Quad CPU Q8300 @ 2.50GHz × 4, Geheugen: 3.9Gb, GPU: nVidia 220GT OS: Windows 7 64 bit / Ubuntu 12.04 64 bit
Notebook:
Processor: Intel® Core™ i7-4700MQ, Geheugen: 8Gb, GPU: nVidia GTX765m (met Optimus) OS: Windows 8 64 bit / Elementary OS Luna 64 bit

Offline Roc.am

  • Lid
  • Steunpunt: Nee
Re: Problemen met scannen
« Reactie #1 Gepost op: 2011/09/30, 19:02:46 »
Werkt het misschien beter met XSane, deze gebruikt volgens mij zijn eigen drivers en zoekt de scanner als XSane opstart.

- Roc

Offline Cheap Applications

  • Lid
  • Steunpunt: Nee
Re: Problemen met scannen
« Reactie #2 Gepost op: 2011/09/30, 19:04:01 »
Volgens mij gebruik ik al een SANE driver, maar ik zal even kijken.

EDIT: XSane geeft "geen apparaten aanwezig" terwijl ik wel de scanner hoor brommen als XSane opstart.
EDIT 2: Quote van Simple Scan vanuit het softwarecentrum: "Simple Scan is basically a frontend for SANE - which is the same backend as XSANE uses. This means that all existing scanners will work and the interface is well tested."
Oftewel; een ander jasje van XSane ;)
« Laatst bewerkt op: 2011/09/30, 19:21:17 door Cheap Applications »
Desktop:
Processor: Intel® Core™2 Quad CPU Q8300 @ 2.50GHz × 4, Geheugen: 3.9Gb, GPU: nVidia 220GT OS: Windows 7 64 bit / Ubuntu 12.04 64 bit
Notebook:
Processor: Intel® Core™ i7-4700MQ, Geheugen: 8Gb, GPU: nVidia GTX765m (met Optimus) OS: Windows 8 64 bit / Elementary OS Luna 64 bit

Offline gavinspearhead

  • Lid
    • URD
  • Steunpunt: Nee
Re: Problemen met scannen
« Reactie #3 Gepost op: 2011/09/30, 19:32:39 »
uit de logfiles kan mesetal wel opgemaakt worden welke driver wordt geladen... kijk een is dmesg
URD - http://www.urdland.com - Usenet Resource Downloader

Offline gavinspearhead

  • Lid
    • URD
  • Steunpunt: Nee
Re: Problemen met scannen
« Reactie #4 Gepost op: 2011/09/30, 19:48:57 »
Waarschijnlijk moet je  aan "/lib/udev/rules.d/40-libsane.rules" zo'n soort regel toevoegen.
    # Brother scanners
    ATTRS{idVendor}=="04f9", ENV{libsane_matched}="yes"
     
Alleen dan voor een ander type.... wsl heeft de vendor site wel info.
URD - http://www.urdland.com - Usenet Resource Downloader

Offline Cheap Applications

  • Lid
  • Steunpunt: Nee
Re: Problemen met scannen
« Reactie #5 Gepost op: 2011/09/30, 20:06:48 »
dmesg is een grote brei met letters. Wat moet ik daar uit zien te vinden?
Desktop:
Processor: Intel® Core™2 Quad CPU Q8300 @ 2.50GHz × 4, Geheugen: 3.9Gb, GPU: nVidia 220GT OS: Windows 7 64 bit / Ubuntu 12.04 64 bit
Notebook:
Processor: Intel® Core™ i7-4700MQ, Geheugen: 8Gb, GPU: nVidia GTX765m (met Optimus) OS: Windows 8 64 bit / Elementary OS Luna 64 bit

Offline gavinspearhead

  • Lid
    • URD
  • Steunpunt: Nee
Re: Problemen met scannen
« Reactie #6 Gepost op: 2011/09/30, 21:28:24 »
device afkoppelen, weer aankoppelen en dan naar dmesg kijken
of evt dmesg|grep -i usb
de laatste regel(s) geven aan welke driver geladen wordt

[277624.120036] usb 1-9: new high speed USB device using ehci_hcd and address 9
[277624.280533] scsi11 : usb-storage 1-9:1.1
zo iets staat er dan, en ehci_hcd en usb-storage zijn in dit geval de drivers (voor een removable disk)

als je dat weet kun je in modprobe kijken of de driver geladen is
zo niet dan moet je of nog wat installeren of je kunt de driver met de hand laden
URD - http://www.urdland.com - Usenet Resource Downloader

Offline Cheap Applications

  • Lid
  • Steunpunt: Nee
Re: Problemen met scannen
« Reactie #7 Gepost op: 2011/09/30, 23:08:48 »
[ 7465.387956] usb 3-1: usbfs: interface 0 claimed by usbfs while 'simple-scan' sets config #1
[ 7465.388271] usb 3-1: usbfs: interface 0 claimed by usbfs while 'simple-scan' sets config #1
[ 7490.133122] usb 3-1: usbfs: interface 0 claimed by usbfs while 'simple-scan' sets config #1
[ 7490.133433] usb 3-1: usbfs: interface 0 claimed by usbfs while 'simple-scan' sets config #1
[ 8006.290049] usb 3-1: USB disconnect, address 2
[ 8047.000023] usb 3-1: new full speed USB device using uhci_hcd and address 3
[13186.423507] usb 1-1: USB disconnect, address 4
remco@remco-ubuntu-maverick:~$ modprobe -l *usb
kernel/drivers/net/wireless/orinoco/orinoco_usb.ko
kernel/drivers/net/wireless/at76c50x-usb.ko
kernel/drivers/net/wireless/libertas_tf/libertas_tf_usb.ko
kernel/drivers/net/wireless/rt2x00/rt2x00usb.ko
kernel/drivers/net/wireless/rt2x00/rt2500usb.ko
kernel/drivers/net/wireless/rt2x00/rt73usb.ko
kernel/drivers/net/wireless/rt2x00/rt2800usb.ko
kernel/drivers/net/wireless/p54/p54usb.ko
kernel/drivers/net/wireless/ath/ar9170/ar9170usb.ko
kernel/drivers/net/can/usb/ems_usb.ko
kernel/drivers/net/usb/plusb.ko
kernel/drivers/net/irda/irda-usb.ko
kernel/drivers/net/wimax/i2400m/i2400m-usb.ko
kernel/drivers/usb/otg/twl4030-usb.ko
kernel/drivers/usb/misc/ldusb.ko
kernel/drivers/usb/serial/ir-usb.ko
kernel/drivers/i2c/busses/i2c-tiny-usb.ko
kernel/drivers/media/IR/mceusb.ko
kernel/drivers/media/video/cpia_usb.ko
kernel/drivers/media/video/dabusb.ko
kernel/drivers/media/dvb/b2c2/b2c2-flexcop-usb.ko
kernel/drivers/media/dvb/dvb-usb/dvb-usb.ko
kernel/drivers/media/dvb/dvb-usb/dvb-usb-cxusb.ko
kernel/drivers/media/dvb/siano/smsusb.ko
kernel/drivers/watchdog/pcwd_usb.ko
kernel/drivers/isdn/hardware/mISDN/hfcsusb.ko
kernel/drivers/isdn/hisax/hfc_usb.ko
kernel/drivers/staging/lirc/lirc_igorplugusb.ko
kernel/drivers/staging/go7007/go7007-usb.ko
kernel/drivers/staging/wlan-ng/prism2_usb.ko
kernel/drivers/staging/rtl8192su/r8192s_usb.ko
kernel/drivers/staging/rtl8192u/r8192u_usb.ko
kernel/drivers/staging/line6/line6usb.ko
kernel/drivers/uwb/i1480/dfu/i1480-dfu-usb.ko
kernel/drivers/bluetooth/bfusb.ko
kernel/drivers/bluetooth/btusb.ko
Ik denk dat dat de data is waar we naar op zoek zijn, maar ik zou verder niet weten hoe of wat.

In libsane.rules staat wel:
# Hewlett-Packard ScanJet 5300C | Hewlett-Packard ScanJet 5370C
ATTRS{idVendor}=="03f0", ATTRS{idProduct}=="0701", ENV{libsane_matched}="yes"

Wat lijkt te kloppen

En vergeet niet dat hij soms wel werkt en soms niet, dus het zal niet aan een nog te installeren driver liggen, want die is al van xsane gedownload bij het installeren van het apparaat.
Desktop:
Processor: Intel® Core™2 Quad CPU Q8300 @ 2.50GHz × 4, Geheugen: 3.9Gb, GPU: nVidia 220GT OS: Windows 7 64 bit / Ubuntu 12.04 64 bit
Notebook:
Processor: Intel® Core™ i7-4700MQ, Geheugen: 8Gb, GPU: nVidia GTX765m (met Optimus) OS: Windows 8 64 bit / Elementary OS Luna 64 bit

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Problemen met scannen
« Reactie #8 Gepost op: 2011/10/01, 01:54:44 »
Werkt het misschien beter met XSane, deze gebruikt volgens mij zijn eigen drivers en zoekt de scanner als XSane opstart.

- Roc
Nee. Simple Scane gebruikt gewoon Sane, net als XSane Sane gebruikt.

Offline koos4401

  • Lid
  • Steunpunt: Nee
Re: Problemen met scannen
« Reactie #9 Gepost op: 2011/10/01, 10:20:03 »
@femke98: dat zal niet helpen: HP5300c is alleen een scanner, geen all-in-one. (net als mijn eigen antiek: HP3750c)
Hier de specs, als je 't leuk vindt: http://h10025.www1.hp.com/ewfrf/wc/document?cc=nl&lc=nl&dlc=nl&docname=bds03614
Op 27-okt-2009 om 08.20 GMT geregistreerd als gebruiker nr.: 498523

Offline petervs

  • Lid
  • Steunpunt: Nee
Re: Problemen met scannen
« Reactie #10 Gepost op: 2011/10/01, 15:44:27 »
Misschien dat als je de standaard dpi instelling verandert, dat je dan geen of minder problemen krijgt. Het schijnt dat dit in het verleden bij deze scanner ook 'n issue was, en dat het wijzigen van de dpi de scanner wel deed werken.
Ubuntu MATE 16.04

Offline softbart

  • Lid
  • Steunpunt: Nee
Re: Problemen met scannen
« Reactie #11 Gepost op: 2011/10/01, 16:49:24 »
Hij werkt niet altijd.

Of een brakke verbinding????

groet,

Theo

Offline Cheap Applications

  • Lid
  • Steunpunt: Nee
Re: Problemen met scannen
« Reactie #12 Gepost op: 2011/10/02, 10:20:22 »
Ik heb de resolutie nu weer lager gezet (op standaard, ik had ze wat hoger gezet voor de kwaliteit) en nu blijkt het weer te werken... Na nog een keertje opnieuw opgestart te hebben.
Kabel is dus denk ik nog wel in orde.
Desktop:
Processor: Intel® Core™2 Quad CPU Q8300 @ 2.50GHz × 4, Geheugen: 3.9Gb, GPU: nVidia 220GT OS: Windows 7 64 bit / Ubuntu 12.04 64 bit
Notebook:
Processor: Intel® Core™ i7-4700MQ, Geheugen: 8Gb, GPU: nVidia GTX765m (met Optimus) OS: Windows 8 64 bit / Elementary OS Luna 64 bit

Offline Cheap Applications

  • Lid
  • Steunpunt: Nee
Re: Problemen met scannen
« Reactie #13 Gepost op: 2011/10/02, 10:40:59 »
AAARGHH F$@#. Heb ik weer: heb ik al wat blaadjes gescand, crasht simple-scan bij de laatste ¬¬
Wat er exact gebeurde: simple-scan gaf de melding kan scanner niet vinden. Daarna vrijwel gelijk crash.
Scanner doet het verder wel weer gewoon.

EDIT: Het lijkt opgelost te zijn: resolutie veranderen, pc aantal keer opnieuw opstarten (Ctrl + Alt + Backspace is niet genoeg!)
« Laatst bewerkt op: 2011/10/02, 10:59:43 door Cheap Applications »
Desktop:
Processor: Intel® Core™2 Quad CPU Q8300 @ 2.50GHz × 4, Geheugen: 3.9Gb, GPU: nVidia 220GT OS: Windows 7 64 bit / Ubuntu 12.04 64 bit
Notebook:
Processor: Intel® Core™ i7-4700MQ, Geheugen: 8Gb, GPU: nVidia GTX765m (met Optimus) OS: Windows 8 64 bit / Elementary OS Luna 64 bit