Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Distributie update?!  (gelezen 863 keer)

Offline Carharttguy

  • Lid
  • Steunpunt: Nee
Distributie update?!
« Gepost op: 2011/09/23, 14:51:43 »
Hallo!

ik kreeg vandaag zo'n ventstertje voor te updaten, wat ik gedaan heb. Maar blijkbaar was er een conflict ofzo, en er moesten wat pakketten verwijderd worden. Dat heb ik dus gedaan (uit goed vertrouwen) Nu blijkt dat er eigenlijk pakketten weg zijn die ik niet weg wou (waaronder empathy)

Het kan toeval zijn of niet, maar ik heb gisteren of eergisteren de telepathy PPA toegevoegd zodat mijn empathy eens zou updaten. Nu denk ik dat dat de boosdoener is. Want ik vond het al raar dat die update, niet gewoon update maar 'distributie update' noemde.

Nu krijg ik empathy ook niet meer geinstalleerd uit USC, want er zijn depency fouten:

Citaat
De afhankelijkheden van de volgende pakketten konden niet geïnstalleerd worden:

empathy: Depends: libchamplain-0.10-0 (>= 0.9.0) maar het zal niet worden geïnstalleerd
         Depends: libchamplain-gtk-0.10-0 (>= 0.9.0) maar het zal niet worden geïnstalleerd
         Depends: libcheese-gtk20 (>= 3.0.1) maar het zal niet worden geïnstalleerd
         Depends: libgcr-3-0 (>= 2.91.4) maar het zal niet worden geïnstalleerd
         Depends: libgnome-control-center1 (>= 1:2.91.2) maar het zal niet worden geïnstalleerd
         Depends: libgudev-1.0-0 (>= 147) maar 1:167-0ubuntu3 zal worden geïnstalleerd
         Depends: empathy-common (= 3.1.91-1~ppa11.04+1) maar 3.1.91-1~ppa11.04+1 zal worden geïnstalleerd

Nu zie ik die PPA duidelijk staan in USC, maar ik krijg die dus gewoonweg niet verwijderd, ik weet niet hoe ik die moet wegkrijgen uit USC, zodat ik weer de gewone repo's kan gebruiken. Iemand een idee?

Bij voorbaat dank.

Offline Carharttguy

  • Lid
  • Steunpunt: Nee
Re: Distributie update?!
« Reactie #1 Gepost op: 2011/09/23, 14:53:36 »
Update: Ik heb de softwarebron dus wel weggekregen, maar de foutmelding blijft jammer genoeg :(
Dus ik zoek nog een manier om die update op 1 of andere manier terug te draaien.

Offline dellkubuntu

  • Lid
  • Steunpunt: Nee
Re: Distributie update?!
« Reactie #2 Gepost op: 2011/09/23, 14:54:21 »
Ook niet in synaptic onder 'software van derden'?Als het goe d is moet daar de ppa tussenstaan en kun je hem daar verwijderen.
edit:ik zie net dat je dus de softwarebron al verwijderd hebt. ;)
Kloppen de overige softwarebronnen nog wel,staan die op je huidige distroversie?
« Laatst bewerkt op: 2011/09/23, 14:56:37 door dellkubuntu »

Offline Carharttguy

  • Lid
  • Steunpunt: Nee
Re: Distributie update?!
« Reactie #3 Gepost op: 2011/09/23, 15:02:24 »
Ja, jammer genoeg wel, staan allemaal op Natty, en die heb ik.

Nog even versienummer meegeven die ik heb:

Uitgave 11.04 (natty)
Kernel Linux 2.6.38-11-generic-pae

Ik denk dat ik door die ppa te installeren echt wel wat fout heb gedaan :')

Edit: Ik heb ondertussen alle overbodige ppa's weg gedaan (ook die van PySide die ik had)
En nog eens update gedaan enzo.

Nu ziet de foutmelding er als volgt uit:

Citaat
De afhankelijkheden van de volgende pakketten konden niet geïnstalleerd worden:

empathy: Depends: libcamel1.2-19 (< 2.33) maar 2.32.2-0ubuntu2 zal worden geïnstalleerd
         Depends: libnspr4 (>= 4.7.0~1.9b1) maar 4.8.7-0ubuntu1 zal worden geïnstalleerd
         Depends: libnss3 (>= 3.12.2~rc1) maar 3.12.9+ckbi-1.82-0ubuntu2.1 zal worden geïnstalleerd
         Depends: libsqlite3-0 (>= 3.7.3) maar 3.7.4-2ubuntu5 zal worden geïnstalleerd
         Depends: libunity4 (>= 3.4.6) maar 3.8.4-0ubuntu1 zal worden geïnstalleerd
         Depends: empathy-common (= 2.34.0-0ubuntu3.1) maar 3.1.91-1~ppa11.04+1 zal worden geïnstalleerd

Overigens snap ik niet wat het probleem is, want de meeste versies die ik in de foutmelding zie, zijn nieuwer dan nodig...
Overigens vind ik het raar dat de laatste zin er staat:

Depends: empathy-common (= 2.34.0-0ubuntu3.1) maar 3.1.91-1~ppa11.04+1 zal worden geïnstalleerd

Want ik heb de ppa al verwijderd, of moet ik nog iets doen om dat in z'n werking te laten gaan?
« Laatst bewerkt op: 2011/09/23, 15:07:26 door Carharttguy »

Offline maasnet

  • Lid
    • m-vd-hoeven
  • Steunpunt: Ja
Re: Distributie update?!
« Reactie #4 Gepost op: 2011/09/23, 15:05:32 »
Kan je niet bij Synaptic en dan --> Bestand -> Geschiedenis kijken wat er geinstalleerd is
Je ziet wel wat een ander heeft, maar je ziet niet wat hij mist.

OS: Ubuntu Gnome 18.04/Xubuntu 18.04; Windows 10 (dualboot) RPI: Ubuntu Mate; Asus 1005PE: Linux Lite 3.8
***Steunpunt***  voor andere steunpunten: https://kaart.ubuntu-nl.org/

Offline Carharttguy

  • Lid
  • Steunpunt: Nee
Re: Distributie update?!
« Reactie #5 Gepost op: 2011/09/23, 15:08:55 »
Kan je niet bij Synaptic en dan --> Bestand -> Geschiedenis kijken wat er geinstalleerd is

Als ik dat bekijk, zie ik alleen dingen staan die ik handmatig heb geïnstalleerd in Synaptic, en de oudste is daar van 9 dagen geleden. Jammer genoeg.

Offline maasnet

  • Lid
    • m-vd-hoeven
  • Steunpunt: Ja
Re: Distributie update?!
« Reactie #6 Gepost op: 2011/09/23, 15:11:54 »
Niet geschoten is altijd mis :-)

Dit al geprobeerd sudo dpkg --configure -a
Je ziet wel wat een ander heeft, maar je ziet niet wat hij mist.

OS: Ubuntu Gnome 18.04/Xubuntu 18.04; Windows 10 (dualboot) RPI: Ubuntu Mate; Asus 1005PE: Linux Lite 3.8
***Steunpunt***  voor andere steunpunten: https://kaart.ubuntu-nl.org/

Offline Carharttguy

  • Lid
  • Steunpunt: Nee
Re: Distributie update?!
« Reactie #7 Gepost op: 2011/09/23, 16:03:13 »
Helaas zie ik bij dat commando niets zichtbaars gebeuren, dus ik weet ook niet of het gewerkt heeft.
Toch bedankt dat je meedenkt.

Als ik via terminal wat apt-get:

Citaat
mathias@mathias-Satellite-L670:~$ sudo apt-get install empathy
[sudo] password for mathias:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
De status informatie wordt gelezen... Klaar
Sommige pakketten konden niet geïnstalleerd worden. Dit kan betekenen dat u
een onmogelijke situatie gevraagd hebt of dat u de 'unstable'-distributie
gebruikt en sommige benodigde pakketten nog vastzitten in 'incoming'.
De volgende informatie helpt u mogelijk verder:

De volgende pakketten hebben niet-voldane vereisten:
 empathy : Vereisten: empathy-common (= 2.34.0-0ubuntu3.1) maar 3.1.91-1~ppa11.04+1 zal geïnstalleerd worden
           Aanbevelingen: nautilus-sendto-empathy maar het zal niet geïnstalleerd worden
E: Niet-werkende pakketten:

Hij blijft dus proberen versie 3.1.91 binnen te trekken, al weet ik niet van waar, want ik heb de ppa uit mijn softwarebronnen verwijderd.

Offline maasnet

  • Lid
    • m-vd-hoeven
  • Steunpunt: Ja
Re: Distributie update?!
« Reactie #8 Gepost op: 2011/09/23, 17:56:42 »
Heb je misschien ook iets van GETDEB bij de softwarebronnen staan?

Van de week had ik ongeveer hetzelfde met pidgin.

Ik heb toen die software bron uitgezet en vervolgens genoemde opdracht (sudo dpkg --configure -a) gegeven.

Kan je anders je sources.list hier eens posten.

Je ziet wel wat een ander heeft, maar je ziet niet wat hij mist.

OS: Ubuntu Gnome 18.04/Xubuntu 18.04; Windows 10 (dualboot) RPI: Ubuntu Mate; Asus 1005PE: Linux Lite 3.8
***Steunpunt***  voor andere steunpunten: https://kaart.ubuntu-nl.org/

Offline Carharttguy

  • Lid
  • Steunpunt: Nee
Re: Distributie update?!
« Reactie #9 Gepost op: 2011/09/23, 19:45:02 »
Dit is mijn sources.list:

# deb cdrom:[Ubuntu 11.04 _Natty Narwhal_ - Release i386 (20110427.1)]/ natty main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://be.archive.ubuntu.com/ubuntu/ natty main restricted
deb-src http://be.archive.ubuntu.com/ubuntu/ natty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://be.archive.ubuntu.com/ubuntu/ natty-updates main restricted
deb-src http://be.archive.ubuntu.com/ubuntu/ natty-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://be.archive.ubuntu.com/ubuntu/ natty universe
deb-src http://be.archive.ubuntu.com/ubuntu/ natty universe
deb http://be.archive.ubuntu.com/ubuntu/ natty-updates universe
deb-src http://be.archive.ubuntu.com/ubuntu/ natty-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://be.archive.ubuntu.com/ubuntu/ natty multiverse
deb-src http://be.archive.ubuntu.com/ubuntu/ natty multiverse
deb http://be.archive.ubuntu.com/ubuntu/ natty-updates multiverse
deb-src http://be.archive.ubuntu.com/ubuntu/ natty-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://be.archive.ubuntu.com/ubuntu/ natty-backports main restricted universe multiverse
# deb-src http://be.archive.ubuntu.com/ubuntu/ natty-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu natty-security main restricted
deb-src http://security.ubuntu.com/ubuntu natty-security main restricted
deb http://security.ubuntu.com/ubuntu natty-security universe
deb-src http://security.ubuntu.com/ubuntu natty-security universe
deb http://security.ubuntu.com/ubuntu natty-security multiverse
deb-src http://security.ubuntu.com/ubuntu natty-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu natty partner
# deb-src http://archive.canonical.com/ubuntu natty partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu natty main
deb-src http://extras.ubuntu.com/ubuntu natty main

Ik zie niet veel speciaal, maar ik ken er wel niet veel van :)

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Distributie update?!
« Reactie #10 Gepost op: 2011/09/23, 20:24:23 »
Start 'Updatebeheer' en klik linksonder op de knop "Instellingen". Kijk daar in tabblad "Updates" of enkel de eerste twee Ubuntu-updates aangevinkt zijn. Als ook de andere aangevinkt zijn, vink ze dan uit.

Onder tabblad "Overige Software" vind je alle andere. Vink alles uit en herlaad. Sluit dan de softwarebronnen en kies voor "controleren". Geeft dit geen error (en wel eventuele updates) installeer dan de updates.

Daarna kan je weer naar de Instellingen gaan en onder het tabblad "Overige Software" telkens één vinkje zetten en terug laten controleren. De vinkjes naast de source moet je niet aanvinken. (degene waar het volgende aan toegevoegd is: (Brondcode)) Dat dient enkel geloof ik als je de source pakketten ook wil om deze te kunnen aanpassen of zo maar die zijn niet nodig om gewoon met Ubuntu te werken.

Na iedere controle zal je zo hopelijk te zien krijgen waar de fout zit.

Wel even wat werk maar zo kan je alles checken.

Zo'n tussentijdse upgrade kan je beter negeren. In het verleden hebben meerdere (ook ik) er last mee gehad.