Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Opgelost] canon mp560 64 bit  (gelezen 5145 keer)

Offline diplomsommelier

  • Lid
  • Steunpunt: Nee
[Opgelost] canon mp560 64 bit
« Gepost op: 2011/09/17, 09:07:57 »
Hallo Ubunters,

Omdat ik konstant aan het uitproberen ben en vele fouten maak heb ik gisteren alles opnieuw moeten installeren.
Ubuntu 11.04 64 bit. in de Virtualbox Windows 7 64 bit.

Alles werkt perfekt behalve mijn canon printer, wordt wel gezien door de simple scan en scant ook werkelijk maar kan niks printen.
Hoe is dat mogelijk als printer wordt hij niet gezien als simple scan wel.

Verder hoe kan ik printen vanuit de virtual box.

bedankt maar weer

diplomsommelier
« Laatst bewerkt op: 2011/09/24, 12:24:00 door diplomsommelier »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: canon mp560 64 bit
« Reactie #1 Gepost op: 2011/09/17, 16:04:33 »
Heb je wel alle poorten geactiveerd in de Virtualbox onder instellingen?
In der Beschränkung zeigt sich der Meister.

Offline diplomsommelier

  • Lid
  • Steunpunt: Nee
Opgelost MP560 Printer Canon
« Reactie #2 Gepost op: 2011/09/20, 11:16:15 »
Hallo Ubunters,
Bedankt voor de hulp printer MP560 Canon. Het is me niet gelukt via de diverse aanleidingen te programmeren in de Terminal.
Maar ik heb het anders opgelost.
Ubuntu 11.04 64 bit
in de Virtualbox Windows 7 64 bit daarin geinstalleerd de MP560 drivers als Netwerk printer aangesteld en het print.
door de Dokumenten in Ubuntu te verbinden met Windows in de Virtrualbox kan ik toegrijpen op mijn files ze normaal bewerken en printen.
Wellicht een idee voor de anderen een beetje omslachtig maar het werkt.

groeten vanuit een sneeuwrijk Oostenrijk

diplomsommelier

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: Opgelost MP560 Printer Canon
« Reactie #3 Gepost op: 2011/09/20, 12:44:13 »
Meld dit voortaan graag ff bij de betreffende topic.
Dit maakt de wirwar van topcs alleen groter.
Edit: (Is nu bijgesteld)

Ik ben alleen een beetje verward met de berichten.
Was het probleem specifiek om in VirtualBox de printer op windows te installeren?
Of was het probleem om de printer in Ubuntu te installaren?

Dat laatste is mij kort geleden prima gelukt.  ;)
« Laatst bewerkt op: 2011/09/20, 13:12:01 door Erik Krom »

Offline Brumm3l

  • Lid
  • Steunpunt: Nee
Re: canon mp560 64 bit
« Reactie #4 Gepost op: 2011/09/20, 13:04:32 »
Ik heb de topics even samengevoegd en de titel aangepast met [Opgelost].

Offline diplomsommelier

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] canon mp560 64 bit
« Reactie #5 Gepost op: 2011/09/20, 13:12:54 »
Hallo Erik,

Het probleem was de Printer in Ubuntu 64 bit te installeren.
Kan niet goed porgammeren dat is nog een stap te ver.
Maar als je een goede beschrijving heb hoe ik dat moet doen.
Ga ik het weer proberen.

Verder weet ik niet of ik alle poorten heb geopend in Virtualbox Windows 7 64 bit
ik kan in mijn files kijken die in Ubuntu One staan en deze in de
Virtuelebox bewerken en printen.
Moet ook nog de USB stick zien te krijgen in de VB.

Bedankt zover

Diplomsommelier

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] canon mp560 64 bit
« Reactie #6 Gepost op: 2011/09/20, 14:33:48 »
Ik weet dat heir4c bezig is met een handleiding.
Ik kan hem ff niet zo snel vinden.

Met de zoek opdracht vond ik wel dat dat je printer wel geïnstalleerd hebt gekregen op een 32-bits Ubuntu.
Dit heb je waarschijnlijk gedaan met de driver die je van canon hebt gedownload. (MP560_debian_driver_pack.tar)

- Dit bestand kan je opennen (dan hoort hij te openen met archiefbeheer.)
- Navigeer naar de .deb bestanden. Deze zitten helaas een beetje wegestopt.
- Kopieer deze .deb bestanden naar een map.

Open een terminal en navieer naar de map waar de .deb bestanden staan.
cd [pad naar de map]Om te controleren welke bestanden en mappen er in die map zitten kan je gebruiken:
ls
Heb je de juiste map gebruik dan het volgende commando.
sudo dpkg -i --force-architecture [het .deb bestand]
Doe eerst de '...common...deb' en daarna de '...mp560series...deb'.

Note: tussen de [] moet natuurlijk de juiste bestand of pad worden aangegeven.

Dit is ff de meest korte beschrijving.

Voor usb moet aleen nog de kabel insteken.
Voor het netwerk moet je de printer nog appart toevoegen.
(Maar heb nu ff geen tijd om dat nog bij te typen.)

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] canon mp560 64 bit
« Reactie #7 Gepost op: 2011/09/20, 18:45:17 »
Het uitpakken van het .tar bestand doe je best in je Persoonlijke Map. Als je dan een commando ingeeft moet je niet het lange pad/adres naar dat bestand ingeven. En zo staan je drivers ook niet tussen andere documenten of zo.
Dubbelklikken op de .deb pakketten zorgt ervoor dat deze automatisch geïnstalleerd worden.


Indien je bij het installeren van het 'common' pakket een foutmelding krijgt in verband met het pakket 'libcupsys2', dan kan je hier naar mijn howto kijken:
http://forum.ubuntu-nl.org/documentatie/howto-ip-2600/



Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] canon mp560 64 bit
« Reactie #8 Gepost op: 2011/09/20, 19:47:44 »
Hier de hervatting van mijn verhaal.
Voor netwerkprinters is het installeren van de drivers niet genoeg.

- Zorg er voor dat de printer aan staat en verbinding heeft met het netwerk.
- Open Systeem>Beheer>Afdrukken kiest u voor toeoegen. (Bij Unity kunt u met de dash gewoon zoeken naar Afdrukken)
- Kies voor toevoegen.
- klap de netwerk printers uit.
- Ff wachten en dan hoort de canon er vanzelf te voorschijn te komen.
- Selecteer deze en werk de wizard verder af.

Het uitpakken van het .tar bestand doe je best in je Persoonlijke Map. Als je dan een commando ingeeft moet je niet het lange pad/adres naar dat bestand ingeven. En zo staan je drivers ook niet tussen andere documenten of zo.
Dubbelklikken op de .deb pakketten zorgt ervoor dat deze automatisch geïnstalleerd worden.
In dit geval werkt dat alleen bij 32-bit Ubuntu. Bij een 64-bits komt de melding dat het niet kan.
Hiervoor is die force-architecture nodig.

Citaat
Indien je bij het installeren van het 'common' pakket een foutmelding krijgt in verband met het pakket 'libcupsys2', dan kan je hier naar mijn howto kijken:
http://forum.ubuntu-nl.org/documentatie/howto-ip-2600/
Kijk die zocht ik.  :D
Eens kijken of ik nog wat vind missen.
« Laatst bewerkt op: 2011/09/20, 19:53:34 door Erik Krom »

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] canon mp560 64 bit
« Reactie #9 Gepost op: 2011/09/20, 20:12:21 »

In dit geval werkt dat alleen bij 32-bit Ubuntu. Bij een 64-bits komt de melding dat het niet kan.
Hiervoor is die force-architecture nodig.

Bedankt voor de info, dat wist ik niet.
Als je wil kan je die info meedelen in een apart bericht in mijn topic. Dat kan ik dan later toevoegen als ik het op de wiki zet.
ThanX

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] canon mp560 64 bit
« Reactie #10 Gepost op: 2011/09/20, 21:34:01 »
Tuurlijk is het prima als je dit meedeelt in je topic. :D
Graag zelfs.

Ff een opmerking over de force-architecture.
Voor onbeproefde .deb bestanden kan het een risico zijn.
Het kan zelfs je systeem zo zwaar ontregelen dat er een herinstallatie van Ubuntu nodig is.

De MP560 is nu gelukkig wel beproeft.

Offline diplomsommelier

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] canon mp560 64 bit
« Reactie #11 Gepost op: 2011/09/22, 11:49:39 »
Hallo Erik,

Alles geprobeerd met howto enzovoort met force architecture niks lukt krijg alleen maar foutmeldingen met o.a. gebruik aptitude.???
Opent met Software Centeer en geeft dan aan foute architecture i386-
Ziet de printer wel maar drukt niks ook niet via usb ziet natuurlijk niet de common of de andere file.. Kan wel een scan maken.
Zal wel aan mijn onkunde met programmeren te doen hebben.
Kan wel printer via VMBox waarin Windows7 64bit staat.
Wellicht kan ik toch beter een HP kopen
groeten

diplomsommelier

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: [Opgelost] canon mp560 64 bit
« Reactie #12 Gepost op: 2011/09/22, 11:58:00 »
HP heeft inderdaad de beste Linux-ondersteuning en bijna elke HP-printer werkt out-of-the box! :)

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] canon mp560 64 bit
« Reactie #13 Gepost op: 2011/09/22, 12:56:12 »
Post de exacte foutmelding.

De melding van het Softwate Center klopt.
Dit is precies wat je met force-architecture moet omleiden.

Offline diplomsommelier

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] canon mp560 64 bit
« Reactie #14 Gepost op: 2011/09/24, 10:30:30 »
Hallo Erik en andere Ubunters,

MP560 aangesloten via USB
Als scanner werkt hij wel (via WLAN)
In de virtualbox met Windows 64 bit Netwerkprinter werkt hij ook (via WLAN)

Gedownload cnijfilter geopend in persoonlijke order (mp560) uitgepakt dubbel geklikt dan geopend met
Download centrum fout melding niet geschikt 64 bit.

Ingegeven in Terminal:sudo dpkg-i --force-architecture cnijfilter-common_3.20-1_i386.deb

Foutmelding in Terminal:
dpkg: fout bij het verwerken van de cnijfiltere-common_3.20-1_i386 (install): het archief kan niet geopend worden
datei niet gevonden
fouten bij het verwerken van cnijfilter-common_3.20-1_i386.

kunnen jullie daar wat mee????

 groeten
diplomsommelier

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] canon mp560 64 bit
« Reactie #15 Gepost op: 2011/09/24, 10:49:19 »
Verander eens de naam van het pakket. De i386 moet je veranderen in amd64 omdat je een 64bit systeem hebt.
Installeer het nu nog eens via dat commando.
Gaat dit?

Zo niet, hernoem het pakket terug naar de oude staat en volg deze howto: http://ubuntuforums.org/showpost.php?p=9261461&postcount=26
Let wel op!!! De namen van de pakketten moet je wel aanpassen aan jouw pakketten.
Het commando waarna je het woordje libcupsys2 moet veranderen in libcups2: Daar moet je kijken of het al dan niet moet veranderd worden. Is het al libcups2 dan zit het goed, volg gewoon dan verder de commando's. Je kan ook mijn howto volgen maar ik heb wel de i386 behouden, bij die commando's moet je dan wel amd64 gebruiken.

Heb zelf geen 64bit computer anders zou ik de drivers even installeren op mijn systeem om uit te testen.

Ter info:
Uitpakken dus in je Persoonllijke Map i.v.m. de commando's (Zoals gezegd heb je dan minder in te tikken en moet je niet nog eens bijvoorbeeld /Download ofzo bijvoegen, zo ook bij al die andere commando's zou je dan het pad naar de map waarin je het pakket gezet hebt erbij moeten voegen. Dus we gaan voor het gemak en dus de Persoonlijke Map)

Offline diplomsommelier

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] canon mp560 64 bit
« Reactie #16 Gepost op: 2011/09/24, 12:23:36 »
Heir4c,

Goedemiddag,

Ik heb dit ook geprobeerd krijg konstant foutmelding.
het is voor mij schijnbaar te moeilijk ivb programmeren omdat ik daar geen bal verstand van heb.
Ik print voorlopig via de Viturelebox en ga volgende week een HP Printer kopen.
Hartelijk dank voor alles ik meld me weer

diplomsommelier

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] canon mp560 64 bit
« Reactie #17 Gepost op: 2011/09/24, 13:04:59 »
Dat heeft niets te maken met programmeren.
Enkel met terminal en commando's. Dat is nog niet programmeren.
Ikzelf kan helemaal niet programmeren hoor.
Kan je nog even aangeven waar je de driver download en welke het precies is. Dan test ik het hier even uit. Wel de 32bit versie maar dan kan ik even kijken of die libcupsys2 reeds als libcups2 staat en kan ik je misschien wel een kleine howto meegeven hieronder.

Offline diplomsommelier

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] canon mp560 64 bit
« Reactie #18 Gepost op: 2011/09/24, 13:39:10 »
Hallo Heir4c,

Debian Linux Print Driver  www.canon.de  Linux.
Ik moet nu weer aan het werk dus kan ik vandaag niks meer doen
bedankt weer

diplomsommelier

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] canon mp560 64 bit
« Reactie #19 Gepost op: 2011/09/25, 10:04:56 »
Er zijn al problemen bij het openen en inlezen van de .deb.
Als de 32 v.s 64 bit het probleem was. Dan was er een melding in die trant.

Het kan zijn dat het bestand ergens beschadigd is geraakt.
Dit kan tijdens de download of het uitpakken zijn gebeurd.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] canon mp560 64 bit
« Reactie #20 Gepost op: 2011/09/25, 10:38:41 »
Deze downloaden en laten openen met Archiefbeheer:
http://www.canon.de/Support/Consumer_Products/products/Fax__Multifunctionals/InkJet/PIXMA_MP_series/MP560.aspx?DLtcmuri=tcm:83-728013&page=1&type=download
Een beetje naar beneden scrollen en het vinkje plaatsen en op "Herunterladen" klikken.

Kiezen voor openen met Archiefbeheer.

Dubbelklik op 'cnijfilter-mp560series-3.20-1-i386-deb.tar.gz. Dubbelklik nog verder tot je bij twee pakketten komt:



Selecteer het bovenste pakket en klik op de knop "uitpakken" en kies dan voor je Persoonlijke Map. klik op uitpakken rechtsonderaan en dan komt dit pakket in je Persoonlijke Map.
Doe hetzelfde met het andere pakket.
Sluit het venster van 'Archiefbeheer'.


Open nu een terminal (Ctrl+Alt+T)
Tik in (of Kopieer en Plak):
dpkg-deb -x cnijfilter-common_3.20-1_i386.deb common(Klik Enter)

Volgende:
dpkg-deb --control cnijfilter-common_3.20-1_i386.deb
Normaal gezien openen we in de editor gedit het bestand DEBIAN/control om de aanpassing van het woord libcupsys2 door te voeren met het commando:
gedit DEBIAN/controlIk ben nagegaan of het pakket juist vermeld is libcups2 i.p.v. libcupsys2 en dat is in orde, dus dat hoef je niet te veranderen. Dus in zekere zin hoef je bovenstaand commando niet uit te voeren en kan je dit gerust overslaan. Je kan het echter wel doen omdat je dan kan zien wat je in sommige gevallen wel moet veranderen.

We maken het operating bestand tot een pakket:
mv DEBIAN/ common/
We zetten de rechten goed:
sudo chown -R root.root commonWachtwoord zal gevraagd worden.

We verwijderen  het oude pakket:
rm cnijfilter-common_3.20-1_i386.deb
En we maken een nieuw:
Let dus hier op, je moet hier de i386 veranderen in amd64:
dpkg -b common/ cnijfilter-common_3.20-1_amd64.deb



Het zelfde voor het tweede pakket:
dpkg-deb -x cnijfilter-mp560series_3.20-1_i386.deb mp560(Je ziet dat het pakket vermeld word en dat daar achter mp560 staat. Dat zal de naam zijn van de map die aangemaakt word, net zoals bij het eerste pakket er common achter stond en je de map common daarna kon terug vinden in je Persoonlijke Map)

dpkg-deb --control cnijfilter-mp560series_3.20-1_i386.deb
Hier net hetzelfde met het volgende commando. Dat hoef je dus niet uit te voeren omdat het pakket libcups2 reeds vermeld staat.
gedit DEBIAN/control(Dit kan je dus gerust overslaan)

Volgende:
mv DEBIAN/ mp560/sudo chown -R root.root mp560rm cnijfilter-mp560series_3.20-1_i386.debdpkg-deb -b mp560/  cnijfilter-mp560series_3.20-1_amd64.debHier verander je ook weer de i386 in amd64.


We installeren de pakketten:

sudo dpkg -i --force-architecture cnijfilter-common_3.20-1_amd64.deb cnijfilter-mp560series_3.20-1_amd64.deb(Je ziet de twee pakketten achter elkaar vermeld)


Nu zou de drivers geïnstalleerd moeten zijn.

Ik kan ze zelf niet installeren met die amd64 in de pakket namen dus ik kan het niet uitproberen of hij goed installeerd.

Nu kan je in mijn howto zelf de Volgende stappen uitvoeren. http://forum.ubuntu-nl.org/documentatie/howto-ip-2600/
De instructies zijn dus wel voor de ip2600 maar die naam moet je dan maar telkens veranderen naar je eigen printer namelijk de mp560.
Ook zijn de instructies voor de desktop omgeving met gnome2 (dus in 10.04), dus je zal even in 11.04 moeten zoeken waar dat "Afdrukken" ergens staat.

Hopelijk ben je met deze mini howto een eind op weg en werkt het nu. Laat zeker iets weten of het gelukt is.

Met vriendelijke groet,
heir4c

Offline diplomsommelier

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] canon mp560 64 bit
« Reactie #21 Gepost op: 2011/09/26, 10:16:48 »
Hallo heirc4,
Met het common pakket is het gelukt met de mp560 series niet geeft foutmelding

verplaatsen van DEBIAN naar mv DEBIAN niet mogelijk geen rechten daarvoor.

wat heb ik fout gedaan???


diplomsommelier

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] canon mp560 64 bit
« Reactie #22 Gepost op: 2011/09/28, 18:37:43 »
Heb het hier even uitgeprobeerd (wel met i386 i.p.v. amd64) en de driver installeerde zich hier prima.
Misschien ergens iets fout overgtypt?
Misschien nog eens alles over doen? Dus verwijder de map mp560 (Open wel eerst nautilus met root rechten via Alt+F2 en tik daar in: gksudo nautilus
Als je dit niet doet dan kan je die map niet verwijderen)

Doe dan alle commando over die te maken hebben met het tweede pakket.

Offline diplomsommelier

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] canon mp560 64 bit
« Reactie #23 Gepost op: 2011/09/28, 22:13:40 »
Hallo heir4c,

Overgedaan wie door u gezegd tot nu toe gelukt ik ga nu verder met howto
weer bedankt zover.

diplomsommelier

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: [Opgelost] canon mp560 64 bit
« Reactie #24 Gepost op: 2011/09/28, 22:16:41 »
Ok, goed om horen dat het nu wel gelukt is.
En graag gedaan.

Met vriendelijke groet,
heir4c