Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] Probleem met mijn dual-boot (Ubuntu/Win7)  (gelezen 1145 keer)

Offline Antique

  • Lid
  • Steunpunt: Nee
[OPGELOST] Probleem met mijn dual-boot (Ubuntu/Win7)
« Gepost op: 2011/08/21, 22:27:57 »
Beste lezer,

Ik gebruik voornamelijk Ubuntu (11.04), maar voor mijn opleiding moet ik af en toe gebruik maken van Windows 7.

Vandaag wilde ik mijn laptop (Packerd bell) terug zetten naar fabrieksinstellingen om zo een schone Windows partitie te hebben naast mijn Ubuntu.
Ik heb nog nooit eerder een laptop die dual boot terug gezet naar fabrieksinstellingen, maar alles leek goed te gaan.
De laptop herstartte zichzelf ..
En normaal, nadat de laptop is opgestart, krijg ik natuurlijk de optie om Ubuntu op te starten of Windows op te starten.
Ubuntu werkt, heerlijk. Maar mijn Windows 7 loader op sda2 en sda3 werken niet meer.
Ik krijg de volgende melding:
Citaat
no such device: AA38F(cijfers en letters)
no such disk

 Druk op een toets om verder te gaan ..
sda1 is de Windows recovery, en ik heb inmiddels een volledig systeemherstel geprobeerd en éen waarbij de gebruikgegevens behouden worden.
maar allebei dus zonder succes.

 Ubuntu kan ik probleemloos gebruiken en daar ben ik ontzettend blij om, want dat is mijn main OS.
Maar heeft iemand enig idee hoe ik nu mijn Windows terug krijg? Want het lijkt erop alsof deze nog wel ergens op mijn hardeschijf staat.
Want Linux en Windows delen deze nog steeds 50/50. Ik heb het hard nodig voor mijn opleiding die binnenkort weer van start gaat.
  Ook vroeg ik me af of iemand enig idee heeft wat dit inhoud, ik zag het terwijl ik mijn systeem probeerde te herstellen:
bron: "E:\D2D\Images\WOP000170OXXTC018.SWM"

Nogmaals, ik zou graag willen weten waar mijn falende OS naartoe is verdwenen,
alvast bedankt voor uw reactie!  :)

Edit 1:
Is er een manier om mijn partities te bekijken en verplaatsen? Ik heb wat gezocht op internet en kwam iets tegen over "GParted" is dat iets waarmee ik dit zou kunnen oplossen?.
Sinds ik heb geprobeerd mijn laptop terug te zetten naar fabrieksinstellingen is Windows namelijk herschreven naar een ander deel op de hardeschijf neem ik aan. Dus daarom het kan niet gevonden worden op sda2 of sda3.
Als het mogelijk is zou ik deze terug willen zetten naar sda2, of desnoods via systeemherstel Windows' bestemming sda2 laten worden.
Want ik had gister gemerkt dat de bestemming "Harddisk0\Partition3" was. En ik weet niet precies waar dit is, en ik kreeg ook niet de kans op deze bestemming te veranderen.

Danku.
« Laatst bewerkt op: 2011/08/22, 17:53:24 door Antique »

Offline DirkJan

  • Lid
  • Steunpunt: Nee
Re: Probleem met mijn dual-boot
« Reactie #1 Gepost op: 2011/08/21, 22:33:29 »
Hallo Antique,

Wellicht kan deze pagina van Pjotr je verder helpen http://sites.google.com/site/computertip/grub

Gaat over het herstellen van GRUB opstartlader en teruggaan naar windows. Met name pt. 2 is denk ik van belang.

Offline Antique

  • Lid
  • Steunpunt: Nee
Re: Probleem met mijn dual-boot
« Reactie #2 Gepost op: 2011/08/21, 22:38:47 »
Hartstikke bedankt voor de snelle reactie en de refferentie  ^-^!
Ik zal er eens in duiken.

Offline Antique

  • Lid
  • Steunpunt: Nee
Re: Probleem met mijn dual-boot
« Reactie #3 Gepost op: 2011/08/22, 00:16:00 »
Ik heb geprobeerd grub te verwijderen met behulp van een usb geheugenstick, omdat ik geen windows installatie CD heb, maar het is me nog niet gelukt.
Op: http://sites.google.com/site/computertip/grub, wordt er gesproken over de usb geheugenstick opstartbaar maken met Freedos door
er testdisk.exe en CWSDPMI.exe op te zetten.
Op de site waar dus naar verwezen wordt (http://www.cgsecurity.org/wiki/TestDisk_Download), heb ik de windows 64-bit versie gedownload. Ik neem aan dat ik die moest hebben aangezien ze over .exe praten en ik op een 64 bit systeem zit.
In het .zip bestand zitten er echter geen "testdisk.exe" en "CWSDPMI.exe", maar "fidentify_win.exe", "photorec_win.exe" en "testdisk_win.exe".
Ik besloot dit te negeren omdat het wellicht om een verouderde handleiding ging op computertip/grub. Naast deze drie .exe bestanden zaten er nog wat .dll en tekst bestanden in de .zip.

Ik heb alles gewoon op de usb stick gezet en vervolgens geprobeerd hiervanuit op te starten.
Hierbij kreeg ik de volgende melding:
Citaat
No default or UI configuration directive found
boot:_

heeft iemand enig idee of ik iets fout heb gedaan, of als ik wel de juiste "testdisk voor DOS" (de win 64-bit versie) op mijn usb heb gezet?
Ik zou ook graag willen achterhalen op welk deel van mijn hardeschijf Linux staat en op welk deel Windows, want mijn Windows schijnt verplaatst te zijn of iets dergelijks want voorheen stond deze op sda2/sda3, maar nu dus niet meer.

Alvast bedankt voor uw antwoord en moeite.  :)
« Laatst bewerkt op: 2011/08/22, 00:19:46 door Antique »

Offline Antique

  • Lid
  • Steunpunt: Nee
Re: Probleem met mijn dual-boot
« Reactie #4 Gepost op: 2011/08/22, 12:43:58 »

Offline DirkJan

  • Lid
  • Steunpunt: Nee
Re: Probleem met mijn dual-boot
« Reactie #5 Gepost op: 2011/08/22, 15:51:04 »
Hier ben ik overvraagd. Heb ooit grub hersteld zoals Pjotr aangeeft op zijn pagina. De noodingreep heb ik nooit gedaan.

Het is ook niet helemaal duidelijk wat je nu in eerste instantie hebt gedaan. Wat bedoel je met terug naar fabrieksinstellingen? Heb je een Windows recovery gedaan vanaf DVD of HDD of is dit iets anders. Windows recovery help nl je Ubuntu installatie om zeep terwijl hier het omgekeerde aan de hand is.

Tenzij anderen nog ander opties aandragen zou ik het volgende doen:
- Booten vanaf Ubuntu CD of  USB;
- Data van windows en linuxpartitie veiligstellen op externe HDD
- Windows recovery (opnieuw installeren dus)
- Ubuntu opnieuw installerenAntique,

N.B. Om te beginnen kun je eens via de live sessie nagaan of alle partities nog worden herkend en wat waar staat.

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: Probleem met mijn dual-boot
« Reactie #6 Gepost op: 2011/08/22, 17:20:01 »
Een back-up van je data is natuurlijk erg belangrijk. Zeker er nu op glad ijs wordt bevonden.

Verder:
Beste lezer,

Ik gebruik voornamelijk Ubuntu (11.04), maar voor mijn opleiding moet ik af en toe gebruik maken van Windows 7.

Vandaag wilde ik mijn laptop (Packerd bell) terug zetten naar fabrieksinstellingen om zo een schone Windows partitie te hebben naast mijn Ubuntu.
Ik heb nog nooit eerder een laptop die dual boot terug gezet naar fabrieksinstellingen, maar alles leek goed te gaan.
De laptop herstartte zichzelf ..
En normaal, nadat de laptop is opgestart, krijg ik natuurlijk de optie om Ubuntu op te starten of Windows op te starten.
Ubuntu werkt, heerlijk. Maar mijn Windows 7 loader op sda2 en sda3 werken niet meer.
Ik krijg de volgende melding:
Citaat
no such device: AA38F(cijfers en letters)
no such disk
 

Het lijkt erop dat het adres dat grub gebruikt voor je windows partitie niet meer bestaat.
Het kan natuurlijk zo zijn dat dit adres is gewijzigd door de recovery.

De instellingen van grub moeten dus worden geüpdatet.
Dit kan je als het goed is gewoon vanuit je bestaande Ubuntu doen.
Open een terminal en voet het volgende commando uit.
sudo update-grubVoer je wachtwoord in. Het klopt dat er niets te zien is als je dit doet.
« Laatst bewerkt op: 2011/08/22, 17:21:36 door Erik Krom »

Offline Antique

  • Lid
  • Steunpunt: Nee
Re: Probleem met mijn dual-boot
« Reactie #7 Gepost op: 2011/08/22, 17:33:37 »
@DirkJan
Excuses ja, ik heb nooit vermeld hoe ik mijn laptop heb geprobeerd terug te stellen naar fabrieksinstellingen.
Ik heb dit (zoals dit bij Packerd Bells gaat) met alt + f4 gedaan nog voordat grub opstart.
En inderdaad is hier juist het geval dat Ubuntu het gewoon doet, maar Windows niet meer.

Alle partities bestaan nog, maar zoals Erik Krom al zegt, denk ik ook gewoon dat windows niet meer op het adress bestaat waar grub denkt dat het is. Ik heb met GParted mijn partities bekeken, en het adres (of root) van de ntfs partities komen niet overeen met wat grub aangeeft.

Ik zal eerst proberen grub te updaten, en anders jouw advies opvolgen.

@Erik Krom
Ik zal nu grub proberen up te daten.

Dankuwel voor jullie reacties.
« Laatst bewerkt op: 2011/08/22, 17:52:36 door Antique »

Offline Antique

  • Lid
  • Steunpunt: Nee
Re: Probleem met mijn dual-boot
« Reactie #8 Gepost op: 2011/08/22, 17:51:46 »
Citaat
Het lijkt erop dat het adres dat grub gebruikt voor je windows partitie niet meer bestaat.
Het kan natuurlijk zo zijn dat dit adres is gewijzigd door de recovery.

De instellingen van grub moeten dus worden geüpdatet.
Dit kan je als het goed is gewoon vanuit je bestaande Ubuntu doen.
Open een terminal en voet het volgende commando uit.
sudo update-grubVoer je wachtwoord in. Het klopt dat er niets te zien is als je dit doet.

Dit doet wonderen. Het heeft gewerkt! De adressen van mijn partities zijn geupdate en ik kan mijn Windows weer booten en mijn Ubuntu doet het ook nog gewoon :)

Hartstikke bedankt Erik Krom en DirkJan voor al jullie hulp en moeite!

Iedereen onthouden dus:
sudo update-grubBij een soortgelijk probleem
« Laatst bewerkt op: 2011/08/24, 17:11:32 door Antique »

Offline DirkJan

  • Lid
  • Steunpunt: Nee
Re: [OPGELOST] Probleem met mijn dual-boot (Ubuntu/Win7)
« Reactie #9 Gepost op: 2011/08/23, 10:57:21 »
@Erik , weer wat geleerd, dat het zo simpel kan zijn....

@Antique , graag gedaan, wel blij dat Erik een makkelijker oplossing wist aan te dragen. Succes.