Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: fouten bij samba-common, smbclient en samba-common-bin  (gelezen 1005 keer)

Offline T.W. van den Haak

  • Lid
  • Steunpunt: Nee
fouten bij samba-common, smbclient en samba-common-bin
« Gepost op: 2011/08/11, 14:59:01 »
Wie kan mij helpen?


Als ik uit het Ubuntu software centrum programma's wil installeren lukt dat niet.
Ik krijg dan steeds de melding dat er een systeemfout is:

samba-common, smbclient en samba-common-bin niet geconfigureerd kunnen worden.

Herinstallatie levert de volgende reactie op:
E: samba-common: subproces installed post-installation script gaf een foutwaarde 10 terug
E: samba-common-bin: vereistenproblemen - blijft ongeconfigureerd
E: smbclient: vereistenproblemen - blijft ongeconfigureerd

Herkent iemand dit probleem? Wat kan ik doen?

Bij voorbaat dank voor de eventueel gegeven adviezen

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: fouten bij samba-common, smbclient en samba-common-bin
« Reactie #1 Gepost op: 2011/08/11, 18:59:20 »
Start eerst even de computer weer op en kies in het grubmenu voor de tweede regel (de recovery mode). Na de lap tekst die voorbij vliegt krijg je een menu te zien. Daar staat iets in verband met gebroken pakketten herstellen. Selecteer en druk op Enter.

Als je daarna weer het menu te zien krijgt kies je voor de optie "rootshell met internet verbinding".
Onderaan krijg je een 'prompt' te zien. Tik daar achter:
apt-get update && apt-get upgrade(hier moet je géén sudo gebruiken omdat je reeds als root werkt.)
Nadat de computer zijn werk heeft gedaan, en je weer het menu ziet klik dan gewoon op enter om verder op te starten.

Laat iets weten of dat dit het probleem oplost.

Offline Tom

  • Lid
  • Steunpunt: Nee
Re: fouten bij samba-common, smbclient en samba-common-bin
« Reactie #2 Gepost op: 2011/08/11, 20:07:12 »
Ik heb geen samba , en geen samba-common-bin  op mijn pc staan en toch heb ik geen enkel probleem om iets te installeren vanuit het software centre.
Het enige wat er op staat is samba-common anders gaat mijn xubuntu desktop er van door.

smbclient die staat er ook nog op.
« Laatst bewerkt op: 2011/08/11, 20:09:45 door Wanda »
Netbook Xuby Xenial 16.04.5 Lts (gestripte versie). Desktop blijvend Xuby Bionic 18.04.5 Lts - Laptop Xuby Bionic 18.04.5 Lts.

Offline T.W. van den Haak

  • Lid
  • Steunpunt: Nee
Re: fouten bij samba-common, smbclient en samba-common-bin
« Reactie #3 Gepost op: 2011/08/12, 16:13:56 »
Hier is een reactie als antwoord, het is een heel verhaal:

In het grupmenu gekozen voor herstel modes:

In het verslag van de herstelmodes “ pakketten herstellen”
volgt een lang verslag waaruit blijkt dat er verbinding gezocht wordt met: getdropbox.com. Die verbinding komt niet tot stand en derhalve kunnen er geen indexbestanden opgehaald worden.

Tevens staat er ergens in de tekst:
U kan  apt-get autoremove uitvoeren.

Meteen uitgevoerd: lukt niet, melding:
toegang geweigerd, kan beheersmap niet vergrendelen. Heeft u beheersrechten?
Dit is wellicht een ander probleempje.
Vervolgens heb ik Ubuntu opgestart en een terminalvenster geopend

Auto remove geeft aan:
Een hele rits waarschuwingen die er uitzien als volgt:
dpkg: waarschuwing: files list file for package `libparted0debian1' missing, assuming package has no files currently installed.


Een hele lijst, te veel om te kopieren en dan ten slotte:
dpkg: waarschuwing: files list file for package `xserver-xorg-input-vmmouse' missing, assuming package has no files currently installed.

(Database inlezen ... 23017 bestanden en mappen geïnstalleerd.)

kdelibs4c2a wordt verwijderd ...

kdelibs-data wordt verwijderd ...

libavahi-qt3-1 wordt verwijderd ...

liblualib50 wordt verwijderd ...

liblua50 wordt verwijderd ...

Instellen van samba-common (2:3.4.7~dfsg-1ubuntu3.7) ...

dpkg: fout bij afhandelen van samba-common (--configure):

 subproces installed post-installation script gaf een foutwaarde 10 terug

dpkg: vereistenproblemen verhinderen de configuratie van samba-common-bin:

 samba-common-bin is afhankelijk van samba-common (>= 2:3.4.0~pre1-2); maar:

  Pakket samba-common is nog niet geconfigureerd.

dpkg: fout bij afhandelen van samba-common-bin (--configure):

 vereistenproblemen - blijft ongeconfigureerd

dpkg: vereistenproblemen verhinderen de configuratie van smbclient:

 smbclient is afhankelijk van samba-common (= 2:3.4.7~dfsg-1ubuntu3.7); maar:

  Pakket samba-common is nog niet geconfigureerd.

dpkg: fout bij afhandelen van smbclient (--configure):

 vereistenproblemen - blijft ongeconfigureerd

Geen apport-rapport geschreven omdat de foutmelding aangeeft dat het gaat om een fout die voortvloeit uit een eerdere fout.

Fouten gevonden tijdens behandelen van:

 samba-common

 samba-common-bin

 smbclient

E: Sub-process /usr/bin/dpkg returned an error code (1)

twvdh@compac-desktopvantwvdhh:~$


Vervolgens uw bovenstaand advies opgevolgd, zijnde:
apt-get update && apt-get upgrade 
Dan komt het volgende bericht:
Pakketlijsten worden ingelezen... Klaar

Boom van vereisten wordt opgebouwd       

De status informatie wordt gelezen... Klaar

0 pakketten opgewaardeerd, 0 pakketten nieuw geïnstalleerd, 0 te verwijderen en 0 niet opgewaardeerd.

3 pakketten niet volledig geïnstalleerd of verwijderd.

Door deze operatie zal er 0B extra schijfruimte gebruikt worden.

Wilt u doorgaan [J/n]? j

Instellen van samba-common (2:3.4.7~dfsg-1ubuntu3.7) ...

dpkg: fout bij afhandelen van samba-common (--configure):

 subproces installed post-installation script gaf een foutwaarde 10 terug

dpkg: vereistenproblemen verhinderen de configuratie van samba-common-bin:

 samba-common-bin is afhankelijk van samba-common (>= 2:3.4.0~pre1-2); maar:

  Pakket samba-common is nog niet geconfigureerd.

dpkg: fout bij afhandelen van samba-common-bin (--configure):

 vereistenproblemen - blijft ongeconfigureerd

dpkg: vereistenproblemen verhinderen de configuratie van smbclient:

 smbclient is afhankelijk van samba-common (= 2:3.4.7~dfsg-1ubuntu3.7); maar:

  Pakket samba-common is nog niet geconfigureerd.

dpkg: fout bij afhandelen van smbclient (--configure):

 vereistenproblemen - blijft ongeconfigureerd

Geen apport-rapport geschreven omdat de foutmelding aangeeft dat het gaat om een fout die voortvloeit uit een eerdere fout.

                                           Geen apport-rapport geschreven omdat de foutmelding aangeeft dat het gaat om een fout die voortvloeit uit een eerdere fout.

      Fouten gevonden tijdens behandelen van:

 samba-common

 samba-common-bin

 smbclient

E: Sub-process /usr/bin/dpkg returned an error code (1)

twvdh@compac-desktopvantwvdhh:~$


Tot zover de pogingen.
Als “leek” lijkt het mij dat :
- dropbox problemen geeft (heb ik een tijdje geleden verwijderd, van het begin af aan immer meldingen bij de updates dat dropbox niet geheel
  ge-updated kon worden. Dat heb ik altijd maar zo gelaten...)
- dpkg niet lekker zit (herinstalleren?)
- daardoor de drie samba's niet ge configureerd kunnen worden


Excuus voor het lange verhaal, maar zaken vallen en staan met details dus beter te veel info dan te weinig.

Gaarne uw reactie en mogelijk uw advies.
Alvast hartelijk dank daarvoor.

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: fouten bij samba-common, smbclient en samba-common-bin
« Reactie #4 Gepost op: 2011/08/12, 17:11:05 »
Dropbox bij je sources uitvinken, en misschien niet originele ubuntu sources.
Dan opnieuw verversen en dan updaten of samba installeren.

Offline T.W. van den Haak

  • Lid
  • Steunpunt: Nee
Re: fouten bij samba-common, smbclient en samba-common-bin
« Reactie #5 Gepost op: 2011/08/13, 19:32:01 »
het volgende heb ik gedaan/bereikt:

- bij software bronnen heb ik dropbox uitgevinkt
- samba bestanden verwijderd

En wat gebeurde er toen?
Ik kan weer software van het ubuntu softwarecentrum installeren! (gevolg: mijn onlangs op de kop getikte (gebruikte) printer doet het nu !!!)
Ik denk dat ik voorlopig maar zonder samba bestanden door het leven zal gaan! (ik weet niet waar ik ze voor nodig heb, de beschrijvingen die ik ervan gelezen heb wekken niet de gedachte bij mij van " die moet ik hebben" Dan dringt zich de vraag op: "hoe komt het dat ze geinstalleerd waren?" antwoord: "ik zou het niet weten")

Overigens: wat is "verversen" ?
Heeft u nog bedenkingen of kritische aantekeningen?

Groet van Wim v.d. Haak