Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] Canon Pixma iP 1600  (gelezen 7217 keer)

Offline HeinXIX

  • Lid
  • Steunpunt: Nee
[OPGELOST] Canon Pixma iP 1600
« Gepost op: 2011/07/30, 17:54:30 »
Ik wil een Canon Pixma IP 1600 printer installeren maar ik kan nergens de juiste drivers vinden. Ik heb nog de originele CD maar daar lukt het ook niet echt mee.
Kan iemand helpen?
Heb Ubuntu versie 11.04

Hein
« Laatst bewerkt op: 2011/08/14, 16:01:59 door Hein. »

Offline koos4401

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma iP 1600
« Reactie #1 Gepost op: 2011/07/30, 19:58:08 »
« Laatst bewerkt op: 2011/07/30, 21:44:24 door koos4401 »
Op 27-okt-2009 om 08.20 GMT geregistreerd als gebruiker nr.: 498523

Offline HeinXIX

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma iP 1600
« Reactie #2 Gepost op: 2011/07/30, 20:54:59 »
Dank je. Ga het meteen proberen.

Offline HeinXIX

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma iP 1600
« Reactie #3 Gepost op: 2011/07/30, 21:21:55 »
Helaas na een aantal keer proberen moet ik tot de conclusie komen dat het niet werkt.
Zo gauw ik de extract code heb ingevoerd en op enter druk krijg ik dit bericht:

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now

Daarna kan hij de ander codes niet meer uitvoeren.

Offline koos4401

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma iP 1600
« Reactie #4 Gepost op: 2011/07/30, 21:46:38 »
Sorry; heb zelf MP640 die zo uitstekend aan de praat kwam. Ik weet van andere linuxfora dat die voor Canonprinters ook goed met deze site uit de voeten kunnen. Misschien komt er verder nog wat; mijn denkwerk stopt hier.
Op 27-okt-2009 om 08.20 GMT geregistreerd als gebruiker nr.: 498523

Offline pip44

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma iP 1600
« Reactie #5 Gepost op: 2011/07/30, 21:47:26 »
We proberen allebij hetzelde en lopen ook tegen hetzelfde probleem aan :-[

Offline HeinXIX

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma iP 1600
« Reactie #6 Gepost op: 2011/08/06, 15:04:12 »
Bumb.
Heeft niemand een idee?

Hein

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma iP 1600
« Reactie #7 Gepost op: 2011/08/06, 15:22:10 »
Download http://ubuntuone.com/p/18iN/, pak het bestand ergens uit, bijvoorbeeld in je persoonlijke map. Open een terminalvenster (ctrl+alt+t). Als je het bestand in je persoonlijke map hebt uigepakt, typ je:
cd pixma/
Druk op enter. Typ nu:
sudo dpkg -i --force-all *.deb
Druk op enter en voer je wachtwoord in indien gevraagd. Nu wordt, als het goed is, de driver geïnstalleerd. Je zou nu je printer moeten kunnen kiezen in de printerinstellingen (Systeem -> Beheer -> Afdrukken).

Offline HeinXIX

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma iP 1600
« Reactie #8 Gepost op: 2011/08/06, 17:39:48 »
Dank je voor de moeite.
Maar helaas. De juiste drivers staan er niet tussen.
Ik heb bijna alle andere Pixma en iP drivers geprobeert maar of ze werken niet of ze geven fout meldingen.
Denk dat ik het maar op geef en een veel oudere HP laserjet printer installeer waarvan de drivers gewoon aanwezig zijn. Helaas kan ik met deze geen kleur printen. :'(

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma iP 1600
« Reactie #9 Gepost op: 2011/08/06, 17:44:32 »
Ervan uitgaande dat de juiste drivers zijn geïnstalleerd (de op de pagina vermelde drivers zijn offline), werkt dit ook niet?

http://arzanulhaq.blogspot.com/2007/06/how-to-setup-canon-pixma-ip1600-and.html

Offline HeinXIX

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma iP 1600
« Reactie #10 Gepost op: 2011/08/06, 18:41:45 »
Na wat gefrunnik en gedoe heb ik toch waarschijnlijk de goede drivers geïnstalleerd iP2200 Ver.2.60 (en). Eerst dacht ik dat deze niet werkte omdat ik elke keer een fout melding kreeg. Maar wat blijkt met het afdrukken van afbeeldingen, PDF en text bestanden heeft de printer geen problemen. Maar zo gauw ik een LibreOffice bestand wil afdrukken (Calc, writer maakt niet uit) geeft hij een fout melding en doet de printer niks. Wat kan hier het probleem zijn? Misschien een oude versie van LibreOffice?

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma iP 1600
« Reactie #11 Gepost op: 2011/08/06, 20:18:55 »
Welke foutmelding kreeg je? Was dat tijdens de installatie? of erna?

Offline HeinXIX

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma iP 1600
« Reactie #12 Gepost op: 2011/08/06, 20:55:22 »
Het was na de installatie. Alleen LibreOffice kon ik niet afdrukken. Wat de fout melding was kan ik niet zeggen. De printer heeft besloten om helemaal niets meer te doen.
Wat er gebeurt is weet ik niet precies. Maar ik ging naar het Ubuntu softwarecentrum gewoon om even te kijken of er nog wat leuks te vinden was. Ik kreeg toen een waarschuwingsscherm met de mededeling dat Ubuntu softwarecentrum een fout bevatten en eerst herstelt moest worden. Na hiervoor opdracht te hebben gegeven kan ik er weer gewoon terecht. Maar wat blijkt het heeft wel pstocanonbj (3.3-1) verwijdert. Hierna werkte de printer dus helemaal niet meer. Kan het er iets mee te maken hebben?

Sorry voor al de vragen.

Hein
« Laatst bewerkt op: 2011/08/06, 20:56:53 door Hein. »

Offline HeinXIX

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma iP 1600
« Reactie #13 Gepost op: 2011/08/07, 10:25:57 »
Nog wat extra info.
Ik ben er achtergekomen met gebruik van Synaptic dat pstocanonbj (3.3-1) wordt aangegeven als een gebroken pakket.
Deze is niet te herstellen en kan alleen verwijderd worden. Helaas moet ik dit doen want anders werkt de updatebeheer niet meer.
Nadeel is nu dat de printer niets meer doet. Ook geen foutmeldingen. Hij doet wel alsof hij een pagina aan het printen is maar er komt niets op papier.
Misschien toch maar eens gaan kijken naar een nieuwe printer die wel ondersteunt wordt met de goede drivers. =D

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma iP 1600
« Reactie #14 Gepost op: 2011/08/08, 22:49:44 »
Het probleem is dat er geen echte driver specifiek voor de ip1600 is omdat dit blijkbaar een iets ouder type is. Er zijn wel drivers voor Windows en Mac OS. Maar voor linux zelf is er geen. Maar blijkbaar zou dus die driver voor de 2200 moeten werken.
Heb je die geïnstalleerd met de .deb files?

Offline HeinXIX

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma iP 1600
« Reactie #15 Gepost op: 2011/08/08, 23:11:11 »
Ik heb alles geprobeerd wat een ieder aan oplossingen heeft aangedragen.
De drivers voor de 2200 zijn geïnstalleerd. Hierna kon ik alles afdrukken behalve LibreOffice bestanden. Deze geven dan een fout melding.
Wat ook gebeurde is dat na het installeren van de drivers dat ik bij het openen van het softwarecentrum een foutmelding kreeg nl dat Items niet kunnen worden geïnstalleerd of verwijderd totdat pakketcatalogus is gerepareerd.
Ook kreeg ik een fout melding als ik het Update beheer opende. Ik kwam er dus achter via Synaptic dat pstocanonbj (3.3-1) wordt aangegeven als een gebroken pakket en deze verwijdert moet worden. Als ik dat pakket verwijder doet de printer niks meer. Als ik een test pagina laat afdrukken wordt wel aangegeven dat het verwerkt wordt en dat de pagina geprint wordt. Alleen de printer doet helemaal niks. Als ik het pstocanonbj (3.3-1) pakket er op laat staan werken het softwarecentrum en  Update beheer dus niet. Heb er dus maar voor gekozen om het pakket te verwijderen. Ik denk dat updates binnen krijgen iets belangrijker is. :)

Offline HeinXIX

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma iP 1600
« Reactie #16 Gepost op: 2011/08/09, 09:58:45 »
Als je dat pakket had laten staan en je was bij opstart naar de recovery partitie gegaan, (dus in de grub de recovery aanklikken) dan krijg je daar een optie om gebroken pakketten te herstellen.
Wie weet had dat de boel hersteld. Zeker weten doe ik dat natuurlijk niet, maar het was te proberen geweest.
Misschien een domme vraag maar hoe doe ik dit? Recovery partitie en grub klinkt erg nieuw voor mij.
Ik kan drivers er weer gewoon opzetten. En dan dit nog als nog proberen.

Citaat
Heb je deze link al gevonden en gelezen?
http://ubuntuforums.org/showthread.php?t=1784041

en probeer deze eens:
http://www.canon-europe.com/Support/Consumer_Products/products/printers/InkJet/PIXMA_iP_series/iP2200.aspx?DLtcmuri=tcm:13-743106&page=1&type=download
De eerste ken ik al de tweede niet. dank daarvoor.
Hein

Offline Timo

  • Forumteam
    • timo.diedering
  • Steunpunt: Ja
Re: Canon Pixma iP 1600
« Reactie #17 Gepost op: 2011/08/09, 10:09:16 »
Grub is de opstartlader die zorgt dat jij kan kiezen tussen Windows en Ubuntu tijdens de opstart (als je nog windows hebt)
Als je geen Windows hebt houd je direct na de BIOS de linker SHIFT toets ingedrukt dan krijg je een menu te zien waar die recovery mode tussenstaat. :)
Trotse eigenaar van een Nokia N900, een Nokia N9 en een Jolla.

Offline HeinXIX

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma iP 1600
« Reactie #18 Gepost op: 2011/08/09, 10:18:08 »
Dank U. :)

Offline HeinXIX

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma iP 1600
« Reactie #19 Gepost op: 2011/08/09, 10:53:41 »
Oke ik heb Femke's idee geprobeerd. Helaas ook dit helpt niet. Pstocanonbj (3.3-1) wordt gewoon weer verwijdert.

Maar wat mij opviel na het installeren van de drivers is het volgende.
Het overzicht in de terminalvenster gaf op het einde de volgende melding:

pstocanonbj is afhankelijk van libcupsys2 (>= 1.2.3); maar:
  Pakket `libcupsys2' is niet geïnstalleerd.
 pstocanonbj is afhankelijk van cupsys; maar:
  Pakket `cupsys' is niet geïnstalleerd.

Ik kijken in Synaptic (volgens mij moet ik daar zijn.) en zie dat:
Er 1 cupsys wordt aangegeven nl: cupsys-driver-gutenprint. Maar Pakket wordt aangegeven als niet geïnstalleerd.
En van libcupsys2 is er geen pakket aanwezig.

Zou het kunnen zijn doordat deze 2 pakketten niet geïnstalleerd zijn het probleem veroorzaakt wordt?
« Laatst bewerkt op: 2011/08/09, 10:57:46 door Hein. »

Offline HeinXIX

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma iP 1600
« Reactie #20 Gepost op: 2011/08/09, 11:15:00 »
Dan installeer je deze en dan kijk je wat er gebeurt.

De linken ook bekeken?
Dat wil ik ook doen als ik terug ben van mijn werk. Maar helaas is het libcupsys2 helemaal niet aanwezig.

Yup links bekeken.
Maar de drivers worden gewoon geïnstalleerd dat is het probleem niet. Deze blijven na het verwijderen van Pstocanonbj (3.3-1) gewoon aanwezig. Pstocanonbj (3.3-1) is wat problemen geeft.
Ik heb al verschillende pakketten gedownload van allerlei sites maar het probleem blijft het zelfde.

Wil even iedereen bedanken voor het helpen. Zeker zo'n lastig persoon als ik ben. ;)

Offline HeinXIX

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma iP 1600
« Reactie #21 Gepost op: 2011/08/09, 16:49:20 »
cupsys-driver-gutenprint geïnstalleerd maar dit heeft geen effect.
Vond met synaptic ook nog Pstocanonbj (dus niet Pstocanonbj (3.3-1) ) deze wou ik ook installeren maar dat is niet mogelijk.
Ik vond ook nog deze link op het forum maar deze bevat, plus alle links naar verwezen wordt in die draad, veel abacadabra voor mij.
http://forum.ubuntu-nl.org/hardware-en-drivers/libcupsys2-vervangen-door-libcups2/

Ik wordt langzaam een beetje gek  =D

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma iP 1600
« Reactie #22 Gepost op: 2011/08/09, 19:42:48 »
In verband met die libcupsys2, kijk eens naar deze howto:
http://forum.ubuntu-nl.org/documentatie/howto-ip-2600/
libcupsys2 bestaat niet meer, tenminste de naam. Die is veranderd in libcups2. (Waarom dit is weet ik niet)
Heb je tijdens het installeren van de pakketten een foutmelding gehad over dit pakket? (Bij het installeren van het pakket waar "common" in de naam staat). De foutmelding word in het rood weergegeven.

Offline HeinXIX

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma iP 1600
« Reactie #23 Gepost op: 2011/08/09, 21:28:28 »
Ik neem aan dat je met installeren bedoelt, Installeren via Terminalvenster. In dat geval is mij niks opgeval aan rode tekst.

Jouw Howto doorgelezen en ook aan begonnen maar helaas ging het bij de eerste code al fout.
Ik heb zover ik kan zien  driver pakketten:
1 cnijfilter-common_2.60-2_i386.deb
2 cnijfilter-ip2200_2.60-2_i386.deb
3 libcnbj-2.6_0-1_i386.deb
4 bjfilter-2.6_1-1_i386.deb
5 pstocanonbj_3.3-1_i386.deb

Ik heb dus de eerste code verandert in:
dpkg-deb -x cnijfilter-common_2.60-2_i386.deb common

Ik kreeg toen de volgende fout melding:
dpkg-deb: error: kan niet lezen uit archief `cnijfilter-common_2.60-2_i386.deb': Bestand of map bestaat niet

Heb ik iets verkeerd gedaan?

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: Canon Pixma iP 1600
« Reactie #24 Gepost op: 2011/08/10, 18:35:56 »
Een .deb file installeer je niet via de terminal. Je klikt er gewoon dubbel op en dan installeert deze zich vanzelf. Dus verwijder even in sinaptic al de bovenstaande pakketten en installeer ze opnieuw via dubbelklikken. Misschien dat er dan wel een rode foutmelding verschijnt in verband met die libcupsys2.
Is dat dan zo dan volg je mijn howto en verander je de naam van die libcupsys2 naar libcups2 en dat in beide pakketten.
Let op: Als je dus die aanpassing doet moet je natuurlijk wel de namen van de pakketten veranderen in de commando's die ik in mijn howto geef naar de bestandsnamen die jouw pakketten hebben.

Maar eerst zien of er wel degelijk een foutmelding is.