Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: probleeem met sli configuratie  (gelezen 2972 keer)

Offline summer of 69

  • Lid
  • Steunpunt: Nee
probleeem met sli configuratie
« Gepost op: 2011/07/24, 17:27:37 »
Hallo,

Mijn zoon heeft een 2de grafische kaart geïnstalleerd om een sli configuratie te bekomen. hij heeft een dualboot systeem met win 7.
In het begin startte Natty normaal op maar nu boot ie niet meer, noch de 8 als de 10 kernel.
Ik heb al geprobeerd om als root "nvidia-xconfig" uit te voeren maar geen succes. Ikzelf heb geen enkele ervaring met sli configuratie.
Graag advies :)
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: probleeem met sli configuratie
« Reactie #1 Gepost op: 2011/07/24, 17:47:45 »
Summer of 69,

Ik heb geen SLI... Maar heb je al iets gevonden wat je kan helpen met zoeken oa google op "SLI Linux"
MvG,
MauRice
Registered Linux user: 473556

Offline summer of 69

  • Lid
  • Steunpunt: Nee
Re: probleeem met sli configuratie
« Reactie #2 Gepost op: 2011/07/24, 18:22:15 »
Summer of 69,

Ik heb geen SLI... Maar heb je al iets gevonden wat je kan helpen met zoeken oa google op "SLI Linux"
Heb nog niks concreet gevonden op google  :(
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: probleeem met sli configuratie
« Reactie #3 Gepost op: 2011/07/24, 18:45:49 »
Summer of 69,

Ik heb geen SLI... Maar heb je al iets gevonden wat je kan helpen met zoeken oa google op "SLI Linux"
Heb nog niks concreet gevonden op google  :(
Summer of 69,

Tja, SLI is leuk voor gamen dus Windows.
Ik weet dat het ook onder Linux moet gaan.
Maar zie niet direct het nut er van in.
MvG,
MauRice
Registered Linux user: 473556

Offline Vincentlaborant

  • Lid
    • vincentvandenbergh
    • openSUSE tips
  • Steunpunt: Nee
Re: probleeem met sli configuratie
« Reactie #4 Gepost op: 2011/07/24, 19:17:52 »
SLI werkt voor zover ik weet niet onder Linux. Ik ben er al een aantal keren een paar dagen achtereen mee wezen experimenteren maar veel verder dan booten zonder X kwam ik niet. Ik kreeg dus enkel een tekstbased systeem draaiend, daar de aanpassingen die je in X.org zou moeten doen enorm zijn (en ik zelf x.org niet heel erg goed ken ga ik daar ook niet lopen pielen). Indien je het draaiend krijgt zal je wel regelmatig een kernel panic krijgen  ??? (had ik heel veel last van en was 1 van de redenen om op te geven)

Je kan SLI dus op dit moment enkel gebruiken op textbased systemen (ala freedos/ ubuntu server), maar dan heb je er vrij weinig aan denk ik (hoewel ik cuda dan wel aan de praat krijg).
Toshiba Satellite P500 1C8
openSUSE Leap Xfce

https://sites.google.com/site/guidetoopensuse/home

Offline summer of 69

  • Lid
  • Steunpunt: Nee
Re: probleeem met sli configuratie
« Reactie #5 Gepost op: 2011/07/24, 19:29:19 »
Summer of 69,

Ik heb geen SLI... Maar heb je al iets gevonden wat je kan helpen met zoeken oa google op "SLI Linux"
Heb nog niks concreet gevonden op google  :(
Summer of 69,

Tja, SLI is leuk voor gamen dus Windows.
Ik weet dat het ook onder Linux moet gaan.
Maar zie niet direct het nut er van in.

Leuk commentaar maar vertel me liever eens zaken die ik niet weet ;)

SLI werkt voor zover ik weet niet onder Linux. Ik ben er al een aantal keren een paar dagen achtereen mee wezen experimenteren maar veel verder dan booten zonder X kwam ik niet. Ik kreeg dus enkel een tekstbased systeem draaiend, daar de aanpassingen die je in X.org zou moeten doen enorm zijn (en ik zelf x.org niet heel erg goed ken ga ik daar ook niet lopen pielen). Indien je het draaiend krijgt zal je wel regelmatig een kernel panic krijgen  ??? (had ik heel veel last van en was 1 van de redenen om op te geven)

Je kan SLI dus op dit moment enkel gebruiken op textbased systemen (ala freedos/ ubuntu server), maar dan heb je er vrij weinig aan denk ik (hoewel ik cuda dan wel aan de praat krijg).

Bedankt. Ik had al zo'n vermoeden. Ben zelf nooit voorstander geweest van sli. Maar ja, de zoon wil graag snel gamen in windows en was overtuigd van de snelheidswinst.
Nu heb ik via de veilige grafische modus het nvidia stuurprogramma verwijderd en nu start het systeem wel op, weliswaar onder de klassieke omgeving en niet onder Unity.
Op google vond ik instructies om via een ppa bronnen toe te voegen om de nieuwste nvidia driver te installeren. Blijkbaar is men op de hoogte van sli problemen in de 38 kernel. Heb het maar gelaten, daar ik geen voorstander ben van ppa bronnen. En aan uw uitleg te horen zie ik dat sli gedoe niet goed komen ;)

http://www.multimediaboom.com/install-nvidia-driver-ubuntu-1-04-11-10-ppa/
« Laatst bewerkt op: 2011/07/24, 19:31:54 door summer of 69 »
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline Vincentlaborant

  • Lid
    • vincentvandenbergh
    • openSUSE tips
  • Steunpunt: Nee
Re: probleeem met sli configuratie
« Reactie #6 Gepost op: 2011/07/24, 19:33:34 »
Niet zonder allerlei ppa's toe te voegen nee. En driver ppa's moet je enkel toevoegen op het moment dat je of een compleet gebroken systeem hebt of dat het een officiële ppa is van de fabrikant.

Daar fabrikanten van hardware geen ppa's opzetten (moet de eerste nog tegenkomen  :P ) zou ik mij daar inderdaad verre van houden.

Mijn testen die ik heb gedaan zijn met de 2.6.32, 2.6.35 en de 2.6.38 series van de kernel. Binnenkort zal ik een test gaan doen met de 3.0 serie van de kernel maar heb er een hard hoofd in tot nu toe.
Toshiba Satellite P500 1C8
openSUSE Leap Xfce

https://sites.google.com/site/guidetoopensuse/home

Offline summer of 69

  • Lid
  • Steunpunt: Nee
Re: probleeem met sli configuratie
« Reactie #7 Gepost op: 2011/07/24, 19:47:14 »
Prima, nog bedankt voor de uitleg ;)
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline Vincentlaborant

  • Lid
    • vincentvandenbergh
    • openSUSE tips
  • Steunpunt: Nee
Re: probleeem met sli configuratie
« Reactie #8 Gepost op: 2011/07/24, 20:17:44 »
Prima, nog bedankt voor de uitleg ;)

Graag gedaan. Ik test sli ongeveer elke keer als er een nieuwe uitgave is van ubuntu. In oktober/ november is de volgende testronde en dan test ik sli enkel op de op dat moment standaard meegeleverde kernel en drivers van Nvidia.

Crossfire (de sli variant van AMD) werkt trouwens nog beroerder. Je komt dan niet voorbij grub  >:(
Toshiba Satellite P500 1C8
openSUSE Leap Xfce

https://sites.google.com/site/guidetoopensuse/home

Offline summer of 69

  • Lid
  • Steunpunt: Nee
Re: probleeem met sli configuratie
« Reactie #9 Gepost op: 2011/07/25, 14:19:40 »
Het rare is wel dat na het plaatsen van de 2de grafische kaart het systeem wel opstartte met kernel 2.6.38-10. Nadien meldde m'n zoon dat ie ubuntu niet meer kon opstarten.
Toen heb ik kernel 2.6.38-8 geprobeerd en die deed het wel. In de gui van nvidia was ook duidelijk te zien dat er 2 gpu's waren.
Nadien startte ie helemaal niet meer op. Zoals gezegd draait het systeem nu wel met de opensource driver wss. maar dan niet onder Unity.
Raar  =D
Verdere suggesties zijn uiteraard welkom.
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: probleeem met sli configuratie
« Reactie #10 Gepost op: 2011/07/25, 21:05:00 »
Summer of 69,

Hoe je draait of keert je zal je /etc/X11/xorg.conf moeten tunen voor SLI.
Misschien is deze al een stap in de goede richting: http://forums.nvidia.com/index.php?showtopic=192916

De volledige sets met parameter om je xorg.conf te tunen vind je op de site van nVidia.
http://us.download.nvidia.com/XFree86/Linux-x86/275.21/README/index.html
http://linux.die.net/man/1/nvidia-xconfig
http://linux.die.net/man/1/nvidia-settings

Een paar tips als je er aan begint om je xorg.conf te tunen:
Zorg er voor dat de toesten-combinatie <Ctrl>+<Alt>+<Backspace> werkt om de X-server te killen.
Zorg er voor dat je niet grafisch inlog, dus in een CMDLI omgevening.
En via de opdracht startx de X opstarten.
Het zal in het begin wel wat gevloek geven...
Maar om je xorg.conf te tunen is dit wel, volgens mij het handigst.
Het scheel in het rebooten.
MvG,
MauRice
Registered Linux user: 473556

Offline summer of 69

  • Lid
  • Steunpunt: Nee
Re: probleeem met sli configuratie
« Reactie #11 Gepost op: 2011/07/26, 08:56:45 »
Hay,
Dat ga ik zeker eens nader onderzoeken. Misschien een domme vraag maar inloggen in de CMDLI omgeving; daar bedoel je wss de recovery mode mee of gewoon inloggen en "ctrl alt F2" ?
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: probleeem met sli configuratie
« Reactie #12 Gepost op: 2011/07/26, 19:25:00 »
Summer of 69,

Domme vragen bestand niet, alleen domme antwoorden.

Wat ik bedoel is dat je echt in console mode opstart.
En van hierin de X-server.
Dus even je grub config bestand aanpassen.
Zie: http://fooninja.net/2010/07/29/text-boot-in-ubuntu-lucid-lynx-10-04-disabling-gdm/
MvG,
MauRice
Registered Linux user: 473556

Offline summer of 69

  • Lid
  • Steunpunt: Nee
Re: probleeem met sli configuratie
« Reactie #13 Gepost op: 2011/07/28, 08:33:18 »
Vervolg op het verhaal :
Gisteren hebben we de partitie van Natty dan verwijderd en de punt uitgave 10.04.3 geïnstalleerd. Maar met de 2 grafische kaarten kreeg ik het systeem met geen stokken opgestart. Als laatste optie heb ik dan 1 graf. kaart verwijderd en vanaf toen verliep de installatie gesmeerd zoals ik gewoon ben. Na het volledig tweaken (volgens Pjotr's site)
heb ik dan de 2de graf. kaart teruggeplaatst en startte het systeem wel op. Ik had wel in eerste instantie het stuurprogramma van nvidia geïnstalleerd.
Dan nvidia-xconfig zodat ik een bestand xorg.conf had in /etc/X11
Daarna met de gui nvidia-settings als root het bestand aangepast.
Als laatste in de terminal nog nvidia-xconfig --enable-all-gpus en nvidia-xconfig --only-one-x-screen --sli=AutoHet systeem draait nu vlot en in de gui van nvidia zijn ook 2 gpu's te zien. Of SLI werkelijk werkt weet ik niet. Daarvoor ga ik uw instructies volgen, maar dan een volgende keer.  ;)
dierenliefde is onvoorwaardeljk, dierenleed ten zeerste verwerpelijk