Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Opgelost] Installatie ndiswrapper  (gelezen 1333 keer)

Offline Fizz

  • Lid
  • Steunpunt: Nee
[Opgelost] Installatie ndiswrapper
« Gepost op: 2011/07/19, 01:04:34 »
Beste allemaal,

Sinds enkele dagen ben ik met een usb-installatie overgestapt naar Ubuntu 11.04. Ik heb verder geen linux-ervaring. Ik wil graag ndiswrapper installeren om de draadloze verbinding werkend te krijgen, verbinding via de ethernetkabel is lastig realiseerbaar. Ik loop echter vast bij de installatie.

Zoals op de wiki beschreven is, werkt niet doordat wanneer ik zoek op bijv. ndiswrapper-common, er geen resultaten verschijnen.

Ik heb geprobeerd om het via deze tutorial uit te voeren. Ik heb:
- ndwiswrapper gedownload op een andere pc en via usb in de map /home/fizz/Documenten/ndiswrapfizz/ gezet.
- met tar -xzf * uitgepakt
- naar de nieuwe map gegaan
- make

Vervolgens kreeg ik deze melding:
fizz@Dimension-C521:~/Documenten/Ndiswrapfizz/ndiswrapper-1.56$ make
make -C driver
make[1]: Entering directory `/home/fizz/Documenten/Ndiswrapfizz/ndiswrapper-1.56/driver'
make -C /usr/src/linux-headers-2.6.38-8-generic M=/home/fizz/Documenten/Ndiswrapfizz/ndiswrapper-1.56/driver
make[2]: Entering directory `/usr/src/linux-headers-2.6.38-8-generic'
  CC [M]  /home/fizz/Documenten/Ndiswrapfizz/ndiswrapper-1.56/driver/loader.o
/home/fizz/Documenten/Ndiswrapfizz/ndiswrapper-1.56/driver/loader.c:834:2: error: unknown field ‘ioctl’ specified in initializer
/home/fizz/Documenten/Ndiswrapfizz/ndiswrapper-1.56/driver/loader.c:834:2: warning: initialization from incompatible pointer type
make[3]: *** [/home/fizz/Documenten/Ndiswrapfizz/ndiswrapper-1.56/driver/loader.o] Error 1
make[2]: *** [_module_/home/fizz/Documenten/Ndiswrapfizz/ndiswrapper-1.56/driver] Error 2
make[2]: Leaving directory `/usr/src/linux-headers-2.6.38-8-generic'
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/home/fizz/Documenten/Ndiswrapfizz/ndiswrapper-1.56/driver'
make: *** [all] Error 2

In het filmpje wordt op 4.40 iets gezegd als "Just make sure you have the development packages for your distrition installed: development packages included general headers, GCC, standard library etc."
Mogelijk heb ik dat niet. Doordat ik niet wist hoe ik dat kon controleren ben ik verder gegaan.. en kreeg ik bovenstaande melding.

Kan jij mij verder helpen om ndiswrapper te installeren?

Alvast bedankt,
Fizz



« Laatst bewerkt op: 2011/07/19, 22:17:35 door Fizz »

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Installatie ndiswrapper
« Reactie #1 Gepost op: 2011/07/19, 01:43:53 »
Download ndiswrapper-common, ndiswrapper-utils-1.9,ndisgtk,ndiswrapper-dkms en ndiswrapper-source van packages.ubuntu.com. Plaats ze in een map bijvoorbeeld de homefolder, cd naar de map in de terminal en doe:

sudo dpkg -i ./*.deb

Offline Vistaus

  • Lid
    • vistaus
  • Steunpunt: Nee
Re: Installatie ndiswrapper
« Reactie #2 Gepost op: 2011/07/19, 11:25:46 »
./*.deb ???
Bij mijn weten is dat altijd nog sudo dpkg -i *.deb

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Installatie ndiswrapper
« Reactie #3 Gepost op: 2011/07/19, 11:48:52 »
./*.deb ???
Bij mijn weten is dat altijd nog sudo dpkg -i *.deb
Oke. Ik voeg er altijd een ./ aan toe, voor de zekerheid.

Offline Fizz

  • Lid
  • Steunpunt: Nee
Re: Installatie ndiswrapper
« Reactie #4 Gepost op: 2011/07/19, 13:48:04 »
Ik heb de versie van Natty gedownload en sudo dpkg -i ./*.deb gedaan. Vervolgens kreeg ik dit:

fizz@Dimension-C521:~$ sudo dpkg -i ./*.deb
[sudo] password for fizz:
Selecteren van voorheen niet geselecteerd pakket ndisgtk.
(Database inlezen ... 129644 files and directories currently installed.)
Uitpakken van ndisgtk (uit ./ndisgtk_0.8.5-1_i386.deb) ...
Selecteren van voorheen niet geselecteerd pakket ndiswrapper-common.
Uitpakken van ndiswrapper-common (uit .../ndiswrapper-common_1.56+r2729-1_all.deb) ...
Selecteren van voorheen niet geselecteerd pakket ndiswrapper-dkms.
Uitpakken van ndiswrapper-dkms (uit .../ndiswrapper-dkms_1.56+r2729-1_all.deb) ...
Selecteren van voorheen niet geselecteerd pakket ndiswrapper-source.
Uitpakken van ndiswrapper-source (uit .../ndiswrapper-source_1.56+r2729-1_all.deb) ...
Selecteren van voorheen niet geselecteerd pakket ndiswrapper-utils-1.9.
Uitpakken van ndiswrapper-utils-1.9 (uit .../ndiswrapper-utils-1.9_1.56+r2729-1_i386.deb) ...
Instellen van ndiswrapper-common (1.56+r2729-1) ...
dpkg: vereistenproblemen verhinderen de configuratie van ndiswrapper-dkms:
 ndiswrapper-dkms is afhankelijk van dkms (>= 2.1.0.0); maar:
  Pakket `dkms' is niet geïnstalleerd.
dpkg: fout bij afhandelen van ndiswrapper-dkms (--install):
 vereistenproblemen - blijft ongeconfigureerd
dpkg: vereistenproblemen verhinderen de configuratie van ndiswrapper-source:
 ndiswrapper-source is afhankelijk van module-assistant; maar:
  Pakket `module-assistant' is niet geïnstalleerd.
 ndiswrapper-source is afhankelijk van debhelper (>= 5); maar:
  Pakket `debhelper' is niet geïnstalleerd.
dpkg: fout bij afhandelen van ndiswrapper-source (--install):
 vereistenproblemen - blijft ongeconfigureerd
Processing triggers for man-db ...
Instellen van ndiswrapper-utils-1.9 (1.56+r2729-1) ...
Instellen van ndisgtk (0.8.5-1) ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.nl_NL.utf8.cache...
Processing triggers for hicolor-icon-theme ...
Processing triggers for python-support ...
Fouten gevonden tijdens behandelen van:
 ndiswrapper-dkms
 ndiswrapper-source
fizz@Dimension-C521:~$

Moet ik het nog een keer zonder ./ doen? Of wat moet ik met deze foutmelding doen?

edit: Daarnaast kreeg ik de volgende meldingen op het scherm (screenshot)
« Laatst bewerkt op: 2011/07/19, 13:58:22 door Fizz »

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Installatie ndiswrapper
« Reactie #5 Gepost op: 2011/07/19, 16:03:27 »
Oh, je hebt nog het pakket dkms nodig zie ik, dat zul je ook moeten downloaden. Vervolgens zul je het moeten installeren via:

sudo dpkg -i ./dkms*.deb

Excuses, ik heb het vergeten te noemen.

Offline Fizz

  • Lid
  • Steunpunt: Nee
Re: Installatie ndiswrapper
« Reactie #6 Gepost op: 2011/07/19, 17:26:01 »
Maakt niet uit hoor, ik ben al blij dat je me helpt :)

Ik heb het geïnstalleerd en vervolgens bovenstaande post overnieuw gedaan. Ik krijg nu het volgende:
fizz@Dimension-C521:~$ sudo dpkg -i ./*.deb
[sudo] password for fizz:
(Database inlezen ... 129768 files and directories currently installed.)
Voorbereiden om dkms 2.1.1.2-5ubuntu1 te vervangen (door .../dkms_2.1.1.2-5ubuntu1_all.deb) ...
Uitpakken van vervangende dkms ...
Voorbereiden om ndisgtk 0.8.5-1 te vervangen (door ./ndisgtk_0.8.5-1_i386.deb) ...
Uitpakken van vervangende ndisgtk ...
Voorbereiden om ndiswrapper-common 1.56+r2729-1 te vervangen (door .../ndiswrapper-common_1.56+r2729-1_all.deb) ...
Uitpakken van vervangende ndiswrapper-common ...
Voorbereiden om ndiswrapper-dkms 1.56+r2729-1 te vervangen (door .../ndiswrapper-dkms_1.56+r2729-1_all.deb) ...
Uitpakken van vervangende ndiswrapper-dkms ...
Voorbereiden om ndiswrapper-source 1.56+r2729-1 te vervangen (door .../ndiswrapper-source_1.56+r2729-1_all.deb) ...
Uitpakken van vervangende ndiswrapper-source ...
Voorbereiden om ndiswrapper-utils-1.9 1.56+r2729-1 te vervangen (door .../ndiswrapper-utils-1.9_1.56+r2729-1_i386.deb) ...
Uitpakken van vervangende ndiswrapper-utils-1.9 ...
Instellen van dkms (2.1.1.2-5ubuntu1) ...
Instellen van ndiswrapper-common (1.56+r2729-1) ...
dpkg: vereistenproblemen verhinderen de configuratie van ndiswrapper-source:
 ndiswrapper-source is afhankelijk van module-assistant; maar:
  Pakket `module-assistant' is niet geïnstalleerd.
 ndiswrapper-source is afhankelijk van debhelper (>= 5); maar:
  Pakket `debhelper' is niet geïnstalleerd.
dpkg: fout bij afhandelen van ndiswrapper-source (--install):
 vereistenproblemen - blijft ongeconfigureerd
Processing triggers for man-db ...
Instellen van ndiswrapper-dkms (1.56+r2729-1) ...
Loading new ndiswrapper-1.56+r2729 DKMS files...
First Installation: checking all kernels...
Building only for 2.6.38-8-generic
Building initial module for 2.6.38-8-generic
Done.

ndiswrapper.ko:
Running module version sanity check.

Error! Module version 1.56 for ndiswrapper.ko
is not newer than what is already found in kernel 2.6.38-8-generic (1.56).
You may override by specifying --force.

depmod.......

DKMS: install Completed.
Instellen van ndiswrapper-utils-1.9 (1.56+r2729-1) ...
Instellen van ndisgtk (0.8.5-1) ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.nl_NL.utf8.cache...
Processing triggers for hicolor-icon-theme ...
Processing triggers for python-support ...
Fouten gevonden tijdens behandelen van:
 ndiswrapper-source

Moet ik nu module-assistent en debhelper installeren? Zo ja, wat moet ik in de terminal na sudo dpkg -i tikken?

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Installatie ndiswrapper
« Reactie #7 Gepost op: 2011/07/19, 17:36:53 »
Eigenlijk zou ndiswrapper nu al moeten werken, probeer het eens via Systeem -> Beheer -> ndisgtk (ik weet niet precies hoe het menu-item heet)?

Offline Fizz

  • Lid
  • Steunpunt: Nee
Re: Installatie ndiswrapper
« Reactie #8 Gepost op: 2011/07/19, 17:50:09 »
Je hebt helemaal gelijk. Het werkt (het start op)!
Alleen wordt er nog aangegeven dat een package broken is (ndiswrapper-source volgens mij). Is het van belang dat ik dat repareer?

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Installatie ndiswrapper
« Reactie #9 Gepost op: 2011/07/19, 19:10:32 »
Je kunt ndiswrapper-source verwijderen, want het is niet nodig.
sudo dpkg -r ndiswrapper-source dkms

Offline Fizz

  • Lid
  • Steunpunt: Nee
Re: Installatie ndiswrapper
« Reactie #10 Gepost op: 2011/07/19, 22:16:15 »
Oké, bedankt voor de hulp! :)