Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Plots ati problemen :s  (gelezen 1442 keer)

Offline Didius

  • Lid
  • Steunpunt: Nee
Plots ati problemen :s
« Gepost op: 2007/01/28, 23:40:00 »
Ik heb vandaag mijn dapper verwijderd en edgy geinstalleerd op mijn laptop. Behoorlijk wat werk alles over te zetten.

En eenmaal mijn machientje in orde begint te geraken wou ik ook de grafische driver eens gaan veranderen. Iets wat in dapper vlot ging gaat hier niet meer vlot :s.
Het gaat om deze grafsische kaart (lspci)
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]

Ik doe het volgende:
Ik haal xorg-driver-fglrx van synaptic
En ga dan naar command line waar ik het volgende intik:
sudo dpkg-reconfigure xserver-xorg en dan selecteer ik fglrx ipv ati.

ik krijg echter nog altijd op mijn glxinfo het volgende:
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)

Enige tips?

Offline Mescaline

  • Lid
  • Steunpunt: Nee
Plots ati problemen :s
« Reactie #1 Gepost op: 2007/01/28, 23:43:20 »
Knap dat het zowiezo al gelukt is in ubuntu te komen met een ati video kaart.
Ik heb nu nvidia maar had hiervoor ook een ati. kon toen ubuntu wel installeren maar zodra ik het op wou starten kreeg ik een probleem met de x server.
Ben geen computer-nerd.. weet niet super veel van pcs.
Maar ben er graag mee bezig :)

Offline Didius

  • Lid
  • Steunpunt: Nee
Plots ati problemen :s
« Reactie #2 Gepost op: 2007/01/28, 23:45:16 »
Citaat van: Mescaline
Knap dat het zowiezo al gelukt is in ubuntu te komen met een ati video kaart.
Ik heb nu nvidia maar had hiervoor ook een ati. kon toen ubuntu wel installeren maar zodra ik het op wou starten kreeg ik een probleem met de x server.
Wel ja, nu gebruik ik de mesa drivers. Die werken wel, maar die geven echt ondermaatse video prestaties.
Maar ik begrijp het eigenlijk niet echt, onder dapper had ik het probleem precies niet.

O ja, voor ik het vergeet ik krijg ook altijd:
Xlib:  extension "XFree86-DRI" missing on display ":0.0".

Offline Mescaline

  • Lid
  • Steunpunt: Nee
Plots ati problemen :s
« Reactie #3 Gepost op: 2007/01/28, 23:52:01 »
Ok... :O
Sorry ik kan je daar ook niet verder bij helpen..
6.10 schijnt idd op somige gebieden nog wat zwak tezijn ..
Daarom gebruik ik zelf ook nog maar even 6.06 :)
Ben geen computer-nerd.. weet niet super veel van pcs.
Maar ben er graag mee bezig :)

Piet

  • Gast
Plots ati problemen :s
« Reactie #4 Gepost op: 2007/01/29, 01:23:23 »
Heb je opnieuw opgestart na het installeren van de drivers? Dit is nodig bij die fglrx drivers meen ik me te herinneren.
Bij mij werkte installatie via synaptic overigens ook niet. Ik heb het nu werkend via deze guide (methode2 dus).
Heb zelf ook edgy en een ati 9600 dus goede kans dat het bij jou ook lukt. Succes :)

Offline Didius

  • Lid
  • Steunpunt: Nee
Plots ati problemen :s
« Reactie #5 Gepost op: 2007/01/29, 10:49:16 »
Bedankt voor de hulp piet, maar toch lukt het nog niet echt.

Ik heb ook methode 1 van de guide eens geprobeerd maar dan crashde X.
methode 2 geeft het volgende:

in xorg.conf:
Section "Device"
Identifier  "Ati Radeon"
Driver      "fglrx"
Option    "UseFBDev" "true"
Option    "VideoOverlay" "on"
Option    "OpenGLOverlay" "off"
BusID       "PCI:1:0:0"
EndSection
en fglrxinfo geeft het volgende:
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)
En glxgears geeft nog altijd ondermaatse prestaties (heel lage ;) )

Piet

  • Gast
Plots ati problemen :s
« Reactie #6 Gepost op: 2007/01/29, 16:07:57 »
hmmm Ik weet niet of het de oorzaak is van het falen, maar heb je composite uitgeschakeld?Section "Extensions"
Option    "Composite" "Disable"
EndSection
En heb je voor die handmatige installatie eerst die andere versie verwijderd in synaptic? Dat kan misschien ook problemen veroorzaken.
Anders weet ik het ook niet, bij mij werkt die methode die ik linkte altijd prima. Veel meer verstand heb ik er dus ook niet van :P

Offline Didius

  • Lid
  • Steunpunt: Nee
Plots ati problemen :s
« Reactie #7 Gepost op: 2007/01/29, 19:25:26 »
Gelukt, blijkbaar was dat het inderdaad!

Bedankt piet!

Piet

  • Gast
Plots ati problemen :s
« Reactie #8 Gepost op: 2007/01/29, 22:21:51 »
Hoera :)
graag gedaan

Offline Sachjan

  • Lid
  • Steunpunt: Nee
Plots ati problemen :s
« Reactie #9 Gepost op: 2007/01/30, 16:08:07 »
Het zal wel vloeken in de kerk zijn hier, maar ook ik had de nodige problemen met mijn ATI radeon 9600 kaart. D.w.z. als ik Google Earth probeerde te draaien deed hij of niks en bleef in het opstarten hangen. Na alle posts te hebben gelezen deed hij het wel maar zolangzaam dat ik de zaterdag telegraaf kon lezen voor ik mijn thuis lokatie eindelijk scherp in beeld had. Van ellende er maar weer afgegooid. Toen zag ik het programmaatje Automatix. bleeder. Hier in staat een ATI driver. Die toch maar weer laten installeren met in het achterhoofd dat er een totale herinstallatie van ubuntu achterweg zou komen maar alles bleef werken. Toen de stoute schoenen aangetrokken en Google Earth weer laten installeren en wonder boven wonder hij werkt fantastisch. Vraag me niet wat er nu anders is dan voorheen maar ik ben er blij mee. Ook mijn andere programmas werken als voorheen.

Mischien heb je er wat aan.

groten Jan