Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: mysql: kan root passwd niet instellen  (gelezen 1600 keer)

stewie

  • Gast
mysql: kan root passwd niet instellen
« Gepost op: 2007/01/27, 19:33:38 »
Hoi,

Ik kan de root password voor mysql niet instellen. Op verschillende site's en howto's zie ik dat ik de volgende regels moet toepassen:


mysqladmin -u root password yourrootsqlpassword
mysqladmin -h server1.example.com -u root password yourrootsqlpassword


Echter krijg ik bij beide commado's de volgende melding:


mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'


Ik ben nu al een paar uur aan het rondsnuffelen maar ik kom er niet uit! :mad:

wr19026

  • Gast
mysql: kan root passwd niet instellen
« Reactie #1 Gepost op: 2007/01/27, 22:38:04 »
Installeer phpmyadmin eens en probeer het daarmee.

Offline Gandyman

  • Lid
  • Steunpunt: Nee
mysql: kan root passwd niet instellen
« Reactie #2 Gepost op: 2007/01/28, 02:22:02 »
Kleine makke misschien van Ubuntu.
Tis wel veilig natuurlijk maar er is geen root password.

Die moet je eerst zetten
en dus heb je problemen met dit soort proggie's enof bijv, webmin, samba ......

Zet een root pw.
sudo -spasswd rootNu dit pw doorvoeren naar MySQL als dit nog nodig is.

:D
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline kennywest

  • Lid
    • http://kennywest.blogspot.com
  • Steunpunt: Nee
mysql: kan root passwd niet instellen
« Reactie #3 Gepost op: 2007/01/28, 08:59:57 »
Je hebt het paswoord van de gebruiker voor mysql verkeerd ingesteld. Je bent -h vergeten:
/usr/bin/mysqladmin -u root -h localhost password 'new-password'

Lees dit eens: http://www.gentoo.org/doc/en/mysql-howto.xml Ik heb nog niets beters gevonden.

Offline Pieterjan2

  • Lid
    • http://
  • Steunpunt: Nee
mysql: kan root passwd niet instellen
« Reactie #4 Gepost op: 2007/01/28, 10:32:25 »
de Linux root user moet nie mee de mysql root user verward worden he :)

Is server1.example.com wel je hostname?

Wat zegt: cat /root/.mysql_history|more

Volgende commando's zouden voldoende moeten zijn, misschien is er nog geen wachtwoord ingesteld:
mysqladmin -u root password jenieuwwachtwoord

Indien wel wijzig dan het mysql root wachtwoord als volgt:
mysqladmin -u root -p oudwachtwoord nieuwwachtwoord

(tussen haakjes in sommige howto's zie je mss tekentjes zoals ' en " maar je hoeft deze dus wel nooit te gebruiken als je een mysql root wachtwoord insteld)

Indien bovenstaande nie werkt, bekijk dan eens http://linux-tweaks.blogspot.com/2006/09/access-denied-for-user-rootlocalhost.html

stewie

  • Gast
mysql: kan root passwd niet instellen
« Reactie #5 Gepost op: 2007/01/28, 13:58:46 »
Via de -p parameter kon ik een nieuw password instellen. Kennelijk had ik dus al een password ingesteld.

thank u guys!

Bieleke

  • Gast
mysql: kan root passwd niet instellen
« Reactie #6 Gepost op: 2007/08/15, 08:54:49 »
Ik krijg altijd dezelfde melding bij het tweede commando, het eerste commanda daarintegen gaat bij mij altijd zonder problemen. Zelfs als ik -h localhost opgeeft krijg ik diezelfde irritante foutmelding.

Iedereen gebruikt dezelfde twee commando's op de diverse lamp installatie handleidingen die je tegen komt op internet, dus ik vraag me echt af wat nu precies het probleem is hier.