Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: CUPS werkt niet meer  (gelezen 572 keer)

Offline flippo1000

  • Lid
  • Steunpunt: Nee
CUPS werkt niet meer
« Gepost op: 2011/06/30, 15:43:10 »
Beste allemaal,

Ik heb computer met Ubuntu 10.10 met 2 printers namelijk een HP Color Laserjet 1600 en een Canon MP540.
Nu gebruikte ik CUPS om de printers te gebruiken. Maar omdat maar 1 printer het deed namelijk de HP ben ik allerlij oplossingen van het internet gaan proberen om deze printer aan het printen te krijgen. Het scannen werkt wel. Een keer heb ik de rechten van de mappen waarin cups geinstalleert is aangepast namelijk de mappen in /usr/lib/cups/filters maar door dit aan te passen in de Canon printer niet gaan printen maar het zorgde wel voor het effect dat de HP printer nu ook niet meer werkt omdat CUPS kapot is. Dat cups niet meer werkt ligt denk ik aan de rechten in de mappen waarin ik de rechten heb aangepast.

Nu heb ik net de computer geupgraded naar Ubuntu 11.04 maar dit heeft niet geholpen om CUPS en de printers weer werkend te krijgen.

Verder heb ik ook via Synaptic alles van CUPS eraf gegooid er opnieuw erop gezet maar dit heeft ook niet geholpen.
Heeft er hier iemand een Canon MP540? En is deze werkend op Ubuntu?
Wie weet hoe ik CUPS met de command line opnieuw kan installeren?

UPDATE: ik heb met "sudo apt-get --purge remove cups" cups verwijdert en daarna opnieuw geïnstalleerd. Hierna krijg ik nog steeds de melding " insecure filter".

Alle reacties en advies mbt CUPS en de printers hoor ik graag alvast bedankt!

Vriendelijke groeten,

Flippo
« Laatst bewerkt op: 2011/06/30, 15:58:19 door flippo1000 »

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: CUPS werkt niet meer
« Reactie #1 Gepost op: 2011/06/30, 21:29:24 »
Flippo,

Met alleen CUPS te her-installeren zal niet voldoende zijn.
Alles wat al geinstalleerd is met betrekking HPLIP, voor de HP printer, zal je ook moeten her-installeren.
Dan niet vergeten wat je allemaal voor de Canon heb geinstalleerd, deze de-installeren of her-installeren.

Mocht er ook nog een verborgen map .cups in je home-map zitten, even verwijderen.
MvG,
MauRice
Registered Linux user: 473556

Offline flippo1000

  • Lid
  • Steunpunt: Nee
Re: CUPS werkt niet meer
« Reactie #2 Gepost op: 2011/07/02, 12:52:19 »
Ik heb toch maar gekozen voor een herinstallatie omdat ik al meerdere upgrades had gedaan. Maar nu zit ik nog met het volgende:

De HP Color laserjet 1600 werkt nu uitstekent.
De Canon MP540 werkt het scannen met het programma Simple Scan prima. Maar het printen wil nog niet lukken. Dus is er iemand die een Canon MP540 heeft en deze printer wel aan het werk heeft? Want in een oude versie (8.**) werkte het printen op de Canon printer wel.

Groeten,

Flippo