Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [opgelost] /windows mount niet en verdwijnt uit grub  (gelezen 849 keer)

Offline arnoldk

  • Lid
  • Steunpunt: Nee
[opgelost] /windows mount niet en verdwijnt uit grub
« Gepost op: 2011/06/18, 21:20:02 »
Ik heb (had) een dual boot 10.10 / win7. Na installeren van AVG free wil de /windows partitie niet meer mounten en, erger, staat ook niet meer in het grub menu. Ik kan dus AVG niet verwijderen of vervangen door minder destructieve antivirus prog. Wat kan ik doen?
(HP 550 laptop)
« Laatst bewerkt op: 2011/06/19, 14:01:11 door arnoldk »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: /windows mount niet en verdwijnt uit grub
« Reactie #1 Gepost op: 2011/06/18, 22:20:23 »
Open een terminal (onder hulpmiddelen) en voer een voor een de volgende commando's uit:

sudo os-prober en geef een ENTER, hierna moet je het wachtwoord intypen, hier zie je niks van, gewoon blind typen en geef een ENTER

sudo update-grub en geef een ENTER Hierna hoef je waarschijnlijk geen wachtwoord in te vullen, dit heeft met de tijdsduur te maken van de root rechten.

Start de PC opnieuw op, staat Windows nu wel vermeld in Grub?
« Laatst bewerkt op: 2011/06/18, 22:31:06 door Gijsbert »
In der Beschränkung zeigt sich der Meister.

Offline arnoldk

  • Lid
  • Steunpunt: Nee
Re: /windows mount niet en verdwijnt uit grub
« Reactie #2 Gepost op: 2011/06/18, 22:42:45 »
Gijsbert,

Hier is de uitvoer van je twee opdrachten: zo te zien wordt de windows partitie niet herkend:

arnold@arnold-HP-550:~$ sudo os-prober
[sudo] password for arnold:
ls: reading directory /var/lib/os-prober/mount: Input/output error
ls: reading directory /var/lib/os-prober/mount: Input/output error
ls: reading directory /var/lib/os-prober/mount: Input/output error
ls: reading directory /var/lib/os-prober/mount: Input/output error
arnold@arnold-HP-550:~$ sudo update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.35-28-generic
Found initrd image: /boot/initrd.img-2.6.35-28-generic
Found linux image: /boot/vmlinuz-2.6.35-27-generic
Found initrd image: /boot/initrd.img-2.6.35-27-generic
Found linux image: /boot/vmlinuz-2.6.35-22-generic
Found initrd image: /boot/initrd.img-2.6.35-22-generic
Found memtest86+ image: /boot/memtest86+.bin
ls: reading directory /var/lib/os-prober/mount: Input/output error
ls: reading directory /var/lib/os-prober/mount: Input/output error
ls: reading directory /var/lib/os-prober/mount: Input/output error
ls: reading directory /var/lib/os-prober/mount: Input/output error
done

Bij herstarten weer geen windows en bij booten van ubu de foutmelding dat /windows niet gemount kan worden.


Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: /windows mount niet en verdwijnt uit grub
« Reactie #3 Gepost op: 2011/06/18, 23:14:59 »
Geef eens in de terminal het commando sudo fdisk -l (laatste letter is een kleine L) en geef een ENTER, nu je password invullen en geef een ENTER
Kan je de uitkomst hier plaatsen?
In der Beschränkung zeigt sich der Meister.

Offline arnoldk

  • Lid
  • Steunpunt: Nee
Re: /windows mount niet en verdwijnt uit grub
« Reactie #4 Gepost op: 2011/06/19, 08:38:15 »
Hier is de uitvoer: Ik zie er niks mis aan.

arnold@arnold-HP-550:~$ sudo fdisk -l
[sudo] password for arnold:

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x80d2f3ee

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        4256    34186288+   7  HPFS/NTFS
/dev/sda3            4257       19458   122103697+   5  Extended
/dev/sda5            4257        7903    29294496   83  Linux
/dev/sda6            7904       12766    39062016   83  Linux
/dev/sda7           12767       13374     4883728+  82  Linux swap / Solaris
/dev/sda8           13375       19458    48863232   83  Linux
arnold@arnold-HP-550:~$

Offline donpedroII

  • Lid
  • Steunpunt: Nee
Re: /windows mount niet en verdwijnt uit grub
« Reactie #5 Gepost op: 2011/06/19, 10:56:02 »
Denk dat je de CD moet pakken van Windows en eens via de rescue mode moet kijken of je de partitie weer 'tot leven ' kunt wekken.
Gebruik hier zelf ook AVG op een Windows partitie, maar dit nog niet tegengekomen.
Er was recent wel een uitgave van AVG die je systeem kon laten crashen, maar ik neem aan dat je de laatste versie van AVG hebt gedownload van de site.

Rescue Windows 7 in Five Minutes or Less
Ubuntu Pocket Guide and Reference - LinuxCommands.org - Manual Pages (man)

PC: Ubuntu 18.04 LTS /  Intel Core i5 8600 / Gigabyte B360M DS3H / Samsung 970 EVO / Corsair Vengeance LPX 16GB

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: /windows mount niet en verdwijnt uit grub
« Reactie #6 Gepost op: 2011/06/19, 12:06:58 »
Is ook niks mis mee, arnoldk. Ik denk dat je ook het beste de link van donpedroII kan volgen. :)
In der Beschränkung zeigt sich der Meister.

Offline arnoldk

  • Lid
  • Steunpunt: Nee
[opgelost] Re: /windows mount niet en verdwijnt uit grub
« Reactie #7 Gepost op: 2011/06/19, 14:00:26 »
Ik heb inderdaad de win7 DVD geboot en vandaaruit herstel gekozen. In een terminal venster

CHKDSK /F c:

gedaan. Dat herstelde een heleboel fouten op die schijf. Vervolgens ubuntu geboot en (weer)

sudo update-grub

Dat vond nu wel de windows 7 partitie. Alles lijkt weer in orde, ook na herhaald hen en weer tussen ubu en win. Hartelijk dank voor de assistentie.