Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Teksten door elkaar en verspringen  (gelezen 7623 keer)

Offline ron1872

  • Lid
  • Steunpunt: Nee
Teksten door elkaar en verspringen
« Gepost op: 2011/06/06, 10:46:59 »
Van het weekend heb ik Ubuntu 10.04 als dualboot geinstalleerd naast Windows 7.

Alles werkt prima op 1 ding na en dat is een probleem met teksten schrijven in mailtjes en OpenOffice. De teksten verspringen op een zeer vreemde en willekeurige manier, enters komen spontaan en de cursor springt terug in de tekst. Wat is hier het probleem en hoe is dit aan te passen? Alvast bedankt voor de hulp!
Ubuntu 14.04 LTS

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Teksten door elkaar en verspringen
« Reactie #1 Gepost op: 2011/06/06, 14:02:48 »
Dat klinkt als een toetsenbord of een muis die op hol slaan. Je zou het probleem dan echter ook onder Windows moeten hebben, tenzij je een exotisch toetsenbord of muis hebt: dan kan het een driver probleem zijn.

Moeilijk op afstand in te schatten wat het probleem kan zijn.

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: Teksten door elkaar en verspringen
« Reactie #2 Gepost op: 2011/06/06, 15:02:08 »
Is het echt alleen bij mail en Openoffice of ook bij andere onderdelen.
Verder idd handig erbij te vermelden welke hardware je hebt.
- Toetsenbord
- Muis
- Moederbord
- Grafische kaart
- ...

Offline ron1872

  • Lid
  • Steunpunt: Nee
Re: Teksten door elkaar en verspringen
« Reactie #3 Gepost op: 2011/06/06, 19:16:56 »

- Moederbord


Het gaat om een Packard Bell laptop met megagrote toetsen. Ik heb er vandaag eens verder mee gespeeld en het doet zich  inderdaad ook bij andere prgramma´s voor. Ondanks de grote toetsen moeten ze echt in het midden aangeslagen worden. De minste geringste aanraking van naastgelegen toetsen geeft al wartaal. Dus mijn vraag is eigenlijk: is de gevoeligheid aan te passen?
Ubuntu 14.04 LTS

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: Teksten door elkaar en verspringen
« Reactie #4 Gepost op: 2011/06/06, 19:49:36 »
Kijk eens bij de toetsenbord instellingen.
Misschien dat het helpt om hier het juiste toetsenbord in te stellen.
Bij het tabblad 'indelingen' kan je het toetsenbordmodel instellen.

Hoewel, de gevoelligheid van de toetsen is niet zomaar software afhankelijk.
Een toets wordt wel of niet ingedrukt. Software veranderd daar niets aan.
Wel kan er worden gespeeld met een vertraging, dat het langer duurt voor een toets wordt geaccepteerd.

Betreft het verspringen.
Zou het kunnen dat je toevallig met de palm van je hand over de touchpad gaat?
Hier heb ik bij mijn laptop wel eens last van.
Dit testen doe simpelweg door je touchpad uit te schakelen en kijken of je nog steeds last van de verspringingen hebt.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Teksten door elkaar en verspringen
« Reactie #5 Gepost op: 2011/06/06, 20:34:49 »
Betreft het verspringen.
Zou het kunnen dat je toevallig met de palm van je hand over de touchpad gaat?
Hier heb ik bij mijn laptop wel eens last van.
Dit testen doe simpelweg door je touchpad uit te schakelen en kijken of je nog steeds last van de verspringingen hebt.
Dat zou het inderdaad wel kunnen zijn! Kijk onder instellingen (wellicht onder "Voorkeuren" in Ubuntu 10.04), "Muis" ("Mouse" alvast in het Engels). Op het tabblad "Touchpad" heb ik een optie "Disable touchpad while typing" die bij mij standaard aangevinkt staat.

Offline ron1872

  • Lid
  • Steunpunt: Nee
Re: Teksten door elkaar en verspringen
« Reactie #6 Gepost op: 2011/06/07, 09:32:38 »
Kijk onder instellingen (wellicht onder "Voorkeuren" in Ubuntu 10.04), "Muis" ("Mouse" alvast in het Engels). Op het tabblad "Touchpad" heb ik een optie "Disable touchpad while typing" die bij mij standaard aangevinkt staat.

Dacht ik ook gelijk aan, alleen is dat tabblad niet te vinden onder voorkeuren>muis :rolleyes:
Ubuntu 14.04 LTS

Offline ron1872

  • Lid
  • Steunpunt: Nee
Re: Teksten door elkaar en verspringen
« Reactie #7 Gepost op: 2011/06/10, 11:28:53 »
Niemand een idee hoe het touchpad uit te schakelen is?
Ubuntu 14.04 LTS

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: Teksten door elkaar en verspringen
« Reactie #8 Gepost op: 2011/06/10, 14:59:07 »
Meeste laptops hebben een toetscombinatie ervoor.
Fn+[??]
Als deze niet werkt wordt de combinatie waarschijnlijk niet goed herkent en kan het helpen het juiste toetsenbord in te stellen.
Dus specifiek op fabrikant en model. (Voorkeuren>Toetsenbord>Indelingen>Toetsenbordmodel)

Dat het tabblad touchpad niet kan vinden onder voorkeuren>muis kan zijn omdat je touchpad niet als touchpad wordt herkent.
Mijn laptop heeft hier ook last van.
Tik eens in je terminal:
xinput list
Staat je touchpad daar als 'PS2 touchpad' of als 'PS2 muis'?

Hier nog een link naar de topic dat ik ongeveer het zelfde had:
http://forum.ubuntu-nl.org/software-en-configuratie/touchpad-uitschakellen-met-snelknop/
Misschien geeft het nog wat nodige info.

Offline ron1872

  • Lid
  • Steunpunt: Nee
Re: Teksten door elkaar en verspringen
« Reactie #9 Gepost op: 2011/06/10, 16:24:09 »
Citaat
on@ron-laptop:~$ xinput list
⎡ Virtual core pointer                       id=2   [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                 id=4   [slave  pointer  (2)]
⎜   ↳ OM                                         id=10   [slave  pointer  (2)]
⎜   ↳ Macintosh mouse button emulation           id=13   [slave  pointer  (2)]
⎜   ↳ ImPS/2 Logitech Wheel Mouse                id=14   [slave  pointer  (2)]
⎣ Virtual core keyboard                      id=3   [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                id=5   [slave  keyboard (3)]
    ↳ Power Button                               id=6   [slave  keyboard (3)]
    ↳ Video Bus                                  id=7   [slave  keyboard (3)]
    ↳ Power Button                               id=8   [slave  keyboard (3)]
    ↳ Sleep Button                               id=9   [slave  keyboard (3)]
    ↳ 1.3M WebCam                                id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard               id=12   [slave  keyboard (3)]
ron@ron-laptop:~$


De toetsencombinatie, zou het makkelijkst werken zo te zien, alleen Packard Bell en laat staan model TK36 staat niet in de lijst. Is die op een manier alsnog toe te voegen, dan zou het probleem opgelost moeten zijn .... denk ik ;)
Ubuntu 14.04 LTS

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: Teksten door elkaar en verspringen
« Reactie #10 Gepost op: 2011/06/10, 19:15:40 »

⎜   ↳ ImPS/2 Logitech Wheel Mouse                id=14   [slave  pointer  (2)]

Je touchpad wordt hier idd als muis herkent en niet als touchpad.

Betreft het keyboard.
Ik zie idd dat Packard Bell er niet tussen staat.

Om deze twee punten goed in te stellen licht helaas buiten mijn bereik van kennis en kunde.

Wat ik voor het uitschakelen van de touchpad zou kunnen geven is:
xinput set-int-prop "ImPS/2 Logitech Wheel Mouse" "Device Enabled" 14 0
En weer aan zetten:
xinput set-int-prop "ImPS/2 Logitech Wheel Mouse" "Device Enabled" 14 1
Probeer deze twee opdrachten eerst in de terminal om te testen.
Als ze werken kan je een sneltoets maken die deze opdracht uitvoert.

Offline ron1872

  • Lid
  • Steunpunt: Nee
Re: Teksten door elkaar en verspringen
« Reactie #11 Gepost op: 2011/06/10, 19:36:32 »

Wat ik voor het uitschakelen van de touchpad zou kunnen geven is:
xinput set-int-prop "ImPS/2 Logitech Wheel Mouse" "Device Enabled" 14 0

Voor ik dat uitvoer: wordt daar niet de externe muis mee uitgeschakeld ???

Ubuntu 14.04 LTS

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: Teksten door elkaar en verspringen
« Reactie #12 Gepost op: 2011/06/11, 01:20:52 »
nee, alleen de touchpad.

Offline ron1872

  • Lid
  • Steunpunt: Nee
Re: Teksten door elkaar en verspringen
« Reactie #13 Gepost op: 2011/06/11, 07:08:41 »
Invalid format 14
Invalid: command not found

Citaat

ron@ron-laptop:~$ ron@ron-laptop:~$ xinput set-int-prop "ImPS/2 Logitech Wheel Mouse" "Device Enabled" 14 0
ron@ron-laptop:~$: command not found
ron@ron-laptop:~$ Invalid format 14
Invalid: command not found
ron@ron-laptop:~$ ron@ron-laptop:~$
ron@ron-laptop:~$: command not found
ron@ron-laptop:~$
ron@ron-laptop:~$

« Laatst bewerkt op: 2011/06/11, 07:12:09 door ron1872 »
Ubuntu 14.04 LTS

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: Teksten door elkaar en verspringen
« Reactie #14 Gepost op: 2011/06/11, 09:56:57 »
Als ik op internet zoek kom ik tegen dat die '14' gelijk moet zijn aan de id van je touchpad maar nu ik bij mijn laptop kijk is dat niet zo.
Als lastis ergens raakt dat dus messed up.

Bij mij is die 14 een 8 en dat kom ik ook met de voorbeelden op internet tegen:
xinput set-int-prop "ImPS/2 Logitech Wheel Mouse" "Device Enabled" 8 0
Verder schijnt er intussen een multitouch driver beschikbaar te zijn.
Ben nu aan het doornemen hoe ik deze moet installeren.
Is jou touchpad ook een multitouch?

Offline ron1872

  • Lid
  • Steunpunt: Nee
Re: Teksten door elkaar en verspringen
« Reactie #15 Gepost op: 2011/06/11, 13:58:20 »

Bij mij is die 14 een 8 en dat kom ik ook met de voorbeelden op internet tegen:
xinput set-int-prop "ImPS/2 Logitech Wheel Mouse" "Device Enabled" 8 0
Verder schijnt er intussen een multitouch driver beschikbaar te zijn.
Ben nu aan het doornemen hoe ik deze moet installeren.
Is jou touchpad ook een multitouch?

Ik neem aan van wel, zou het verschil niet weten.

Maar inmiddels is het touchpad uitgeschakeld met de waarde 8. Nu misschien nog een eenvoudige toetscombinatie om het aan en uit te zetten, Eerst maar eens kijken hoe dit bevalt en het gespring afgelopen is.
Ubuntu 14.04 LTS

Offline ron1872

  • Lid
  • Steunpunt: Nee
Re: Teksten door elkaar en verspringen
« Reactie #16 Gepost op: 2011/06/11, 19:15:56 »
Het spontaan verspringen van de muiscursor in de tekst blijft helaas. Misschien dat er nog andere tips zijn?
Ubuntu 14.04 LTS

Offline ron1872

  • Lid
  • Steunpunt: Nee
Re: Teksten door elkaar en verspringen
« Reactie #17 Gepost op: 2011/06/19, 20:03:56 »

xinput set-int-prop "ImPS/2 Logitech Wheel Mouse" "Device Enabled" 8 0

Iedere keer na een herstart moet ik dit opnieuw uitvoeren. Is daar nog een oplossing voor?
Ubuntu 14.04 LTS

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: Teksten door elkaar en verspringen
« Reactie #18 Gepost op: 2011/06/19, 22:44:30 »
Ja, er is een oplossing.
Plaats dit in een .sh file en koppel deze file aan een sneltoets.

Ik heb voor mijn laptop dit ooit ingesteld.
In de bijlage een .zip met de .sh file wat ik had aangepast.
Misschien werkt het ook bij jouw direct.

Offline ron1872

  • Lid
  • Steunpunt: Nee
Re: Teksten door elkaar en verspringen
« Reactie #19 Gepost op: 2011/06/19, 23:10:45 »

Plaats dit in een .sh file en koppel deze file aan een sneltoets.


Hoe is de koppeling naar een sneltoets te maken?
Ubuntu 14.04 LTS

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: Teksten door elkaar en verspringen
« Reactie #20 Gepost op: 2011/06/19, 23:22:34 »
Systeem>Voorkeuren>Sneltoetsen
Hier op de knop toevoegen klikken.

Naam mag van alles zijn.
Opdracht: [pad/naar/waar/de/file/staat]/[naam van je file].sh             (Ik hoop dat dit duidelijk genoeg getypt is. ;))

Druk op toepassen.
Hierna kan je er een nieuwe sneltoets aan toekennen.
NOTE: Fn toets combinaties gaan niet.

Offline ron1872

  • Lid
  • Steunpunt: Nee
Re: Teksten door elkaar en verspringen
« Reactie #21 Gepost op: 2011/06/20, 13:58:36 »

Hierna kan je er een nieuwe sneltoets aan toekennen.


Dat laatste lukt dan helaas niet. Ik zie wel de aangemaakte opdrachtregel, maar een sneltoets eraan koppelen lukt niet.
Ubuntu 14.04 LTS

Offline Erik Krom

  • Lid
  • Steunpunt: Nee
Re: Teksten door elkaar en verspringen
« Reactie #22 Gepost op: 2011/06/20, 18:37:38 »
Klik van het onderdeel waar je de sneltoets wilt instellen op de al ingestelde sneltoets.
Van je .sh bestand zal nu natuurlijk op 'uitgeschakeld' staan.

De tekst veranderd in 'nieuwe sneltoets'.
Typ je sneltoets.

Niet alle sneltoets combinaties zijn mogelijk omdat ze dan kunnen vloeken met andere sneltoetsen.

Offline jaalsi

  • Lid
  • Steunpunt: Nee
Re: Teksten door elkaar en verspringen
« Reactie #23 Gepost op: 2011/11/28, 21:13:07 »
 :evil: :evil: Ik heb ook last van een verdwijnende of wegspringende cursor, ook als de muis niet op de laptop is aangesloten. Het touchpad hoeft niet te worden aangeraakt om in de ellende te komen. :evil:
Zelfs worden delen van de tekst gemarkeerd en de muisklikken hebben geen resultaat. Bij vorige versies leek het of het probleem na enige tijd verdween.
De verschijnselen treden op inderdaad bij e-mail, tekstverwerking (zowel Open Office als Libre Office) en in webformulieren.
Wat ik tot nu toe hier heb gelezen helpt mij niet verder. Alvast dank voor een reactie!