Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Samba correct geïnstalleerd maar geen verbinding met Win client  (gelezen 2005 keer)

Offline kekovski

  • Lid
  • Steunpunt: Nee
Hallo,

Voor mijn eindwerk heb ik besloten om een Samba server op te stellen. Ik heb eerst UbuntuServer 10.04 LTS geïnstalleerd en daarna heb ik de tutorials gevolgd op https://help.ubuntu.com/10.04/serverguide/C/samba-fileserver.html . Maar hoe moet ik mijn IP adressen configureren zodanig dat mijn client en server verbinding hebben met elkaar? Ik gebruik voor mijn server 192.168.1.3 en voor mijn WinXP client 192.168.1.4 . Telkens als ik via XP naar \\192.168.1.3 wil gaan geeft hij een error en zegt hij dat hij de netwerklocatie niet kan bereiken.

Kan er iemand mij helpen?  ???

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Samba correct geïnstalleerd maar geen verbinding met Win client
« Reactie #1 Gepost op: 2011/05/25, 23:10:08 »
Heb je al de mappen gedeeld in Linux die je wilt delen met Windows en dit in je samba configuratie file gezet? Zo ja heb je de samba server opnieuw opgestart? Dit altijd doen na een verandering in het configuratie script.

Hier nog wat leesvoer http://www.multidesk.be/artikels/artikel/233/Bestanden-delen-tussen-Windows-en-Linux-via-Samba.html , zeker het tweede gedeelte.
In der Beschränkung zeigt sich der Meister.

Offline kekovski

  • Lid
  • Steunpunt: Nee
Re: Samba correct geïnstalleerd maar geen verbinding met Win client
« Reactie #2 Gepost op: 2011/06/02, 10:47:47 »
Heb je al de mappen gedeeld in Linux die je wilt delen met Windows en dit in je samba configuratie file gezet? Zo ja heb je de samba server opnieuw opgestart? Dit altijd doen na een verandering in het configuratie script.

Hier nog wat leesvoer http://www.multidesk.be/artikels/artikel/233/Bestanden-delen-tussen-Windows-en-Linux-via-Samba.html , zeker het tweede gedeelte.
Ja ik heb mappen gedeeld en opnieuw opgestart.

Ik heb ook met openSUSE, fedora, CentOs samba geprobeerd maar telkens krijg ik dezelfde fout.  ???
Kan het iets te maken hebben met virtual box? Ik heb alle mogelijke tutorials geprobeerd maar toch heb ik geen resultaat  :(
Mijn windows wil maar niet connecteren met de server  ???

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Samba correct geïnstalleerd maar geen verbinding met Win client
« Reactie #3 Gepost op: 2011/06/02, 11:31:26 »
Dit type je in de adresbalk vanuit Windows?  smb://192.168.1.3 (adres van de server, smb: moet er voor)
In der Beschränkung zeigt sich der Meister.

Offline kekovski

  • Lid
  • Steunpunt: Nee
Re: Samba correct geïnstalleerd maar geen verbinding met Win client
« Reactie #4 Gepost op: 2011/06/02, 12:11:13 »
Dit type je in de adresbalk vanuit Windows?  smb://192.168.1.3 (adres van de server, smb: moet er voor)
er komt een messagebox waarin dat er staat dat hij smb niet herkent

Ik heb mijn virtual box herinstalleerd.
Op virtual box heb ik Ubuntu Server 10.04 zo geconfigureerd:
1: sudo apt-get install samba
2: /etc/samba/smb.conf
Citaat
workgroup = WORKGROUP
 security = user

[share]
    comment = Ubuntu File Server Share
    path = /srv/samba/share
    browsable = yes
    guest ok = yes
    read only = no
    create mask = 0755
3: sudo mkdir -p /srv/samba/share
4: sudo chown nobody.nogroup /srv/samba/share/
5: sudo restart smbd
6: sudo restart nmbd
7: Hierna typte ik in terminal  "ifconfig"
Citaat
inet adr: 10.0.2.15 Bcast: 10.0.2.255 Mask; 255.255.255.0  


Dan ging ik naar mijn WinXP sp2 client op virtual box.
Chekte ik voor alle zekerheid mijn ipadres en werkgroep
cmd --> ipconfig
Citaat
Ipadres: 10.0.2.15
Mask: 255.255.255.0
Citaat
werkgroep: WORKGROUP
Hierna typte ik in mijn brower "\\10.0.2.15\share\" en kreeg ik deze fout
Citaat
Kan het item \\10.0.2.15\share\ niet vinden. Controlleer of u de naam juist hebt gespeld en probeer het opnieuw U kunt ook naar het item zoeken door de knop Start en vervolgens op de optie Zoeken te klikken.

Ik snap niet wat ik fout aan het doen ben?  ???
« Laatst bewerkt op: 2011/06/02, 14:06:20 door kekovski »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Samba correct geïnstalleerd maar geen verbinding met Win client
« Reactie #5 Gepost op: 2011/06/02, 14:04:31 »
In de smb.conf file heb je voor workgroup staan EXAMPLE en in Windows heb je WORKGROUP staan, moet dat niet hetzelfde zijn?
In der Beschränkung zeigt sich der Meister.

Offline kekovski

  • Lid
  • Steunpunt: Nee
Re: Samba correct geïnstalleerd maar geen verbinding met Win client
« Reactie #6 Gepost op: 2011/06/02, 14:07:27 »
In de smb.conf file heb je voor workgroup staan EXAMPLE en in Windows heb je WORKGROUP staan, moet dat niet hetzelfde zijn?
Excuseer het staat wel op workgroup heb zojuist gezien dat ik het verkeerd getypt heb.
Maar toch heb ik geen connectie?
Doe ik iets mis? of moet ik het eens op een andere computer uitproberen?

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Samba correct geïnstalleerd maar geen verbinding met Win client
« Reactie #7 Gepost op: 2011/06/02, 14:36:32 »
Heb je gast edition geinstalleerd?

Netwerk adapter op nas en bridge proberen.

Probeer eens met alleen de ip nummer in te geven om naar de server te gaan.
(ik heb hier 2 ubuntu's staan, die zien elkaar niet, maar met ip nummer werkt wel).
« Laatst bewerkt op: 2011/06/02, 14:40:33 door jan11000 »

Offline siegi

  • Lid
  • Steunpunt: Nee
Re: Samba correct geïnstalleerd maar geen verbinding met Win client
« Reactie #8 Gepost op: 2011/06/02, 14:41:37 »
Je brengt er in elk geval een extra complexiteit bij door het met virtuele machines te willen doen.

Even voor de duidelijkheid:
Je hebt 1 host computer waar je virtualbox op draait.
Vervolgens heb je op deze host 2 gast besturingssystemen geïnstalleerd.
1) ubuntu server
2) windows xp

Ik zou eerst controleren of alles klopt op netwerkvlak, dat de twee computers elkaar kunnen zien. Probeer bijv vanuit windows eens te pingen naar ubuntu.

BTW:
Eerst spreek je over ip adressen uit de 192 reeks (meestal van thuisrouters)
En dan ineens spreek je over ip adressen uit de 10. (ip adressen die virtualbox uitdeeld)

Wat voor een soort netwerk heb je gekozen in virtualbox? NAT, bridged,...?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Samba correct geïnstalleerd maar geen verbinding met Win client
« Reactie #9 Gepost op: 2011/06/02, 15:01:08 »
Heb je ook nog in de smb.conf dit toegevoegd? guest account = gebruikersnaam kan je anders je volledige smb.conf hier plaatsen?
In der Beschränkung zeigt sich der Meister.

Offline kekovski

  • Lid
  • Steunpunt: Nee
Re: Samba correct geïnstalleerd maar geen verbinding met Win client
« Reactie #10 Gepost op: 2011/06/02, 15:09:26 »
Je brengt er in elk geval een extra complexiteit bij door het met virtuele machines te willen doen.

Even voor de duidelijkheid:
Je hebt 1 host computer waar je virtualbox op draait.
Vervolgens heb je op deze host 2 gast besturingssystemen geïnstalleerd.
1) ubuntu server
2) windows xp

Ik zou eerst controleren of alles klopt op netwerkvlak, dat de twee computers elkaar kunnen zien. Probeer bijv vanuit windows eens te pingen naar ubuntu.

BTW:
Eerst spreek je over ip adressen uit de 192 reeks (meestal van thuisrouters)
En dan ineens spreek je over ip adressen uit de 10. (ip adressen die virtualbox uitdeeld)

Wat voor een soort netwerk heb je gekozen in virtualbox? NAT, bridged,...?
Oef eindelijk opgelost   XD

Ik heb op virtual box de netwerkadapters van Ubuntu Server en Win XP van NAT naar bridge veranderd. Toen lukte het wel om een verbinding vast te leggen met \\78.21.44.41\share\

Bedankt voor jullie hulp  :D