Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: foutmelding ati driver  (gelezen 1402 keer)

Offline liawim

  • Lid
  • Steunpunt: Nee
foutmelding ati driver
« Gepost op: 2011/05/20, 20:50:55 »
Hallo krijg de volgende foutmelding bij het installeren:

liawim@liawim-Aspire-T660:~$ sudo ./ati-driver-installer-9-3-x86.x86_64.runCreated directory fglrx-install.v0pCbN
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.593...
==================================================
 ATI Technologies Linux Driver Installer/Packager
==================================================

Error: ./default_policy.sh does not support version
default:v2:i686:lib::none:2.6.38-8-generic; make sure that the version is being
correctly set by --iscurrentdistro

Removing temporary directory: fglrx-install.v0pCbN

Heb op de ati/amd site de juiste driver opgezocht.
Iemand enig idee?

het gaat om een ati radeon express 200 met ubuntu 11.04

Offline Thomas de Graaff

  • Lid
  • Steunpunt: Nee
Re: foutmelding ati driver
« Reactie #1 Gepost op: 2011/05/20, 22:59:41 »
Dat is een vrij oude kaart, ik denk niet dat je daarvoor drivers hoeft te downloaden van de ATI website. Kan je niet gewoon gesloten stuurprogramma's activeren oid? (systeem->beheer->stuurprogramma's)

Offline liawim

  • Lid
  • Steunpunt: Nee
Re: foutmelding ati driver
« Reactie #2 Gepost op: 2011/05/20, 23:47:06 »
Bij extra stuurprogrammas is de lijst leeg, en vlc loopt vast met de opensource driver, vandaar dat ik probeer om de restricted driver te installeren maar dat lukt niet echt.

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: foutmelding ati driver
« Reactie #3 Gepost op: 2011/05/21, 08:38:45 »
Liawim,

Klassiek probleem.
Je ATi kaart is te oud en wordt niet meer ondersteund door de huidige fglrx-driver.
De versie van de fglrx-driver die je kaart nog ondersteund is niet te compileren met de huidige kernel-versie.

Maar als ik me niet vergist gebruik Ubuntu 11.04 de Gallium 3D driver.
Kan je controleren met glxinfo in een terminal.
Die zal stukken beter zijn dan de X-org ati-driver.

Zie ook:
http://forum.ubuntu-nl.org/hardware-en-drivers/driver-voor-ati-radeon-x1300/msg713037/#msg713037

Dat is een reden dat ik in mijn desktop PC de ATi-kaarten heb vervangen door nVidia-kaarten.


« Laatst bewerkt op: 2011/05/21, 08:48:22 door MauRice2 »
MvG,
MauRice
Registered Linux user: 473556

Offline liawim

  • Lid
  • Steunpunt: Nee
Re: foutmelding ati driver
« Reactie #4 Gepost op: 2011/05/21, 12:04:10 »
met glxinfo staat er niks bij van gallium3d driver. alleen mesa. Kan ik gallium3d installeren en moet ik xorg dan verwijderen?

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: foutmelding ati driver
« Reactie #5 Gepost op: 2011/05/21, 12:37:11 »
met glxinfo staat er niks bij van gallium3d driver. alleen mesa. Kan ik gallium3d installeren en moet ik xorg dan verwijderen?
Liawim,

Nee, X-org niet verwijderen.
http://www.phoronix.com/image-viewer.php?id=mesa_r300g_oct10&image=ati_r500_r300g_lrg
Volgens de screenshot is het een onderdeel van X-org en Mesa.
Hoe je deze precies moet installeren, ikke (nog) niet weet.
Ik vermoed dat je een /etc/X11/xorg.conf moet hebben en daarin wat wijzigen.

In het slechte geval kan zijn dat Ubuntu deze pas met 11.10 standaard opneem.

Gisteren, op een laptop die een ATi Radeon X700 heeft, de LiveCD 11.04 gestart.
-> Start dus out-of-the-box met Unity.
-> Glxinfo geeft Gallium 0.4 zoals het screenshot.

« Laatst bewerkt op: 2011/05/22, 09:20:12 door MauRice2 »
MvG,
MauRice
Registered Linux user: 473556