Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: SSH sessie met ubuntu server  (gelezen 5874 keer)

hieronymus

  • Gast
SSH sessie met ubuntu server
« Gepost op: 2005/08/26, 18:34:55 »
Ik heb een pc als server neergezet met daarop ubuntu geinstalleerd. Ik heb geen scherm meer voor de pc dus ik wil het beheer via ssh uitvoeren vanaf mijn laptop. Het probleem is het volgende:

root@laptop:/home/dusty # ssh 10.0.0.155
ssh_exchange_identification: Connection closed by remote host
Waar kan ik de instellingen aanpassen om te zorgen dat de ssh sessie wel kan worden gestart??

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
SSH sessie met ubuntu server
« Reactie #1 Gepost op: 2005/08/26, 21:03:07 »
heb je openssh-server wel ge

maarten84

  • Gast
SSH sessie met ubuntu server
« Reactie #2 Gepost op: 2005/11/25, 14:49:15 »
Ik krijg ssh maar niet aan de praat...

Ik heb een tutorial gevolgd via google gevonden (http://www.bartendavid.be/doc/howto/netwerk/servers/ssh.html) ... Redelijk duidelijke (lees: eigenlijk zeer duidelijke) tutorial, maar toch slaag ik er niet in te connecteren.

Ik krijg de volgende error:  "connect to host 192.168.0.114 port 2222: Connection refused"


# Package generated configuration file
# See the sshd(8) manpage for details

# What ports, IPs and protocols we listen for

# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
Port 2222
#ListenAddress 0.0.0.0
#Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication yes


# To change Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#AFSTokenPassing no
#KerberosTicketCleanup no

# Kerberos TGT Passing does only work with the AFS kaserver
#KerberosTgtPassing yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
KeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

UsePAM yes
Zie ik iets over het hoofd?

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
SSH sessie met ubuntu server
« Reactie #3 Gepost op: 2005/11/25, 15:02:56 »
okee, laten we opnieuw beginnen..
sudo apt-get remove --purge openssh-server
sudo apt-get install openssh-server

Werkt een ssh verbinding naar poort 22 dan?

maarten84

  • Gast
SSH sessie met ubuntu server
« Reactie #4 Gepost op: 2005/11/26, 12:13:33 »
Citaat van: Dennis
okee, laten we opnieuw beginnen..
sudo apt-get remove --purge openssh-server
sudo apt-get install openssh-server

Werkt een ssh verbinding naar poort 22 dan?
Okidoki, geunistalled, daarna terug installed...
Nu even testen...
Normaal zou poort 21 niet mogen werken (wordt door mijn provider niet toegestaan naar het schijnt).

Dus ik moet enkel de commentaarteken (#) van poort 22 wegdoen?

(in bestand /etc/ssh/sshd_conf)

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
SSH sessie met ubuntu server
« Reactie #5 Gepost op: 2005/11/26, 12:54:10 »
Naar mijn mening wil je ssh intern gebruiken. Indien je ISP de poorten onder, neem nu, 1024 blokt, is dat enkel voor communicatie over het externe netwerk. Zolang je niet door je router moet, ben je baas in eigen huis :)
Tip: zorg voor een goede firewall op router-niveau.

maarten84

  • Gast
SSH sessie met ubuntu server
« Reactie #6 Gepost op: 2005/11/26, 13:15:10 »
Citaat van: zappa
Naar mijn mening wil je ssh intern gebruiken. Indien je ISP de poorten onder, neem nu, 1024 blokt, is dat enkel voor communicatie over het externe netwerk. Zolang je niet door je router moet, ben je baas in eigen huis :)
Tip: zorg voor een goede firewall op router-niveau.
Idd, die poorten worden idd voor extern verkeer geblokt.

Wat moet ik minstens aanzetten in de /etc/ssh/sshd_conf file om ssh te kunnen gebruiken en in te loggen intern/extern ... of is dit een zeer moeilijke (uitgebreide) vraag? :)

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
SSH sessie met ubuntu server
« Reactie #7 Gepost op: 2005/11/26, 13:40:33 »
Eerlijk gezegd, ik gebruik het (nog) niet. Maar ik raad je toch af om standaard poorten naar het extern netwerk open te zetten. Het is wel 'secure'sh, maar dat slaat vooral op het feit dat uw paketten versleuteld worden (als ik mij dat nog goed herinner).

Maar laat ik uw vraag anders formuleren: Iemand ervaring hiermee of VPN onder Ubuntu?

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
SSH sessie met ubuntu server
« Reactie #8 Gepost op: 2005/11/26, 14:18:54 »
Ik gebruik een overdosis ssh en zolang je sterke wachtwoorden of RSA keys gebruikt is dat veilig genoeg.

Om te testen of SSH werkt kun je ook gewoon 'ssh localhost' doen op dezelfde machine. Als dat werkt kunnen we naar stap 2 (de poort veranderen) wat heel simpel is.

maarten84

  • Gast
SSH sessie met ubuntu server
« Reactie #9 Gepost op: 2005/11/27, 10:32:27 »
Citaat van: Dennis
Ik gebruik een overdosis ssh en zolang je sterke wachtwoorden of RSA keys gebruikt is dat veilig genoeg.

Om te testen of SSH werkt kun je ook gewoon 'ssh localhost' doen op dezelfde machine. Als dat werkt kunnen we naar stap 2 (de poort veranderen) wat heel simpel is.
yeps, ssh @localhost werkt... Hij vraagt zoiets van rsa .. heb Yes ingetypt... en dan paswoord ... en da gaf geen errors :)

Next step... /etc/ssh/sshd_conf ?

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
SSH sessie met ubuntu server
« Reactie #10 Gepost op: 2005/11/27, 11:57:56 »
sshd_config :)

Inderdaad, vervang daar 22 eens door 5555 en doe sudu /etc/init.d/ssh restart

En daarna: ssh localhost -p 5555

Als dat werkt probeer je het van buiten: ssh je.ip.adres -p 5555

maarten84

  • Gast
SSH sessie met ubuntu server
« Reactie #11 Gepost op: 2005/11/28, 15:30:10 »
Citaat van: Dennis
sshd_config :)

Inderdaad, vervang daar 22 eens door 5555 en doe sudu /etc/init.d/ssh restart

En daarna: ssh localhost -p 5555

Als dat werkt probeer je het van buiten: ssh je.ip.adres -p 5555
Thanks Dennis!!

maarten84

  • Gast
SSH sessie met ubuntu server
« Reactie #12 Gepost op: 2005/11/28, 19:20:29 »
Citaat van: Dennis
sudu /etc/init.d/ssh restart
Wat is het doel van de directory init.d (en alles erin?)
Welke functionaliteit komt hier in voor?

Ps: die functie restart kent hij niet :(

Edit: hij kende het commando sudo niet :( ... mmm raar :)

Offline Dennis Kaarsemaker

  • Administrator
    • dennis
    • http://www.kaarsemaker.net
  • Steunpunt: Nee
SSH sessie met ubuntu server
« Reactie #13 Gepost op: 2005/11/28, 21:00:51 »
Het starten/stoppen van services :)

Doe anders gewoon als root, zonder sudo.

maarten84

  • Gast
SSH sessie met ubuntu server
« Reactie #14 Gepost op: 2005/11/28, 21:03:32 »
Citaat van: Dennis
Het starten/stoppen van services :)

Doe anders gewoon als root, zonder sudo.
Als root ist idd geen probleem...
Kheb het ook kunnen oplossen door gewoon eens het venster af te sluiten en en nieuw op te starten.

Werkt perfect. Straks even de poorten op de router mappen en dan es testen vanop een andere pc :) (buiten het netwerk).

maarten84

  • Gast
SSH sessie met ubuntu server
« Reactie #15 Gepost op: 2005/11/30, 19:22:56 »
Okidoki, even een overzicht.

- Ssh loopt over poort 5000
- Ssh -p 5000 localhost lukt
- Ssh via andere pc binnen het netwerk (lan) lukt
- Router config: private ip van de pc die de sshserver draait wordt via poort 5000 doorgestuurd
- Pingen naar de router (ip) lukt perfect

Wat gaat er dan niet?

Ssh van eigen pc door commando: ssh -p 5000 'ipvanderouter' ... gewoon geen reactie, geen foutmelding, niks... nieuwe lijn, blanco :(

maarten84

  • Gast
SSH sessie met ubuntu server
« Reactie #16 Gepost op: 2005/11/30, 19:25:48 »
Citaat van: maarten84
Okidoki, even een overzicht.

- Ssh loopt over poort 5000
- Ssh -p 5000 localhost lukt
- Ssh via andere pc binnen het netwerk (lan) lukt
- Router config: private ip van de pc die de sshserver draait wordt via poort 5000 doorgestuurd
- Pingen naar de router (ip) lukt perfect

Wat gaat er dan niet?

Ssh van eigen pc door commando: ssh -p 5000 'ipvanderouter' ... gewoon geen reactie, geen foutmelding, niks... nieuwe lijn, blanco :(
EDIT: dit is het publiek adres 'adres van de router'

Als ik gewoon 'ssh -p 5000 192.168.0.1' doe dan krijg ik wel reactie
Connection refused

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
SSH sessie met ubuntu server
« Reactie #17 Gepost op: 2005/11/30, 19:41:13 »
Je moet je router zo configureren dat hij dat toestaat (als dat kan...). Je botst namelijk op zijn firewall.

maarten84

  • Gast
SSH sessie met ubuntu server
« Reactie #18 Gepost op: 2005/11/30, 19:58:34 »
Citaat van: zappa
Je moet je router zo configureren dat hij dat toestaat (als dat kan...). Je botst namelijk op zijn firewall.
Wel, ik heb een nieuw toestemming gegeven aan de router.
als ik ga naar firewall options, dan zie ik ook dat hij daar een nieuwe toestemming heeft automatisch bijgestoken met als status allow, met dezelfde gegevens als die dat ik ingevuld had op de pagina voor wan-toegang ...

EDIT: mijn router is een DLINK router als dit zou helpen :)

maarten84

  • Gast
SSH sessie met ubuntu server
« Reactie #19 Gepost op: 2005/11/30, 20:50:35 »
Beste mensen,

problem solved!
Wat ging er dan verkeerd?

Niets aan mijn eigen instellingen blijkbaar... die waren goed dankzij jullie hulp.
Het was gewoon mijn firewall van de pc zelf nl. firestarter die lastig deed. Gewoon firerstarter stoppen en het probleem was opgelost.

Nu nog even firestarter configureren dat hij aan kan blijven staan EN dat ik kan ssh'en :)