Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: 11.04 - geen geluid uit boxen  (gelezen 1001 keer)

Offline reezjer

  • Lid
  • Steunpunt: Nee
11.04 - geen geluid uit boxen
« Gepost op: 2011/05/04, 23:01:21 »
Hallo

Ik heb een probleem met het geluid van men latop -> wel geluid via oortjes van headset (en mic werkt ook), maar geen geluid via de boxen van de laptop.

Laptop: MSI S262
OS: Ubuntu 11.04

cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ALC883
Codec: LSI Si3054

sudo gedit /etc/modprobe.d/alsa-base.conf

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
options snd_hda_intel model=auto

Bij die laatste lijn heb ik al auto, targa, targa-dig, targa-2ch-dig, targa-8ch-dig geprobeerd, allen met hetzelfde resultaat.

Bij controle via de Alsa mixer staan de schuiven open....

Iemand een oplossing ?

Thx


Offline joeri_damian

  • Lid
    • undergroundlinux.webs.com
  • Steunpunt: Nee
Re: 11.04 - geen geluid uit boxen
« Reactie #2 Gepost op: 2011/05/09, 17:51:54 »
Staat Speaker er ook tussen?

bij alsa-mixer inconsole

Offline reezjer

  • Lid
  • Steunpunt: Nee
Re: 11.04 - geen geluid uit boxen
« Reactie #3 Gepost op: 2011/05/10, 18:19:57 »
ik dacht het wel, zal eens een screenshot nemen als ik de laptop ├╝berhaupt terug opgestart krijg  >:(

krijg enkel nog een zwart scherm met
/sbin/init: error while loading shared libraries: libnih.so.1: cannot open shared object file: Input/output error
en bij opstarten in herstelmodus gebeurt er ook niets