Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Samba, probleempje met mounten  (gelezen 663 keer)

Offline DePurpereWolf

  • Lid
  • Steunpunt: Nee
Samba, probleempje met mounten
« Gepost op: 2011/05/02, 13:28:29 »
Het doel is om via mijn ubuntu 10.04 machine bepaalde mappen te archiveren op mijn Win7 machine, (en andersom) Het gaat hier dan om grote mappen, zoals 20GB voor photo's en 100GB voor video's. Voor zoiets wil ik dan rsync gebruiken.

Maar voordat ik dat opstel wil ik eerst het mounten via samba goed onder de knie krijgen. Het netwerk werkt, maar volgens mij niet helemaal perfect. Ik ben dus de Ubuntu documentatie aan het afstruinen zodat ik het werkend kan krijgen, en ook echt een smb adres kan mounten, wat geloof ik nodig is voor rsync.

Ik ben op deze pagina begonnen, maar kom al meteen in moeilijkheden, en ik zou daar graag jullie mening over willen hebben.
https://help.ubuntu.com/community/Samba/SambaClientGuide

Onder 'manual configuration' kan ik zonder problemen een serverlijst krijgen:
smbclient -L //server -U userAl moet ik wel een workgroup en een username specificieren
smbclient -L //Win7 -U UserNameOnWin7 -W workgoupMaar als ik dan vervolgens een map wil aanspreken via:
smbclient -L //Win7/handycam -U UserNameOnWin7 -W workgoupKrijg ik dezelfde lijst weer te zien maar niet een prompt met smb:
smb: \>
Als ik dat dan even voor lief neem en verder ga kan ik het volgende uitvoeren:
sudo mount -t cifs //Win7/handycam ~/mnt -o username=UserNameOnWin7 workgroup=workgroup ,noexec
Krijg ik enkel een soort van man pages te zien. Maar niks is gemount.
Usage: mount -V                 : print version
       mount -h                 : print this help
       mount                    : list mounted filesystems
       mount -l                 : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
       mount -a [-t|-O] ...     : mount all stuff from /etc/fstab
       mount device             : mount device at the known place
       mount directory          : mount known device here
       mount -t type dev dir    : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
       mount --bind olddir newdir
or move a subtree:
       mount --move olddir newdir
One can change the type of mount containing the directory dir:
       mount --make-shared dir
       mount --make-slave dir
       mount --make-private dir
       mount --make-unbindable dir
One can change the type of all the mounts in a mount subtree
containing the directory dir:
       mount --make-rshared dir
       mount --make-rslave dir
       mount --make-rprivate dir
       mount --make-runbindable dir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using  -L label  or by uuid, using  -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say  man 8 mount .

Iemand enig idee wat ik hier niet goed doe?

Offline softbart

  • Lid
  • Steunpunt: Nee
Re: Samba, probleempje met mounten
« Reactie #1 Gepost op: 2011/05/02, 19:29:47 »
Wanneer er een syntaxt fout wordt gemaakt in mount wordt de opdracht niet uitgevoerd en wordt de help text getoond.

De komma dient tussen de user-item en groep item te staan.

groet,

Theo

Offline DePurpereWolf

  • Lid
  • Steunpunt: Nee
Re: Samba, probleempje met mounten
« Reactie #2 Gepost op: 2011/05/07, 14:32:02 »
Het is uiteindelijk gelukt met:
sudo mount -t cifs //192.168.1.103/handycam ~/mnt/ -o user=workgroup/UserName%PassWordBedankt voor de hint.