Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [opgelost]ltsp: trying to load: pxelinux.cfg/0veel nullen  (gelezen 1015 keer)

Offline blokkendoos

  • Lid
  • Steunpunt: Nee
[opgelost]ltsp: trying to load: pxelinux.cfg/0veel nullen
« Gepost op: 2011/05/02, 09:35:24 »
Beste mensen,

Ik dacht een simpel projectje te beginnen met LTSP op een bestaande desktop Ub 10.04. Heb daarbij min of meer dit draadje gevolgd dat bij de ltsp-documentatie vermeld wordt:http://ubuntuforums.org/showthread.php?t=599166&highlight=ltsp = ltsp server with 2 nic cards. Na vele uren rommelen met de
dhcpd.conf en opnieuw opstarten van dhcp3-server

ben ik wel toe aan wat ondersteuning.
Mijn beide servernetwerkkaarten zijn allebei actief. Een van de twee heeft het default ip-adres van ltsp = 192.168.0.1.
Mijn dhcpd.conf ziet er zo uit:
authoritative;

subnet 192.168.0.0 netmask 255.255.255.0 {
    range 192.168.0.150 192.168.0.250;
    option domain-name "*";
    option domain-name-servers 192.168.0.1;
    option broadcast-address 192.168.0.255;
    option routers 192.168.0.1;
#    next-server 192.168.0.1;
#    get-lease-hostnames true;
    option subnet-mask 255.255.255.0;
    option root-path "/opt/ltsp/i386";
    if substring( option vendor-class-identifier, 0, 9 ) = "PXEClient" {
        filename "/ltsp/i386/pxelinux.0";
    } else {
        filename "/ltsp/i386/nbi.img";
    }
}

Wanneer, d.w.z. na welke wijzigingen moet je een nieuwe opdracht ltsp-build-client geven?

De client maakt contact met de dhcp3 server zie ik aan het ip-adres dat'ie krijgt toegewezen.
Maar het blijft steken met de mededeling:
Trying to load: pxelinux.cfg/0veel nullen

Wie kan me verder helpen?

b.v.d.

pablo k
----------------------------------
Ondertussen word ik bij onze oosterburen gewaar van het belang van een lopende tftp-daemon die wordt opgestart door inetd.
in mijn /etc/inetd.conf komt inderdaad helemaal niets voor dat lijkt op het starten van tftp. Dus voegen we aldaar de
tftp           dgram   udp4     wait    root  /usr/sbin/in.tftpd /usr/sbin/in.tftpd -s /var/lib/tftpboot
regel toe.
Daarnaast blijkt dat vanaf versie 10.04 het bestand /etc/default/tftpd-hpa ook aangepast moet worden:
TFTP_USERNAME="tftp"
TFTP_DIRECTORY="/var/lib/tftpboot"
TFTP_ADDRESS="0.0.0.0:69"
TFTP_OPTIONS="-l -s"

Vervolgens leren we ook daar, dat vanaf versie Hardy de nbd-dienst ervoor zorgt dat de LTSP-images worden klaargezet. De opdracht sudo ltsp-update-image maakt deze image in /opt/ltsp/images. Ook nbd biedt zijn dienst aan via inetd. Daarvoor moet er dus een regel
2000    stream  tcp     nowait  nobody /usr/sbin/tcpd /usr/sbin/nbdrootd /opt/ltsp/images/i386.img

in /etc/inetd.conf terug te vinden zijn (een regel per architectuur).

Na deze aanpassingen moeten meerdere diensten herstart worden:
sudo /etc/init.d/dhcp3-server restart
sudo /etc/init.d/tftpd-hpa restart
# bei Hardy
sudo /etc/init.d/openbsd-inetd restart

De 'nieuw ontdekte nadruk' op nbd en mijn hierboven genoteerde probleem met mijn eerste client die niet voorbij de PXE-opstart komt, doen me besluiten de opstartregel in /etc/ltsp/dhcpd.conf aan te passen, zodanig dat wanneer in de kennismakingsstring PXEClient staat
if substring( option vendor-class-identifier, 0, 9 ) = "PXEClient" {
        # filename "/ltsp/i386/pxelinux.0";
        filename "/ltsp/i386/nbi.img";
    } ...
het nbi.img geladen dient te worden.

Tevens begin ik te beseffen dat mijn eerste test-client voor ltsp misschien niet zo'n doorsnee pceetje is als ik in eerste instantie had aangenomen. Het gaat namelijk om een 14 Watt AMD Geode NX 1200+ processor.
Dus probeer ik het op een andere client en die start meteen op. Ik kan inloggen. ;)

Even later, terug bij de eerste client, krijg ik nu een melding dat "NBP is too big to fit in free base memory".
Ik besluit de if substring ...="PXEClient"-regel weer om te keren om te zien of dat helpt bij de Geode-pc. Helaas. Nog niet.

Hulp blijft uiterst welkom!

b.v.d.

pablo k
« Laatst bewerkt op: 2011/05/03, 17:18:46 door blokkendoos »

Offline blokkendoos

  • Lid
  • Steunpunt: Nee
Re: ltsp: trying to load: pxelinux.cfg/0veel nullen
« Reactie #1 Gepost op: 2011/05/03, 17:18:20 »
Na veel gezoek, getest en ander gerommel ontdekt dat het probleem de chipset van het mobo is = SiS900. Dus maar eens rondgekeken bij http://rom-o-matic.net/ en een gPXE bootrom-image voor deze SiS900 gedownload en gebrand op een cd.
Bingo!
Overigens kan ik eenieder die met LTSP aan de slag gaat aanraden een kijkje te nemen op http://wiki.ubuntuusers.de/LTSP. Ik houd wel van de Duitse volledigheid i.t.t. Angelsaksische halfslachtigheid.

m.v.g.

pablo k