Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: installatie met oude kernel  (gelezen 2166 keer)

Offline sidius

  • Lid
  • Steunpunt: Nee
installatie met oude kernel
« Gepost op: 2011/04/25, 09:51:47 »
ik heb problemen met de kernel van ubuntu 10.10 en hoger.
ik kan wel 10.04 gebruiken.
ik heb ook al 10.10 hebben draaien met de kernel van 10.04, ook dan geen groot probleem.
ik heb altijd gebruik gemaakt van kubuntu.
ik zou graag eens ubuntu 11.04 willen proberen met unity.
zou het goed gaan als ik ubuntu 10.04 installeer en deze (over 3 dagen) upgrade naar 11.04
krijg ik dan ook unity er op?
hoe doe ik dat dan precies?

en wie kan me helpen met het regelen van mijn backlight?
x-backlight werkt niet, de samsung tools werken alleen maar met de kernel van 10.10 of hoger........

Offline HarzG

  • Lid
  • Steunpunt: Nee
Re: installatie met oude kernel
« Reactie #1 Gepost op: 2011/04/25, 11:02:02 »
Je kan de live-CD proberen van 11.04 en daarmee kijken of het werkt. Dan heb je meteen zicht op de hardware-herkenning en de functionaliteit.
Xubuntu 16.04; siduction-15.1.0 Xfce

Offline sidius

  • Lid
  • Steunpunt: Nee
Re: installatie met oude kernel
« Reactie #2 Gepost op: 2011/04/25, 11:30:58 »
nee met 11.04 loopt ie niet, gaat mij er om of 11.04 loopt met die oudere kernel en of unity er dan automatishc opkomt bij upgrade vanaf 10.04 en hoe ik anders unity krijg

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: installatie met oude kernel
« Reactie #3 Gepost op: 2011/04/25, 11:33:39 »
Ik zou het gewoon houden bij 10.04 LTS. Topkwaliteit. En de schermhelderheid kun je misschien zo regelen:
http://sites.google.com/site/computertip/samsung-n150#TOC-Schermhelderheid

Offline sidius

  • Lid
  • Steunpunt: Nee
Re: installatie met oude kernel
« Reactie #4 Gepost op: 2011/04/25, 11:55:48 »
okeej, die schermhelderheid, dat werkt perfect.
zal er wel een scriptje van maken ofzo
mooiste zou zijn als ik het omhoog en omlaag kon doen met twee toetsen die je er aan koppelt.
dus dat hij hem uitleest, en hem dan verhogen met 10 bv
allermooiste is als het aan de functietoetsen kan functie omhoog-pijltje en functie omlaag pijltje.
maar goed, dat is alleen als het echt mooi kan.

ik ben zelf niet echt gecharmeerd van gnome, heb altijd onder kde gewerkt
ik heb de beta van 1104 van unity gedraaid, en deze vind ik wel wat hebben
werkt unity niet goed?
en als ik kubuntu weer installeer moet ik van bepaalde programmas wel nieuwere versies hebben
vooral dingen als voor msn (kmess) enzo
is er een lijst met ppa 's ergens te vinden?

Offline HarzG

  • Lid
  • Steunpunt: Nee
Re: backlight
« Reactie #5 Gepost op: 2011/04/25, 12:30:15 »
Je backlight-probleem kan op de manier van Pjotr opgelost worden maar het kan ook handmatig in "percentages" zoals tante Google mij vertelde.
De hele operatie lijkt ingewikkeld, maar je kan hierdoor afhankelijk van de omgeving de helderheid aanpassen.

Ik heb een NL-versie ervan gemaakt en de handleiding hoe het zou moeten werken.

1. Map en bestand aanmaken als sudo
Maak in de terminal als sudo een submap aan in /opt met de naam /uth_backlight.
sudo mkdir /opt/uth_backlight
Maak als in een terminal een bestand aan met de naam
sudo nano /opt/uth_backlight/helderh.sh
Kopieer/plak de onderstaande code in het bestand (de rechtermuisknop werkt wel in de terminal met nano, CTRL-V en CTRL-INS doen het niet).

#!/bin/bash
if [ -z "$1" ]; then waarde=100
else waarde=$1
fi
waarde=$(echo $waarde"*2.55" | bc)
waarde=$(echo "scale=0; "$waarde"/1" | bc)
if [ $waarde -lt 51 ]; then waarde=51; fi
if [ $waarde -gt 255 ]; then waarde=255 ; fi
hex=$(echo "obase=16; $waarde" | bc)
setpci -s 00:02.0 F4.B=$hex

Hierna CTRL-X, J (of Y als het er Engels staat), ENTER.

2. Voeg het script toe bij sudoers
sudo nano /etc/sudoersen voeg daar onderstaande code toe
jegebruikersnmaam ALL=(root) NOPASSWD: /opt/uth_backlight/helderh.shHierna CTRL-X, J (of Y als het er Engels staat), ENTER.

Hierna kan je de helderheid als user " jegebruikersnmaam" aanpassen van 20 tot 100 door een terminalopdracht zoals:
helderh 55
3. Maak het script uitvoerbaar
sudo chmod a+x /opt/uth_backlight/helderh.shDat is dan voor alle users uitvoerbaar. NB: Maar ik heb slechts 1 laten toevoegen voor het script bij de sudoers.

4. Vertel of het werkt
Dan horen andere forumleden ook of het zo kan.
« Laatst bewerkt op: 2011/04/25, 12:32:00 door HarzG »
Xubuntu 16.04; siduction-15.1.0 Xfce

Offline sidius

  • Lid
  • Steunpunt: Nee
Re: installatie met oude kernel
« Reactie #6 Gepost op: 2011/04/25, 12:45:19 »
okeej
ik heb het script geprobeerd.
maar ik werk vanaf een live-usb, dit omdat ik nog even alles getest wil hebben voordat ik weer ga installeeren.
het script werkt goed hoor.............
is het ook mogelijk om 2 scripts te hebben?
1 tje voor omhoog en omlaag met bv stappen van 10?


Offline sidius

  • Lid
  • Steunpunt: Nee
Re: installatie met oude kernel
« Reactie #7 Gepost op: 2011/04/25, 13:27:45 »
en kunnen jullie eens een blik werpen op:
https://bbs.archlinux.org/viewtopic.php?pid=915684
heeft dat ook te maken met mijn probleem?

Offline HarzG

  • Lid
  • Steunpunt: Nee
Re: installatie met oude kernel
« Reactie #8 Gepost op: 2011/04/25, 17:18:20 »
is het ook mogelijk om 2 scripts te hebben?
1 tje voor omhoog en omlaag met bv stappen van 10?
Omdat ik geen Samsung heb en ook geen uitgebreide ervaring met scripts, doe ik maar een gok.
Je maakt 1 script helderg voor 10 omhoog en 1 script helderk voor 10 omlaag. helderh laat je zo om in 1 keer een bepaalde waarde te kunnen vastleggen.
De inhoud zou dan zo kunnen zijn voor helderg.sh (groter):
#!/bin/bash
if [ -z "$1" ]; then waarde=100
else waarde=$1
fi
waarde=$(echo $waarde"*2.55" | bc)
waarde=$(echo "scale=0; ("$waarde"+10)/1" | bc)
if [ $waarde -lt 51 ]; then waarde=51; fi
if [ $waarde -gt 255 ]; then waarde=255 ; fi
hex=$(echo "obase=16; $waarde" | bc)
setpci -s 00:02.0 F4.B=$hex
... en voor helderk.sh (klein)
#!/bin/bash
if [ -z "$1" ]; then waarde=100
else waarde=$1
fi
waarde=$(echo $waarde"*2.55" | bc)
waarde=$(echo "scale=0; ("$waarde"-10)/1" | bc)
if [ $waarde -lt 51 ]; then waarde=51; fi
if [ $waarde -gt 255 ]; then waarde=255 ; fi
hex=$(echo "obase=16; $waarde" | bc)
setpci -s 00:02.0 F4.B=$hex
Of dat met de berekening zo correct is en met de haakjes, weet ik zo niet. Laat maar weten of dat zo kan.

Als je beiden snel wilt "bakken", maak je in de terminal 2 kopieën als sudo:
sudo cp /opt/uth_backlight/helderh.sh /opt/uth_backlight/helderg.sh
sudo cp /opt/uth_backlight/helderh.sh /opt/uth_backlight/helderk.sh
Vervolgens pas je de code aan van deze bestanden door de plus 10 en min 10 erin te plaatsen.
Omdat je de eigenschappen ook gekopieerd hebt, ben je klaar met de bestanden.

Het zou kunnen (ben geen expert, slechts "de vertaler van"), dat je in het bestand /etc/sudoers ook met een wildcard kan werken.
Dan zou dit volstaan voor de drie scripts.
jegebruikersnmaam ALL=(root) NOPASSWD: /opt/uth_backlight/helder*
De andere manier is misschien een ppa die samsung-backlight heet. Het is nog in de 0.13.2-versie en ik gebruik zelf vrijwel nooit ppa's.
Dat zou je eerst even kunnen lezen.

Deze samsung-backlight-ppa is beschikbaar voor 10.04, dan kan je de kernel blijven gebruiken en met de LTS-versie rustig afwachten totdat de experts alles out-of-the-box werkend hebben bij de volgende LTS-versie.
Xubuntu 16.04; siduction-15.1.0 Xfce

Offline sidius

  • Lid
  • Steunpunt: Nee
Re: installatie met oude kernel
« Reactie #9 Gepost op: 2011/04/25, 18:58:25 »
helaas werk dat programma van samsung niet, en de scripts doen eigenlijk niet meer als het heel fel zetten of wat gedimd, niet in stappen.
maar is niet de grootste ramp hoor.

Offline sidius

  • Lid
  • Steunpunt: Nee
Re: installatie met oude kernel
« Reactie #10 Gepost op: 2011/04/26, 20:10:13 »
Ik zou het gewoon houden bij 10.04 LTS. Topkwaliteit. En de schermhelderheid kun je misschien zo regelen:
http://sites.google.com/site/computertip/samsung-n150#TOC-Schermhelderheid
ik ben nog wel heel benieuwd naar jou mening over unity
van gnome niet echt gecharmeerd, sorrie
het wordt voor mij unity of weer kde...
wat raadt je mij aan?

Offline MKe

  • Lid
  • Steunpunt: Nee
Re: installatie met oude kernel
« Reactie #11 Gepost op: 2011/04/26, 21:53:02 »
Ik zou het gewoon houden bij 10.04 LTS. Topkwaliteit. En de schermhelderheid kun je misschien zo regelen:
http://sites.google.com/site/computertip/samsung-n150#TOC-Schermhelderheid
ik ben nog wel heel benieuwd naar jou mening over unity
van gnome niet echt gecharmeerd, sorrie
het wordt voor mij unity of weer kde...
wat raadt je mij aan?
Als je problemen hebt met de nieuwe kernel zou ik 10.04 met KDE houden. Zeker als KDE goed bevalt. Unity werkt na een tijdje wennen prima, maar waarom zou je ernaar overstappen als KDE prima is?

Offline sidius

  • Lid
  • Steunpunt: Nee
Re: installatie met oude kernel
« Reactie #12 Gepost op: 2011/04/26, 22:08:46 »
ik probeer graag andere dingen uit..........

Offline Tom

  • Lid
    • Wanda´s Blog Linux Xubuntu.
  • Steunpunt: Nee
Re: installatie met oude kernel
« Reactie #13 Gepost op: 2011/04/26, 22:51:02 »
Tsja is uw keuze een stabiel lopend systeem gebruiken of een nieuwere en de hele boel (misschien) in puin.
Voor mij niet moeilijk stabiliteit ,maar ik ben u niet. :)

Offline Maik

  • Lid
  • Steunpunt: Nee
Re: installatie met oude kernel
« Reactie #14 Gepost op: 2011/04/27, 00:27:07 »
De tussen versies zijn net zo stabiel, het is alleen dat de LTS versies langer ondersteund worden. Kijk naar de Beta's van Ku- en Xubuntu 11.04, deze zijn, zeker de laatsgenoemde, echt stabiel. Goed voor alledaags gebruik net als een LTS.

Ook bij een LTS versie stuiten mensen op problemen of sluipt er wel eens een fout in.

Offline HarzG

  • Lid
  • Steunpunt: Nee
Re: installatie met oude kernel
« Reactie #15 Gepost op: 2011/04/27, 23:10:47 »
De tussen versies zijn net zo stabiel, het is alleen dat de LTS versies langer ondersteund worden.
Hoewel je een prachtige afbeelding als avatar hebt, ben ik het niet met je eens.

De eerste versie die na een LTS verschijnt (zoals 10.10), heeft per definitie meer haken en ogen. Dat komt omdat er na een LTS meer nieuwe dingen worden geprobeerd en die zijn voor minder configuraties "geschikt". Als je dus pech hebt, was er bijv. een overstap naar een nieuwe technologie voor de grafische weergave en heeft je chip daar moeite mee.

De LTS-versies zijn "conservatiever" om "iedereen" van een oudere LTS-versie een upgrade na 3 jaar te laten uitvoeren. Dat betekent dat de technologie / hardware van dat wat 3 jaar geleden werkte nog ondersteund wordt.
Deze ondersteuning voor oudere hardware kan bij de "tussenversies" niet worden gegarandeerd, maar wordt wel geprobeerd te leveren. Het beste is dan gewoon een live-CD uit te proberen, dan weet iedereen of e.e.a. werkt.

Opvallend was overigens wel, dat er destijds bij 10.04 nogal problemen waren met bepaalde hardware. Dat hadden de gebruikers van LTS-versies niet verwacht vanwege het conservatieve/stabiele imago van de LTS-versies. Dat heeft een jaar geleden ook enige ontevredenheid over deze versie opgeleverd. In de eerste weken na het verschijnen van 10.04 werden deze problemen volgens mij opgelost.

Achtergrond:
Ubuntu zit "in het schap" van "Debian unstable". 100% garantie hebben wij niet dat "alles" "altijd" "meteen" werkt.

De Ubuntu-filosofie voor de 2 (tussen)versies per jaar is, verkort gezegd:
zo min mogelijk gedoe, het werkt direct en mensen tussen de 12 en 102 kunnen het systeem installeren en gebruiken zonder uitgebreide handleidingen te lezen of drivers te moeten zoeken.
Maar - aandachtspunt: tussentijdse upgrades kunnen technische problemen opleveren.

Voor de LTS-versies komt er een extra/eis bij:
Als de automatische veiligheids-upgrades en "alleen LTS-ondersteuning" aan staan, hoef je in de 3 jaar looptijd niets meer handmatig te veranderen. Je systeem blijft veilig en werkt elke dag zonder verrassingen.

off topic:
Op kantoor werk ik met een "reboot-OS". Na de laatste grote patch-dag was de veel besproken "autorun"-functie weer aan. Deze functie (USB-sticks, CD/DVD automatisch starten) werd voor de veiligheid uitgeschakeld bij een eerdere patch-dag.
Hierdoor heb ik als gebruiker het gevoel: het eerdere uitschakelen was niet nodig/overdreven of de onveilige situatie van vroeger is terug zonder dat de risico's van het "reboot-OS" verholpen werden. De documentatie van de upgrades leverde mij hierover geen informatie.
Dat noem ik een bijzondere verrassing zonder uitleg bij een upgrade en die heb ik met Ubuntu LTS (of bijv. bij Debian stable) nog nooit gezien.
Vandaar dat ik een (luie  :) ) fan van de Ubuntu LTS-versies ben.
« Laatst bewerkt op: 2011/04/27, 23:12:23 door HarzG »
Xubuntu 16.04; siduction-15.1.0 Xfce