Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPL.:Andere versie Ubuntu] deb pakket installeren-An older version is available  (gelezen 1368 keer)

Offline Nonito

  • Lid
  • Steunpunt: Nee
Via Synaptic Packet Manager had ik een libwxbase2.8-0 pakket geïnstalleerd (versie 2.8.10.1-0ubuntu1.2).
Dit moet vervangen worden door versie 2.8-0_2.8.11.0-0ubuntu8

Ik heb de oude versie via Synaptic Packet Manager verwijderd en vervolgens dubbel klik op het nieuwe pakket libwxbase2.8-0_2.8.11.0-0ubuntu8_i386.deb
Dan krijg ik de melding “An olderversion is available in a software channel” en krijg ik het oude bestand terug om te installeren.

Vervolgens geprobeerd via Terminal het nieuwe pakket te installeren:
me@TravelMate:~$ sudo dpkg -i libwxbase2.8-0_2.8.11.0-0ubuntu8_i386.deb
[sudo] password for me:
dpkg: status database area is locked by another process

Ook hier kom ik niet verder.
Wat te doen om toch de laatste versie te installeren?
« Laatst bewerkt op: 2011/04/18, 16:46:37 door Nonito »

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: deb pakket installeren - An olderversion is available
« Reactie #1 Gepost op: 2011/04/18, 13:49:14 »
Dan zou ik de oudere versie laten staan. Sommige andere pakketten zouden kunnen verwijzen naar die oudere versie en dan krijg je gegarandeerd een error/foutmelding.

Is er een reden waarom je een nieuwere versie van een lib bestand wil installeren?

Soms zullen latere updates er zelf voor zorgen dat het een nieuwere versie word. Soms ook niet. Bijvoorbeeld in een LTS versie kan het zijn dat (ik noem maar iets) FireFox geen update zal krijgen naar versie 4 maar doorgaan met de oudere 3.6.... versie.
Dat is om het systeem zo stabiel mogelijk te houden.
Nieuwere versies zouden wel eens conflicten kunnen veroorzaken.

Offline Nonito

  • Lid
  • Steunpunt: Nee
Re: deb pakket installeren - An olderversion is available
« Reactie #2 Gepost op: 2011/04/18, 13:56:59 »
Maar dan lukt de installatie van wxCam niet.
Als ik dit met Synaptic Packet Manager wil installeren, dan krijg ik de foutmelding zoals in de afbeelding.

Dus op de één of andere manier moet ik toch de nieuwe versie installeren.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: deb pakket installeren - An older version is available
« Reactie #3 Gepost op: 2011/04/18, 14:37:35 »
Ok, Zelf even vanalles geprobeerd.
Het probleem zit hem in het feit dat die wxCam met pakketten werkt die pas voorkomen in 10.10.
Jij hebt waarschijnlijk 10.04

Je kan proberen van dit te doen:
Je moet onderstaande pakketten één voor één installeren. Daarna zou je dus die wxCam moeten kunnen installeren.

http://launchpadlibrarian.net/50543917/libglib2.0-0_2.25.9-1ubuntu1_i386.deb
http://launchpadlibrarian.net/52388478/libgdk-pixbuf2.0-0_2.21.6-2ubuntu1_i386.deb
http://launchpadlibrarian.net/65034209/libwxgtk2.8-0_2.8.11.0-0ubuntu4.1_i386.deb
http://launchpadlibrarian.net/52194029/libwxbase2.8-0_2.8.11.0-0ubuntu2_i386.deb

Ik kreeg echter een melding van conflicten nadat ik het pakket libwxgdk-picbuf wilde installeren.
Misschien dat het bij jou werkt maar anders zou je een dualboot kunnen doen met 10.10 (dus een verse installatie van die versie of nog even wachten en de 11.04 installeren, deze komt binnen enkele dagen uit).


Hier de fout melding:


Offline Nonito

  • Lid
  • Steunpunt: Nee
Re: deb pakket installeren - An older version is available
« Reactie #4 Gepost op: 2011/04/18, 14:52:40 »
Bedankt voor je inspanning, maar het gaat bij het eerste pakket al mis.

Ik heb inderdaad 10.04. Werd mij aangeraden, omdat deze versie stabieler zou zijn 10.10
Het is dan toch het beste om 10.10 te installeren, of nog even wachten op 11.04

Bedankt   :)
« Laatst bewerkt op: 2011/04/18, 14:56:03 door Nonito »

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: deb pakket installeren - An older version is available
« Reactie #5 Gepost op: 2011/04/18, 14:58:29 »
Graag gedaan,

En inderdaad is 10.04 goed omdat het een LTS is en dus 3jaar ondersteund word. De tussentijdse versies krijgen slechts 1,5 jaar ondersteuning (en zijn eigenlijk ook wel een beetje versies waar nieuwe zaken worden uitgeprobeerd voor ze evt. in de LTS geïntegreerd worden)

Maar je kunt ook een dualboot doen op je PC/Laptop als je ruimte genoeg hebt. Dan kan je dus de LTS bewaren en de 10.10 gebruiken voor de wxCam.

Offline Tom

  • Lid
    • Wanda´s Blog Linux Xubuntu. ♥
  • Steunpunt: Nee
Het zou verdorie niet mogen dat er een pakket in een LTS versie niet werkt omdat de bijbehorende pakjes verouderd zijn.
Dus update die boel ... of eraf flikkeren.
Dat is dus het gene wat mij het meeste ergert aan Ubuntu en daar zou de gemeenschap duchtig over moeten klagen.
2 x Xuby 14.04.5 Lts 64 bits stand alone. 2 x Xuby 16.04.3 Lts 64 bits stand alone. ♥
https://sites.google.com/site/wandabloglinuxxubuntu/pc-s-installeren-configureren

Offline heir4c

  • Lid
  • Steunpunt: Nee
Eigenlijk heb je wel gelijk wanda. Een nieuwe versie van iets en hup je kan al dan niet gebruik maken van dat progje. Soms is dat wel....

Offline donpedroII

  • Lid
  • Steunpunt: Nee
Citaat
dpkg: status database area is locked by another process
Als je de database open hebt staan, oftewel de sysnaptic package manager, krijg je een soortgelijke melding.

Het is niet mogelijk om twee applicaties gelijktijdig te laten rotzooien in de database .... maar goed ook  =D

Offline heir4c

  • Lid
  • Steunpunt: Nee
donpedroII, dat had ik helemaal over het hoofd gezien die foutmelding. (staat in het eerste bericht)
Goed dat je ons daarop attent maakt. ThX

Offline Nonito

  • Lid
  • Steunpunt: Nee
Alvorens ik geprobeerd heb de nieuwe libwxbase2.8-0_2.8.11.0-0ubuntu8_i386.deb te installeren, heb ik in Synaptic Packet Manager de oude versies aangevinkt om te verwijderen.
Waar kan de melding dpkg: status database area is locked by another process dan betrekking op hebben?

Afgezien van het genoemde probleem was het ook niet mogelijk libglib2.0-0_2.25.9-1ubuntu1_i386.deb uit te voeren (# 4). En hier gaat # 8 dus niet op.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Als de .deb installer én synaptic te samen open staan gaat het niet. Dus sluit synaptic, en laat dus de .deb installer alleen open staan. Dan zal je die melding niet meer krijgen.

Offline Nonito

  • Lid
  • Steunpunt: Nee
Even nog en vraagje over de .deb installer

Als ik zoek naar installtie van .deb files, dan heb ik de volgende mogelijkheden:
- dubbelklik op de .deb file
- sudo dpkg –i file_name.deb

Vervolgens op zoek naar de “.deb installer” , maar het enige wat ik vind is een artikel  (https://lists.ubuntu.com/archives/ubuntu-desktop/2005-October/000012.html) , waar ik niet echt veel wijzer van wordt.

Met .deb installer wordt bedoeld GDebi ?

Offline heir4c

  • Lid
  • Steunpunt: Nee
Ja dat word ermee bedoelt.
Het is een beetje als yum in een Redhat distro (met rpm bestanden in plaats van deb bestanden)
Is het een .deb file, dan is het dus echt wel het snelste om gewoon te dubbelklikken op het bestand en dan word gdebi gestart. Zo word ook gecontroleerd of aan alle voorwaarden voldaan is.

Hier een paar linkjes in verband met installers en installeren van software in linux (wel engels, sorry):
http://www.psychocats.net/ubuntu/installingsoftware
http://www.linuxforums.org/forum/linux-tutorials-howtos-reference-material/64958-how-install-software-linux.html
http://laptoplogic.com/resources/a-beginners-guide-on-how-to-install-linux-software
http://journalxtra.com/2010/03/linux-software-installation-easyguide/