Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Opgelost] NVIDIA Driver  (gelezen 6354 keer)

Offline Jaxo

  • Lid
  • Steunpunt: Nee
[Opgelost] NVIDIA Driver
« Gepost op: 2011/04/16, 14:05:43 »
Ik probeerde net Alien Arena te spelen maar ik had erge screen lagg dus besloot ik om iets aan mijn NVIDIA driver te doen.
Ik keek wat rond bij Systeem tab en vond wat ik zocht. Ik installeerde en downloadde het en toen moest ik mijn pc opnieuw opstarten.
Toen ik dat had gedaan zag ik het Ubuntu logo niet verschijnen maar stond er alleen Ubuntu 10.10
Daarna kreeg ik een error waar iets stond over een interrupted endpoint en usb
Kan iemand mij hier mee helpen? =D
« Laatst bewerkt op: 2011/04/21, 11:21:28 door Jaxo »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Ubuntu start niet op
« Reactie #1 Gepost op: 2011/04/16, 14:28:00 »
Kan je wel nog in de recovery komen via Grub? Probeer dan de optie fixXserver (o.i.d.) en start de computer opnieuw op. Kom je nu wel verder?
In der Beschränkung zeigt sich der Meister.

Offline Jaxo

  • Lid
  • Steunpunt: Nee
Re: Ubuntu start niet op
« Reactie #2 Gepost op: 2011/04/16, 14:29:32 »
Kan je wel nog in de recovery komen via Grub? Probeer dan de optie fixXserver (o.i.d.) en start de computer opnieuw op. Kom je nu wel verder?

Hoe kom in de Grub?
Sorry, ben nieuw met linux  :(

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Ubuntu start niet op
« Reactie #3 Gepost op: 2011/04/16, 14:39:32 »
Heb je een dualboot met Windows? Als je de computer opstart, krijg je eerst de BIOS te zien, daarna komt het Grub scherm met wat regels tekst, bij een van de regels staat recovery, van deze moet je opstarten.
Heb je alleen een Ubuntu versie eropstaan, dan de SHIFT toets indrukken na de BIOS, dan krijg je het Grub menu te zien.
In der Beschränkung zeigt sich der Meister.

Offline Jaxo

  • Lid
  • Steunpunt: Nee
Re: Ubuntu start niet op
« Reactie #4 Gepost op: 2011/04/16, 14:52:19 »
Hartstikke bedankt!
Met wat gelummel in het recovery scherm waar ik in kwam via de recovery mode kwam ik in de veilige modus!
'k Heb NVIDIA's stuurprogramma verwijderd en gebruik weer nu die default van Ubuntu.
Maar hoe kom ik nu van die screen lagg af, als ik een game speel?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Ubuntu start niet op
« Reactie #5 Gepost op: 2011/04/16, 15:17:51 »
De default van Ubuntu is VESA, met de VESA driver heb je een lage frame rate. Welke Nvidia kaart heb je?
Kijk even onder Systeem>Beheer>Extra Stuurprogramma's  Hier krijg je diverse stuurprogramma's te zien voor je Nvidia kaart. Bij een staat er Aanbevolen, deze moet je installeren.
In der Beschränkung zeigt sich der Meister.

Offline Jaxo

  • Lid
  • Steunpunt: Nee
Re: Ubuntu start niet op
« Reactie #6 Gepost op: 2011/04/16, 15:52:14 »
De default van Ubuntu is VESA, met de VESA driver heb je een lage frame rate. Welke Nvidia kaart heb je?
Kijk even onder Systeem>Beheer>Extra Stuurprogramma's  Hier krijg je diverse stuurprogramma's te zien voor je Nvidia kaart. Bij een staat er Aanbevolen, deze moet je installeren.
Ik heb een NVIDIA Gforce 8400GS.
Ik had de driver gedownload zoals jij het zei maar ik kreeg weer hetzelfde wat ik de net had (dat kwam ook door dit) daarna downloadde ik nog een oudere versie maar ik kreeg hetzelfde.
Ik heb het weer gemaakt nu.
Kan ik niet de frame rate van de VESA driver niet veranderen?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Ubuntu start niet op
« Reactie #7 Gepost op: 2011/04/16, 17:50:53 »
Nee die frame rate kan je niet veranderen. Vesa is een grafisch veilige modus driver.
Download anders hier http://www.downloadatoz.com/driver/articles/update-nvidia-linux-display-driver-to-260-19-36-whql-for-ubuntu-10-10.html de driver of direct van de Nvidia site http://www.nvidia.com/Download/index.aspx?lang=en-us even de juiste kaart selecteren net als 32 of 64 bit.
In der Beschränkung zeigt sich der Meister.

Offline Jaxo

  • Lid
  • Steunpunt: Nee
Re: Ubuntu start niet op
« Reactie #8 Gepost op: 2011/04/16, 18:53:21 »
Nee die frame rate kan je niet veranderen. Vesa is een grafisch veilige modus driver.
Download anders hier http://www.downloadatoz.com/driver/articles/update-nvidia-linux-display-driver-to-260-19-36-whql-for-ubuntu-10-10.html de driver of direct van de Nvidia site http://www.nvidia.com/Download/index.aspx?lang=en-us even de juiste kaart selecteren net als 32 of 64 bit.
Ik heb de .run file en heb al de chmod veranderd en als root kunnen uitvoeren.
Maar het lukte me niet om te installeren :(
Hoe moet ik dit doen?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Ubuntu start niet op
« Reactie #9 Gepost op: 2011/04/16, 19:58:31 »
Navigeer met de terminal naar de map waar de run file staat, dat doe je door in de terminal het cd commando te typen;
Bijv. je run file staat in de map Downloads, type dan:
cd Downloads en geef een ENTER. Nu even een tip, als je de naam van een bestand intypt dan kan je na het derde teken op de TAB drukken, dan wordt de rest van de tekens automatisch aangevuld.
Vervolgens ga je het bestand uitvoerbaar maken, type:
sudo chmod +x naam_bestand.run en geef een ENTER, nu moet je het wachtwoord invullen, hier zie je niets van, geen sterretjes, balletjes o.i.d. gewoon blind intypen en geef een ENTER.
Nu installeren, type sudo sh ./naam_bestand.run Let op het puntje voor de slash (/) vergeet je deze gebeurt er niets.
Waarschijnlijk hoef je nu niet je wachtwoord in te geven er is nl. een tijdslimiet voor het werken als root.

In der Beschränkung zeigt sich der Meister.

Offline Jaxo

  • Lid
  • Steunpunt: Nee
Re: Ubuntu start niet op
« Reactie #10 Gepost op: 2011/04/16, 20:02:37 »
Ik krijg nu een error met:
You appear to be running an X server; please exit X before installing etc etc
als ik de laatste stap heb gedaan

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Ubuntu start niet op
« Reactie #11 Gepost op: 2011/04/16, 21:19:48 »
Start de computer opnieuw op, ga weer naar de recovery mode, kies nu drop to rootshell, nu kom je in een grote terminal. Dan moet je eerst inloggen. Navigeer weer naar de map waar je het bestand hebt staan en voer de commando's weer uit. Start de computer opnieuw op.
In der Beschränkung zeigt sich der Meister.

Offline Jaxo

  • Lid
  • Steunpunt: Nee
Re: Ubuntu start niet op
« Reactie #12 Gepost op: 2011/04/16, 21:47:00 »
Start de computer opnieuw op, ga weer naar de recovery mode, kies nu drop to rootshell, nu kom je in een grote terminal. Dan moet je eerst inloggen. Navigeer weer naar de map waar je het bestand hebt staan en voer de commando's weer uit. Start de computer opnieuw op.
Het lukte me om daar te komen en het .run bestand te openen, maar toen kreeg ik een error dat ik in runlevel 1 zat en dat dit problemen kan veroorzaken. Hij raadde me aan om in runlevel 3 te gaan.
Wat is dit en hoe moet dit? :D

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Ubuntu start niet op
« Reactie #13 Gepost op: 2011/04/16, 22:09:13 »
Even wat over run levels, dit kan iets afwijken per distrubutie.

init 0
Runlevel 0 (halt) sluit het systeem onherroepelijk af
init 1
Runlevel 1 (single user mode) laat slechts een gebruiker toe. U hebt het root wachtwoord nodig. Dit kan handig zijn als u systeemonderhoud (fsck) pleegt.
init 2
Runlevel 2 (multi user mode) is gelijk aan runlevel 3 zonder netwerk (NFS).
init 3
Runlevel 3 (full multi-user mode) is de standaard modus. Linux is gereed voor het gebruik door meerdere personen.
init 4
Runlevel 4 (unused) komt in de praktijk neer op runlevel 3.
init 5
Runlevel 5 (X11) start een grafisch inlogscherm op.
init 6
Runlevel 6 (reboot) herstart Linux.

Start nogmaals op in de recovery mode, als het goed is kan je ook voor de gewone shell kiezen, dus niet de root shell, dan kom je in runlevel 3.
In der Beschränkung zeigt sich der Meister.

Offline Jaxo

  • Lid
  • Steunpunt: Nee
Re: Ubuntu start niet op
« Reactie #14 Gepost op: 2011/04/16, 22:28:51 »
Even wat over run levels, dit kan iets afwijken per distrubutie.

init 0
Runlevel 0 (halt) sluit het systeem onherroepelijk af
init 1
Runlevel 1 (single user mode) laat slechts een gebruiker toe. U hebt het root wachtwoord nodig. Dit kan handig zijn als u systeemonderhoud (fsck) pleegt.
init 2
Runlevel 2 (multi user mode) is gelijk aan runlevel 3 zonder netwerk (NFS).
init 3
Runlevel 3 (full multi-user mode) is de standaard modus. Linux is gereed voor het gebruik door meerdere personen.
init 4
Runlevel 4 (unused) komt in de praktijk neer op runlevel 3.
init 5
Runlevel 5 (X11) start een grafisch inlogscherm op.
init 6
Runlevel 6 (reboot) herstart Linux.

Start nogmaals op in de recovery mode, als het goed is kan je ook voor de gewone shell kiezen, dus niet de root shell, dan kom je in runlevel 3.
Het lukte me op in runlevel 3 te komen met de command:
unit 3
in rootshell
Daarna deed ik al de commands maar toen kreeg ik iets over de Nouveau driver en dat hij een bestand kon schrijven om hem te disablen.
Daarna kreeg ik een error dat de installatie mislukt was.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Ubuntu start niet op
« Reactie #15 Gepost op: 2011/04/16, 22:42:41 »
Je moet niet in de rootshell zitten of daar vanuit commando's invoeren. We gaan het even anders proberen.
Start Ubuntu op de normale wijze op, als je ingelogd bent en het bureaublad voor je hebt druk je tegelijkertijd op CTRL+ALT+F1 nu kom je in een terminal (tty1) Voer de commando's nogmaals uit. Lukt het nu? Om weer om te schakelen naar de Xserver druk je tegelijkertijd  op CTRL+ALT+F7
Start de computer opnieuw op.
In der Beschränkung zeigt sich der Meister.

Offline Jaxo

  • Lid
  • Steunpunt: Nee
Re: Ubuntu start niet op
« Reactie #16 Gepost op: 2011/04/16, 23:42:55 »
Ik kom in tty1 maar daarna probeer ik het weer te openen en dan krijg ik weer de error dat ik Xserver aan heb
Log:
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sat Apr 16 23:44:01 2011
installer version: 260.19.44

PATH:
/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin

option status:
  license pre-accepted               : false
  update                             : false
  force update                       : false
  expert                             : false
  uninstall                          : false
  driver info                        : false
  precompiled interfaces             : true
  no ncurses color                   : false
  query latest version               : false
  no questions                       : false
  silent                             : false
  no recursion                       : false
  no backup                          : false
  kernel module only                 : false
  sanity                             : false
  add this kernel                    : false
  no runlevel check                  : false
  no network                         : false
  no ABI note                        : false
  no RPMs                            : false
  no kernel module                   : false
  force SELinux                      : default
  no X server check                  : false
  no cc version check                : false
  run distro scripts                 : true
  no nouveau check                   : false
  run nvidia-xconfig                 : false
  sigwinch work around               : true
  force tls                          : (not specified)
  X install prefix                   : (not specified)
  X library install path             : (not specified)
  X module install path              : (not specified)
  OpenGL install prefix              : (not specified)
  OpenGL install libdir              : (not specified)
  utility install prefix             : (not specified)
  utility install libdir             : (not specified)
  installer prefix                   : (not specified)
  doc install prefix                 : (not specified)
  kernel name                        : (not specified)
  kernel include path                : (not specified)
  kernel source path                 : (not specified)
  kernel output path                 : (not specified)
  kernel install path                : (not specified)
  precompiled kernel interfaces path : (not specified)
  precompiled kernel interfaces url  : (not specified)
  proc mount point                   : /proc
  ui                                 : (not specified)
  tmpdir                             : /tmp
  ftp mirror                         : ftp://download.nvidia.com
  RPM file list                      : (not specified)
  selinux chcon type                 : (not specified)

Using: nvidia-installer ncurses user interface
-> The file '/tmp/.X0-lock' exists and appears to contain the process ID '1200'
   of a runnning X server.
ERROR: You appear to be running an X server; please exit X before installing.
       For further details, please see the section INSTALLING THE NVIDIA DRIVER
       in the README available on the Linux driver download page at
       www.nvidia.com.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at www.nvidia.com.

Misschien kan ik beter wachten op de release van Ubuntu 11.04 waar dit waarschijnlijk makkelijker gaat:
http://www.youtube.com/watch?v=J1nQNa8FRV8&feature=related
Hij komt toch over een paar dagen al uit?
« Laatst bewerkt op: 2011/04/16, 23:50:01 door Jaxo »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Ubuntu start niet op
« Reactie #17 Gepost op: 2011/04/17, 00:17:58 »
Ubuntu 11.04 komt eind april uit.
Wat je nog wel kan proberen, open Synaptic.  Systeem>Beheer>Synaptic en installeer de current driver maar ook
nvidia-173-modaliases
In der Beschränkung zeigt sich der Meister.

Offline Jaxo

  • Lid
  • Steunpunt: Nee
Re: Ubuntu start niet op
« Reactie #18 Gepost op: 2011/04/17, 00:38:50 »
Ubuntu 11.04 komt eind april uit.
Wat je nog wel kan proberen, open Synaptic.  Systeem>Beheer>Synaptic en installeer de current driver maar ook
nvidia-173-modaliases

Dit heb ik nu

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Ubuntu start niet op
« Reactie #19 Gepost op: 2011/04/17, 21:58:39 »
Ziet er het zelfde uit als bij mij. Ik heb een Nvidia 7600 GS, dus een eerdere kaart dan jij hebt. Daar verwacht je toch een betere prestatie dan die van mij. Activeer nu via Systeem>Beheer>Extra stuurprogramma's de current versie. Nu zou een xorg.conf niet nodig moeten zijn, naar ik heb dit er instaan:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder58)  Thu Apr 22 20:35:23 PDT 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
#    InputDevice    "Keyboard0" "CoreKeyboard"
# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
#    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
#Section "InputDevice"
#    # generated from default
#    Identifier     "Mouse0"
#    Driver         "mouse"
#    Option         "Protocol" "auto"
#    Option         "Device" "/dev/psaux"
#    Option         "Emulate3Buttons" "no"
#    Option         "ZAxisMapping" "4 5"
#EndSection

# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
#Section "InputDevice"
#    # generated from default
#    Identifier     "Keyboard0"
#    Driver         "kbd"
#EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Kijk door middel van dit commando sudo gedit /etc/X11/xorg.conf of dit
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"           <---------------- er staat en geen nv of iets anders
    VendorName     "NVIDIA Corporation"

Als dit klopt herstart de computer, kom je nu wel verder? En hoe is de frame rate?
In der Beschränkung zeigt sich der Meister.

Offline Jaxo

  • Lid
  • Steunpunt: Nee
Re: Ubuntu start niet op
« Reactie #20 Gepost op: 2011/04/18, 14:56:43 »
Ik heb gisteren mijn Ubuntu moeten herinstalleren omdat hij niet goed meer opstartte, maar dat geeft niet want ik had nog niets bijzonders erop opgeslagen.
Wat moet ik precies installeren?
Want als je zo'n driver installeerd met "Extra Stuurprogramma's" installeer je niet de NVIDIA X Settings (nvidia-settings) en nvidia-current(-dev) wat driver versie 260 is.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Ubuntu start niet op
« Reactie #21 Gepost op: 2011/04/18, 23:07:58 »
nvidia-settings en nvidia-current moet je naderhand appart installeren. nvidia-settings installeert in je xorg.conf
In der Beschränkung zeigt sich der Meister.

Offline Jaxo

  • Lid
  • Steunpunt: Nee
Re: Ubuntu start niet op
« Reactie #22 Gepost op: 2011/04/19, 07:21:02 »
nvidia-settings en nvidia-current moet je naderhand appart installeren. nvidia-settings installeert in je xorg.conf
Dus ik moet gewoon naar het software centrum nvidia-current en nvidia-settings installeren?
En ook nog die driver van NVIDIA bij "Extra Stuurprogramma's"?

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: Ubuntu start niet op
« Reactie #23 Gepost op: 2011/04/19, 08:58:45 »
De default van Ubuntu is VESA, met de VESA driver heb je een lage frame rate. Welke Nvidia kaart heb je?
Kijk even onder Systeem>Beheer>Extra Stuurprogramma's  Hier krijg je diverse stuurprogramma's te zien voor je Nvidia kaart. Bij een staat er Aanbevolen, deze moet je installeren.
Dat is niet waar. Ik gok dat met de GeForce 8400 de nouveau-driver wordt geladen, een opensource driver voor Nvidia-kaarten. Je hebt er 3d-ondersteuning mee, maar bij lange na niet zo snel als met de officiële driver.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Ubuntu start niet op
« Reactie #24 Gepost op: 2011/04/19, 10:53:41 »
Ik heb met mijn Nvidia 7600 GS geen problemen met de nouveau-driver, dat ik een lage framerate heb.
Maar het is wel een goed idee voor Jaxo, om de gesloten driver te downloaden, maar ik dacht dat hij dat al geprobeerd had. In ieder geval zal ik vanavond eens de framerate van de open en gesloten driver opnemen, eens kijken wat het verschil is. :)
« Laatst bewerkt op: 2011/04/19, 23:40:30 door Gijsbert »
In der Beschränkung zeigt sich der Meister.