Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] ubuntu 10.10 start niet meer na gebruik van gparted  (gelezen 3921 keer)

Offline sebas2831983

  • Lid
  • Steunpunt: Nee
Hallo,

Ubuntu 10.10 werkte als een trein, totdat ik met gparted een partitie (FAT32) erbij maakte. Wanneer ik Ubuntu nu boot krijg ik wel het logo te zien, maar verder dan dat komt het niet. In recovery mode, krijg ik de volgende melding:

Begin: Loading essential drivers ... done.
Begin: Running /scripts/init-premount ... done.
Begin: Mounting root file system ... Begin: Running /scripts/local-top ... done.
Begin: Running /scripts/local-premount ... done.
[       3.644823] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
Begin: Running /scripts/local-bottom ... done
done.
Begin: Running /scripts/init-bottom ... done.
mount: mounting /proc on /root/proc failed: No such file or directory
init: Error while reading from descriptor: Bad file descriptor
init: hwclock main process (314) terminated with status 127
init: ureadahead main process (315) terminated with status 3
/bin/sh: Can't open /proc/self/fd/8
init: mountall main process (316) terminated with status 127

Kennelijk een probleem met mounten maar voor een nube als mij moeilijk te begrijpen. Hoe kan ik dit oplossen? Iemand een idee? Suggesties?

Veel dank alvast!
Bas
« Laatst bewerkt op: 2011/04/20, 19:33:46 door sebas2831983 »

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #1 Gepost op: 2011/04/13, 21:01:20 »
Je hebt de partitie opnieuw ingedeeld, waardoor de verwijzing niet meer klopt.
Je zult de file /etc/fstab opnieuw moeten maken/veranderen.
Zo uit mijn hoofd weet ik niet hoe, maar anderen op dit forum kunnen je ongetwijfeld verder helpen.
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

Offline sebas2831983

  • Lid
  • Steunpunt: Nee
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #2 Gepost op: 2011/04/13, 21:30:25 »
Hoi Ron,

Dank voor je reactie.

1. Heeft iemand een procedure in gedachte om deze /etc/fstab file te wijzigen?

2. Kan ik deze file openen via een live-cd van gparted of iets dergelijks?

Cheers,
Bas


Offline metalhead

  • Lid
  • Steunpunt: Nee
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #3 Gepost op: 2011/04/13, 22:08:53 »
met de live cd van ubuntu
dan de partitie mounten waar ubuntu opstaat
en met het commando gksu nautilus
de verkenner openen , navigeren naar /etc/fstab
en dit openen met gedit en dan bewerken
opslaan en herstarten

Offline Ron

  • Forumteam
    • r0n
    • Dwarsligger
  • Steunpunt: Ja
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #4 Gepost op: 2011/04/14, 13:01:20 »
Nu wordt er verwezen naar een sector, met een lange HEX regel.
Dit moet aangepast worden, eventueel werkt een kreet als /dev/sda1 ook.
Zoek even op het forum, op de wiki, of op de site van Pjotr naar de juiste/makkelijkste oplossing.
OpenStandaard evangelist, OpenSource promotor,  OpenData liefhebber.
Xubuntu gebruiker, liefhebber en tester.
In Nederland bekend als een dwarsligger.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #5 Gepost op: 2011/04/14, 13:23:21 »
De hulp voor een niet ervaren gebruiker is hier wat vaag, vind ik.

Je kan dus in recovery mode opstarten. Ik onderstel dat je naar een "root prompt" gegaan bent, met of zonder netwerking. Post hier eens de uitkomst van de volgende commando's
blkid
cat /etc/fstab
Als er inderdaad geen overeenkomst meer is tussen de UUID van het eerste commando, en deze van het tweede, dan hebben we het probleem gevonden en kunnen we zeggen hoe je het kan herstellen.

Het vervelende van de root prompt is dat je niet zomaar kan kopiëren/plakken in het forum. En overschrijven van UUIDS is zeer lastig. Je zou de uitkomst van die commando's naar een bestand kunnen schrijven:
blkid > /partitionering
cat /etc/fstab >> /partitionering

Als je daarna met een live CD opstart, dan zal je op je systeempartitie (mogelijk moet je die eerst aankoppelen) het tekstbestand "partitionering" vinden, dat je dan kan openen om de inhoud hier te posten.

Offline sebas2831983

  • Lid
  • Steunpunt: Nee
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #6 Gepost op: 2011/04/15, 21:13:03 »
Hallo allemaal,

Dank voor jullie reacties!

Ik ga even in op het bericht van 'vanadium'. Ik heb Ubuntu vanaf de live-cd gestart. de volgende commando's resulteren in:

sudo blkid
/dev/loop0: TYPE="squashfs"
/dev/sda1: UUID="9c30c37f-81ae-4423-a660-20318be12e52" TYPE="ext4"
/dev/sda3: UUID="D477-5BE7" TYPE="vfat"
/dev/sda5: UUID="b715c668-22a9-4a24-af8c-54d9d4a95e96" TYPE="swap"

sudo cat /etc/fstab
aufs / aufs rw 0 0
tmpfs /tmp tmpfs nosuid,nodev 0 0
/dev/sda5 swap swap defaults 0 0

Kunnen we hier verder mee?

Groet, Bas

Offline sebas2831983

  • Lid
  • Steunpunt: Nee
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #7 Gepost op: 2011/04/15, 22:25:28 »
Als toevoeging, fstab ziet er als volgt uit:

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
/dev/sda1       /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=b715c668-22a9-4a24-af8c-54d9d4a95e96 none            swap    sw              0       0

Offline sebas2831983

  • Lid
  • Steunpunt: Nee
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #8 Gepost op: 2011/04/15, 22:53:44 »
Nog een toevoeging....
Gebaseerd op mijn eerste post in dit topic, heb ik (denk ik) alleen een probleem met het mounten van '/proc' :

mount: mounting /proc on /root/proc failed: No such file or directory
init: Error while reading from descriptor: Bad file descriptor
init: hwclock main process (314) terminated with status 127
init: ureadahead main process (315) terminated with status 3
/bin/sh: Can't open /proc/self/fd/8
init: mountall main process (316) terminated with status 127

Wat betekend /proc ? Waarom kan deze opeens niet gemount worden?

Offline HarzG

  • Lid
  • Steunpunt: Nee
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #9 Gepost op: 2011/04/16, 11:50:11 »
Je bent volgens mij niet klaar met een aanpassing van /etc/fstab.
De verwijzing met de eerder vastgelegde UUID komt namelijk ook voor in Grub.
Als in Grub een onjuiste UUID wordt doorgegeven, loop je volgens mij vast bij /proc - dat is nl. de eerste regel die wordt toegepast voordat je überhaupt bij de partities sda1 etc. komt.

Mijn voorstel gaat in 3 stappen. Eerst tijdelijk aanpassen van fstab en Grub, hierna wordt de normale situatie weer hersteld.

Stap 1: aanpassen van Grub (tijdelijk)
Hieronder staat een voorbeeld van het bestand /boot/grub/grub.cfg
Dat bestand is niet hetzelfde als bij jou, het gaat mij om het voorbeeld.
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 4a21f67c-fake-8ad1-a130-4446485057f5
if loadfont /usr/share/grub/unicode.pf2 ; then
set gfxmode=800x600
  insmod gfxterm
  insmod vbe
  if terminal_output gfxterm ; then true ; else
    # For backward compatibility with versions of terminal.mod that don't
    # understand terminal_output
    terminal gfxterm
  fi
fi
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 4a21f67c-fake-8ad1-a130-4446485057f5
set locale_dir=($root)/boot/grub/locale
set lang=nl
insmod gettext
if [ ${recordfail} = 1 ]; then
  set timeout=-1
else
  set timeout=3
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 4a21f67c-fake-8ad1-a130-4446485057f5
insmod png
if background_image /usr/share/images/desktop-base/moreblue-orbit-grub.png ; then
  set color_normal=black/black
  set color_highlight=magenta/black
else
  set menu_color_normal=white/black
  set menu_color_highlight=black/light-gray
fi
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/06_mint_theme ###
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 4a21f67c-fake-8ad1-a130-4446485057f5
insmod png
if background_image /boot/grub/linuxmint.png ; then
  set color_normal=white/black
  set color_highlight=white/light-gray
else
  set menu_color_normal=white/black
  set menu_color_highlight=white/light-gray
fi
### END /etc/grub.d/06_mint_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry "Linux Mint 9 Xfce, 2.6.32-26-generic (/dev/sda1)" --class linuxmint --class gnu-linux --class gnu --class os {
recordfail
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 4a21f67c-fake-8ad1-a130-4446485057f5
linux /boot/vmlinuz-2.6.32-26-generic root=UUID=4a21f67c-fake-8ad1-a130-4446485057f5 ro  vga=771  quiet splash
initrd /boot/initrd.img-2.6.32-26-generic
}
menuentry "Linux Mint 9 Xfce, 2.6.32-26-generic (/dev/sda1) -- recovery mode" --class linuxmint --class gnu-linux --class gnu --class os {
recordfail
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 4a21f67c-fake-8ad1-a130-4446485057f5
echo 'Linux 2.6.32-26-generic laden ...'
linux /boot/vmlinuz-2.6.32-26-generic root=UUID=4a21f67c-fake-8ad1-a130-4446485057f5 ro single  vga=771
echo 'Initiële ramdisk laden ...'
initrd /boot/initrd.img-2.6.32-26-generic

Wat hieronder staat is de correctie zonder UUID te gebruiken. Ik heb het als citaat geplaatst om met kleuren de verschillen te laten zien.
Citaat
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-dev --set /dev/sda1
if loadfont /usr/share/grub/unicode.pf2 ; then
set gfxmode=800x600
  insmod gfxterm
  insmod vbe
  if terminal_output gfxterm ; then true ; else
    # For backward compatibility with versions of terminal.mod that don't
    # understand terminal_output
    terminal gfxterm
  fi
fi
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-dev --set /dev/sda1
set locale_dir=($root)/boot/grub/locale
set lang=nl
insmod gettext
if [ ${recordfail} = 1 ]; then
  set timeout=-1
else
  set timeout=3
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-dev --set /dev/sda1
insmod png
if background_image /usr/share/images/desktop-base/moreblue-orbit-grub.png ; then
  set color_normal=black/black
  set color_highlight=magenta/black
else
  set menu_color_normal=white/black
  set menu_color_highlight=black/light-gray
fi
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/06_mint_theme ###
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-dev --set /dev/sda1
insmod png
if background_image /boot/grub/linuxmint.png ; then
  set color_normal=white/black
  set color_highlight=white/light-gray
else
  set menu_color_normal=white/black
  set menu_color_highlight=white/light-gray
fi
### END /etc/grub.d/06_mint_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry "Linux Mint 9 Xfce, 2.6.32-26-generic (/dev/sda1)" --class linuxmint --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd0,1)'
   search --no-floppy --fs-dev --set /dev/sda1
   linux   /boot/vmlinuz-2.6.32-26-generic root=UUID=/dev/sda1 ro  vga=771  quiet splash
   initrd   /boot/initrd.img-2.6.32-26-generic
}
menuentry "Linux Mint 9 Xfce, 2.6.32-26-generic (/dev/sda1) -- recovery mode" --class linuxmint --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd0,1)'
   search --no-floppy --fs-dev --set /dev/sda1
   echo   'Linux 2.6.32-26-generic laden ...'
   linux   /boot/vmlinuz-2.6.32-26-generic root=UUID=/dev/sda1 ro single  vga=771
   echo   'Initiële ramdisk laden ...'
   initrd   /boot/initrd.img-2.6.32-26-generic

Dat was dus stap 1, hierna moet in de fstab de aanpassing worden gedaan.

Stap 2: fstab aanpassen (tijdelijk)
Als stap 2 wordt dus, naast de verwijzing naar de root-partitie als "dev' i.p.v. UUID, ook de verwijzing naar SWAP aangepast. De UUID van de SWAP kan nl. ook in de war zijn. (De oorzaak hiervan is, dat de nieuwe FAT32-partitie vóór de SWAP partitie werd geplaatst.)
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
/dev/sda1       /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=b715c668-22a9-4a24-af8c-54d9d4a95e96 none            swap    sw              0       0

... en dat moet het worden
Citaat
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
/dev/sda1       /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
/dev/sda5 none            swap    sw              0       0

Alle handelingen moeten met de live-CD worden uitgevoerd. De veranderingen aan de bestanden vereisen dat de "administrator" (sudo) de bewerkingen uitvoert.

Stap 3: terg naar de normale situatie met UUIds
Als je hierna weer normaal kan booten, dan is het verstandig om een update van Grub uit te voeren. Hierdoor worden automatisch de juiste UUIDs weer in de configuratie geschreven. Dat gebeurt trouwens ook automatisch zodra voor je systeem een nieuwe kernel beschikbaar komt en geïnstalleerd wordt.
Zodra Grub weer correct met UUIDs werkt, kan de aanpassing ook weer voor de fstab hersteld worden met de juiste UUIDs.
Maar deze hersteloperaties moeten ook in de juiste volgorde gedaan worden.

Eerst aanpassen van Grub in de terminal met
sudo update-grubHierna rebooten en kijken of dat ook werkt.

Vervolgens nogmaals de UUIDs uitlezen in de terminal met
sudo blkid... laat de terminal dan open staan om de code te kunnen kopiëren.
Het bestand fstab wordt dan aangepast met de uitgelezen codes.

ALT-F2 en daarin typen "gksudo gedit /etc/fstab" (zonder de aanhalingstekens)
Deze UUIDs kunnen uit de terminal met kopiëren/plakken in de fstab worden geplaatst.

Rebooten en kijken of alles weer zoals vanouds werkt.
« Laatst bewerkt op: 2011/04/16, 12:09:48 door HarzG »
Xubuntu 16.04; siduction-15.1.0 Xfce

Offline sebas2831983

  • Lid
  • Steunpunt: Nee
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #10 Gepost op: 2011/04/17, 10:29:41 »
Hello again,

HarzG, dank voor je uitgebreide omschrijving. Ik heb de UUID's vervangen door de device tags, en daar nog alternatieven geprobeerd. Het komt allemaal op dezelfde boot error neer. /proc directory kan niet gevonden worden en niet gemount worden tijdens het booten:

mount: mounting /proc on /root/proc failed: No such file or directory

Ik ben ondertussen ook in zee geweest met jullie internationale collega's:
http://ubuntuforums.org/showthread.php?t=1730113

Even samenvattend wat daar is besproken:
  • met bootinfoscript (http://bootinfoscript.sourceforge.net/) bleek de bootloader niet in de MBR geinstalleerd te zijn. Hoe dit toch allemaal kan na het resizen van een partitie? Apart zeg.
  • Die is toen opnieuw geinstalleerd, volgens:

sudo mount /dev/sda1 /mnt
sudo grub-install --root-directory=/mnt /dev/sda


  • Tijdens booten geeft het beestje weer de volgende melding:

mount: mounting /proc on /root/proc failed: No such file or directory

  • De bootloader is wel geinstalleerd, echter men maakt zich zorgen over de melding:

Grub 2 is installed in the boot sector of sda1 and
                       looks at sector 34023240 of the same hard drive for
                       core.img, but core.img can not be found at this
                       location.

  • Anyways, om in het geinstalleerde systeem te komen, en om van daar uit de grub.cfg te updaten, hebben we geprobeerd dit via supergrub2 te doen (http://www.bootproblems.com/). Echter, tijdens booten weer de melding dat /proc niet gemount kan worden.

  • Toen nog geprobeerd om via chroot-ing, in het geinstalleerde systeem te komen en daar het 1 en al te updaten. Dit kan je via het live-systeem doen, door een tijdelijke mount van het geinstalleerde probleem systeem. Dit kon via de guide "HOWTO: Purge and Reinstall Grub 2 from the Live CD" op http://ubuntuforums.org/showthread.php?t=1581099. Daar stap 1C genomen, namelijk het tijdelijk mounten van het geinstaleerde systeem:


sudo mount --bind /dev /mnt/temp/dev
sudo mount --bind /dev/pts /mnt/temp/dev/pts
sudo mount --bind /proc /mnt/temp/proc
sudo mount --bind /sys /mnt/temp/sys

Helaas, weer de melding:

mount: mount point /mnt/temp/proc does not exist


Ik kan ook in het geinstalleerde systeem nergens de /proc directory vinden. Die kan ik wel voor het live-systeem vinden, als ik daar in ben. Deze directory moet er in principe toch gewoon zijn. Lijkt het erop dat deze is verdwenen, en ik eigenlijk mijn hele systeem moet herinstalleren? Iemand een idee?

Groet en dank!
Bas

« Laatst bewerkt op: 2011/04/17, 10:38:59 door sebas2831983 »

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #11 Gepost op: 2011/04/17, 10:52:56 »
http://sites.google.com/site/computertip/grub
Hier staat hoe je grub kunt herstellen of andere hd kiezen.

Offline HarzG

  • Lid
  • Steunpunt: Nee
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #12 Gepost op: 2011/04/17, 10:53:35 »
Volgens mij moet de map /proc aanwezig zijn. Als de HD/partitie niet in gebruik is, bestaat de map /proc wel maar is dan leeg.
De eigenschappen zijn: eigenaar root, eigenaar "kan bekijken/wijzigen", groep en anderen "kan inhoud bekijken".
NB: Bij geavanceerde toegangsrechten moet voor eigenaar/groep/anderen "openen" aangevinkt staan.

Tijdens het starten van het systeem wordt de inhoud van /proc gevuld. Er komen dan van een paar honderd mappen in te staan met de lopende processen van je systeem.

Maak met de live-CD de map /proc aan met de genoemde bijzonderheden/eigenschappen en reboot.

... maar nog even terugkomend op de oorzaak ...
Hoe dit toch allemaal kan na het resizen van een partitie? Apart zeg.
Welke partitie heb je verkleind? Misschien zit daar een oorzaak en is behalve /proc nog iets anders beschadigd.
« Laatst bewerkt op: 2011/04/17, 11:31:42 door HarzG »
Xubuntu 16.04; siduction-15.1.0 Xfce

Offline sebas2831983

  • Lid
  • Steunpunt: Nee
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #13 Gepost op: 2011/04/17, 11:34:17 »
Hey HarzG,

Okay, om als superuser dit te kunnen doen, voer ik het volgende in de terminal:

gksudo nautilus

Dan kan ik namelijk pas een folder aanmaken. De eigenschappen van deze aangemaakte proc directory zijn:

Owner: root
Folder access: Create and delete files
File access: --

Group: root
Folder access: Create and delete files
File access: --

Others
Folder access: Access files
File access: --

Bedoel je deze eigenschappen? Geen opties aangegeven voor file access?
« Laatst bewerkt op: 2011/04/17, 11:36:54 door sebas2831983 »

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #14 Gepost op: 2011/04/17, 11:38:13 »
Heb hier even wat uitgeprobeerd.
Als je via de terminal als root werkt dan is er ook geen /root/proc te zien.




Via Alt+F2 en gksudo nautilus kan je ook de /proc map niet in. Je kan er wel op klikken maar de muis aanwijzer blijft draaien.

Herstel/herinstalleer grub eens via de LiveCD en deze wiki:
http://wiki.ubuntu-nl.org/community/Grub2#HerstelGrub2meteenLiveCD
Goed lezen en de commando's i.v.m. de /boot partitie overslaan.


Offline sebas2831983

  • Lid
  • Steunpunt: Nee
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #15 Gepost op: 2011/04/17, 11:40:12 »
Citaat
Welke partitie heb je verkleind? Misschien zit daar een oorzaak en is behalve /proc nog iets anders beschadigd.
De sda1 partitie vanuit het einde verkleint.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #16 Gepost op: 2011/04/17, 11:42:48 »
Wat geeft het commando:
sudo fdisk -lals output?

Of post hier een afb. van gParted. Zodat we een zicht krijgen over de indeling van je schijf.

Offline sebas2831983

  • Lid
  • Steunpunt: Nee
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #17 Gepost op: 2011/04/17, 11:47:57 »
Hoi heir4c,

Grub2 heb ik al geherinstaleerd, zie thread:
http://ubuntuforums.org/showthread.php?t=1730113&page=1

Fdisk output had ik volgens mij al in het begin van deze thread gedaan, oh  toch niet, hier komt ie:

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00001d06

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        7870    63214751   83  Linux
/dev/sda2            9348        9730     3069953    5  Extended
/dev/sda3            7871        9347    11864002+   b  W95 FAT32
/dev/sda5            9348        9730     3069952   82  Linux swap / Solaris

Partition table entries are not in disk order

ps: ik heb al eens geprobeerd scrnshots te posten, maar lukt me niet, wat moet ik tussen {img}{/img} (accolade=blokhaak) zetten?

Groet, Bas
« Laatst bewerkt op: 2011/04/17, 11:56:13 door sebas2831983 »

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #18 Gepost op: 2011/04/17, 11:59:36 »
Je moet eerst de afbeelding uploaden naar een upload-site. (tinypic of imgur. zie mijn handtekening. Maak een account aan, dan kan je je afb. snel terug vinden)
Nadien verschijnen er verschillende codelijnen. Die met de IMG tag moet je kopiëren en in je bericht zetten. Dat is alles.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #19 Gepost op: 2011/04/17, 12:05:46 »
In je eerste bericht daar op de andere site staat een commando dat je kan gebruiken om de UUID van je partities te vinden.
blkid -o value -s UUIDAchter dit commando typ je bijv. /dev/sda1
Dan krijg je de UUID van sda1
Dit kan je doen voor alle partities en zo je fstab misschien aanpassen. (Zeker voor sda1 wat je bootable partitie is)
Misschien lukt het daarmee.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #20 Gepost op: 2011/04/17, 12:09:06 »
Ik zie nu ook verder in dat topic dat je een bepaald script hebt uitgevoerd en daar de UUID zichtbaar zijn. Dus die heb je dus al.
Ik zie wel dat de sda3 een heel korte UUID heeft (meestal te zien bij een aangekoppelde usb) Weet niet of dit normaal is maar is toch vreemd.

Offline HarzG

  • Lid
  • Steunpunt: Nee
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #21 Gepost op: 2011/04/17, 12:11:23 »
Heb hier even wat uitgeprobeerd.
Als je via de terminal als root werkt dan is er ook geen /root/proc te zien.
@heir4c
Citaat
$ls
bin    dev   initrd.img.old  lib64       mnt   root     srv  usr
boot   etc   lib             lost+found  opt   sbin     sys  var
cdrom  home  lib32           media       proc  selinux  tmp  vmlinuz.old
De map is geen submap van root maar staat als hoofdmap /proc in je systeem.

gksudo nautilus
Dan kan ik namelijk pas een folder aanmaken. De eigenschappen van deze aangemaakte proc directory zijn:

Owner: root
Folder access: Create and delete files
File access: --

Group: root
Folder access: Create and delete files
File access: --

Others
Folder access: Access files
File access: --

Bedoel je deze eigenschappen? Geen opties aangegeven voor file access?
Dat zou voldoende moeten zijn.
Group: root
Folder access: Access files
File access: --

Bij mij staat ook de streepjes voor files, maar dat kan een weergave-probleem zijn. Om te voorkomen dat je te veel heen en weer moet switchen/rebooten, kan je voor de zekerheid bij File access voor root/group/others vastleggen "access". Leg daar niet vast die "others" alles mogen lezen/schrijven. Anders krijg je volgens mij een vreemd/onveilig systeem.
Xubuntu 16.04; siduction-15.1.0 Xfce

Offline sebas2831983

  • Lid
  • Steunpunt: Nee
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #22 Gepost op: 2011/04/17, 12:16:09 »
Hey heir4c,

Voor dat ik het vergeet, ook dank voor je sugesties.

screenshot van gparted:


In fstab heb ik al eens /dev/sda1 vervangen door zijn UUID. Dit had geen effect. fstab ziet er op dit moment zo uit:
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
#/dev/sda1       /               ext4    errors=remount-ro 0       1
UUID=9c30c37f-81ae-4423-a660-20318be12e52 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
#/dev/sda5 none            swap    sw              0       0
UUID=b715c668-22a9-4a24-af8c-54d9d4a95e96 none            swap    sw              0       0
[\CODE]

Offline HarzG

  • Lid
  • Steunpunt: Nee
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #23 Gepost op: 2011/04/17, 12:20:02 »
Je systeem staat als submap van /media, dat hoort niet zo, maar dat komt ws. door de live-CD.
De UUID schijnt te kloppen
Xubuntu 16.04; siduction-15.1.0 Xfce

Offline sebas2831983

  • Lid
  • Steunpunt: Nee
Re: ubuntu 10.10 start niet meer na gebruik van gparted
« Reactie #24 Gepost op: 2011/04/17, 12:22:58 »
Okay, ik ga maar een rebooten met de gemaakte /proc map. Maar zien wat er gebeurd.