Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: FTP server  (gelezen 2956 keer)

Offline bjorn_bos1333

  • Lid
  • Steunpunt: Nee
FTP server
« Gepost op: 2011/04/12, 12:19:18 »
Hallo allemaal,

Ik wil graag dat ik verschillende FTP accounts kan aanmaken voor vrienden. Mijn vrienden moeten voor maximaal 1gb dingen op mijn server kunnen
zetten en ze eraf kunnen halen. Mijn ubuntu software staat geïnstalleert op de schrijf C, en de schijf die ik voor mijn vrienden wil gebruiken
is schijf D (weet ik veel, ik noem maar iets).

In dit geval gebruik ik 3 namen die in de groep "FTPgroepD: komen. (D staat voor de schijf)

Piet
Jan
Hans

Voor deze mensen maak ik de volgende mappen aan:

D:/Gebruikers/Piet
D:/Gebruikers/Jan
D:/Gebruikers/Hans

Bovendien moet er een map komen voor mijzelf:

D:/Administrator

Wat ik wil is:

-   Nu wil ik, dat wanneer ik inlog met "FTPgroepD + wachtwoord" ik terecht kom in "Gebruikers" en ik alle namen van mijn gebruikers zie (Piet,
   Jan, Hans). Bovendien moet ik alle rechten hebben, behalve die van het uitvoeren van bestanden. Dus ik mag wel dingen verwijderen, overschrijven,
   verwijderen, lezen en/of aanpassen, alleen niet uitvoeren.

-   Nu wil ik ook, dat wanneer Piet inlogt met zijn gebruikersnaam: "Piet (dezelfde als die van zijn persoonlijke map) + wachtwoord (die ik voor
   hem aanmaak)" hij terecht komt in de map D:/Gebruikers/Piet. Daar mag hij bestanden op zetten, afhalen, veranderen, verwijderen, overschrijven,
   maar NIET uitvoeren. Hij mag ook alleen in de map van hemzelf komen, voor de rest NERGENS anders. Dus: D:/Gebruikers/Piet/*
   
-   Hetzelfde geldt voor alle andere gebruikers.

-   De gebruikers mogen maar maximaal 1gb aan bestanden op de schijf zetten, tenzij ik dit verander.

-   De gebruikers moeten in verbinding met de server kunnen komen door in hun browser ftp://IPadres in te tikken. Dit mag uiteraard ook in verkenner.

-   De gebruikers mogen op geen mogelijkheid bij andere betsanden of mappen kunnen komen, ze mogen ze zelfs niet zien. Ze mogen ALLEEN bij HUN
   persoonlijke map komen.


Kan iemand mij verder helpen over hoe ik dit moet aanpakken?


Met vriendelijke groeten,

Björn Bos

PS: Ik heb ubuntu 10.10 Maverick Meerkat op mijn server geïnstalleert.

Offline bjorn_bos1333

  • Lid
  • Steunpunt: Nee
Re: FTP server
« Reactie #1 Gepost op: 2011/04/12, 13:46:43 »
Het enige wat ik trouwens tot nu toe op de server heb geïnstalleert is:

sudo apt-get lamp-server^ of iets in die richting.

Het is trouwens de meerkat desktop versie van ubuntu.

Mvg,

Björn Bos

Offline bjorn_bos1333

  • Lid
  • Steunpunt: Nee
Re: FTP server
« Reactie #2 Gepost op: 2011/04/12, 14:05:45 »
Heeft iemand een idee?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: FTP server
« Reactie #3 Gepost op: 2011/04/12, 14:15:02 »
Ik weet niet of je heel veel haast hebt of zo, maar het is niet de bedoeling om je topic meerdere keren kort achter elkaar te 'kicken'. Heb even geduld en er komt vast wel iemand langs die je kan helpen.

Verder is FTP verouderd en onveilig. Ik kan je daarom aanraden om SSH te gaan gebruiken.
Een handleiding hiervoor staat hier
Zie ook de OpenSSH pagina hier


Tot slot snap ik niet wat je met C: en D: schijven wil in Ubuntu. Dat zijn typisch Windows-ideeën die heel anders werken in Linux...

Offline bjorn_bos1333

  • Lid
  • Steunpunt: Nee
Re: FTP server
« Reactie #4 Gepost op: 2011/04/12, 14:23:07 »
Hey, bedankt voor je reactie!

Dat met C en D geeft alleen mijn verschillende harde schijven aan. Ik had ze ook 1 en 2 kunnen noemen. Ik wil mijn gebruikers gewoon op een andere schijf hebben, zodat dáár de gegevens op komen en mijn grootste schrijf voor mijzelf niet gebruikt word. Dat is ook de schijf waar ubuntu op staat geïnstalleert.

Bedankt voor je links, ik ben die nu aan het bekijken. Als jij zegt dat sftp veiliger is, dan zal ik die tutorial gaan volgen.

Sorry voor het "omhoog kicken" van mijn topic. Ik wist niet dat dit mocht, ik heb nu eenmaal weinig geduld!

Groetjes,

Björn Bos

Offline bjorn_bos1333

  • Lid
  • Steunpunt: Nee
Re: FTP server
« Reactie #5 Gepost op: 2011/04/12, 15:20:33 »
Ok, ik zal me aan passen!

En ik heb het stappenplan gevolgd. Ik heb nu een gebruiker "gast" in de groep "sftpgroepa", alleen weet ik niet hoe je nu in moet loggen als gast@ipadres.

Er staat dat ik in moet loggen op een andere computer als: "sftp gast@ipadres", maar wáár moet ik inloggen? Of hoe?

Met vriendelijke groeten,

Björn Bos

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: FTP server
« Reactie #6 Gepost op: 2011/04/12, 15:27:20 »
Dit is om vanaf een andere computer te testen of het allemaal werkt.
Daarvoor zou je op een andere (linux) computer een terminal moeten openen en dat in moeten typen. ipadres moet je dan vervangen door het ip van jouw computer.
Het is alleen veel makklijker om bijv. de grafische (S)FTP client hiervoor te gebruiken. Ik neem aan dat je al wel snapt hoe FTP enzo werkt...
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Offline bjorn_bos1333

  • Lid
  • Steunpunt: Nee
Re: FTP server
« Reactie #7 Gepost op: 2011/04/12, 15:30:25 »
Zo'n beetje,

Maargoed, ik wil dus graag dat iemand via zijn browser (of verkenner) gewoon naar mijn server kan gaan en op die manier in zijn/haar map terecht komt...

Offline Rachid

  • Vertaalteam
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: FTP server
« Reactie #8 Gepost op: 2011/04/12, 15:34:59 »
Oh, dat is een ander verhaal
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Offline bjorn_bos1333

  • Lid
  • Steunpunt: Nee
Re: FTP server
« Reactie #9 Gepost op: 2011/04/12, 15:38:58 »
Oke, maar ik word dus wel doorverwezen naar deze pagina's:

http://wiki.ubuntu-nl.org/community/SftpServer#Meerderegebruikersdeleneenmap
http://wiki.ubuntu-nl.org/community/Openssh-server

Ik ben nu dus bij de stap waarbij ik dus in moet loggen zoals ik zei (bij link 1), maargoed, die moet ik dan overslaan ofzo?


Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: FTP server
« Reactie #10 Gepost op: 2011/04/12, 15:41:57 »
Dat inloggen doe je dus in een terminalvenster, via het commando dat daar staat.
Gewoon om te testen, zodat je vrij snel weet of het werkt of niet.

Offline bjorn_bos1333

  • Lid
  • Steunpunt: Nee
Re: FTP server
« Reactie #11 Gepost op: 2011/04/12, 15:43:36 »
Bedankt voor je reactie! Jammer dat ik dat dan niet kan, kan ik dit op een andere manier testen op een windows computer? Intern binnen dit netwerk.

Met vriendelijke groeten,

Björn Bos

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: FTP server
« Reactie #12 Gepost op: 2011/04/12, 15:44:29 »
Je kan wel wat testen via FileZilla of een ander programma dat SFTP ondersteunt.

Offline bjorn_bos1333

  • Lid
  • Steunpunt: Nee
Re: FTP server
« Reactie #13 Gepost op: 2011/04/12, 15:56:11 »
hij maakt verbinding, alleen komt hij terecht in de hoofdmap en ik wil juist dat hij in de map:

/home/gast

terecht komt, zoals de tutorial beschrijft.

Hoe doe ik dit..?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: FTP server
« Reactie #14 Gepost op: 2011/04/12, 16:02:25 »
Wat heb je precies aangepast in /etc/ssh/sshd_config ?

Offline bjorn_bos1333

  • Lid
  • Steunpunt: Nee
Re: FTP server
« Reactie #15 Gepost op: 2011/04/12, 16:03:31 »
Momentje, ik ga hem even opzoeken!

Offline bjorn_bos1333

  • Lid
  • Steunpunt: Nee
Re: FTP server
« Reactie #16 Gepost op: 2011/04/12, 16:06:00 »
# Package generated configuration file
# See the sshd_config(5) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp internal-sftp

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes
Match group sftponly
ChrootDirectory /home/%u
X11Forwarding no
AllowTcpForwarding no
ForceCommand internal-sftp
« Laatst bewerkt op: 2011/04/12, 16:13:34 door Johan van Dijk »

Offline bjorn_bos1333

  • Lid
  • Steunpunt: Nee
Re: FTP server
« Reactie #17 Gepost op: 2011/04/12, 16:06:26 »
Dit is hem, heb ik gedaan volgens de tutorial! Ik neem aan dat deze klopt?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: FTP server
« Reactie #18 Gepost op: 2011/04/12, 16:13:10 »
Kan je voortaan code-tags gebruiken als je een configuratiebestand of terminal-uitvoer plaatst?
Zo dus:
[code]
hier je lap tekst
[/code]

Dat leest een stuk makkelijker :)

Zo te zien klopt de volgorde niet helemaal.
Ik zou na 'UsePAM yes' even een paar enters geven, en daaronder het SFTP gedeelte plaatsen.
....
UsePAM yes

Subsystem sftp internal-sftp
Match group sftponly
ChrootDirectory /home/%u
X11Forwarding no
AllowTcpForwarding no
ForceCommand internal-sftp

Dus die eerdere regel 'Subsystem sftp internal-sftp' weghalen of naar beneden verplaatsen.
Verder is het ook handig en overzichtelijk om met de Tab-toets in te springen, zoals in het voorbeeld op de wiki staat.

Offline bjorn_bos1333

  • Lid
  • Steunpunt: Nee
Re: FTP server
« Reactie #19 Gepost op: 2011/04/12, 16:17:01 »
Oh ja ik zal dat de volgende keer doen!

En ik heb gedaan wat je zei, maar nog steeds komt ik in de hoofdmap terecht.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: FTP server
« Reactie #20 Gepost op: 2011/04/12, 16:22:49 »
Heb je de ssh-server wel even opnieuw gestart voordat je het nog eens probeerde?
Dat doe je via sudo service ssh restart

Offline bjorn_bos1333

  • Lid
  • Steunpunt: Nee
Re: FTP server
« Reactie #21 Gepost op: 2011/04/12, 16:27:08 »
Ik had hem restart volgens het commando die in de tut werd weergegeven: sudo /etc/init.d/ssh restart
Ik heb die van jou uitgevoerd, alleen nu krijg ik in filezille de volgende melding:

Fout: Connection closed by server with exitcode 1
Fout: Kan niet verbinden met server

Wat nU?

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: FTP server
« Reactie #22 Gepost op: 2011/04/12, 16:30:47 »
Wat denk je zelf? :)
Staat er verder nog iets in de foutmeldingen of logbestanden van Filezilla?
Nu is het een beetje raden wat er mis is...

Offline bjorn_bos1333

  • Lid
  • Steunpunt: Nee
Re: FTP server
« Reactie #23 Gepost op: 2011/04/12, 16:36:08 »
Ja sorry, ik weet het echt niet, ander zou ik het hier niet vragen.

Ik heb gewoon netjes de tutorial gevolgd. Net kon ik met gast wel op de server komen, alleen kwam ik in de verkeerde map en nadat ik jouw command heb uitgevoerd doet hij het helemaal niet meer. Dat is het enige wat ik zie, voor de rest lijkt de sshd_config te kloppen, dus ik zou het dan ook niet weten?

Zo veel heb ik er nou ook weer niet mee gedaan, ik ben nu gewoon aan het leren hoe het werkt, alleen zo kom ik niet verder natuurlijk...

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: FTP server
« Reactie #24 Gepost op: 2011/04/12, 16:37:41 »
Heb je die gastgebruiker wel in de goede groep gezet?
En kan je met je normale gebruiker wel gewoon inloggen via SSH (via Putty bijv.)?