Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Solved Van Python 2.6 naar 2.5?  (gelezen 638 keer)

Offline ayla

  • Lid
  • Steunpunt: Nee
Solved Van Python 2.6 naar 2.5?
« Gepost op: 2011/03/26, 16:57:56 »
Is het mogelijk om van Ubuntu 10.10 _ Python 2.6 down to grade naar 2.5
Waarom, Google appengine SDK werkt uitsluitend met de Python 2.5 versie. Hierdoor zijn er Google appengine apps die ik nu niet op kan starten.


Gr Ayla
« Laatst bewerkt op: 2011/03/26, 22:03:30 door ayla »

Offline Rachid

  • Lid
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: Van Python 2.6 naar 2.5?
« Reactie #1 Gepost op: 2011/03/26, 17:24:56 »
Dit topic past beter in het "programmeren" forum imho.

Haha, toevallig heb ik hier net een blog over geschreven. Hier leg ik uit hoe je de Google App Engine werkend kunt krijgen op 10.04 met Python 2.6. Ik neem aan dat dit voor 10.10 ook zal werken. Anders heb ik nog wel een andere suggestie.

Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Offline ayla

  • Lid
  • Steunpunt: Nee
Re: Van Python 2.6 naar 2.5?
« Reactie #2 Gepost op: 2011/03/26, 17:57:42 »
Dit topic past beter in het "programmeren" forum imho.

Haha, toevallig heb ik hier net een blog over geschreven. Hier leg ik uit hoe je de Google App Engine werkend kunt krijgen op 10.04 met Python 2.6. Ik neem aan dat dit voor 10.10 ook zal werken. Anders heb ik nog wel een andere suggestie.




Bedankt voor je reactie:
De meeste Apps weken wel onder Python 2.6 echter enkel niet - zoals b.v Wiki, todo en nog enkele die niet uit de voeten kunnen met de 2.6 version.

Wat ik dus wil zeggen is dat ik niet het probleem heb zoals als door jouw op je blog beschreven. De SDK werk eenvoudig en naar volle tevredenheid. Ik maak er al meer dan twee jaar met veel plezier gebruik van. Echter nu wil ik het oplossen dat ook die niet onder 2.6 werkende apps het gaan doen.


vr Gr ayla

Offline Rachid

  • Lid
    • rachidbm
    • Mijn blog
  • Steunpunt: Nee
Re: Van Python 2.6 naar 2.5?
« Reactie #3 Gepost op: 2011/03/26, 18:21:47 »
Ah, dat is duidelijk. Je kunt het werkend krijgen door Python 2.5 handmatig te installeren en de app engine draaien in een virtualenv. Dit had ik voor elkaar, alleen ben ik kwijt wat ik precies had gedaan.

Wat ik nog wel kon terugvinden zijn de regels om zo'n virtualenv te installeren:
sudo apt-get install virtualenv
mkdir -p ~/opt/python/virtualenvs
cd ~/opt/python/virtualenvs
virtualenv appengine --no-site-packages

alias virtenv='source ~/opt/python/virtualenvs/appengine/bin/activate'
Als ik nu virtenv in je Terminal typt, draai ik met Python 2.5.
Maar het kan zijn dat je nog ergens moet instellen dat ie ook echt Python 2.5 gebruikt ipv de standaard 2.6 van Ubuntu. Dat weet ik dus niet precies meer.

Een beetje google op Python 2.5 virtualenv moet hoop ik helpen ;)
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Offline ayla

  • Lid
  • Steunpunt: Nee
Re: Van Python 2.6 naar 2.5?
« Reactie #4 Gepost op: 2011/03/26, 19:08:05 »
Ah, dat is duidelijk. Je kunt het werkend krijgen door Python 2.5 handmatig te installeren en de app engine draaien in een virtualenv. Dit had ik voor elkaar, alleen ben ik kwijt wat ik precies had gedaan.

Wat ik nog wel kon terugvinden zijn de regels om zo'n virtualenv te installeren:
sudo apt-get install virtualenv
mkdir -p ~/opt/python/virtualenvs
cd ~/opt/python/virtualenvs
virtualenv appengine --no-site-packages

alias virtenv='source ~/opt/python/virtualenvs/appengine/bin/activate'
Als ik nu virtenv in je Terminal typt, draai ik met Python 2.5.
Maar het kan zijn dat je nog ergens moet instellen dat ie ook echt Python 2.5 gebruikt ipv de standaard 2.6 van Ubuntu. Dat weet ik dus niet precies meer.

Een beetje google op Python 2.5 virtualenv moet hoop ik helpen ;)


O.k Heel hartelijk bedankt voor je hulp. Hiermee ga ik aan de slag en wordt mij duidelijk wat je eigenlijk op je blog zegt. Dit over de virtualenv is nieuwe informatie voor me.

~:sudo apt-get install virtualenv
[sudo] password for ayla:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
De status informatie wordt gelezen... Klaar
E: Kan pakket virtualenv niet vinden

En wanneer ik deze aanwijzingen volg komik nog steeds uit op Python 2.6: http://wiki.pylonshq.com/display/pylonscookbook/Using+a+Virtualenv+Sandbox

>>> import pylons
>>> pylons
<module 'pylons' from '/usr/local/lib/python2.6/dist-packages/Pylons-0.9.6.1-py2.6.egg/pylons/__init__.pyc'>
>>>



Gr Ayla
« Laatst bewerkt op: 2011/03/26, 19:36:03 door ayla »

Offline ayla

  • Lid
  • Steunpunt: Nee
Re: Van Python 2.6 naar 2.5?
« Reactie #5 Gepost op: 2011/03/26, 20:19:52 »
Ah, dat is duidelijk. Je kunt het werkend krijgen door Python 2.5 handmatig te installeren en de app engine draaien in een virtualenv. Dit had ik voor elkaar, alleen ben ik kwijt wat ik precies had gedaan.

Wat ik nog wel kon terugvinden zijn de regels om zo'n virtualenv te installeren:
sudo apt-get install virtualenv
mkdir -p ~/opt/python/virtualenvs
cd ~/opt/python/virtualenvs
virtualenv appengine --no-site-packages

alias virtenv='source ~/opt/python/virtualenvs/appengine/bin/activate'
Als ik nu virtenv in je Terminal typt, draai ik met Python 2.5.
Maar het kan zijn dat je nog ergens moet instellen dat ie ook echt Python 2.5 gebruikt ipv de standaard 2.6 van Ubuntu. Dat weet ik dus niet precies meer.

Een beetje google op Python 2.5 virtualenv moet hoop ik helpen ;)

Dit is hoe ik het bij mij werkt:

The Python runtime environment uses Python 2.5.2.

The Python SDK includes a web server application that simulates the App Engine environment, including a local version of the datastore, Google Accounts, and the ability to fetch URLs and send email directly from your computer using the App Engine APIs. The Python SDK runs on any computer with Python 2.5, and versions are available for Windows, Mac OS X and Linux. (The Python SDK is not compatible with Python 3.)

http://code.google.com/intl/nl-NL/appengine/docs/python/gettingstarted/devenvironment.html


sudo apt-get install build-essential gcc
cd Downloads
wget http://www.python.org/ftp/python/2.5.2/Python-2.5.2.tgz
tar -xvzf Python-2.5.2.tgz
cd Python-2.5.2
./configure --prefix=/usr/local/python2.5.2
make
make test
sudo make install
sudo ln -s /usr/local/python2.5.2/bin/python /usr/bin/python2.5.2

http://welcometoubuntu.blogspot.com/2010/05/howto-install-python-255-on-ubuntu-1004.html

Dit is de code om de server op te starten met python 2.5.2
python2.5.2 dev_appserver.py --port=9000 app/wiki



Gr Ayla
« Laatst bewerkt op: 2011/03/26, 22:01:07 door ayla »

Offline ayla

  • Lid
  • Steunpunt: Nee
Solved! Van Python 2.6 naar 2.5?
« Reactie #6 Gepost op: 2011/03/26, 22:01:58 »
Is het mogelijk om van Ubuntu 10.10 _ Python 2.6 down to grade naar 2.5
Waarom, Google appengine SDK werkt uitsluitend met de Python 2.5 versie. Hierdoor zijn er Google appengine apps die ik nu niet op kan starten.


Gr Ayla