Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] trage inlog op ftp en mysql server  (gelezen 1385 keer)

Offline JeanC

  • Lid
    • www.jcremers.com
  • Steunpunt: Nee
[OPGELOST] trage inlog op ftp en mysql server
« Gepost op: 2011/03/17, 12:35:31 »
Hoi,
Ik heb recentelijk een nieuwe pc gekocht en daar kubuntu 10.4 op gezet om m'n server met xp te vervangen.
Ik heb eerder een jaartje met linux gewerkt en ben dus nu pas weer begonnen maar ben nog niet geroutineerd.

Als ik over het lokale netwerk wil inloggen op de ftp server of de mysql server (vanuit windows xp met leechftp / mysql yog) heb ik een delay van ongeveer 7 seconden. Ook mensen van buiten die op de ftp server inloggen hebben die delay.
Toen de server nog op xp draaide, met xampp/apache en filezilla als servers had ik die delay niet.
Je zou zeggen waarom maak je je druk over die paar seconden maar het is toch jammer en misschien op te lossen.
Ik heb op tweakers.net er ook al een thread (http://gathering.tweakers.net/forum/list_message/35699370#35699370) over geopend maar dat schiet niet echt op, vandaar dat ik hier kom aankloppen.
Het meest waarschijnlijk is dat er toch nog ergens een dns lookup wordt gedaan, alhoewel ik dat voor pure-ftp bv expliciet heb uitgezet.

Bedankt voor hulp!
« Laatst bewerkt op: 2011/03/18, 12:06:23 door JeanC »

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: trage inlog op ftp en mysql server
« Reactie #1 Gepost op: 2011/03/17, 14:51:21 »
Inloggen via SSH gaat ook traag?
Log eens in via ssh -v user@host, misschien leveren de meldingen die je dan ziet meer informatie op.

En wat kan je zoal vinden in de logbestanden van je client?
En wat staat er in /var/log/ van de server? Je kan met grep makkelijk kijken of er iets in je logbestanden staat wat met pureftp te maken heeft. Vind je niks, dan zou je eens kunnen kijken of je verbose logging ergens aan kan zetten in de configuratie van pureftp.

Offline JeanC

  • Lid
    • www.jcremers.com
  • Steunpunt: Nee
Re: trage inlog op ftp en mysql server
« Reactie #2 Gepost op: 2011/03/17, 16:26:02 »
Thanks.
Een ssh inlog is zowel lokaal als over het netwerk snel zat. De prompt zie ik meteen, en opzoeken van passwoord gaat over het netwerk in 4 seconden, en lokaal direct.
Ssh over het netwerk kan ik niet zo goed met -v testen omdat dat een xp machine is en putty accepteert volgens mij geen parameters, ik kan het in ieder geval niet zo snel vinden. Maar omdat ssh verder prima gaat denk ik niet dat dat me verder helpt.

car /var/log/messages | grep pure levert ook niet veel info op:
Mar 16 08:28:23 server pure-ftpd: (?@192.168.1.11) [INFO] New connection from 192.168.1.11
Mar 16 08:28:23 server pure-ftpd: (?@192.168.1.11) [INFO] PAM_RHOST enabled. Getting the peer address
Mar 16 08:28:29 server pure-ftpd: (?@192.168.1.11) [INFO] xxx is now logged in
Je ziet dat de inlog ongeveer 6 seconden duurt, maar verder geen info.
Ik ga eens zoeken naar verbose logging in pureftpd.

Edit:
Dit is met debug aan:
Mar 17 16:30:35 server pure-ftpd: (?@192.168.1.11) [INFO] New connection from 192.168.1.11
Mar 17 16:30:35 server pure-ftpd: (?@192.168.1.11) [DEBUG] Command [user] [xxx]
Mar 17 16:30:35 server pure-ftpd: (?@192.168.1.11) [DEBUG] Command [pass] [<*>]
Mar 17 16:30:35 server pure-ftpd: (?@192.168.1.11) [INFO] PAM_RHOST enabled. Getting the peer address
Mar 17 16:30:42 server pure-ftpd: (?@192.168.1.11) [INFO] xxx is now logged in

Is toch volgens mij iets met die PAM, daar had ik het in het begin in die andere thread ook al over, maar ben ik niet verder mee gekomen.

Edit2: Ik kan wel vanuit virtualbox met ssh -v connecten en krijg dan dit:

OpenSSH_5.3p1 Debian-3ubuntu5, OpenSSL 0.9.8k 25 Mar 2009
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to 192.168.1.10 [192.168.1.10] port 22.
debug1: Connection established.
debug1: identity file /home/jean/.ssh/identity type -1
debug1: identity file /home/jean/.ssh/id_rsa type -1
debug1: identity file /home/jean/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3p1 Debian-3ubuntu5
debug1: match: OpenSSH_5.3p1 Debian-3ubuntu5 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.3p1 Debian-3ubuntu5
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
The authenticity of host '192.168.1.10 (192.168.1.10)' can't be established.
RSA key fingerprint is 51:7c:3d:73:57:d5:46:ff:0d:17:11:f5:05:f3:f1:22.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.1.10' (RSA) to the list of known hosts.
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Trying private key: /home/jean/.ssh/identity
debug1: Trying private key: /home/jean/.ssh/id_rsa
debug1: Trying private key: /home/jean/.ssh/id_dsa
debug1: Next authentication method: password
jean@192.168.1.10's password:
debug1: Authentication succeeded (password).
debug1: channel 0: new [client-session]
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug1: Sending environment.
debug1: Sending env LANG = en_US.UTF-8
Linux server 2.6.32-29-generic #58-Ubuntu SMP Fri Feb 11 20:52:10 UTC 2011 x86_64 GNU/Linux
Ubuntu 10.04.2 LTS

Welcome to Ubuntu!
« Laatst bewerkt op: 2011/03/17, 16:43:11 door JeanC »

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: trage inlog op ftp en mysql server
« Reactie #3 Gepost op: 2011/03/17, 16:57:15 »
Mar 16 08:28:23 server pure-ftpd: (?@192.168.1.11) [INFO] PAM_RHOST enabled. Getting the peer address
Mar 16 08:28:29 server pure-ftpd: (?@192.168.1.11) [INFO] xxx is now logged in
Hier zitten 6 seconden tussen, dus hier zou het probleem kunnen zitten.
Is het mogelijk om uitgebreidere logging aan te zetten voor pure-ftpd? Dat is handig om te bepalen of de vertraging iets met PAM te maken heeft of dat er tussendoor nog iets anders gebeurt wat lang duurt maar nu niet gelogd wordt.

Offline JeanC

  • Lid
    • www.jcremers.com
  • Steunpunt: Nee
Re: trage inlog op ftp en mysql server
« Reactie #4 Gepost op: 2011/03/17, 17:18:34 »
Ja ik denk dat ik met PAM in de goede richting zit. Het enige dat ik gevonden heb over pureftp en loggin is 'echo 'yes' > /etc/pure-ftpd/conf/VerboseLog'. /var/log/messages is ook niet veel in te zien, dat staat hier al.

Zoeken naar PAM logs...

cat /var/log/auth.log | grep pure geeft oa dit voor ongeveer datzelfde tijdstip:
xxx rhost=
Mar 16 08:28:06 server pure-ftpd: pam_winbind(pure-ftpd:auth): getting password (0x00000388)
Mar 16 08:28:06 server pure-ftpd: pam_winbind(pure-ftpd:auth): pam_get_item returned a password
Mar 16 08:28:28 server pure-ftpd: pam_unix(pure-ftpd:auth): check pass; user unknown
Mar 16 08:28:28 server pure-ftpd: pam_unix(pure-ftpd:auth): authentication failure; logname= uid=0 euid=0 tty=pure-ftpd ruser

En dat klopt wel want is was fail2ban aan het testen met een ongeldige inlog.

Weet je nog wat? :)

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: trage inlog op ftp en mysql server
« Reactie #5 Gepost op: 2011/03/17, 17:59:06 »
Heb je pure-ftpd wel opnieuw gestart nadat je de configuratie aangepast hebt?
Anders wordt die verandering niet doorgevoerd.

Offline JeanC

  • Lid
    • www.jcremers.com
  • Steunpunt: Nee
Re: trage inlog op ftp en mysql server
« Reactie #6 Gepost op: 2011/03/17, 18:13:26 »
Ja hoor. :)

Dit is het laatste bericht uit de tweakers thread:
Citaat
Voor SSH kan ik nog wat extra complicaties bedenken. Eerlijk gezegd sluit ik me aan bij al mijn voorgangers die over DNS beginnen. Je probleem klinkt precies zo. Alle andere mogelijkheden (zoals PAM) worden direct heel ingewikkeld en redelijk onwaarschijnlijk. Daarom zou ik je adviseren eerst DNS tot op de grond uit te zoeken voordat je naar andere mogelijkheden gaat kijken.

Geef op je server eens het commando "host <client ip>". Als dat niet onmiddelijk de hostname van de client ophoest dan heb je het probleem gevonden.

Zet de 192.168 adressen van client en server in /etc/hosts en probeer het opnieuw.
Die 127 adressen zijn speciaal, die verwijzen altijd naar de computer zelf en die kun je dus niet gebruiken om naar een andere computer te verwijzen.

Ik kan er vanavond niet meer mee verder, ik ben er morgen weer.

Edit: Dit is dus wel de oplossing tenminste lokaal. Na 192.168.1.10 in /etc/hosts te hebben gezet is de inlog direct, zowel ftp als mysql.
Alleen zal dit niks helpen aan mensen die op ftp van buiten inloggen, die hebben nu ook ongeveer 7 sec vertraging ipv vroeger direct maar hier ben ik al heel blij mee.
« Laatst bewerkt op: 2011/03/17, 20:50:07 door JeanC »