Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [OPGELOST] Symbolische links in gedeelde map  (gelezen 1079 keer)

Offline 10o

  • Lid
  • Steunpunt: Nee
[OPGELOST] Symbolische links in gedeelde map
« Gepost op: 2011/03/13, 20:56:02 »
Omdat niet allemaal mijn video bestanden op de schijf passen waarop zich dit (samba) gedeelde mapje bevindt, heb ik vanuit een tweetal andere schijven een aantal andere losse videomapjes middels symbolische links aan dit gedeelde "hoofd" videomapje toegevoegd. Op de desktop zelf werkt dit allemaal prima en transparant.

Echter, op de Mediatank worden de symbolisch gelinkte mapjes wel getoond als submappen van de map Video, maar de inhoud ervan is niet te zien of te benaderen...

Nu heb ik onderstaande al toegevoegd aan /etc/samba/smb.conf:
follow symlinks = yes
wide links = yes

Maar hiermee kom ik de mapjes nog steeds niet in, om vanuit de Mediatank bestanden af te spelen.

Weet iemand hoe dit voor elkaar te krijgen is?

EDIT: Opgelost middels onderstaande toevoeging:
unix extensions = no
« Laatst bewerkt op: 2011/03/13, 21:05:14 door 10o »
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: [OPGELOST] Symbolische links in gedeelde map
« Reactie #1 Gepost op: 2011/03/13, 21:07:34 »
Ken ik zelf niets van, maar hier http://www.linuxquestions.org/questions/linux-software-2/samba-client-wont-follow-sym-links-801633/ wordt uitgelegd dat sedert een update wide links niet meer werken als unix extensions aan staan omwille van veiligheidsredenen. Het zou terug moeten werken als je ook dit toevoegt:
unix extensions = no

Offline 10o

  • Lid
  • Steunpunt: Nee
Re: [OPGELOST] Symbolische links in gedeelde map
« Reactie #2 Gepost op: 2011/03/13, 21:12:12 »
Hartelijk dank voor het opzoeken vanadium!
Inmiddels was ik er na een iets uitgebreidere Google-search ook net achter gekomen...
Maar, altijd handig dat het nu ook op dit forum staat! In case I forget bij een volgende Ubuntu installatie.  ;)
Workstation:  i7-5820K 16GiB - GeForce GTX 960 2GiB - 4K  (Ubuntu 16.04.1)
Server: Asus E35M1-I Deluxe - AMD Fusion APU E-350 (Ubuntu Server 16.04.1)