Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Nukkige grub na upgrade 10.04 naar 10.10  (gelezen 1721 keer)

Offline Alver1

  • Lid
  • Steunpunt: Nee
Nukkige grub na upgrade 10.04 naar 10.10
« Gepost op: 2011/03/12, 22:26:50 »
Hallo, eergisteren heb ik een upgrade doorgevoerd van 10.04 naar 10.10. Alles is goed verlopen, het duurt een beetje lang maar dat kende ik al van vorige upgrades. Het enige probleem dat ik nu tegenkom is een grub zonder timer. Ik kan de tijd wel instellen in de Opstart Manager maar er gebeurt niks, bovendien kan ik de lettergrootte van het grub scherm niet instellen, iets wat ik bij vorige upgrades wel kon. Wie weet raad?

Alver1

Toshiba L505-10M, dual boot W7 64 b / U 10.10 64 b. 500 GB HD, 6 GB ram

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Nukkige grub na upgrade 10.04 naar 10.10
« Reactie #1 Gepost op: 2011/03/12, 23:57:07 »
In der Beschränkung zeigt sich der Meister.

Offline Alver1

  • Lid
  • Steunpunt: Nee
Re: Nukkige grub na upgrade 10.04 naar 10.10
« Reactie #2 Gepost op: 2011/03/15, 22:44:08 »
Probeer je Grub eens te herstellen.
http://wiki.ubuntu-nl.org/community/Grub2#HerstelGrub2meteenLiveCD
Hallo, bedankt voor uw reactie. Ik heb deze herstelroutine eens goed doorgelezen en vooral de zin helemaal op het einde " Als nu het systeem wordt herstart, zal het GRUB 2 starten en het menu getoond worden" doet me denken dat ik een ander probleem heb. Bij mij start het GRUB 2 nu al, met alle keuze mogelijkheden - helemaal onderaan staat bijv. Windows 7 en dat start ook zonder morren. Alleen 1) de timer vertikt het iets te doen 2) ik kan de lettergrootte niet instellen. De hele GRUB 2 opnieuw installeren is misschien een beetje overkill, of zie ik dat totaal verkeerd?

Alver1

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Nukkige grub na upgrade 10.04 naar 10.10
« Reactie #3 Gepost op: 2011/03/16, 00:12:43 »
Als je de beschrijving hebt gevolgd. En op het eind het systeem opstart, zonder de cd in de lade, dan hoor je het Grub menu te zien, afhankelijk van de tijd instelling zal of Grub direct doorstarten, als de tijd 0 seconde is, tot de tijd die je zelf instelt.
Kijk hier hoe je de tijd instelt http://wiki.ubuntu-nl.org/community/Grub2#AanpassenvanGrub2 met name dit stukje:
#

GRUB_TIMEOUT=10

    *

      (!) Deze instructie is ondergeschikt aan de GRUB_HIDDEN_TIMEOUT instellelling tenzij GRUB_HIDDEN_TIMEOUT is uitgeschakeld (zoals besproken met een #). Als GRUB_HIDDEN_TIMEOUT actief is, heeft GRUB_TIMEOUT eenmalig effect en zal het menu worden weergegeven.
    * Bij een waarde van -1 zal het menu worden weergegeven totdat de gebruiker een keuze maakt.
    * Het GRUB 2 menu is standaard verborgen, tenzij een ander besturingssysteem is gevonden. Als er geen ander besturingssysteem is gevonden kan deze regel zijn uitgeschakeld (met een #), tenzij de gebruiker dit heeft veranderd. Schakel deze regel in (zonder #-teken aan het begin) om het menu altijd te tonen en gebruik een waarde van 1 of meer.
Een klein stukje lager staat een stukje over resoluties, hoe groter de resolutie hoe kleiner de letter.
# GRUB_GFXMODE=640x480

    * Wis het # teken om deze regel te gebruiken. Hiermee kan de resolutie van de grafische menu (menu tekst grootte) worden ingesteld (bijvoorbeeld 640x480, 800x600, 1280x1024, enz.) als deze door de grafische kaart worden ondersteund. De instelling is alleen voor het boot menu, niet de resolutie van het besturingssysteem.
          o Tip: Het instellen van dezelfde resolutie in GRUB 2 als in het besturingssysteem zal de opstarttijd iets verkorten.
    * Hoewel niet vereist is, kan ook de kleurdiepte worden toegevoegd aan de resolutie-instelling. Voorbeelden zijn 1280x1024x24 of 640x480x32.
    *

      Er kunnen meerdere resoluties worden opgenomen. Als GRUB 2 de 1e resolutie niet kan gebruiken, zal de volgende resolutie worden geprobeerd. Instellingen worden gescheiden door een komma. Voorbeeld: 1280x1024x16, 800x600x24, 640x480.
    * Neem bij het gebruik van een splash afbeelding een bijpassende resolutie-instelling.
    *

      Om de beschikbare resoluties te zien kan de opdracht vbeinfo op de GRUB 2 opdrachtregel worden gegeven. Druk op "c" in het GRUB 2 menu voor een GRUB 2 opdrachtregel.
    *

      Als deze lijn is uitgeschakeld (#) of de resoluties zijn niet bruikbaar voor GRUB 2 wordt de standaardinstelling bepaald door /etc/grub.d/00_header.
Dus Grub geheel opnieuw installeren is niet nodig, ik hoop dat dit je vragen beantwoord. Anders schrijf je maar weer.
In der Beschränkung zeigt sich der Meister.

Offline Alver1

  • Lid
  • Steunpunt: Nee
Re: Nukkige grub na upgrade 10.04 naar 10.10
« Reactie #4 Gepost op: 2011/03/16, 09:26:29 »
Als je de beschrijving hebt gevolgd. En op het eind het systeem opstart, zonder de cd in de lade, dan hoor je het Grub menu te zien, afhankelijk van de tijd instelling zal of Grub direct doorstarten, als de tijd 0 seconde is, tot de tijd die je zelf instelt.
Kijk hier hoe je de tijd instelt http://wiki.ubuntu-nl.org/community/Grub2#AanpassenvanGrub2 met name dit stukje:
#

GRUB_TIMEOUT=10

    *

      (!) Deze instructie is ondergeschikt aan de GRUB_HIDDEN_TIMEOUT instellelling tenzij GRUB_HIDDEN_TIMEOUT is uitgeschakeld (zoals besproken met een #). Als GRUB_HIDDEN_TIMEOUT actief is, heeft GRUB_TIMEOUT eenmalig effect en zal het menu worden weergegeven.
    * Bij een waarde van -1 zal het menu worden weergegeven totdat de gebruiker een keuze maakt.
    * Het GRUB 2 menu is standaard verborgen, tenzij een ander besturingssysteem is gevonden. Als er geen ander besturingssysteem is gevonden kan deze regel zijn uitgeschakeld (met een #), tenzij de gebruiker dit heeft veranderd. Schakel deze regel in (zonder #-teken aan het begin) om het menu altijd te tonen en gebruik een waarde van 1 of meer.
Een klein stukje lager staat een stukje over resoluties, hoe groter de resolutie hoe kleiner de letter.
# GRUB_GFXMODE=640x480

    * Wis het # teken om deze regel te gebruiken. Hiermee kan de resolutie van de grafische menu (menu tekst grootte) worden ingesteld (bijvoorbeeld 640x480, 800x600, 1280x1024, enz.) als deze door de grafische kaart worden ondersteund. De instelling is alleen voor het boot menu, niet de resolutie van het besturingssysteem.
          o Tip: Het instellen van dezelfde resolutie in GRUB 2 als in het besturingssysteem zal de opstarttijd iets verkorten.
    * Hoewel niet vereist is, kan ook de kleurdiepte worden toegevoegd aan de resolutie-instelling. Voorbeelden zijn 1280x1024x24 of 640x480x32.
    *

      Er kunnen meerdere resoluties worden opgenomen. Als GRUB 2 de 1e resolutie niet kan gebruiken, zal de volgende resolutie worden geprobeerd. Instellingen worden gescheiden door een komma. Voorbeeld: 1280x1024x16, 800x600x24, 640x480.
    * Neem bij het gebruik van een splash afbeelding een bijpassende resolutie-instelling.
    *

      Om de beschikbare resoluties te zien kan de opdracht vbeinfo op de GRUB 2 opdrachtregel worden gegeven. Druk op "c" in het GRUB 2 menu voor een GRUB 2 opdrachtregel.
    *

      Als deze lijn is uitgeschakeld (#) of de resoluties zijn niet bruikbaar voor GRUB 2 wordt de standaardinstelling bepaald door /etc/grub.d/00_header.
Dus Grub geheel opnieuw installeren is niet nodig, ik hoop dat dit je vragen beantwoord. Anders schrijf je maar weer.

Hallo, bedankt nogmaals voor uw uitvoerig antwoord. Ik heb het desbetreffende bestand nogmaals nagezien. Het blijkt dat regel over de schermwaarde reeds was ingesteld: GRUB_GFXMODE=1024x768x24 (zonder hekje ervoor natuurlijk) en ... zonder het minste resultaat.
Ik heb bovendien getracht de schermgrootte te veranderen in het bestand /etc/grub.d/00_header zoals u aangaf, ook daar niet het minste resultaat. Oh ja, ik heb natuurlijk na elke bewerking sudo updat-grub uitgevoerd. Het stukje over de time-out heb ik nog niet uitgevoerd, dat is waarschijnlijk iets voor deze avond.

Alver1

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Nukkige grub na upgrade 10.04 naar 10.10
« Reactie #5 Gepost op: 2011/03/16, 17:48:24 »
Je moet niet daar veranderingen aanbrengen, daar kan je bijv. een eigen script maken voor eigen menu keuzes, maar in /etc/default/grub Dit bestand kan je bewerken door in de terminal te typen:
sudo gedit /etc/default/grub

of via de grafische manier type in de terminal gksudo nautilus  na dit moet je het wachtwoord invullen, daarna kan je naar de map /etc/default navigeren en bestand grub bewerken met gedit of een andere tekst bewerker en opslaan
Voor beide geld na opslaan inderdaad, sudo update-grub uitvoeren
Als voorbeeld, mijn bestand ziet er zo uit:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT="0"
#GRUB_HIDDEN_TIMEOUT="0"
GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_TIMEOUT="5"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE="1024x768x16"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

export GRUB_MENU_PICTURE="/home/gijs/Afbeeldingen/Jeff Beck 13-10-2010/IMG_0042.JPG"
export GRUB_COLOR_NORMAL="light-gray/black"
export GRUB_COLOR_HIGHLIGHT="dark-gray/light-gray"
In der Beschränkung zeigt sich der Meister.

Offline Alver1

  • Lid
  • Steunpunt: Nee
Re: Nukkige grub na upgrade 10.04 naar 10.10
« Reactie #6 Gepost op: 2011/03/17, 10:33:19 »
Je moet niet daar veranderingen aanbrengen, daar kan je bijv. een eigen script maken voor eigen menu keuzes, maar in /etc/default/grub Dit bestand kan je bewerken door in de terminal te typen:
sudo gedit /etc/default/grub

of via de grafische manier type in de terminal gksudo nautilus  na dit moet je het wachtwoord invullen, daarna kan je naar de map /etc/default navigeren en bestand grub bewerken met gedit of een andere tekst bewerker en opslaan
Voor beide geld na opslaan inderdaad, sudo update-grub uitvoeren
Als voorbeeld, mijn bestand ziet er zo uit:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT="0"
#GRUB_HIDDEN_TIMEOUT="0"
GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_TIMEOUT="5"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE="1024x768x16"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

export GRUB_MENU_PICTURE="/home/gijs/Afbeeldingen/Jeff Beck 13-10-2010/IMG_0042.JPG"
export GRUB_COLOR_NORMAL="light-gray/black"
export GRUB_COLOR_HIGHLIGHT="dark-gray/light-gray"

Hallo, inbrengen van verschillende settings in TIME_OUT heeft geen enkel gevolg. Ik moet handmatig booten anders gebeurt er niks en kan ik blijven wachten tot Sint-Juttemis. Wat ik wel wil onderstrepen is dat mijn GRUB menu onderaan geen time-out lijntje meer heeft. Wat kan ik verder nog doen? Handmatig booten kan natuurlijk maar de timer heeft altijd gewerkt (sinds U 8.04). Wachten op 11.04??

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Nukkige grub na upgrade 10.04 naar 10.10
« Reactie #7 Gepost op: 2011/03/17, 18:36:15 »
Je kan dit grafische programma nog proberen Grub Customizer, http://www.webupd8.org/2010/10/grub-customizer-lets-you-reorder-add-or.html
In der Beschränkung zeigt sich der Meister.

Offline Alver1

  • Lid
  • Steunpunt: Nee
Re: Nukkige grub na upgrade 10.04 naar 10.10
« Reactie #8 Gepost op: 2011/03/18, 22:10:13 »
Je kan dit grafische programma nog proberen Grub Customizer, http://www.webupd8.org/2010/10/grub-customizer-lets-you-reorder-add-or.html

Hallo, ik heb dit programma geïnstalleerd maar het is me niet duidelijk hoe ik daarmee mijn bijv. mijn timer lijntje terug krijg. Enige vingerwijzingen misschien?

Alver1

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Nukkige grub na upgrade 10.04 naar 10.10
« Reactie #9 Gepost op: 2011/03/19, 00:16:12 »
In het programma druk je op de knop Preferences dan staat er op de tab General op ongeveer de helft visibility, en bij time out kan je de tijd instellen.
In der Beschränkung zeigt sich der Meister.

Offline Alver1

  • Lid
  • Steunpunt: Nee
Re: Nukkige grub na upgrade 10.04 naar 10.10
« Reactie #10 Gepost op: 2011/03/19, 11:07:48 »
In het programma druk je op de knop Preferences dan staat er op de tab General op ongeveer de helft visibility, en bij time out kan je de tijd instellen.
Hallo Gijsbert, ik gevonden wat u aangaf maar helaas het werkt niet. Het time-out regeltje dat bij vorige installatie (10.04 LTS en vroeger) te zien was en werkte is er niet meer en het komt ook niet tevoorschijn via uw programma. Nog enig idee om deze bizarre toestand op te lossen? Gelukkig werkt handmatig alles.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Nukkige grub na upgrade 10.04 naar 10.10
« Reactie #11 Gepost op: 2011/03/19, 21:52:28 »
Ik heb vanavond ook lopen rommelen met Grub. Ik heb versie 1o.04 en versie 11.04. Het blijkt dat je de Grub alleen kan wijzigen met de hoogst geïnstalleerde versie van Ubuntu. Als je Grub Customizer in 11.04 installeert zal het geen probleem zijn, nog even testen. :)
In der Beschränkung zeigt sich der Meister.