Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Wireless N wil niet werken, G wel  (gelezen 2781 keer)

Offline rrgjl

  • Lid
  • Steunpunt: Nee
Wireless N wil niet werken, G wel
« Gepost op: 2011/03/09, 11:34:09 »
Ik krijg mijn Ubuntu systeem niet aan het werken met wireless N. Als ik het netwerk op mixed mode instel dan werkt het gewoon. Hij connect dan via G. Als ik het netwerk instel op N, dan vraagt hij om het wachtwoord van het netwerk, en blijft vervolgens proberen te verbinden. Er gebeurt verder niets.
Het werkt wel gewoon op andere pc's met Windows 7 en Mac OS, dus het heeft iets met de instellingen of driver van Ubuntu te maken.

Ik heb na wat googelen een oplossing gevonden waarbij ik in /etc/modprobe.d/ het bestand intel-5300-iwlagn-disable11n.conf moest aanpassen van 1 naar 0, maar dit verhelpt het probleem niet.
Ik ben volledig nieuw in Linux, dus ik hoop dat iemand mij een beetje op weg kan helpen :)
Het gaat trouwens om een intel netwerkkaart in een Asus laptop. De router is een Linksys wrt 300n.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Wireless N wil niet werken, G wel
« Reactie #1 Gepost op: 2011/03/09, 11:47:24 »
Welke USB of interne wifi heb je van intel?
En heb je het ook al geprobeerd met ndiswrapper?
In der Beschränkung zeigt sich der Meister.

Offline rrgjl

  • Lid
  • Steunpunt: Nee
Re: Wireless N wil niet werken, G wel
« Reactie #2 Gepost op: 2011/03/09, 11:55:14 »
Ik weet zo niet welke netwerkkaart het is. Waar kan ik dat zien in Ubuntu?
Ndiswrapper zegt mij als noob niets. Ik zal zometeen eens even googelen en kijken of ik daar verder mee kom.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Wireless N wil niet werken, G wel
« Reactie #3 Gepost op: 2011/03/09, 12:34:56 »
Open een terminal en type voor een intern kaartje lspci  (de eerste letter is een kleine L)
Open een terminal en type voor een extern kaartje lsusb  (de eerste letter is een kleine L)
Kan je de uitkomst hier plaatsen?
ndiswrapper is een programmaatje om Windows drivers te installeren, zou ik pas gebruiken als je er helemaal niet uitkomt.
http://sites.google.com/site/computertip/geendraadloosinternet#TOC-Het-Windows-stuurprogramma-in-een-L
In der Beschränkung zeigt sich der Meister.

Offline rrgjl

  • Lid
  • Steunpunt: Nee
Re: Wireless N wil niet werken, G wel
« Reactie #4 Gepost op: 2011/03/09, 13:08:13 »
Gevonden :)

02:00.0 Network controller: Intel Corporation WiFi Link 5100

Offline rrgjl

  • Lid
  • Steunpunt: Nee
Re: Wireless N wil niet werken, G wel
« Reactie #5 Gepost op: 2011/03/09, 13:31:26 »
Ik heb ook al via intellinuxwireless.org de goede driver gedownload. Ik heb 'm tevens gekopieerd naar /lib/firmware/.
Nu moet ik 'm alleen nog zien te laden (even als status update).

Edit.. : ok, en daar hang ik nu vast. Geen idee hoe ik die driver geactiveerd krijg.
« Laatst bewerkt op: 2011/03/09, 13:43:50 door rrgjl »

Offline rrgjl

  • Lid
  • Steunpunt: Nee
Re: Wireless N wil niet werken, G wel
« Reactie #6 Gepost op: 2011/03/09, 14:31:05 »
Iemand een idee hoe ik de firmware moet laden? ???

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Wireless N wil niet werken, G wel
« Reactie #7 Gepost op: 2011/03/09, 17:33:26 »
Heb je de tar eerst uitgepakt?
Navigeer met nautilus naar de map waar je het bestand hebt gedownload.
Klik nu met de rechtermuisknop op het bestand.
Klik nu in het menu wat je krijgt op Hier uitpakken.
Nu heb je in die map een map staan met de zelfde naam als de tar.
Open deze map, daar staat een ook een Readme in:
Hierin kan je dit lezen: cp iwlwifi-5000-5.ucode /lib/firmware omdat je wat naar het bestandsysteem gaat kopieren moet er sudo voor.
Dit gaat zo: open een terminal(onder Hulpmiddelen) en type cd Downloads//iwlwifi-5000-ucode-8.83.5.1  De map Downloads heb ik even als voorbeeld genomen, heb jij een andere map, vul je deze in.
Nu type je dit in sudo cp iwlwifi-5000-5.ucode /lib/firmware Geef een ENTER nu moet je het wachtwoord invullen, hier zie je niets van, geen sterretjes, balletjes o.i.d., helemaal niets, gewoon blindtypen, geef een ENTER, als dit is gelukt, sluit je alles af en start de computer opnieuw op.
In der Beschränkung zeigt sich der Meister.

Offline rrgjl

  • Lid
  • Steunpunt: Nee
Re: Wireless N wil niet werken, G wel
« Reactie #8 Gepost op: 2011/03/09, 18:00:32 »
Alleen het kopiëren van het bestand zou dus voldoende moeten zijn? Daarna kan ik rebooten?  :o
Wat je hierboven schrijft had ik namelijk al gedaan. Vervolgens herkent hij de netwerkkaart helemaal niet meer, maar dat kan ook komen doordat ik nog heb liggen prutsen met ndiswrapper. Die heb ik er vanaf gegooid nu, maar de vraag is hoe ik nu die linuxdriver gewoon weer correct aan het werken krijg.
Ik weet het, ik ben ongetwijfeld heel irritant om te helpen, met al die dingen die ik probeer en waarmee ik het mezelf alleen maar moeilijker maak :P

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Wireless N wil niet werken, G wel
« Reactie #9 Gepost op: 2011/03/09, 18:08:56 »
/lib/firmware is een onderdeel van de kernel, als je hier iets neerzet, verandert o.i.d. dan moet je de computer altijd herstarten in tegenstelling tot het installeren van een programma. Waar het maar een heel enkele keer nodig is.


Ik weet het, ik ben ongetwijfeld heel irritant om te helpen, met al die dingen die ik probeer en waarmee ik het mezelf alleen maar moeilijker maak  :P
Irritant valt wel mee, ik heb het ook geleerd met uitproberen, bij mij is er in het begin ook menigmaal een systeem om zeep geholpen. =D
Als jij er maar geholpen mee bent dat is het belangrijkste, je zet in ieder geval door, dat mag je als een pluspunt beschouwen. :)
In der Beschränkung zeigt sich der Meister.

Offline rrgjl

  • Lid
  • Steunpunt: Nee
Re: Wireless N wil niet werken, G wel
« Reactie #10 Gepost op: 2011/03/09, 18:24:50 »
Thanks :)
Maar helaas.. na een reboot doet ie het nog niet. Ik denk dat het te maken heeft met ndiswrapper die ik erop heb gehad.
Als ik nu sudo lshw -C network open in de terminal, dan krijg ik het volgende te zien:

*-network UNCLAIMED    
       description: Network controller
       product: WiFi Link 5100
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:feafe000-feafffff
  *-network
       description: Ethernet interface
       product: AR8131 Gigabit Ethernet
       vendor: Atheros Communications
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: c0
       serial: 90:e6:ba:19:d7:fc
       size: 100MB/s
       capacity: 1GB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.0.2-NAPI duplex=full firmware=N/A ip=192.168.1.100 latency=0 link=yes multicast=yes port=twisted pair speed=100MB/s
       resources: irq:46 memory:febc0000-febfffff ioport:ec00(size=128)

Unclaimed is niet juist, dan is er geen driver toegewezen.. maar hoe zorg ik dat die wel weer toegewezen wordt?  ??? (voor de duidelijkheid, hij staat dus wel gewoon in de firmware map)

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Wireless N wil niet werken, G wel
« Reactie #11 Gepost op: 2011/03/09, 19:01:44 »
Probeer dit nog eens Following a suggestion I actually added the pci=use_crs option to the GRUB_CMDLINE_LINUX_DEFAULT variable in /etc/default/grub and then ran update-grub so that future kernel updates will keep the change.
Van http://ubuntuforums.org/showthread.php?t=1336022

Of deze sudo apt-get install linux-backports-modules-karmic-generic van http://forums.linuxmint.com/viewtopic.php?f=49&t=39781&start=0
Ik wil er wel even bij vermelden dat deze oplossing misschien niet werkt voor 10.10
In der Beschränkung zeigt sich der Meister.

Offline rrgjl

  • Lid
  • Steunpunt: Nee
Re: Wireless N wil niet werken, G wel
« Reactie #12 Gepost op: 2011/03/09, 19:32:46 »
In het grub bestand kom ik de volgende regels tegen (o.a.):

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Waar moet ik nu precies dat pci=use_crs zetten?

Offline rrgjl

  • Lid
  • Steunpunt: Nee
Re: Wireless N wil niet werken, G wel
« Reactie #13 Gepost op: 2011/03/09, 19:40:17 »
Het maffe is (met betrekking tot oplossing nummer 2 die ik nog moet proberen) dat het eerder wel gewoon werkte. Toen was het probleem het niet kunnen verbinden met G netwerken. Nu herkent hij de netwerkkaart helemaal niet meer. Ofja, hij herkent de kaart wel maar wijst er geen driver aan toe, of hoe dat ook precies werkt bij linux :)

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Wireless N wil niet werken, G wel
« Reactie #14 Gepost op: 2011/03/09, 20:35:17 »
Hier GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=use_crs" Als je dit opgeslagen hebt, open een terminal en type sudo update-grub
en herstart de computer.
In der Beschränkung zeigt sich der Meister.

Offline rrgjl

  • Lid
  • Steunpunt: Nee
Re: Wireless N wil niet werken, G wel
« Reactie #15 Gepost op: 2011/03/10, 11:54:30 »
Helaas....
Ik heb ook al via got.tweakers.net wat hulp gekregen en zij raadde me aan om deze driver te installeren: http://linuxwireless.org/en/users/Download
Via de stappen:

1) downloaden van de bleeding edge compat-wireless driver van die site
2) uitpakken (tar xjf ...)
3) naar die directory gaan
4) make
5) sudo make install
6) de file /etc/modprobe.d/intel-5300-iwlagn-disable11n.conf weghalen (niet weggooien, maar even op een veilige plek zetten voor het geval je nog spijt krijgt)
7) reboot

Dat is allemaal gelukt.. echter zie ik nog steeds geen wireless adapter bij mijn netwerkverbindingen. En nog steeds die "UNCLAIMED".
Hoe kan ik een driver toewijzen, handmatig..?

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Wireless N wil niet werken, G wel
« Reactie #16 Gepost op: 2011/03/10, 20:24:35 »
Handmatig toewijzen kan alleen met ndiswrapper(de windows inf file) met het kopieren van het bestand naar /lib/firmware en het opnieuw opstarten van de computer zou de driver geactiveerd moeten zijn. Wat je kan doen is met Nautilus kiken of de file daadwerkelijk in de map /lib/firmware staat. Als je dit gecontroleerd hebt, open een terminal en type iwconfig wlan0
Dan krijg je iets dergelijks te zien:
wlan0     IEEE 802.11bg  ESSID:"MyPlace" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: XX:XX:XX:XX:XX:XX  <-- Dit heb ik aangepast   
          Bit Rate=12 Mb/s   Tx-Power=14 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=42/70  Signal level=-68 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Kan je de uitkomst van jou, hier plaatsen?
In der Beschränkung zeigt sich der Meister.

Offline rrgjl

  • Lid
  • Steunpunt: Nee
Re: Wireless N wil niet werken, G wel
« Reactie #17 Gepost op: 2011/03/10, 21:08:35 »
Het werkt al! :) (nouja.. al..).
Ik heb Ubuntu opnieuw geinstalleerd en de hele riedel opnieuw gedaan. Toen deed ' ie het wel. Ik maak nu gebruik van de nieuwe driver en kan verbinden via N :) Nu hopen dat het ook enigszins stabiel is en blijft.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: Wireless N wil niet werken, G wel
« Reactie #18 Gepost op: 2011/03/10, 22:28:38 »
Mooi dat het nu werkt. Misschien zat er toch nog "iets" van een eerdere installatie in de weg. Hopelijk blijft het nu allemaal stabiel draaien. :)
In der Beschränkung zeigt sich der Meister.