Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Wifi: Alleen maar G ipv N [opgelost]  (gelezen 2937 keer)

Offline koen_92

  • Lid
  • Steunpunt: Nee
Wifi: Alleen maar G ipv N [opgelost]
« Gepost op: 2011/03/03, 18:58:53 »
Hallo,

Omdat ik mijn wifi-netwerk toch wel traag vond heb ik een nieuw access point en N-kaart gekocht (300mbps).
Als accesspoint heb ik gekozen voor de D-link dap-1360 N Open Source Access Point met open source firmware.
Als wifi kaart heb ik gekozen voor een d-link DWA-556 Xtreme N PCI Express Desktop Adapter:
$ lspci
02:00.0 Network controller: Atheros Communications Inc. AR5008 Wireless Network Adapter (rev 01)

Het verbind allemaal netjes en werkt allemaal out-of-the-box, maar enkel op G-snelheden:
wlan0     IEEE 802.11bgn  ESSID:"balferen"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 5C:D9:98:64:09:92  
          Bit Rate=54 Mb/s   Tx-Power=20 dBm    <-------------------------------- N = 300Mb/s, niet 54 Mb/s
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=47/70  Signal level=-63 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:49   Missed beacon:0

Volgens iwlist ondersteunt mijn Access Point geen N-snelheden:
$ sudo iwlist wlan0 scan
wlan0     Scan completed :
          Cell 01 - Address: 5C:D9:98:64:09:92
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=46/70  Signal level=-64 dBm  
                    Encryption key:on
                    ESSID:"balferen"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s <-----------------Meer dan 54Mb/s staat er niet tussen.
                    Mode:Master
                    Extra:tsf=0000000005fa7c65
                    Extra: Last beacon: 796ms ago
                    IE: Unknown: 000862616C666572656E
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 030101
                    IE: Unknown: 2A0100
                    IE: Unknown: 32043048606C
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
                    IE: Unknown: DD0700E04C02022000

Momenteel haal ik op 10 meter afstand snelheden rond de 25 MB/s, waar er gemakkelijk het dubbele gehaald kan worden:
http://nl.hardware.info/reviews/1971/10/review-zeven-access-points-getest-testresultaten-24-ghz

25 MB/s is helaas te weinig om HD-video door te streamen waar ik deze hardware voor gekocht heb.
Ik gebruik Ubuntu 10.04.2.

Heeft iemand een idee? Dit heeft mij namelijk wel 100 euro gekost en dan is het erg jammer dat het niet werkt, terwijl ik wel degelijk linux-compatibele hardware heb gekocht.
« Laatst bewerkt op: 2011/03/06, 13:47:37 door koen_92 »

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: Wifi: Alleen maar G ipv N
« Reactie #1 Gepost op: 2011/03/03, 21:26:20 »
Koen_92,

Ik heb geen ervaring met Atheros WiFi kaarten... Maar het kan zijn dat de n (300Mb/s) op een andere frequentie moet zitten.
Dus de 5 Ghz ipv 2.4 Ghz.

Als voorbeeld een de Intel 2100A.
Deze is op 2.4 Ghz een 11Mb/s maar op 5 Ghz 54Mb/s
ftp://download.intel.com/support/wireless/wlan/pro2100a/specifications.pdf
MvG,
MauRice
Registered Linux user: 473556

Offline petervs

  • Lid
  • Steunpunt: Nee
Re: Wifi: Alleen maar G ipv N
« Reactie #2 Gepost op: 2011/03/03, 22:29:11 »
Na wat zoeken op internet (oa op D-link forum) zie ik dat er meer problemen zijn met de d-link DWA-556, dat de snelheid maar gaat tot 54 mbps. Het schijnt dat ook bijv. windows 7 er last van heeft. Niet dat je er wat mee opschiet maar misschien kun je het omruilen.
Ubuntu MATE 16.04

Offline koen_92

  • Lid
  • Steunpunt: Nee
Re: Wifi: Alleen maar G ipv N
« Reactie #3 Gepost op: 2011/03/03, 22:35:15 »
Het access point kan enkel 2,5ghz uitzenden.
Maar dit is niet het probleem, in de review waar ze het ding getest hebben kan hij op de 2,4ghz wel snelheden tot 60mbit halen.

Maar ik ben inmiddels een stap verder:
Als ik de beveiliging uitzet haal ik wel de volledige snelheid!
iwlist geeft nog steeds 54mbps aan en iwconfig geeft 0 kb/s aan, maar ik kan nu wel 70mbit halen.

Het probleem zit hem dus in de wpa-beveiliging.
Iemand een idee hoe dat op te lossen is?

Offline petervs

  • Lid
  • Steunpunt: Nee
Re: Wifi: Alleen maar G ipv N
« Reactie #4 Gepost op: 2011/03/03, 22:54:10 »
Volgens iemand hier: http://hardforum.com/showthread.php?p=1036226015 kan er verschil zitten in AES en TKIP (TKIP schijnt altijd terug te vallen op 54Mbps?)
Ubuntu MATE 16.04

Offline koen_92

  • Lid
  • Steunpunt: Nee
Re: Wifi: Alleen maar G ipv N
« Reactie #5 Gepost op: 2011/03/03, 23:11:37 »
Ook dat heb ik inmiddels geprobeerd, maar dat maakt geen verschil.

Het moet toch echt aan de WPA-beveiliging liggen, want zonder WPA haal ik 80Mbit en met maar 20.

Heeft iemand nog meer tips?

Offline softbart

  • Lid
  • Steunpunt: Nee
Re: Wifi: Alleen maar G ipv N
« Reactie #6 Gepost op: 2011/03/04, 10:15:45 »
@koen_92,

Ik heb geen direct antwoord op je vraag.

Misschien niet helemaal offtopic.
Ik begrijp dit niet helemaal.
Citaat
25 MB/s is helaas te weinig om HD-video door te streamen waar ik deze hardware voor gekocht heb.

groet,

Theo

Offline koen_92

  • Lid
  • Steunpunt: Nee
Re: Wifi: Alleen maar G ipv N
« Reactie #7 Gepost op: 2011/03/05, 12:20:49 »
@softbart:
Ik een NAS waar heel veel HD-video's op staan.
Deze wil ik graag op mijn pc afspelen via Wifi.

Ik ben inmiddels verder aan het testen geweest:
Ik heb het wifi-kaartje op een pc met Windows 7 getest, en daar haal ik wel de volledige snelheid met WPA-beveiliging ingeschakeld.

Het is dus duidelijk een probleem met Ubuntu icm WPA.

Resultaten:
Windows 7:
Zonder beveiliging: 70 Mbit
Met WPA beveiliging: 70Mbit

Ubuntu 10.04:
Zonder beveiliging: 70 Mbit
Met WPA beveiliging: 15 Mbit (met drops naar 1Mbit!)

Er gaat in Ubuntu hier dus iets echt niet goed.

Offline softbart

  • Lid
  • Steunpunt: Nee
Re: Wifi: Alleen maar G ipv N
« Reactie #8 Gepost op: 2011/03/05, 15:20:14 »
@koen-92,

Ik vroeg dit omdat mijn (WD)nasje, een echte slak, met gemak een mkv streamt via de mediaspeler naar de TV. Dus mogelijk dat stream niet goed loopt met de computer.

Wanneer je je wlan gebruikt met NetworkManger kijk eens naar stukje van Dropl. Misschien zit er iets tussen om de wpa te verbeteren.

http://forum.ubuntu-nl.org/internet-en-draadloos/een-leven-zonder-network-manager/

groet,

Theo


Offline koen_92

  • Lid
  • Steunpunt: Nee
Re: Wifi: Alleen maar G ipv N
« Reactie #9 Gepost op: 2011/03/06, 13:47:07 »
Voor een Blu-ray image van 40GB heb je toch echt wel minimaal 40Mbit nodig, wil dit vloeiend gaan.

Ik heb inmiddels een live-cd van Maverick geprobeerd en daar werkt het wel goed!
Toen heb ik een live-cd van Lucid geprobeerd en daar werkt het ook!

Toen ben ik maar verder gaan kijken wat er verschilt tussen mijn configuratie en die van de live-cd.
Uiteindelijk kwam ik er achter dat ik kernel 2.6.38 gebruik terwijl lucid standaard op 2.6.32 zit.
Ik heb 2.6.38 nodig wegens een infraroodontvanger die alleen daarin gesupport wordt.
Maar die heb ik nu dus maar laten zitten en ik ben weer terug naar 2.6.32 gegaan.
Het probleem is nu dus opgelost!

Verder heb ik even een  Natty alpha 3 live cd getest, en daar zit het probleem dus nog wel in. Zal dit al bekend zijn bij de Ubuntu-developers? Want het is natuurlijk niet de bedoeling dat dit probleem straks ook in de final versie van 11.04 zit.

Mijn probleem is in ieder geval opgelost! Bedankt iedereen voor het meedenken!