Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Logitech Webcam - zwart scherm  (gelezen 1550 keer)

Offline Plecotus

  • Lid
  • Steunpunt: Nee
Logitech Webcam - zwart scherm
« Gepost op: 2011/03/02, 00:31:51 »
Hey all,

de afgelopen 2 uur bezig geweest met een poging een webcam te installeren op mijn Ubuntu 10.10.
Dusver zonder resultaat!

Heb het web al wat zitten afschuimen, maar nog geen oplossing kunnen vinden. Het enige dat Skype and Cheese tonen, is een zwart scherm. Voor alle duidelijkheid: heb net getest op WinXP, en de webcam werkt wel degelijk.

Ubuntu lijkt alles netjes te zien, maar ik krijg hem verder niet aan de praat. Niet in Skype, niet in Cheese.
Het is een re-branded Logitech Quickcam Pro 4000 webcam.

Deze werken niet:
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so cheese
LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so cheese

Onder "gstreamer-properties > Video" is de camera terug te vinden onder de "Standaard Ingang" wanneer ik "Video voor Linux 2 (v4l2)" selecteer als plugin. Bij een test gebeurd er echter helemaal niets. Enkel het lampje op de webcam gaat branden.

Hieronder wat meer info:

*******@****:~/Bureaublad$ tail /var/log/messages
Mar  2 00:15:09 **** kernel: [ 1755.840278] usb 5-2: new full speed USB device using ohci_hcd and address 5
Mar  2 00:15:09 **** kernel: [ 1756.097329] pwc: Logitech/Cisco VT Camera webcam detected.
Mar  2 00:15:09 **** kernel: [ 1756.097515] pwc: Registered as video0.
Mar  2 00:15:09 **** kernel: [ 1756.474247] input: PWC snapshot button as /devices/pci0000:00/0000:00:13.3/usb5/5-2/input/input7


*******@****:~/Bureaublad$ setpwc -p
setpwc v1.2, (C) 2003-2006 by folkert@vanheusden.com
Current device: Cisco VT Camera
VIDIOCPWCPROBE returns: Cisco VT Camera - 740
Serial number:
Resolution (x, y): 160, 120
Offset: 0, 0
Framerate: 10
Brightness: 32256
Hue: 65535
Colour: 32768
Contrast: 32768
Whiteness: 49152
Palette: YUV 4:2:0 Planar
Compression preference: 1
Automatic gain control: -4138
Whitebalance mode: auto
Blinking of LED is not supported by the combination
of your webcam and the driver.
Sharpness: -1
Backlight compensation mode: off
Anti-flicker mode: off
Noise reduction mode: 1
Pan/tilt range is not supported by the combination
of your webcam and the driver.
Get pan/tilt position is not supported by the combination
of your webcam and the driver


*******@****:~/Bureaublad$ v4l-info

### v4l2 device info [/dev/video0] ###
general info
    VIDIOC_QUERYCAP
   driver                  : "pwc"
   card                    : "Cisco VT Camera"
   bus_info                : "usb-0000:00:13.3-2"
   version                 : 10.0.12
   capabilities            : 0x5000001 [VIDEO_CAPTURE,READWRITE,STREAMING]

### video4linux device info [/dev/video0] ###
general info
    VIDIOCGCAP
   name                    : "Cisco VT Camera"
   type                    : 0x1 [CAPTURE]
   channels                : 1
   audios                  : 1
   maxwidth                : 640
   maxheight               : 480
   minwidth                : 160
   minheight               : 120


Iemand enig idee wat ik nog kan proberen?

Bedankt!


Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Logitech Webcam - zwart scherm
« Reactie #1 Gepost op: 2011/03/02, 00:38:14 »

Offline Plecotus

  • Lid
  • Steunpunt: Nee
Re: Logitech Webcam - zwart scherm
« Reactie #2 Gepost op: 2011/03/02, 00:48:30 »
wxCam geïnstalleerd.
Bij de eerste maal opstarten zegt hij dat hij de Webcam gedetecteerd heeft, waarna hij verder gaat, waarna wxCam crashed.
Als ik de webcam disconnecteer komt wxCam terug tot leven...

Offline Pjotr

  • Lid
    • http://sites.google.com/site/computertip
  • Steunpunt: Nee
Re: Logitech Webcam - zwart scherm
« Reactie #3 Gepost op: 2011/03/02, 10:20:09 »
Dan is het waarschijnlijk een stuurprogrammaprobleem. Daar is vermoedelijk niet veel meer aan te doen dan wachten op updates of op een volgende Ubuntuversie....

Offline Plecotus

  • Lid
  • Steunpunt: Nee
Re: Logitech Webcam - zwart scherm
« Reactie #4 Gepost op: 2011/03/02, 10:26:40 »
Half uurtje geleden mijn PC opgestart, en de Webcam werkt nu gewoon  ???
Thans mijn PC gisteren verschillende malen opnieuw opgestart...

Anyway, thanks Pjotr!