Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [opgelost] ik krijg 10.04 niet geinstalleerd  (gelezen 3808 keer)

Offline wolfke

  • Lid
  • Steunpunt: Nee
[opgelost] ik krijg 10.04 niet geinstalleerd
« Gepost op: 2011/02/25, 17:08:13 »
Hallo, ik wil 10.04 installeren op mijn PC op een nieuwe externe HD.
(momenteel draait 9.04 op een andere externe HD)
Telkens ik dit probeer vanaf de Livecd krijg ik na installatie, als ik wil opstarten::
Out of disk
grub rescue>_

In google vind ik dan allerlei mogelijke oorzaken en "probeer eens dit, probeer eens dat.."

Kan mij iemand zeggen hoe en welke partities ik tijdens (of voor) de installatie op die HD moet aanmaken? Ik vermoed dat dat de oorzaak is.
Ik heb 9.04 beschikbaar, kan dus met Gparted die nieuwe HD bewerken.

(momenteel is mijn Livecd defekt en moet ik dus een nieuwe aanmaken waar kan ik die best downloaden  want ik zie dat er verschillende versies van bestaan)
« Laatst bewerkt op: 2011/03/02, 09:48:52 door wolfke »

Offline Coffeepad

  • Lid
  • Steunpunt: Nee
Re: ik krijg 10.04 niet geinstalleerd
« Reactie #1 Gepost op: 2011/02/25, 20:32:52 »
Aha je bent begonnen zie ik .....Leuk !!!
Even wat meer info graag , ben je al begonnen met installeren vanaf een cdrom ofzo of van een usb stick ?
Moet je nog gaan beginnen ? en over de partities weet je al hoe je wat in wil gaan delen of kies je voor een default install of wil je het handmatig indelen maar weet je nog niet hoe ? En waarom een oude versie van buntu ?



Offline wolfke

  • Lid
  • Steunpunt: Nee
Re: ik krijg 10.04 niet geinstalleerd
« Reactie #2 Gepost op: 2011/02/25, 21:27:44 »
Ik heb het al 3x geprobeerd, vertrekkend van een CDrom en heb deze keer op voorhand volgende partities aangemaakt;
ext3   /boot    502MB       met boot-vlag
ext3   /            50GB
linux-swap        2GB
(hierachter staat nog een nfts-partities van windows)

Ubuntu-partities heb ik nog eens bevestigd tijdens de install
(Tijdens install waren geen win-HDs aangekoppeld)
install verliep heel goed, maar ...
Bij de start krijg ik;
error: out of disk

(Dit is al iets beter dan de vorige keren, toen kreeg ik ook nog "grub rescue")

(Momenteel werk ik vanop een andere externe HD met 9.04
« Laatst bewerkt op: 2011/02/25, 22:24:51 door wolfke »

Offline Coffeepad

  • Lid
  • Steunpunt: Nee
Re: ik krijg 10.04 niet geinstalleerd
« Reactie #3 Gepost op: 2011/02/25, 21:43:44 »
Als het goed is krijg je ook te zien bij het maken van je partities , waar ie de bootloader neer moet zetten , dit heb je ook goed gedaan ?
En je computer boot op van die hdd neem ik aan omdat je die foutmelding krijgt ?

Offline emiel1976

  • Lid
  • Steunpunt: Nee
Re: ik krijg 10.04 niet geinstalleerd
« Reactie #4 Gepost op: 2011/02/25, 21:50:58 »
ik maak alleen langs mijn win partitie en NTFS gedeelte het volgende.

EXT4 /   100GB
swap      2GB

De Windows partitie staat als eerste.

Offline wolfke

  • Lid
  • Steunpunt: Nee
Re: ik krijg 10.04 niet geinstalleerd
« Reactie #5 Gepost op: 2011/02/25, 22:18:12 »
Als het goed is krijg je ook te zien bij het maken van je partities , waar ie de bootloader neer moet zetten , dit heb je ook goed gedaan ?
En je computer boot op van die hdd neem ik aan omdat je die foutmelding krijgt ?
- Waar hij de bootloader moet zetten, heb ik niet opgemerkt bij het maken van de partities.
Het enige wat ik deed is een boot-vlag zetten bij die /boot-partitie.
ik zag toevallig wel tijdens de installl dat hij Grub2 aan 't installeren was.
- jaja de PC boot vanaf die HD.

Offline Roc.am

  • Lid
  • Steunpunt: Nee
Re: ik krijg 10.04 niet geinstalleerd
« Reactie #6 Gepost op: 2011/02/25, 22:49:49 »
Heb je het ook al geprobeerd met Systeem -> Beheer -> Opstartschijf aanmaken.
Let op hij zal ALLE inhoud van de schijf wissen dus ook van de andere partities.
Maar daarna kun je wel weer andere partities aanmaken.
Je kut dan via je externe harde schijf opstarten door aan te sluiten en te booten.

- Roc
Is je vraag opgelost? Markeer het als [OPGELOST] in de titel van je bericht!

Offline wolfke

  • Lid
  • Steunpunt: Nee
Re: ik krijg 10.04 niet geinstalleerd
« Reactie #7 Gepost op: 2011/02/25, 23:08:54 »
@Roc.an; waarom zou ik dat doen? ik heb nog steeds (gelukkig maar!!) nog een andere externe HD waar ik met 9.04 op werk,  daarop kan ik die nieuwe externe HD aankoppelen en mee doen wat ik wil.

't zal wel iets met de bootloader te maken hebben zoals Coffepad laat doorschemeren zeker?

Offline Roc.am

  • Lid
  • Steunpunt: Nee
Re: ik krijg 10.04 niet geinstalleerd
« Reactie #8 Gepost op: 2011/02/26, 00:17:43 »
Dit is een complete installatie waar je mee kunt werken net als met de life cd.
Alleen met deze installatie kun je ook installeren enz. en staat los van grub.

- Roc
Is je vraag opgelost? Markeer het als [OPGELOST] in de titel van je bericht!

Offline Coffeepad

  • Lid
  • Steunpunt: Nee
Re: ik krijg 10.04 niet geinstalleerd
« Reactie #9 Gepost op: 2011/02/26, 01:38:26 »
Dit is een complete installatie waar je mee kunt werken net als met de life cd.
Alleen met deze installatie kun je ook installeren enz. en staat los van grub.

- Roc

Dit is niet wat de ts voor ogen heeft en zal derhalve ook de Windows install ongedaan maken.
Ik kan me het probleem ook niet voor de geest halen , Windows en een ubuntu install moet normaal geen probleem geven.
Ik ga er maar vanuit dat je grub in de /boot hebt geinstalleerd , das dus niet goed ;-)
Even om het makkelijk te maken , je hebt een /boot partitie aangemaakt ( zou ik ook doen , echter is meer dan 64 MB niet nodig ) en daar heb je dan grub in geinstalleerd en dat is niet goed , eigenlijk wel maar toch.
/boot daar wordt grub in geinstalleerd maar je moet de optie iets van : opstartlader bla bla op/in mbr installeren hebben.
Dat is het stukje zeg maar van je harde schijf waarvandaan als eerste wordt gelezen tijdens een opstart , en daar staat dan weer in dat ie verder moeten kijken naar /boot.

Maar goed om nu je probleem met je partities op te lossen , ik zou even een schone install doen en van daaruit gaan patitioneren eerst alle partities verwijderen en dan 1 voor 1 weer aanmaken , let wel even op dat je je windhoospartitie niet om zeep helpt.

Misschien iets voor in de Ubuwiki hoe je een dualboot maakt ? Het is niet moeilijk maar met plaatjes gaat het vaak beter.
Ik heb gemerkt dat er veel problemen mee zijn terwijl het toch echt heel simpel is , vandaag een install gedaan vanaf een usb stick op een micro sd met aangesloten hdd en ik ondervond totaal geen problemen. Misschien is Ubu wel te makkelijk ;-)

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: ik krijg 10.04 niet geinstalleerd
« Reactie #10 Gepost op: 2011/02/26, 06:51:12 »
Voor ubuntu installatie, de win harde schijf loskoppelen, moet je niet doen. hierdoor kun je problemen krijgen met grub en de goede harde schijf. Ook bijv niet installeren met externe harde schijf aangesloten, behalve als je deze altijd aangesloten laat.

Je hoeft ubuntu niet opnieuw te installeren, maar grub herstellen.
http://sites.google.com/site/computertip/grub

Offline Coffeepad

  • Lid
  • Steunpunt: Nee
Re: ik krijg 10.04 niet geinstalleerd
« Reactie #11 Gepost op: 2011/02/26, 09:08:34 »

Je hoeft ubuntu niet opnieuw te installeren, maar grub herstellen.
http://sites.google.com/site/computertip/grub

Dat is een goede tip , en op dit site staat het heel mooi uitgelegd zeker de moeite waard om even door te lezen.
Om een hoop geklooi achteraf te voorkomen voor als je niet geheel tevreden bent met je patitieopmaak zou ik toch even een her install overwegen.

Offline grizzler

  • Lid
  • Steunpunt: Nee
Re: ik krijg 10.04 niet geinstalleerd
« Reactie #12 Gepost op: 2011/02/26, 13:33:12 »
Hallo, ik wil 10.04 installeren op mijn PC op een nieuwe externe HD.
(momenteel draait 9.04 op een andere externe HD)
Telkens ik dit probeer vanaf de Livecd krijg ik na installatie, als ik wil opstarten::
Out of disk
grub rescue>_

In google vind ik dan allerlei mogelijke oorzaken en "probeer eens dit, probeer eens dat.."
Er staan nogal wat bugmeldingen open voor dit probleem:

https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/477430
https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/634639
https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/654821

Lijkt dus een bekend Grub2-probleem te zijn. :(

Offline wolfke

  • Lid
  • Steunpunt: Nee
Re: ik krijg 10.04 niet geinstalleerd
« Reactie #13 Gepost op: 2011/02/26, 14:15:45 »
In google vind ik dan allerlei mogelijke oorzaken en "probeer eens dit, probeer eens dat.."
https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/477430
https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/634639
https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/654821
Lijkt dus een bekend Grub2-probleem te zijn. :(
Oei, ik heb gisteren 10.04.02 gedownload, ik zal dan met deze versie eens proberen.
bedankt voor de info.
@coffeepad: ik had de install al 3x gedaan en nergens iets gezien over een vraag waar die bootloader moet geplaatst worden.
Ik zal nu nog eens extra geod opletten.
« Laatst bewerkt op: 2011/02/26, 14:19:56 door wolfke »

Offline wolfke

  • Lid
  • Steunpunt: Nee
Re: ik krijg 10.04 niet geinstalleerd
« Reactie #14 Gepost op: 2011/02/26, 20:19:50 »
De hele namiddag bezig geweest en uiteindelijk resultaat = niks!
Na heel wat geknoei met install-errors is mijn ervaring nu:
- de bootloader wordt goed geladen:
- ik heb mijn interne win-disk aangekoppeld viirdat ik installeerde en dan kreeg ik geen "out of disk";
- ik kon ubuntu 1x opstarten (duurt wel lang) en de updates installeren.
Na de herstart blijft hij vasthangen na het invoeren van mijn paswoord en 't is gedaan :-[ :-[
Na een tijdje kreeg ik write errors op mijn datapartitie.
Zou er iets niet in orde zijn met de specificaties van mijn partities?
hieronder scherm van Gparted
Of heeft iemand een ander idee? ik zie het niet meer zitten.
de externe HD is van hetzelfde merk(Lacie) als diegene waar ik nu reeds meer dan een jaar Ubunut op draaien heb.
« Laatst bewerkt op: 2011/02/26, 20:27:48 door wolfke »

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: ik krijg 10.04 niet geinstalleerd
« Reactie #15 Gepost op: 2011/02/26, 20:51:07 »
Disk utility van ubuntu starten en smart data kontroleren en volledige kontrolle doen van je hard disk.
Wat voor errors kreeg je?
Waarom gebruik je geen ext4, is sneller.

Offline wolfke

  • Lid
  • Steunpunt: Nee
Re: ik krijg 10.04 niet geinstalleerd
« Reactie #16 Gepost op: 2011/02/26, 21:08:41 »
Disk utility van ubuntu starten en smart data kontroleren en volledige kontrolle doen van je hard disk.
Wat voor errors kreeg je?
Waarom gebruik je geen ext4, is sneller.
-geen ext4: tijdens mijn opzoekingen ergens gelezen dat dit ook een probleem kon zijn;
  (ne mens probeert alles he)
- errors: ik dacht write errors maar ze verdwenen te snel van 't scherm.
- waar vind ik die diskutility ergens? en test die ook op logische fouten?

EDIT: ik heb nog eens geprobeerd. nadat ik even het ubuntu-scherm krijg komen er een massa fouten:

67 ........   ext3 fs error (device sdg5) ext3_find directory  ,,,,,,,,

Zou ik een  fsck /dev/sdg5 mogen uitvoeren vanaf een ander draaiend ubuntu-systeem?
(ik lees dat dit een gevaarlijk commando is)
« Laatst bewerkt op: 2011/02/26, 21:53:27 door wolfke »

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: ik krijg 10.04 niet geinstalleerd
« Reactie #17 Gepost op: 2011/02/27, 15:55:46 »
fsck kun je doen dmv opstarten van de livecd.
Dan via disc utility, of gparted, of via terminal. De eerste 2 is grafisch.
Wel de goede schijven pakken, omdat met de livecd de partities veranderen.

Offline wolfke

  • Lid
  • Steunpunt: Nee
Re: ik krijg 10.04 niet geinstalleerd
« Reactie #18 Gepost op: 2011/02/27, 16:22:14 »
fsck kun je doen dmv opstarten van de livecd.
Dan via disc utility, of gparted, of via terminal. De eerste 2 is grafisch.
Wel de goede schijven pakken, omdat met de livecd de partities veranderen.
ik heb daar deluvecd niet nodig: mijn 9.04 draait nog steeds onberispelijk en daar kan ik die HD met 1.04 op aansluiten.
Maar.. in gparted vind ik zo direct geen fsck-functie, of zie ik niet goed?
Kan me ook iemand zeggen wat momenteel de best(=stabielste) ubuntu release is die ik best installeer (als ik nog eens moet herbeginnen)

Offline wolfke

  • Lid
  • Steunpunt: Nee
Re: ik krijg 10.04 niet geinstalleerd
« Reactie #19 Gepost op: 2011/02/27, 19:51:36 »
partitie gecheckt met gparted en alles schjnbaar oke.
ik zal nog eens proberen op te starten.

EDIT: hopeloos, nu krijg ik alleen een zwart scherm.
Ik ga mijn externe HD eens testen door er een image van mijn 9.04 op te zetten.
« Laatst bewerkt op: 2011/02/27, 20:12:14 door wolfke »

Offline wolfke

  • Lid
  • Steunpunt: Nee
Re: ik krijg 10.04 niet geinstalleerd
« Reactie #20 Gepost op: 2011/02/28, 10:59:59 »
Ha, ik zie licht in de tunnel, al is het maar zwart licht.
Ik heb mijn bestaand systeem(op externe HD) met clonezilla overgezet naar die nieuwe externe HD en hiermee pĝestart en getest. Schijnbaar is daar een probleem van snelheid of misschien compatibiliteit met usb2, want dit systeem blokkeerde ook regelmatig

Ik stop dus met deze installatie totdat ik hiervoor een oplossing heb. (gezien de problemen die ik gehad heb; durf ik het niet aan om mijn bestaande 9.04 te overschrijven)
Iedereen al bedankt voor de hulp. I'll be back!  =D

Offline Coffeepad

  • Lid
  • Steunpunt: Nee
Re: [even in de ijskast] ik krijg 10.04 niet geinstalleerd
« Reactie #21 Gepost op: 2011/02/28, 16:05:49 »
Toch nog even een stomme vraag van mijn kant , gebruik je dezelfde usb poort als van de wel werkende usb schijf en installatie ?
Soms wil het nog weleens gebeuren dat een usb poort aan de voorkant van de comp bijvoorbeeld anders reageert dan die aan de achterkant , die aan de voorkant wordt namelijk dmv een kabeltje intern op een andere usb poort gezet.

Offline wolfke

  • Lid
  • Steunpunt: Nee
Re: [even in de ijskast] ik krijg 10.04 niet geinstalleerd
« Reactie #22 Gepost op: 2011/02/28, 18:23:49 »
Geen domme vraag hé: ik gebruikte de poort er juist onder (dus allebei aan de voorkant!
Ik zal mijn huidige (goed werkende) ubuntu-externe-HD eens aan die poort hangen om te zien.
De andere HD is ingepakt en gaat morgen terug naar de verkoper.
Het fenomeen was echt hetzelfde als met 10.04:
- na de imagecopie startte 9.04 heel traag op, maar als ik een .jpg wou openen blokkeerde hij;
- bij een volgende opstart kreeg ik ook die EXT3 fs-fouten zoals bij 10.04.
- volgende opstart -> zwart scherm en de partitie kon zelfs niet meer verwijderd worden met gparted.

Zoals ik al zei: deze schijf is voor USB3 en in kleine letters= compatibel voor usb2. ik denk dat het daar aan ligt.
Blijf ik wel wat zitten met de vraag: welke nu kopen????

Offline Coffeepad

  • Lid
  • Steunpunt: Nee
Re: [even in de ijskast] ik krijg 10.04 niet geinstalleerd
« Reactie #23 Gepost op: 2011/02/28, 22:39:02 »
Usb2 en Usb3 , geen idee hoe deze anders zouden moeten reageren ,ik denk dat er maar 1 oplossing is om daar achter te komen .... ervanuit gaan dat ze beide Sata of juist ide zijn , gewoon even de schroevendraaier pakken en de schijven wisselen van case ;-)  zoals een echte Tweaker zou doen.

Maar ik ben zeer benieuwd naar de afloop van deze zaak.

Offline wolfke

  • Lid
  • Steunpunt: Nee
Re: [even in de ijskast] ik krijg 10.04 niet geinstalleerd
« Reactie #24 Gepost op: 2011/03/01, 17:12:46 »
haha; ik ben de schijf gaan omruilen naar een externe HD die alleen voor USB2 dient en momenteel typ ik dit van op mijn 9.04 die draait op die schijf.
Ik ben dus vol hoop op de installatie van 10.04; maar eerst nog even verder testen.