Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu wil niet opstarten zonder externe harde schijf  (gelezen 3428 keer)

Offline Selma

  • Lid
  • Steunpunt: Nee
Ubuntu wil niet opstarten zonder externe harde schijf
« Gepost op: 2011/02/22, 09:35:06 »
Sinds een maandje ben ik een bijzonder tevreden gebruiken van Ubuntu. Ik heb alleen een klein problemen. Het opstarten gaat niet zonder aanwezigheid van de externe harde schijf.

Als ik mijn computer aan zet zonder harde schijf, dan kan ik wel kiezen of ik windows of ubuntu wil draaien en vervolgens kan ik ook uit een ander lijstje kiezen (met een aantal getallen met daarachter generic). Maar daarna gaat het mis. Ik krijg dan een mededeling met daarin /dev/sdb1 is missing. Dropping to a shell!

Voor zover ik mij kan herinneren heb ik ubuntu niet op mijn externe harde schijf gezet, maar op de c-schijf. Verder kan ik nadat ubuntu is opgestart, de externe harde schijf ook zonder problemen uitzetten. Ubuntu blijft dan gewoon draaien.

Ik heb zelf geen enkel verstand van computers (was al erg tevreden dat ik alle drivers kon installeren dmv sudo-commands), dus het kan best dat jullie meer info nodig hebben om mijn probleem op te lossen. Vraag daar dan maar naar, ik zal kijken of ik die kan proberen te geven.

Verder hoop ik echt dat dit opgelost kan worden zonder het opnieuw installeren van ubuntu, ik heb namelijk erg veel moeite gedaan om alle drivers te installeren, en heb geen zin om dat nog een keer te doen. Verder ben ik bezig met mijn scriptie en wil ik mijn laptop ook zonder externe harde schijf mee kunnen nemen en toch overal op ubuntu kunnen werken.
« Laatst bewerkt op: 2011/02/22, 09:40:31 door Selma »

Offline grizzler

  • Lid
  • Steunpunt: Nee
Re: Ubuntu wil niet opstarten zonder externe harde schijf
« Reactie #1 Gepost op: 2011/02/22, 11:59:52 »
Als ik mijn computer aan zet zonder harde schijf, dan kan ik wel kiezen of ik windows of ubuntu wil draaien en vervolgens kan ik ook uit een ander lijstje kiezen (met een aantal getallen met daarachter generic). Maar daarna gaat het mis. Ik krijg dan een mededeling met daarin /dev/sdb1 is missing. Dropping to a shell!
Kan zijn dat die schijf aan stond bij het installeren van Ubuntu. Blijkbaar wordt hij als een vast onderdeel van je systeem beschouwd, maar dat is voor een externe schijf niet nodig. Hoe heb je Ubuntu precies geïnstalleerd? Binnen Windows (wubi-installatie) of op een aparte partitie?

Misschien kan je ook even laten zien wat er in je fstab staat (start de Tekstbewerker en open het bestand /etc/fstab, kopiëer alles en plak het in je bericht, selecteer dan in je bericht wat je net hebt geplakt en klik op het #-icoontje om de tekst tussen code-tags te zetten).

Offline rja

  • Lid
  • Steunpunt: Nee
Re: Ubuntu wil niet opstarten zonder externe harde schijf
« Reactie #2 Gepost op: 2011/02/22, 13:54:54 »
De output van sudo fdisk -l in een terminal is ook wel handig.


Offline Selma

  • Lid
  • Steunpunt: Nee
Re: Ubuntu wil niet opstarten zonder externe harde schijf
« Reactie #3 Gepost op: 2011/02/22, 20:56:31 »
Als ik mijn computer aan zet zonder harde schijf, dan kan ik wel kiezen of ik windows of ubuntu wil draaien en vervolgens kan ik ook uit een ander lijstje kiezen (met een aantal getallen met daarachter generic). Maar daarna gaat het mis. Ik krijg dan een mededeling met daarin /dev/sdb1 is missing. Dropping to a shell!
Kan zijn dat die schijf aan stond bij het installeren van Ubuntu. Blijkbaar wordt hij als een vast onderdeel van je systeem beschouwd, maar dat is voor een externe schijf niet nodig. Hoe heb je Ubuntu precies geïnstalleerd? Binnen Windows (wubi-installatie) of op een aparte partitie?

Misschien kan je ook even laten zien wat er in je fstab staat (start de Tekstbewerker en open het bestand /etc/fstab, kopiëer alles en plak het in je bericht, selecteer dan in je bericht wat je net hebt geplakt en klik op het #-icoontje om de tekst tussen code-tags te zetten).


Ik heb ubuntu binnen windows geïnstalleerd. Ik heb inderdaad het vermoeden dat mijn externe harde schijf aan stond bij het installeren.
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# Commented out by Dropbox
# /host/ubuntu/disks/root.disk /               ext4    loop,errors=remount-ro 0       1
/host/ubuntu/disks/swap.disk none            swap    loop,sw         0       0
/host/ubuntu/disks/root.disk / ext4 loop,errors=remount-ro,user_xattr 0 1


Offline Selma

  • Lid
  • Steunpunt: Nee
Re: Ubuntu wil niet opstarten zonder externe harde schijf
« Reactie #4 Gepost op: 2011/02/22, 21:00:25 »
Allereerst welkom op ons forum.
Verder eerst even een vraag aan jou, want ik lees dat je heel erg veel moeite heb tmoeten doen om drivers te installeren. Dan vraag ik mij af welke dat zijn, want in feite hoef je in Ubuntu geen drivers te installeren, behalve dan de stuurprogramma's voor je grafische kaart, maar die worden zelf aangegeven. Dus dat kan het ook niet zijn.

Omdat je de externe HD waarschijnlijk loskoppelt elke keer, maar in je configuratie de schijf automatisch wordt aangekoppeld, kan hij dus bij opstarten die externe HD niet vinden, dat is de sdb1 dus.
Je andere schijven zijn sda.
Mijn advies, laat die externe HD aan je pc zitten en koppel hem niet af.
Als er een aan en uitknop op zit, gebruik je die en anders sluit je hem aan op hetzelfde stekkerblok met een aan en uitknop erop. Zo doe ik dat hier ook en dan start alles tegelijk op.



Ik moest drivers voor m'n printer installeren (Brother DCP-195c)... hij kan nu wel printen, maar nog steeds niet scannen helaas (dat is dus nog steeds niet gelukt :( ).

Wat betreft de externe HD, ik zou heel graag mijn laptop mee willen nemen zonder externe HD. Ik werk namelijk dus aan mijn scriptie en vind het wel prettig om ook op andere plekken te kunnen schrijven en die HD is zo zwaar en groot om mee te nemen.

Offline Selma

  • Lid
  • Steunpunt: Nee
Re: Ubuntu wil niet opstarten zonder externe harde schijf
« Reactie #5 Gepost op: 2011/02/22, 21:03:05 »
De output van sudo fdisk -l in een terminal is ook wel handig.


Schijf /dev/sda: 1000.2 GB, 1000204886016 bytes
255 koppen, 63 sectoren/spoor, 121601 cilinders
Eenheid = cilinders van 16065 * 512 = 8225280 bytes
Sectorgrootte (logischl/fysiek): 512 bytes / 512 bytes
in-/uitvoergrootte (minimaal/optimaal): 512 bytes / 512 bytes
Schijf-ID: 0x3ce8f10a

 Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sda1               1      121602   976759808    7  HPFS/NTFS

Schijf /dev/sdb: 120.0 GB, 120034123776 bytes
255 koppen, 63 sectoren/spoor, 14593 cilinders
Eenheid = cilinders van 16065 * 512 = 8225280 bytes
Sectorgrootte (logischl/fysiek): 512 bytes / 512 bytes
in-/uitvoergrootte (minimaal/optimaal): 512 bytes / 512 bytes
Schijf-ID: 0xd14a4375

 Apparaat Opstart   Begin       Einde     Blokken   ID  Systeem
/dev/sdb1   *           1       13693   109988991    7  HPFS/NTFS
/dev/sdb2           13694       14593     7229250    7  HPFS/NTFS

Offline Selma

  • Lid
  • Steunpunt: Nee
Re: Ubuntu wil niet opstarten zonder externe harde schijf
« Reactie #6 Gepost op: 2011/02/22, 21:04:05 »
Oh en bedankt trouwens dat jullie mijn probleem zo serieus nemen en op een voor mij te begrijpen manier uitleggen wat ik moet doen ;-) . Heb op andere forums wel eens anders meegemaakt.

Offline grizzler

  • Lid
  • Steunpunt: Nee
Re: Ubuntu wil niet opstarten zonder externe harde schijf
« Reactie #7 Gepost op: 2011/02/22, 21:58:27 »
De uitvoer van fdisk -l roept bij mij een volgende vraag op: welke van de twee schijven is de externe? Ik zie er een van 1TB (/dev/sda) en een van 120GB (/dev/sdb).

Aangezien die van 120GB de opstartvlag heeft, neem ik aan dat dát de interne is. Ik zou verwachten dat die als sda zou worden aangemerkt. Waarschijnlijk gebeurt dat ook als de externe schijf niet is aangesloten en dat veroorzaakt dan de verwarring.

Mogelijk is in het BIOS van je computer in te stellen in welke volgorde de aanwezige schijven moeten worden 'gezien'. Of je dan van alle problemen af bent, is nog maar de vraag. Het zou kunnen dat bij het installeren toch nog 'iets' van de bootloader (GRUB) op de externe schijf terecht is gekomen. Ik kan me dat eigenlijk niet voorstellen, maar ik heb geen (recente) ervaring met wubi-installaties, dus ik durf er geen harde uitspraak over te doen. :(
« Laatst bewerkt op: 2011/02/22, 22:21:06 door grizzler »

Offline Selma

  • Lid
  • Steunpunt: Nee
Re: Ubuntu wil niet opstarten zonder externe harde schijf
« Reactie #8 Gepost op: 2011/02/22, 22:21:33 »
De uitvoer van fdisk -l roept bij mij een volgende vraag op: welke van de twee schijven is de externe? Ik zie er een van 1TB (/dev/sda) en een van 120GB (/dev/sdb).

Aangezien die van 120GB de opstartvlag heeft, neem ik aan dat dát de interne is. Ik zou verwachten dat die als sda zou worden aangemerkt. Waarschijnlijk gebeurt dat ook als de externe schijf niet is aangesloten en dat veroorzaakt dan de verwarring.

Mogelijk is in het BIOS van je computer in te stellen in welke volgorde de aanwezige schijven moeten worden 'gezien'. Of je dan van alle problemen af bent, is nog maar de vraag. Het zou kunnen dat bij het installeren toch nog 'iets' van de bootloader (GRUB) op de externe schijf terecht is gekomen. Ik kan me dat eigenlijk niet voorstellen, maar ik heb geen ervaring met wubi-installaties, dus ik durf er geen harde uitspraak over te doen. :(

Die van 1TB is de externe, en van 120GB de interne.

Offline grizzler

  • Lid
  • Steunpunt: Nee
Re: Ubuntu wil niet opstarten zonder externe harde schijf
« Reactie #9 Gepost op: 2011/02/22, 22:41:46 »
Die van 1TB is de externe, en van 120GB de interne.
Dan is het in ieder geval zaak om ervoor te zorgen dat die interne altijd als hetzelde device wordt gezien en niet soms als /dev/sda dan weer als /dev/sdb (als de externe is aangesloten). De enige plek om dat te wijzigen die ik kan bedenken, is het BIOS. Hoe je dat precies moet doen kan ik je helaas niet eenduidig uitleggen. Alleen al de manier om in het BIOS te komen verschilt vaak per computer (meestal door tijdens het opstarten op een functietoets te drukken - de laatste keer dat ik dat ergens nodig had, was het F2).

Het feit dat GRUB tijdens het opstarten per se sdb wil zien, lijkt erop te wijzen dat er 'ergens' een verwijzing naar die schijfaanduiding staat. Die zal dan ook - en eerst - moeten worden gewijzigd, anders wordt het probleem alleen maar erger.
Als dit een normale installatie op een aparte partitie was geweest, zou ik verwachten dat het bestand grub.cfg (of menu.lst bij oudere installaties) in /boot/grub daar duidelijkheid over zou verschaffen. Ik heb geen idee in hoeverre een wubi-installatie op dat punt afwijkt.

Kan je eens kijken of dat bestand bestaat en zo ja, laten zien wat er in staat?
« Laatst bewerkt op: 2011/02/22, 22:52:10 door grizzler »

Offline Selma

  • Lid
  • Steunpunt: Nee
Re: Ubuntu wil niet opstarten zonder externe harde schijf
« Reactie #10 Gepost op: 2011/02/23, 19:12:52 »
Die van 1TB is de externe, en van 120GB de interne.
Dan is het in ieder geval zaak om ervoor te zorgen dat die interne altijd als hetzelde device wordt gezien en niet soms als /dev/sda dan weer als /dev/sdb (als de externe is aangesloten). De enige plek om dat te wijzigen die ik kan bedenken, is het BIOS. Hoe je dat precies moet doen kan ik je helaas niet eenduidig uitleggen. Alleen al de manier om in het BIOS te komen verschilt vaak per computer (meestal door tijdens het opstarten op een functietoets te drukken - de laatste keer dat ik dat ergens nodig had, was het F2).

Het feit dat GRUB tijdens het opstarten per se sdb wil zien, lijkt erop te wijzen dat er 'ergens' een verwijzing naar die schijfaanduiding staat. Die zal dan ook - en eerst - moeten worden gewijzigd, anders wordt het probleem alleen maar erger.
Als dit een normale installatie op een aparte partitie was geweest, zou ik verwachten dat het bestand grub.cfg (of menu.lst bij oudere installaties) in /boot/grub daar duidelijkheid over zou verschaffen. Ik heb geen idee in hoeverre een wubi-installatie op dat punt afwijkt.

Kan je eens kijken of dat bestand bestaat en zo ja, laten zien wat er in staat?

Ja, dat bestand bestaat:
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
set default="0"
if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}

function load_video {
}

if [ "${recordfail}" = 1 ]; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/10_lupin ###
menuentry "Ubuntu, Linux 2.6.35-25-generic" {
insmod part_msdos
insmod ntfs
set root='(hd1,msdos1)'
search --no-floppy --fs-uuid --set 78ea0bbf0b1a7518
loopback loop0 /ubuntu/disks/root.disk
set root=(loop0)
linux /boot/vmlinuz-2.6.35-25-generic root=/dev/sdb1 loop=/ubuntu/disks/root.disk ro   quiet splash
initrd /boot/initrd.img-2.6.35-25-generic
}
menuentry "Ubuntu, Linux 2.6.35-25-generic (recovery mode)" {
insmod part_msdos
insmod ntfs
set root='(hd1,msdos1)'
search --no-floppy --fs-uuid --set 78ea0bbf0b1a7518
loopback loop0 /ubuntu/disks/root.disk
set root=(loop0)
linux /boot/vmlinuz-2.6.35-25-generic root=/dev/sdb1 loop=/ubuntu/disks/root.disk ro single
initrd /boot/initrd.img-2.6.35-25-generic
}
menuentry "Ubuntu, Linux 2.6.35-22-generic" {
insmod part_msdos
insmod ntfs
set root='(hd1,msdos1)'
search --no-floppy --fs-uuid --set 78ea0bbf0b1a7518
loopback loop0 /ubuntu/disks/root.disk
set root=(loop0)
linux /boot/vmlinuz-2.6.35-22-generic root=/dev/sdb1 loop=/ubuntu/disks/root.disk ro   quiet splash
initrd /boot/initrd.img-2.6.35-22-generic
}
menuentry "Ubuntu, Linux 2.6.35-22-generic (recovery mode)" {
insmod part_msdos
insmod ntfs
set root='(hd1,msdos1)'
search --no-floppy --fs-uuid --set 78ea0bbf0b1a7518
loopback loop0 /ubuntu/disks/root.disk
set root=(loop0)
linux /boot/vmlinuz-2.6.35-22-generic root=/dev/sdb1 loop=/ubuntu/disks/root.disk ro single
initrd /boot/initrd.img-2.6.35-22-generic
}
### END /etc/grub.d/10_lupin ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Windows Vista (loader) (on /dev/sdb1)" {
insmod part_msdos
insmod ntfs
set root='(hd1,msdos1)'
search --no-floppy --fs-uuid --set 78ea0bbf0b1a7518
chainloader +1
}
menuentry "Windows Vista (loader) (on /dev/sdb2)" {
insmod part_msdos
insmod ntfs
set root='(hd1,msdos2)'
search --no-floppy --fs-uuid --set 2c88743c8874071c
chainloader +1
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###

Offline grizzler

  • Lid
  • Steunpunt: Nee
Re: Ubuntu wil niet opstarten zonder externe harde schijf
« Reactie #11 Gepost op: 2011/02/23, 20:24:13 »
Ja, dat bestand bestaat:
Als ik dat zo zie, is me nu wel duidelijk hoe dit probleem precies is ontstaan. Het komt inderdaad door de volgorde waarin Ubuntu die schijven ziet. Als de externe aan staat, wordt die /dev/sda en de interne /dev/sdb (respectievelijk hd0 en hd1 voor de bootloader). Staat de externe uit, dan wordt de interne /dev/sda (hd0) en is /dev/sdb (hd1) niet te vinden.

Om dit probleem permanent op te lossen, zul je toch iets moeten vinden om die volgorde 'vast te zetten'. Kan zijn dat je dat in het BIOS kunt instellen, maar daar kan ik je zoals gezegd geen eenduidig advies over geven. Als je het merk en de type-aanduiding van je computer vermeldt, kan iemand anders daar misschien meer over zeggen.

Los daarvan moet je ook de bootloader (GRUB) er nog van zien te overtuigen dat /dev/sda (hd0) echt de beste keuze is. Dat moet zelfs eerst, want als je alleen de volgorde in het BIOS aanpast, krijg je Ubuntu helemaal niet meer gestart.
Helaas is dit de nieuwe GRUB. In de oude versie is een en ander vrij makkelijk handmatig in te stellen. De nieuwe bepaalt bij elke serieuze wijziging (zoals de installatie van een nieuwe kernel) van alles zelf. Handmatig aangebrachte wijzigingen aan grub.cfg gaan dan verloren. Desondanks denk ik dat deze situatie om handmatige aanpassingen vraagt, ook al zijn die uiteindelijk tijdelijk.

Je zou allereerst eens kunnen proberen met een handmatig toegevoegde entry in grub.cfg op te starten, zonder dat de externe schijf is aangesloten. Als dat werkt, kan je met sudo update-grub het tijdelijk gewijzigde configuratiebestand weer herstellen.

Even tussendoor aan meelezende wubi- en GRUB-deskundigen: grijp vooral in als jullie denken dat ik op het verkeerde spoor zit. Ik kan dit niet zelf uittesten omdat ik geen wubi-installatie heb en (om hier niet terzake doende redenen) legacy GRUB gebruik.

Selma, het is denk ik verstandig onderstaande handelingen pas uit te voeren als anderen de kans hebben gehad commentaar te leveren.

Je zult uiteraard moeten beginnen met de externe schijf aan.

Waarschijnlijk staat grub.cfg als 'read-only' op je systeem. Wil je iets kunnen aanpassen, dan zul je dat eerst moeten wijzigen. Start daarvoor Nautilus met rootrechten, door op Alt+F2 te drukken en in het venstertje dat dan opent de opdracht
gksudo nautilus /boot/grub
in te voeren (waarschijnlijk volgt dan een wachtwoordprompt).

Als het goed is, kom je gelijk in de juiste map terecht. Klik met rechts op grub.cfg en kies Eigenschappen. Ga naar de Rechten-tab en zorg ervoor dat voor de Eigenaar de toegang op Lezen en schrijven staat. Sluit Eigenschappen en dubbelklik in het Nautilusvenster op grub.cfg. Het bestand zou dan in de tekstbewerker moeten verschijnen. Er mag geen [Alleen-lezen] in de titel van dat venster staan. Staat dat er wel, open grub.cfg dan opnieuw via Alt+F2 gevolgd door
gksudo gedit /boot/grub/grub.cfg

Zoek in grub.cfg naar de regel ### END /etc/grub.d/10_lupin ### en plaats daar direct voor het volgende stuk tekst:
menuentry "Opstarten via sda1" {
insmod part_msdos
insmod ntfs
set root='(hd0,msdos1)'
search --no-floppy --fs-uuid --set 78ea0bbf0b1a7518
loopback loop0 /ubuntu/disks/root.disk
set root=(loop0)
linux /boot/vmlinuz-2.6.35-25-generic root=/dev/sda1 loop=/ubuntu/disks/root.disk ro   quiet splash
initrd /boot/initrd.img-2.6.35-25-generic
}
Let erop dat dit compleet overkomt, met alle haakjes/accolades op de juiste plaats, en precies voor het einde van het 10_lupin-blok staat.

Sla grub.cfg op en herstart je computer. Je externe schijf moet nu UIT staan!

Als je in het GRUB-menu komt, zie je de extra entry Opstarten via sda1.
Selecteer die. Als Ubuntu correct start, open dan een terminal en geef de opdracht
sudo update-grub
Dit zorgt ervoor dat grub.cfg weer helemaal volgens de regeltjes is opgebouwd, maar nu overal met een verwijzing naar de juiste schijf. Controleer dat in de tekstbewerker. De regels die met set root='(hd beginnen, moeten verwijzen naar hd0 en in de linux-regels moet root=/dev/sda1 staan, net als in de tijdelijk toegevoegde entry.

Gaat het opstarten met de extra entry niet goed, dan kan je altijd nog de ongewijzigde 'normale' opstart gebruiken (met de externe schijf aan).

Is een en ander wel gelukt, dan zul je - in ieder geval zolang het BIOS niet is aangepast - dus wel altijd moeten starten met de externe schijf UIT.


Offline Selma

  • Lid
  • Steunpunt: Nee
Re: Ubuntu wil niet opstarten zonder externe harde schijf
« Reactie #12 Gepost op: 2011/02/24, 10:39:21 »
Bedankt Grizzler!

Ik hoop dat er nog wat meer mensen raad kunnen geven! Ik zou het zo fijn vinden om mijn laptop ergens anders mee naar toe te kunnen nemen om op ubuntu aan mijn scriptie te kunnen werken.

Offline grizzler

  • Lid
  • Steunpunt: Nee
Re: Ubuntu wil niet opstarten zonder externe harde schijf
« Reactie #13 Gepost op: 2011/02/24, 20:22:18 »
Nog even een aanvulling, niet zozeer met betrekking tot 'het' probleem, maar meer over wubi-installaties in het algemeen.

Als je dat nog niet hebt gedaan, zou je er goed aan doen om deze (Engelstalige) pagina eens door te lezen: https://wiki.ubuntu.com/WubiGuide. Ook dit: http://ubuntuforums.org/showthread.php?t=1639198 en dan vooral de paragraaf die met FIXED! begint. Dat locken van die grub-packages zou ik zeker doen als ik jou was.

Iets om over na te denken is de opmerking in de ubuntuforums-thread:
"However, Wubi was never intended as anything other than a means to try a Linux operating system and, as such, it is usually recommended to install Ubuntu to a dedicated partition on the hard-drive."

Geen slecht advies...