Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Quick & Dirty installatie QB64 [ongeveer gelijk aan Q(uick)Basic]  (gelezen 1408 keer)

Offline Theo1971

  • Lid
  • Steunpunt: Nee
Regelmatig wordt er gevraagd naar een eenvoudige programmeertaal om te beginnen.
De één is nieuw met het onderwerp, de ander deed het vroeger op een homecomputer.
Misschien is het een 'open deur', maar voor anderen wellicht bruikbaar.

Een poos terug toen de pc's nog geleverd werden met DOS was er een BASIC bijgeleverd met de naam Qbasic. Een uitgebreidere versie (QuickBasic) kon men kopen. Het grote voordeel was dat men met QuickBasic kon compilen, Qbasic was alleen een interpreter.

Nu bestaat er voor Linux een variant die veel op QuickBasic lijkt, genaamd QB64 (te verkrijgen in een 32- en 64 bits versie). De listings (en dat zijn er nogal veel) die draaien op Q(uick)Basic werken veelal ook op QB64.

Genoeg gekletst denk ik, en nu naar de ingredïentenlijst :)
Ik ben van de 32bits versie uitgegaan, omdat ik geen 64 bits ubuntu draai.

Allereerst ben je de g++ compiler nodig, weet je niet of je deze hebt kijk dan even met synaptic. Ontbreekt deze, dan moet je deze aanvinken om te installeren.
Omdat we daar toch al zijn kijken we direct of de benodigde sdl pakketjes geïnstalleerd zijn, zo niet dan nemen we deze direct mee.
Zelf draai ik 10.10 (en weet niet of er verschil is met iets oudere versies)
Wel zijn de versies 1.2 (en/of hoger nodig)

libsdl1.2-dev
libsdl-net1.2-dev
libsdl-ttf2.0-dev
libsdl-image2.0-dev
libsdl-mixer1.2-dev
timidity (alleen voor het afspelen van MIDIfiles)

Bij de eerste van dit lijstje wil hij een paar extra pakketjes installeren, in dit geval geef ik hem maar gelijk. Wanneer hij daar klaar mee is, kun je QB64 downloaden. Deze kun je hier vinden.

Wanneer je deze uitgepakt en netjes in een map geplaatst hebt, kun je de script 'setup.sh' uitvoeren (uiteraard in een terminalvenster, we willen geen informatie missen).
Hij zal ongetwijfeld vragen of je de benodigde bestanden op je computer hebt en na een poosje krijg je een blauw venstertje waar je naar hartenlust in kunt uitleven.

Tot slot nog even dit.
Natuurlijk is dit niet toereikend om super 3d first person shooters te maken. Maar eenvoudige platform-spellen of andere hobby-dingetjes kan met gemak. Combineer je dit met bijvoorbeeld scriptfiles, dan is het volgens mij relatief eenvoudig om bijvoorbeeld een eenvoudige twitterclient te maken.

Veel succes!


Ryzen 7 1700 16gb, RX 580 8gb, AOC 24" FreeSync scherm,  Corsair Strafe Red (mechanisch toetsenbord), 256GB SSD, 4 TB HDD. OS: Linux Mint