Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Archlinux xorg.conf nvidia-xserver  (gelezen 1815 keer)

Offline kehabouter

  • Lid
  • Steunpunt: Nee
Archlinux xorg.conf nvidia-xserver
« Gepost op: 2011/02/07, 10:33:10 »
hallo allemaal,

ik heb wat problemen met mijn nvidia x server.
ik ben onlangs begonnen aan archlinux, ik heb nu de nvidia driver geinstalleerd alleen hji herkent mijn scherm niet.
ik heb namelijk een wat ouder TFT analoog scherm.
Ik krijg mijn settings dus niet hoger als 640x480 op UNKNOWN SCREEN

ik zou waarschijnlijk /etc/X11/xorg.conf moeten aanpassen, maar wat moet ik toevoegen?

of is er een andere mogelijkheid?

xrandr geeft me deze fout

xrandr: Failed to get size of gamma for output default
xrandr: screen cannot be larger than 640x480 (desired size 1280x1024)
[kevin@Archlinux ~]$

mijn /etc/X11/xorg.conf


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 260.19.36  (buildmeister@swio-display-x86-rhel47-06.nvidia.com)  Tue Jan 18 17:31:27 PST 2011

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 260.19.36  (buildmeister@swio-display-x86-rhel47-06.nvidia.com)  Tue Jan 18 17:31:39 PST 2011

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
   DisplaySize    338 270
    ModelName      "CRT-1"
    HorizSync       28.0 - 33.0
    VertRefresh     50
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8600 GS"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    Option         "TwinView" "0"
    Option         "metamodes" "1024x768_50"
    SubSection     "Display"
        Depth       24
        Modes      "1024x768" "800x640" "640x480"
    EndSubSection
EndSection

ik krijg m gewoon niet hoger dan 640x480  :-@

// edit

ik heb een sectie toegevoegd aan deze file ^
nu heb ik 800x600

op naar de volgende stap! (1280x1024)

gr
« Laatst bewerkt op: 2011/02/07, 12:15:49 door kehabouter »

Offline Ramana

  • Lid
  • Steunpunt: Nee
Re: Archlinux xorg.conf nvidia-xserver
« Reactie #1 Gepost op: 2011/02/07, 17:18:29 »
probeer eens in een console (als root) : nvidia-xconfig

Offline TopGear

  • Forumteam
  • Steunpunt: Nee
Re: Archlinux xorg.conf nvidia-xserver
« Reactie #2 Gepost op: 2011/02/07, 20:08:10 »
Wordt dat dan niet sudo nvidia-xconfig ? Of zit ik fout?

Offline Ramana

  • Lid
  • Steunpunt: Nee
Re: Archlinux xorg.conf nvidia-xserver
« Reactie #3 Gepost op: 2011/02/09, 17:52:20 »
Ja, als je sudo hebt geinstalleerd.

anders gewoon su (& wachtwoord)...