Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: amsn microfoon  (gelezen 942 keer)

Offline Willemtk

  • Lid
  • Steunpunt: Nee
amsn microfoon
« Gepost op: 2011/02/05, 13:30:08 »
Ik probeer onder amsn met geluid te werken, maar kennelijk heeft microsoft een ander protocol ingevoerd waardoor geluid niet meer werkt op amsn. Weet iemand een alternatief? En niet skype, ik vraag het niet voor mezelf. Het is voor iemand die familie heeft in Turkije, en kennelijk werkt geluid daar met msn goed, en met skype niet. Dus meneer is niet gered met skype. Het moet msn zijn. Alvast bedankt

Groentjes,
Willem
« Laatst bewerkt op: 2011/02/05, 13:37:38 door Willemtk »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: amsn microfoon
« Reactie #1 Gepost op: 2011/02/05, 18:52:16 »
Even wat vragen:
Welke versie van Ubuntu?
32 bits of 64 bits.
Werkt de microfoon wel in andere programma's?
Welk geluidsysteem gebruik je, PulseAudio of ALSA?
Wat heb je al uit geprobeerd?
In der Beschränkung zeigt sich der Meister.

Offline Willemtk

  • Lid
  • Steunpunt: Nee
Re: amsn microfoon
« Reactie #2 Gepost op: 2011/02/05, 21:34:03 »
Even wat vragen:
Welke versie van Ubuntu?
32 bits of 64 bits.
Werkt de microfoon wel in andere programma's?
Welk geluidsysteem gebruik je, PulseAudio of ALSA?
Wat heb je al uit geprobeerd?

10,04 , 32 bit, ALSA. Maar ik krijg dat microsoft het protocol nog eens heeft veranderd en dus video/ audio niet werkt, zie bijlage. Nu werkt de cam wel, dus ik begrijp het niet goed. Of begrijp ik de boodschap verkeerd?  En als ik de boodschap verkeerd begrepen heb, hoe doe ik de micro in amsn dan wel werken? Hoe stel ik het af? In de skype en de linphone werkt de microfoon prima.
« Laatst bewerkt op: 2011/02/05, 21:36:48 door Willemtk »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: amsn microfoon
« Reactie #3 Gepost op: 2011/02/05, 22:52:42 »
Kijk hier eens http://www.amsn-project.net/wiki/Farsight#Linux of alle benodide pakketten zijn geïnstalleerd.
In der Beschränkung zeigt sich der Meister.

Offline Willemtk

  • Lid
  • Steunpunt: Nee
Re: amsn microfoon
« Reactie #4 Gepost op: 2011/02/07, 19:04:43 »
Kijk hier eens http://www.amsn-project.net/wiki/Farsight#Linux of alle benodide pakketten zijn geïnstalleerd.

Die kan ik inderdaad nergens vinden. Niet in de synaptic, nergens. En op internet staan hier en daar wel download mogelijkheden, maar allemaal tar bestanden, geen deb. Nou, daar kom ik dus niet uit. Voor mij hoeven die dingen allemaal niet, maar als ik niet op een simpele manier iets kan werkend krijgen dat op windows bijzonder vanzelfsprekend werkt, gewoon even simpel downloaden en laten uitvoeren, kan ik nog zoveel moeite doen als ik wil, maar ik ga iemand dan niet kunnen overtuigen over te stappen op ubuntu. Ik weet wel dat windows tegen werkt en dat het niet aan Ubuntu ligt. Maar een nieuweling gaat toch zeggen, Ubuntu werkt niet. Want wat ik normaal gebruik werkt niet op Ubuntu. Dus Ubuntu is maar niks. Zo simpel ligt het. Ik heb er ondertussen ervaring mee. Windows is beter zeggen ze dan, want daar werkt het wel op. Tja.........

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: amsn microfoon
« Reactie #5 Gepost op: 2011/02/07, 19:33:19 »
Voor de meeste hardware drivers worden voor Windows gemaakt, logisch uit commercieel oogpunt, Windows wordt het meest verkocht.
Helaas zal je daarom wat meer moeite doen om onder Ubuntu, of welke Linux distributie dan ook, om de hardware aan de gang te krijgen.
En iemand overtuigen om over te stappen hoef je ook niet te doen, dat werkt alleen maar averechts. Als iemand er aan toe is stapt diegene vanzelf wel over. Dus met een beetje inspanning, Linux steekt nou eenmaal anders in elkaar, krijg je een solider systeem dan Windows.
Zeg maar wat je wilt, een uitleg over een tar installeren of wil je ermee stoppen, aan jou de keuze. :)
In der Beschränkung zeigt sich der Meister.

Offline Willemtk

  • Lid
  • Steunpunt: Nee
Re: amsn microfoon
« Reactie #6 Gepost op: 2011/02/08, 12:51:40 »
Voor de meeste hardware drivers worden voor Windows gemaakt, logisch uit commercieel oogpunt, Windows wordt het meest verkocht.
Helaas zal je daarom wat meer moeite doen om onder Ubuntu, of welke Linux distributie dan ook, om de hardware aan de gang te krijgen.
En iemand overtuigen om over te stappen hoef je ook niet te doen, dat werkt alleen maar averechts. Als iemand er aan toe is stapt diegene vanzelf wel over. Dus met een beetje inspanning, Linux steekt nou eenmaal anders in elkaar, krijg je een solider systeem dan Windows.
Zeg maar wat je wilt, een uitleg over een tar installeren of wil je ermee stoppen, aan jou de keuze. :)

OK, uitleg over tar. Ik probeer dat al zolang te begrijpen, maar het lijkt er op dat er verschillende manieren zijn om het te laten werken. Dus begin er maar aan. Maar denk aan mij als een hopeloos geval. Dus hou het simpel

alcmaer

  • Gast
Re: amsn microfoon
« Reactie #7 Gepost op: 2011/02/08, 19:49:41 »
Om even op de oorspronkelijke vraag te antwoorden, aMSN ondersteunt op dit moment geen audio/video, getuige het onderstaand bericht op http://www.amsn-project.net/ bij de lancering van aMSN 0.98.4:

December 08, 2010
Hello everyone,
aMSN 0.98.4 is out, in the spirit of the holiday season! It contains several bugfixes, including the bug which made you unable to read Offline Messages.
This should be our last bugfix release before 0.99, in which we will enable Audio/Video calls again, as we’ve been working hard on implementing the newest P2P protocol changes.


Voorzover ik weet hebben ook andere (multi-)chatprogramma's geen werkende audio/video voor MSN.
Het wachten is dus op aMSN 0.99.
« Laatst bewerkt op: 2011/02/08, 19:58:23 door alcmaer »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: amsn microfoon
« Reactie #8 Gepost op: 2011/02/08, 21:03:01 »
Dan dit:
The Farsight project is an effort to create a framework to deal with all
known audio/video conferencing protocols. On one side it offers a generic
API that makes it possible to write plugins for different streaming
protocols, on the other side it offers an API for clients to use those
plugins.
This package provides Python bindings for Farsight 2.

@Willemtk
Hoezo hopeloos geval, ik ben ook niet met die kennis geboren. ;)
Ik heb nog wat documentatie materiaal door gelezen.

Kijk eerst eens of de volgende pakketten zijn geïnstalleerd in Synaptic.
libgstfarsight0.10-0 libtelepathy-farsight0 python-farsight
Of via de terminal(onder hulpmiddelen) type:
sudo apt-get install libgstfarsight0.10-0 libtelepathy-farsight0 python-farsight Na een ENTER moet je het wachtwoord invullen, hier zie je niets van, geen sterretjes, balletjes, o.i.d. Gewoon blind intypen en geef een ENTER.
Is het al geïnstalleerd zie je dit:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
De status informatie wordt gelezen... Klaar
libgstfarsight0.10-0 is reeds de nieuwste versie.
libtelepathy-farsight0 is reeds de nieuwste versie.
python-farsight is reeds de nieuwste versie.
0 pakketten opgewaardeerd, 0 pakketten nieuw geïnstalleerd, 0 te verwijderen en 0 niet opgewaardeerd.
Als dit niet het geval is, zijn de pakketten geïnstalleerd, start nu de computer opnieuw op. Werkt het?
Anders kan je het installeren zoals op de site staat.

Download eerst de twee pakketten via de gegeven links, kies de meest recente versie,    libnice-0.1.0.tar.gz en    farsight2-0.0.23.tar.gz
Ik neem even de map Downloads als voorbeeld. Een tar.gz is net een zip bestand, dus moet ook uitgepakt worden.
Navigeer eerst met Nautilus naar de map Downloads, zoek het bestand libnice-0.1.0.tar.gz op, klik nu met de rechtermuisknop op het bestand, nu opent zich een menulijstje, kies Hier Uitpakken. Nu staat er een map met dezelfde naam als de tar.gz dus libnice-0.1.0.
Doe dit ook zo voor farsight2-0.0.23.tar.gz. Sluit nu Nautilus.
Nu gaan we aan de gang met de terminal, de pakketten moeten nu gecompileerd worden.
Open een terminal(onder hulpmiddelen). Type nu:
cd Downloads   <----- Zo navigeer je naar een map
Nu krijg je zoiets te zien
gijs@gijs-desktop:/home/gijs/Downloads$
Type nu:
cd libnice-0.1.0
Nu krijg je dit te zien:
gijs@gijs-desktop:/home/gijs/Downloads/libnice-0.1.0$Nu gaan we verder met de commando's op de site:
gijs@gijs-desktop:/home/gijs/Downloads/libnice-0.1.0$ ./configure --prefix=/usr --disable-gtk-doc  <--- Let op het puntje voor de ./configure
Nu komen er een hoop regels voorbij, als dit klaar is type je make
gijs@gijs-desktop:/home/gijs/Downloads/libnice-0.1.0$ make <------ Nu wordt er gecompileerd.
En nu gaan we installeren met sudo make install, als je na dit commando, een ENTER geeft moet je het wachtwoord invoeren, hier zie je niets van, geen sterretjes, balletjes, o.i.d. Gewoon blind intypen en geef een ENTER.
Als het klaar is doe je het zelfde voor het andere bestand.
En als laatste vergeet dit niet:
sudo ldconfigDe eerste keren ziet het er allemaal spannend uit, maar na wat keren gaat het bijna automatisch.
Start de computer opnieuw op, werkt het? Ik sla bewust het stukje van SVN over om aMSN via de bron te krijgen. Omdat de versie in Ubuntu nieuwer is, zover ik dat kan zien.
Mocht je ergens vastlopen of iets is onduidelijk is schrijf je maar.


« Laatst bewerkt op: 2011/02/08, 21:05:51 door Gijsbert »
In der Beschränkung zeigt sich der Meister.