Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu-Geluidskaart en videokaart niet goed geinstalleerd  (gelezen 3673 keer)

bobey

  • Gast
Ubuntu-Geluidskaart en videokaart niet goed geinstalleerd
« Gepost op: 2007/01/11, 22:34:55 »
Hoi iedereen,

ik heb pas eens zitten puzzelen op een laptop voor er ubuntu op te installeren, dat is wonderwaarlijk goed gelukt, goed internet en alles werkt, behalve het volgende:
Graffische kaart is niet tegoei geinstalleerd (ik kan niet echt naar goeie beeldkwaliteit enzo gaan), en de geluidskaart doet raar: als er muziek uitkomt (soms wilt deze dat dus niet doen), hoor ik daarbij een heel hoge fluittoon.
De geluidskaart zou deze zijn:    AD 1986A HD Audio SoundMAX Codec
videokaart: nVidia GeForce Go 7300
Laptop: Easynote mx 120 (packard bell).

Kan iemand mij uitleggen hoe ik drivers moet installeren (ik ga ervan uit dat linux ook drivers nodig heeft), liefst nogal in detail, ik ken letterlijk niets van linux.

P.S.  Een vraagje uit nieuwsgierigheid, heeft ubuntu ook zoiets dat als je van werkblad (bureaublad ofzo) wisselt dat dat via een animatie gaat?

Dank voor de hulp
Vriendelijke groeten
Bobey

Offline Soul-Sing

  • Lid
  • Steunpunt: Nee
Ubuntu-Geluidskaart en videokaart niet goed geinstalleerd
« Reactie #1 Gepost op: 2007/01/11, 22:40:40 »
voor de grafische kaart:    

 https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia

geluidskaart. iemand?

Offline eendje

  • Lid
  • Steunpunt: Nee
Ubuntu-Geluidskaart en videokaart niet goed geinstalleerd
« Reactie #2 Gepost op: 2007/01/11, 23:03:04 »
Hoi bobey,

Allereerst welkom op het forum!

Voor je grafische kaart kun je voor de beter kualiteit een driver van Nvidia installeren. De beschrijving vind je op https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia
Als je de uitleg niet snapt of de engelse taal niet machtig bent meld je dan even dan slepen we je er wel door.

Bedoel je zoiets als http://desk3d.sourceforge.net/screenshots.php ? Dit kun je installeren via Synaptic  SYsteem > Beheer > Synaptic. Klik op knopje zoeken en geef als zoekterm 3ddesktop op. Rechtermuisklik op het vierkantje naas de naam en kies markeren voor sinatllatie. Klik daarna op de knop toepassen boven in het scherm.
Ga naar Systeem > Voorkeuren > Sessies.
Ga naar tabblad pogramma's starten.
Klik op toevoegen
zet in het invulvak  3ddesk --acquire
klik op OK en sluit sessies

Start nu het terminal venster op Toepassingen > Hulpmiddelen > Terminal venster en type het volgende commando in: gconf-editor
Ga nu naar apps > metacity > global_keybindings en zoek run_command1 op
dubbelklik op disabled en type daar Tab
Ga daarn asleutel riun_command2 en vul daar Tab in
Ga daarna in de boomstructuur aan de linkerkant naar apps > metacity > keybinding_commands
Dubbelklik op command1 en vul daar in: 3ddesk --gotoright
Dubbelklik op command2 en vul daar in: 3ddesk --gotoleft
Sluit configuratie editor

log uit en weer in.
Klik op SHIFT+TAB om één tabblad naar rechts te gaan en
CTRL+SHIFT+TAB om één tabblad naar links te gaan.

Suc6!
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

bobey

  • Gast
Ubuntu-Geluidskaart en videokaart niet goed geinstalleerd
« Reactie #3 Gepost op: 2007/01/11, 23:17:25 »
Hoi iedereen,

Allereerst, heel hard bedankt voor de snelle uitleg!
Nu, bij de laatste stap, krijg ik in het terminalvenster: "Error: your X configuration has been altered.  This script cannot proceed automatically.  If you believe that this not correct, you can update the md5sum entry executing the following command: md5sum...."
Dus ga ik er vanuit dat de drivers niet goed zijn geinstalleerd:p.  Ik ben bang dat ik een beetje extra hulp ga moeten inroepen.  Eventjes nog vertellen wat ik heb geinstalleerd: via dat pakketbeheer: linux-restricted-modules-2.6.15-23-386, linux-restricted-modules-2.6.15-25-386, linux-res...2.6.15-26-386, linux-res...2.6.15-27-386, nvidia-glx-legacy, (nvidia-kernel-common, maar dit was al precies van voren af geinstalleerd).

Idd Eentje, zoiets bedoelde ik, ofwel na eventjes snuffeln: http://members.home.nl/wooz/linux/desktop.jpg, heb ik hier: http://forum.ubuntu-nl.org/topic/2313/2 gevonden.

[edit] Na het installeren van de 3ddesktop werkt dat niet echt bij mij:s, waaraan zou dit kunnen liggen? [edit]

Op voorhand al heel hard bedankt, ik ben verbaasd van de snelle hulp hier!

Bobey

Offline eendje

  • Lid
  • Steunpunt: Nee
Ubuntu-Geluidskaart en videokaart niet goed geinstalleerd
« Reactie #4 Gepost op: 2007/01/11, 23:45:35 »
Ik denk dat het niet helemaal goed gegaan is... Je moet precies de goede versie van de restricted modules installeren. Om er achter te komen welke versie je hebt kun je het beste het terminal venster opnenen Toepassingen > Hulpmiddelen > Terminal venster. Type daar in:

uname -r

Dan komt er iets in het scherm te staan als (in mijn geval)

2.6.15-27-k7

In mij geval moet ik dus linux-restricted-modules-k7 installeren. Als er na 2.6.15.27 niets staat moet je linux-restricted-modules installeren. De andere versies kun je weer deïnstalleren.

Jij het nvidia-legacy geïnstalleerd, maar in jouw geval heb je nvidia-glx nodig, dus deïnstalleer nvidia-legacy en installeer nvidia-glx.

Ik hoop niet dat je nvidia-settings of nvidia-xconfig hebt geïnstalleerd, want die deïnstalleren die goede pakketten.

Als je DApper hebt voer dan in het terminal venster he volgende uit: sudo nvidia-glx-config enable

in edgy doe je: sudo nvidia-xconfig

Doe daarna CTRL+ALT+BACKSPACE

even wachten tot je weer kan inloggen. Als het goed is zie even heeeel kort een nvidia logo, maar dat gebeurt niet altijd. Log weer in.

open het temrinal venster en voer het volgende in:

glxinfo | grep direct

als goed is zegt ie dan direct rendering: Yes

Zo niet is er wat fout gegaan, maar dan zoeken we het wel weer op...


Over dat 3D gebeuren... dat is een experimenteel. Ik gebruik het zelf niet. Als je het wilt gebruiken moeten de anderen je even helpen.
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

bobey

  • Gast
Ubuntu-Geluidskaart en videokaart niet goed geinstalleerd
« Reactie #5 Gepost op: 2007/01/12, 11:28:00 »
Mooi, dit is gelukt, bedankt al,

Iemand een idee voor de geluidskaart?

Met vriendelijke groeten
Bobey

Offline siegi

  • Lid
  • Steunpunt: Nee
Ubuntu-Geluidskaart en videokaart niet goed geinstalleerd
« Reactie #6 Gepost op: 2007/01/12, 20:59:01 »
Komt er soms muziek uit de geluidskaart?  behalve dan wat gefluit?
Toen mijn pc pas nieuw was, toen was er nog geen goede driver voor mijn geluidskaart ik heb toen op de website van alsa-project de laatste nieuwe drivers gecompileerd en toen was mijn geluid in orde.  
Ik heb eigenlijk niet de tijd om terug 100 percent uit te zoeken hoe dit gaat kan iemand anders het eens proberen?

bobey

  • Gast
Ubuntu-Geluidskaart en videokaart niet goed geinstalleerd
« Reactie #7 Gepost op: 2007/01/12, 21:30:10 »
Dit is dus het rare: ik krijg heel soms bij het opstarten geluid, soms met enorme fluittonen bij, en dan net na het inloggen, nog heel eventjes geluid, daarna niets meer.

iemand een ideetje?

Offline eendje

  • Lid
  • Steunpunt: Nee
Ubuntu-Geluidskaart en videokaart niet goed geinstalleerd
« Reactie #8 Gepost op: 2007/01/12, 22:52:57 »
bobey,

Doe eens wat in onderstaande draad van het engelse ubuntu forum staat (post #9):

http://www.ubuntuforums.org/showthread.php?t=179322

Als je het niet snapt moet je je maar even melden.
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

Offline Martin

  • Lid
  • Steunpunt: Nee
Ubuntu-Geluidskaart en videokaart niet goed geinstalleerd
« Reactie #9 Gepost op: 2007/01/17, 21:26:05 »
[OFFTOPIC] Hee eendje, jij woont dichtbij! ( ik in Hattem)[/OFFTOPIC]

Het viel mij persoonlijk mee dat Realtek zelfs aparte drivers heeft voor linux.
( Dan heb ik het over de Realtek HD Audio ALC822 8 channel (onboard)

bobey

  • Gast
Ubuntu-Geluidskaart en videokaart niet goed geinstalleerd
« Reactie #10 Gepost op: 2007/01/17, 21:54:08 »
hoi eendje:

deze had ik idd ook gevonden, drivers al geupdate, enkel deze lijn snap ik niet hoe uit te voeren:

-Put "options snd-hda-intel position_fix=1 model=3stack" to "/etc/modprobe.d/alsa-base".



@mcdesign: misschien van mij een hele domme vraag, maar is mijn geluidskaart realtek?, zoja, waar kan ik verder zoeken naar drivers?

Groetjes
Bobey

Offline eendje

  • Lid
  • Steunpunt: Nee
Ubuntu-Geluidskaart en videokaart niet goed geinstalleerd
« Reactie #11 Gepost op: 2007/01/17, 21:54:38 »
[OFFTOPIC] ALs ik dicht bij jouw woon... woon jij dicht bij mij, maar dat is logisch.... ;) Dan zijn er nu twee forum leden uit Hattem. Florian woont er ook... Mooi stadje Hattem... Kom er regelmatig., m'n broer+gezin woont er. [/OFFTOPIC]

Dus... je hebt het zwikkie aan de praat gekregen... of is dat iets te voorbarig conclusie...
Een dag niets geleerd is een dag niet geleefd!
Ik blog dus ik besta!
__________________________________________________________
Een vraag? Heb je al eens gekeken op: http://wiki.ubuntu-nl.org/FAQ?

Offline Martin

  • Lid
  • Steunpunt: Nee
Ubuntu-Geluidskaart en videokaart niet goed geinstalleerd
« Reactie #12 Gepost op: 2007/01/18, 08:57:51 »
@ Bobey:
Nee, jij hebt geen Realtek audio maar een SoundMax

http://www.analog.com/en/prod/0,2877,AD1986A,00.html (Die heb jij)
Ik kan op die website geen drivers vinden, maar volgens de pagina zou die   Flexible OS Support  moeten hebben.

@ Eendje:  :P

Offline Sander50

  • Lid
    • http://www.somp.nl
  • Steunpunt: Nee
Ubuntu-Geluidskaart en videokaart niet goed geinstalleerd
« Reactie #13 Gepost op: 2007/01/19, 17:54:29 »
@bobey:
Put "options snd-hda-intel position_fix=1 model=3stack" to "/etc/modprobe.d/alsa-base"
betekend dat je de lijn options snd-hda-intel position_fix=1 model=3stack aan het genoemde bestand toe moet voegen, zo dus:
gksudo gedit /etc/modprobe.d/alsa-baseEn dan die lijn toevoegen :D

bobey

  • Gast
Ubuntu-Geluidskaart en videokaart niet goed geinstalleerd
« Reactie #14 Gepost op: 2007/01/21, 10:17:06 »
Hoi iedereen,

net geprobeerd dit te doen, probleem is niet opgelost :(.  Nog iemand ideetjes?

Groetjes
Bobey

Offline Sander50

  • Lid
    • http://www.somp.nl
  • Steunpunt: Nee
Ubuntu-Geluidskaart en videokaart niet goed geinstalleerd
« Reactie #15 Gepost op: 2007/01/21, 20:09:07 »
Probeer eens in Voorkeuren=>Geluid op het eerste tabblad wat te prutsen met de verschillende sound-deamons (OSS, ESD, ALSA), en kijk eens of je misschien iets opvalt (welke het het beste doet enz).