Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: wel cam in Cheese maar niet op site  (gelezen 1637 keer)

Offline arthur2708

  • Lid
  • Steunpunt: Nee
wel cam in Cheese maar niet op site
« Gepost op: 2011/01/29, 13:36:14 »
Als ik Cheese open dan kan ik gewoon mezelf zien en het programma goed gebruiken.
Wil ik echter de cam op een site gebruiken zoals op bijv Facebook dan geeft hij aan dat ik geen cam heb
Ook op andere sites komt dit voor
Hoe kan dit ?
« Laatst bewerkt op: 2011/02/01, 12:11:37 door arthur2708 »
You gotta be hungry !

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: wel cam in Cheese maar niet op site
« Reactie #1 Gepost op: 2011/01/29, 14:52:28 »
Welke webcam heb je? Met een webcam op Facebook kan ik je niet verder mee helpen, die gebruik ik niet, wel met Skype of aMSN.
In der Beschränkung zeigt sich der Meister.

Offline arthur2708

  • Lid
  • Steunpunt: Nee
Re: wel cam in Cheese maar niet op site
« Reactie #2 Gepost op: 2011/01/29, 15:06:26 »
Het is een cam van Genius.
Stond op de doos dat die ook voor Linux bruikbaar is.
Hij heeft wel gewerkt, ook op Facebook, MSN en Skype, maar dat was in een oudere versie.
Ik gebruik nu Ubuntu 10.10
You gotta be hungry !

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: wel cam in Cheese maar niet op site
« Reactie #3 Gepost op: 2011/01/29, 18:30:23 »
Open eens een terminal(onder Hulpmiddelen)en type lsusb (de eerste letter is een kleine L) en geef een ENTER, kan je de uitkomst hier plaatsen?
In der Beschränkung zeigt sich der Meister.

Offline arthur2708

  • Lid
  • Steunpunt: Nee
Re: wel cam in Cheese maar niet op site
« Reactie #4 Gepost op: 2011/01/30, 11:23:23 »
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 0ac8:305b Z-Star Microelectronics Corp. ZC0305 Webcam
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
You gotta be hungry !

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: wel cam in Cheese maar niet op site
« Reactie #5 Gepost op: 2011/01/30, 11:50:05 »
Van deze site http://linuxlike.blogspot.com/2010/06/instalando-webcam-z-star-zc0305-no.html  Vertaling van Google iets aangepast.
Alles gaat in de terminal(onder Hulpmiddelen) als je ergens niet uit komt schrijf je maar.

1 - Installeer de pakketten die nodig zijn voor compilatie (type uname-r in de terminal om de juiste kernel versie te verkrijgen):

    sudo apt-get install build-essential linux-headers-2.6.31-17-generic


2 - Download de broncode van de v4l-dvb:

    wget http://linuxtv.org/hg/v4l-dvb/archive/tip.tar.bz2


3 - Pak het gedownloade bestand en navigeer naar de map:

    tar-jxvf tip.tar.bz2
    cd v4l-dvb-*

 * Opmerking: de naam van de map hierboven kan verschillen per versie.

4 -Kopieer de kernel config bestand nodig voor de configuratie (type uname-r in de terminal om de juiste kernel versie te verkrijgen)
   cp / boot/config-2.6.31-17-generic. config


5 - Compileer en installeer:

    make CONFIG_DVB_FIREDTV:=n || return
    sudo make install

Noot: De parameters "CONFIG_DVB_FIREDTV: = n | | return" lost het probleem op(een fout) als je alleen probeert te bouwen met het make commando.

6 - Ten slotte, het systeem opnieuw opstarten.
« Laatst bewerkt op: 2011/01/30, 11:55:12 door Gijsbert »
In der Beschränkung zeigt sich der Meister.

Offline arthur2708

  • Lid
  • Steunpunt: Nee
Re: wel cam in Cheese maar niet op site
« Reactie #6 Gepost op: 2011/02/01, 12:12:40 »
Als ik V4L aanzet dan springt de cam wel aan ( groene lichte bovenop brandt ), maar de preview blijft zwart (!)
You gotta be hungry !

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: wel cam in Cheese maar niet op site
« Reactie #7 Gepost op: 2011/02/01, 15:56:23 »
Open een terminal en type sudo modprobe  gspca-zc3xx en geef een ENTER, nu je wachtwoord invullen daar zie niets van, geen sterretjes balletjes o.i.d. gewoon intypen en geef een ENTER.
Kijk ook gelijk bij Systeem>Beheer>Gebruikers en Groepen of je vermeld staat bij de groep video.
In der Beschränkung zeigt sich der Meister.

Offline arthur2708

  • Lid
  • Steunpunt: Nee
Re: wel cam in Cheese maar niet op site
« Reactie #8 Gepost op: 2011/02/02, 10:38:34 »
Sudo uitgevoerd en mij bij video aangevinkt.
Maar nog steeds niets.
Alleen Cheese blijft beeld geven.
You gotta be hungry !

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: wel cam in Cheese maar niet op site
« Reactie #9 Gepost op: 2011/02/02, 11:06:07 »
Mijn excuses, ik had in mijn bericht een spatie teveel in het commando gezet, ik weet niet of je het gekopieerd en geplakt hebt? Anders gebeurt er niet veel. Dit was het sudo modprobe  gspca-zc3xx  en dit moet het zijn sudo modprobe gspca-zc3xx
Nog even een vraag tussendoor, welke versie heb je van Ubuntu en heb je daar de 32 bits of 64 bits uitvoering geinstalleerd? Skype is nl. een 32 bits programma.
In der Beschränkung zeigt sich der Meister.

Offline arthur2708

  • Lid
  • Steunpunt: Nee
Re: wel cam in Cheese maar niet op site
« Reactie #10 Gepost op: 2011/02/02, 12:44:56 »
Ubuntu 10.10
32 bit

Ook het aangepaste commando haalt niets uit.

Ik vind het zo vreemd dat het in 9.10 en 10.04 wel werkte en in 10.10 niet
You gotta be hungry !

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: wel cam in Cheese maar niet op site
« Reactie #11 Gepost op: 2011/02/02, 17:23:41 »
Oke,dan kan het probleem niet daar zitten.
Open een terminal en type dmesg|tail Kan je de uitkomst hier plaatsen?
En type in de terminal /sbin/lsmod  Kan je de uitkomst hiervan ook plaatsen?
En nog een ls -la /dev |grep video*   Kan je de uitkomst hiervan ook plaatsen?
Uit deze commando's zal blijken of de drivers zijn geïnstalleerd, de kernelmodules zijn geactiveerd en of de video geregistreerd is.
« Laatst bewerkt op: 2011/02/02, 17:34:05 door Gijsbert »
In der Beschränkung zeigt sich der Meister.

Offline arthur2708

  • Lid
  • Steunpunt: Nee
Re: wel cam in Cheese maar niet op site
« Reactie #12 Gepost op: 2011/02/02, 18:33:16 »
artvds2708@artvds2708-desktop:~$ /sbin/lsmod
Module                  Size  Used by
binfmt_misc             6587  1
fbcon                  35102  71
tileblit                2031  1 fbcon
font                    7557  1 fbcon
bitblit                 4707  1 fbcon
softcursor              1189  1 bitblit
vga16fb                11385  0
vgastate                8961  1 vga16fb
snd_intel8x0           25652  4
snd_ac97_codec        100646  1 snd_intel8x0
ac97_bus                1002  1 snd_ac97_codec
snd_pcm_oss            35308  0
snd_mixer_oss          13746  1 snd_pcm_oss
snd_pcm                70694  4 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_seq_dummy           1338  0
snd_seq_oss            26722  0
snd_seq_midi            4557  0
snd_rawmidi            19056  1 snd_seq_midi
snd_seq_midi_event      6003  2 snd_seq_oss,snd_seq_midi
snd_seq                47263  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              19098  2 snd_pcm,snd_seq
snd_seq_device          5700  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
i915                  287458  3
snd                    54180  17 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
drm_kms_helper         29329  1 i915
gspca_zc3xx            45189  0
ppdev                   5259  0
drm                   162409  4 i915,drm_kms_helper
i2c_algo_bit            5028  1 i915
gspca_main             21199  1 gspca_zc3xx
soundcore               6620  1 snd
intel_agp              24375  2 i915
video                  17375  1 i915
parport_pc             25962  1
videodev               34361  1 gspca_main
v4l1_compat            13251  1 videodev
psmouse                63245  0
serio_raw               3978  0
snd_page_alloc          7076  2 snd_intel8x0,snd_pcm
shpchp                 28835  0
output                  1871  1 video
agpgart                31724  2 drm,intel_agp
lp                      7028  0
parport                32635  3 ppdev,parport_pc,lp
floppy                 53016  0
8139too                18545  0
8139cp                 16186  0
mii                     4381  2 8139too,8139cp
artvds2708@artvds2708-desktop:~$ ls -la /dev |grep video*
crw-rw----   1 root video    10, 175 2011-02-02 18:28 agpgart
crw-rw----   1 root video    29,   0 2011-02-02 18:28 fb0
crw-rw----+  1 root video    81,   0 2011-02-02 18:28 video0
artvds2708@artvds2708-desktop:~$ dmesg|tail
[   24.244662]  domain 0: span 0-1 level SIBLING
[   24.244668]   groups: 0 (cpu_power = 589) 1 (cpu_power = 589)
[   24.244680]   domain 1: span 0-1 level MC
[   24.244685]    groups: 0-1 (cpu_power = 1178)
[   24.244698] CPU1 attaching sched-domain:
[   24.244703]  domain 0: span 0-1 level SIBLING
[   24.244708]   groups: 1 (cpu_power = 589) 0 (cpu_power = 589)
[   24.244719]   domain 1: span 0-1 level MC
[   24.244724]    groups: 0-1 (cpu_power = 1178)
[   28.100010] eth0: no IPv6 routers present
artvds2708@artvds2708-desktop:~$
You gotta be hungry !

Offline Xarvaz

  • Lid
    • Foto Blog
  • Steunpunt: Nee
Re: wel cam in Cheese maar niet op site
« Reactie #13 Gepost op: 2011/02/02, 19:30:07 »
facebook werkt met flash cam, heb je die wel aangezet ?, dit doe je met rechtermuis in scherm, als fox moeilijk doet daarin kun je dit ook op de adobe site zelf doen

http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager02.html

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: wel cam in Cheese maar niet op site
« Reactie #14 Gepost op: 2011/02/02, 20:47:49 »
In lsmod kom ik de gspca tegen maar in dmesg|tail zie ik niets staan.
Bij mij komt dit er uit:
───[gijs@gijs-desktop]──[20:37]──> /
 $ dmesg|tail
[ 2573.257007] usb 4-1.3: configuration #1 chosen from 1 choice
[ 2573.311807] gspca: main v2.7.0 registered
[ 2573.314764] gspca: probing 046d:08da
[ 2575.174816] zc3xx: probe 2wr ov vga 0x0000
[ 2575.224815] zc3xx: probe sensor -> 0011
[ 2575.224821] zc3xx: Find Sensor HV7131R(c)
[ 2575.228936] gspca: probe ok
[ 2575.248457] usbcore: registered new interface driver snd-usb-audio
[ 2575.248475] usbcore: registered new interface driver zc3xx
[ 2575.248480] zc3xx: registered

Doe dit eens:
Check available params:
sudo modinfo gspca_main

Unload the module(s)
sudo modprobe -r gspca-main
sudo modprobe -r gspca-sunplus

Load the module(s):
sudo modprobe gspca-main debug=0x01
sudo modprobe gspca-sunplus
Van uppman http://www.linuxquestions.org/questions/slackware-14/need-help-w-another-webcam-762881/
In der Beschränkung zeigt sich der Meister.

Offline arthur2708

  • Lid
  • Steunpunt: Nee
Re: wel cam in Cheese maar niet op site
« Reactie #15 Gepost op: 2011/02/03, 10:29:26 »
artvds2708@artvds2708-desktop:~$ sudo modinfo gspca_main
[sudo] password for artvds2708:
filename:       /lib/modules/2.6.32-28-generic/kernel/drivers/media/video/gspca/gspca_main.ko
license:        GPL
description:    GSPCA USB Camera Driver
author:         Jean-Francois Moine <http://moinejf.free.fr>
srcversion:     2D3CAB18A22D80F35B7CE06
depends:        videodev
vermagic:       2.6.32-28-generic SMP mod_unload modversions 586
parm:           debug:Debug (bit) 0x01:error 0x02:probe 0x04:config 0x08:stream 0x10:frame 0x20:packet 0x40:USBin 0x80:USBout 0x0100: v4l2 (int)
artvds2708@artvds2708-desktop:~$ sudo modprobe -r gspca-main
FATAL: Module gspca_main is in use.
artvds2708@artvds2708-desktop:~$ sudo modprobe -r gspca-sunplus
artvds2708@artvds2708-desktop:~$ sudo modprobe gspca-main debug=0x01
artvds2708@artvds2708-desktop:~$ sudo modprobe gspca-sunplus
artvds2708@artvds2708-desktop:~$

You gotta be hungry !