Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [opgelost] Problemen met Apache2: SNI & VirtualHosts  (gelezen 1792 keer)

Offline lowrider2025

  • Lid
  • Steunpunt: Nee
[opgelost] Problemen met Apache2: SNI & VirtualHosts
« Gepost op: 2011/01/17, 12:50:33 »
Hier ben ik weer

Situatie:
server draait als virtuele machine
Ubuntu 10.04.1
Apache 2.2.16
OpenSSL 0.9.8k (library: OpenSSL 0.9.8o 01 Jun 2010)

Wat ik wil: meerdere virtual hosts met ssl onder 1 ip-adres:

In mijn voorbeeld: server = 192.168.227.129

Wat ik heb gedaan:
cd /var
mkdir sslsite1
mkdir sslsite1
chmod 755 sslsite1
chmod 755 sslsite2
chown root:root sslsite1
chown root:root sslsite2

cd sslsite1
touch index.html
nano index.html: <h2>SSL Site 1</h2>
cp index.html /var/sslsite2
nano index.html: <h2>SSL Site 2</h2>

cd /etc/apache2/sites-available
touch sslsnihosts
nano sslsnihosts

sslsnihosts:
<VirtualHost *:443>
   ServerName test1.domein.com

   SSLEngine On
   SSLCertificateFile /etc/apache2/ssl/server.crt
   SSLCertificateKeyFile /etc/apache2/ssl/server.key
  
   DocumentRoot /var/sslsite1
</VirtualHost>
<VirtualHost *:443>
   ServerName test2.domein.com

   SSLEngine On
   SSLCertificateFile /etc/apache2/ssl/server.crt
   SSLCertificateKeyFile /etc/apache2/ssl/server.key
  
   DocumentRoot /var/sslsite2
</VirtualHost>

a2ensite sslsnihosts

/etc/apache2/ports.conf
toegevoegd:
NameVirtualHost *:443

stond al:
<IfModule mod_ssl.c>
    Listen 443
</IfModule>

<IfModule mod_gnutls.c>
    Listen 443
</IfModule>

/etc/init.d/apache2 restart (geeft geen foutmeldingen)

op host OS:
windows/system32/drivers/etc/hosts
192.168.227.129 test1.domein.com
192.168.227.129 test2.domein.com

onder firefox 3.6.13
https://test1.domein.com

=> De verbinding werd onderbroken

http://test1.domein.com:443/
=>Bad Request

Your browser sent a request that this server could not understand.
Reason: You're speaking plain HTTP to an SSL-enabled server port.
Instead use the HTTPS scheme to access this URL, please.

Hint: https://test1.domein.com/

Iemand enig idee ?

Alvast bedankt voor het lezen

Als alles achter de rug is en alles werkt zoals het hoort, dan maak ik er een howto van en post ik die hier op het forum.
« Laatst bewerkt op: 2011/01/20, 16:57:37 door lowrider2025 »

Offline Buzzin

  • Lid
  • Steunpunt: Nee
Re: Problemen met Apache2: SNI & VirtualHosts
« Reactie #1 Gepost op: 2011/01/17, 13:04:37 »
Vergeet niet in de algemene config (ports.conf) van apache even aan te geven dat hij op poort 443 moet luistern en doe een herstart (van het OS), dit omdat hij blijkbaar anders niet goed wil gaan luisteren....kun je wel fixen, maar een reboot is sneller.
« Laatst bewerkt op: 2011/01/17, 13:06:37 door Buzzin »
Football: A battle between two teams of mindless thugs over scraps of coloured cloth. Usually accompanied by the spectacle of 22 overpaid primadonnas kicking a ball on a field.
DebianDevuan, KDE & OperaVivaldi addict, RedHat Engineer

Offline lowrider2025

  • Lid
  • Steunpunt: Nee
Re: Problemen met Apache2: SNI & VirtualHosts
« Reactie #2 Gepost op: 2011/01/17, 13:14:41 »
Vergeet niet in de algemene config (ports.conf) van apache even aan te geven dat hij op poort 443 moet luistern en doe een herstart (van het OS), dit omdat hij blijkbaar anders niet goed wil gaan luisteren....kun je wel fixen, maar een reboot is sneller.

in apache2.conf staat: Include ports.conf
ik veronderstel dat dat voldoende moet zijn om apache naar poort 443 te laten luisteren.

uitkomst: netstat -tan
tcp   127.0.0.1:3306  LISTEN
tcp   0.0.0.0:80        LISTEN
tcp   0.0.0.0:443       LISTEN

Offline lowrider2025

  • Lid
  • Steunpunt: Nee
Re: Problemen met Apache2: SNI & VirtualHosts
« Reactie #3 Gepost op: 2011/01/17, 13:15:39 »
(ports.conf)
1ste post:
/etc/apache2/ports.conf
toegevoegd:
NameVirtualHost *:443

stond al:
<IfModule mod_ssl.c>
    Listen 443
</IfModule>

<IfModule mod_gnutls.c>
    Listen 443
</IfModule>

Offline Buzzin

  • Lid
  • Steunpunt: Nee
Re: Problemen met Apache2: SNI & VirtualHosts
« Reactie #4 Gepost op: 2011/01/18, 10:01:35 »
Raar....bij mij (debian) staat er alleen dit in (/etc/ports.conf):
Listen 80
Listen 443
Meer zou er ook niet in hoeven staan lijkt mij....
Football: A battle between two teams of mindless thugs over scraps of coloured cloth. Usually accompanied by the spectacle of 22 overpaid primadonnas kicking a ball on a field.
DebianDevuan, KDE & OperaVivaldi addict, RedHat Engineer

Offline bram103

  • Lid
  • Steunpunt: Nee
Re: Problemen met Apache2: SNI & VirtualHosts
« Reactie #5 Gepost op: 2011/01/18, 17:21:09 »
Heb je in /etc/apache2/sites-enabled een link gemaakt naar sslsnihosts in /etc/apache2/sites-available?

Offline lowrider2025

  • Lid
  • Steunpunt: Nee
Re: Problemen met Apache2: SNI & VirtualHosts
« Reactie #6 Gepost op: 2011/01/18, 21:18:13 »
Heb je in /etc/apache2/sites-enabled een link gemaakt naar sslsnihosts in /etc/apache2/sites-available?

Je bedoelt wellicht "ln -s" enz...
dit werd normaal vervangen door a2ensite. de link is alleszins zichtbaar onder /etc/apache2/sites-enabled

Ben op onderzoek gegaan met: openssl s_client -connect 192.168.227.129:443
geeft oa: SSL23_WRITE:ssl handshake failure:s23_lib.c:188

Hoe kan ik meer details over deze fout vinden ? In welke logs zou dit te vinden zijn ? wellicht in /var/log ?

Offline lowrider2025

  • Lid
  • Steunpunt: Nee
Re: Problemen met Apache2: SNI & VirtualHosts
« Reactie #7 Gepost op: 2011/01/20, 16:57:12 »
Heb turnkey joomla gedownload en ik vertrek van daaruit verder. SSL werkt daar out of the box.