Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Vreemd probleempje met DNS  (gelezen 1032 keer)

Offline KevinTS

  • Lid
  • Steunpunt: Nee
Vreemd probleempje met DNS
« Gepost op: 2011/01/16, 16:36:33 »
Goede middag,

Ik ben onlangs overgestapt van windows naar Ubuntu, echter loop ik nu tegen een aardig vreemd probleempje aan.

Zodra ik iets wil pingen duurt het vrij lang voordat ik een reactie krijg.

Bijvoorbeeld een ping naar Google, voordat hij met de eerste reactie terug kwam duurde het ongeveer 40 seconden:

PCKevin:~$ ping google.com
PING google.com (74.125.79.104) 56(84) bytes of data.
64 bytes from 74.125.79.104: icmp_req=1 ttl=54 time=26.8 ms

Doe ik dit zonder een reverse lookup, geen probleem en binnen de seconde een reactie:

Kevin:~$ ping -n google.com
PING google.com (74.125.79.99) 56(84) bytes of data.
64 bytes from 74.125.79.99: icmp_req=1 ttl=54 time=26.8 ms
64 bytes from 74.125.79.99: icmp_req=2 ttl=54 time=25.9 ms
64 bytes from 74.125.79.99: icmp_req=3 ttl=54 time=26.1 ms
64 bytes from 74.125.79.99: icmp_req=4 ttl=54 time=25.6 ms
64 bytes from 74.125.79.99: icmp_req=5 ttl=54 time=26.4 ms

Als ik nu vervolgens in Wicd klik op Disconnect en weer op Connect, dan gaat alles weer goed.
Alleen is het ip adres wat ik van Google terug krijg nu veranderd.

Kevin:~$ ping google.com
PING google.com (209.85.146.147) 56(84) bytes of data.
64 bytes from 209.85.146.147: icmp_req=1 ttl=55 time=26.6 ms
64 bytes from 209.85.146.147: icmp_req=2 ttl=55 time=26.0 ms
64 bytes from 209.85.146.147: icmp_req=3 ttl=55 time=26.6 ms
64 bytes from 209.85.146.147: icmp_req=4 ttl=55 time=26.6 ms

Dit probleem heb ik niet op andere Windows machines en ik moet dit tafereel elke keer doen zodra de machine opnieuw opstart.

Heeft iemand enig idee waar dit aan kan liggen?
In ieder geval bedankt voor het meedenken!

Bij deze nog mijn resolv.conf:

nameserver 192.168.1.1
nameserver 8.8.8.8

Mijn nsswitch.conf:

passwd:         compat
group:          compat
shadow:         compat

hosts:          files dns
networks:       files

protocols:      db files
services:       db files
ethers:         db files
rpc:            db files

netgroup:       nis

Mijn hosts file:

192.168.1.21 Kevin
127.0.0.1 localhost.localdomain localhost
::1 Kevin localhost6.localdomain6 localhost6
127.0.1.1 Kevin

# The following lines are desirable for IPv6 capable hosts
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

Offline ivo

  • Lid
  • Steunpunt: Nee
Re: Vreemd probleempje met DNS
« Reactie #1 Gepost op: 2011/01/16, 21:31:44 »
Zie je wellicht met
mtr google.com
iets afwijkends/opvallends?
There are only 10 types of people in the world; those who understand binary and those who don't.

Offline KevinTS

  • Lid
  • Steunpunt: Nee
Re: Vreemd probleempje met DNS
« Reactie #2 Gepost op: 2011/01/16, 22:14:05 »
Hallo Ivo,

Zodra ik de traceroute run (voor het Wicd verhaal), dan duurt het vrij lang maar uiteindelijk krijg ik het volgende:

Kevin (0.0.0.0)
Resolver: Recieved error response 2. (server failure)

1. Livebox
2. 85.150.x.x (Externe ip adres)
3. 194.134.154.161
4. 194.134.161.61
5. 194.134.161.102

Bij het ip adres van 94.134.154.161 heb ik een gemiddelde loss van 9 %
En bij 194.134.161.102 ongeveer 30 %

Error response 2. (server failure), is zover ik weet, een probleem met de DNS (geloof ik).

Doe ik dit na het Wicd verhaal:

Geen error, en nu krijg ik ook netjes de namen terug (op die van mijn router na):

Kevin (0.0.0.0)

1. 192.168.1.1
-----
3. V739.dr3-asd6.nl.euro.net
----
5. PC16.er1.asd6.nl.euro.net
----
8. 209.85.240.221

Gemiddelde loss 3: 6%
Gemiddelde loss 5: 35 %
Gemiddelde loss 8: 15%

Offline ivo

  • Lid
  • Steunpunt: Nee
Re: Vreemd probleempje met DNS
« Reactie #3 Gepost op: 2011/01/16, 22:52:00 »
Ik denk dat het te maken heeft met die 2e nameserver (8.8.8.8) in je resolv.conf.
Mijn resolv.conf heeft alleen mijn linksys router de 192.168.1.1.
Dit geeft momentaan ping response op google.com
Als ik dat verander naar 8.8.8.8 dan wordt de zaak hopeloos traag.
Omdat de 8.8.8.8 de public DNS server van google is denk ik dat je niet de enige
bent die dat ding aanspreekt.

8.8.8.8.in-addr.arpa   name = google-public-dns-a.google.com.

Haal die eens uit je resolv.conf zodat je alléén de 192.168.1.1 erin hebt staan.
Gaat het dan beter?
There are only 10 types of people in the world; those who understand binary and those who don't.

Offline KevinTS

  • Lid
  • Steunpunt: Nee
Re: Vreemd probleempje met DNS
« Reactie #4 Gepost op: 2011/01/16, 23:24:53 »
Zojuist geprobeerd zonder succes. Wicd Network Manager schrijf de DNS informatie weg in resolv.conf.
Dus als ik dit aanpas naar het ip adres van mijn router (192.168.1.1) dan zie ik dit ook terug in dat bestand.

Helaas krijg ik dan juist weer waar ik vanaf wil, een ontzettend traag netwerk en een extreem trage reactie van google.com
Lijkt erop dat public DNS van Google mij de mogelijkheid geeft dit te omzeilen. Dat was ook de reden waarom ik het erin had gezet.

Zeer verwarrend...  :|

Wat het nog verwarrender maakt is dat ik dit ook op mijn laptop heb (tevens Ubuntu 10.10), maar niet op mijn windows bak.



« Laatst bewerkt op: 2011/01/16, 23:27:34 door KevinTS »