Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: PCI - PCMCIA slot werkt niet op verschillende distro's  (gelezen 4088 keer)

Offline TheCrow01

  • Lid
  • Steunpunt: Nee
PCI - PCMCIA slot werkt niet op verschillende distro's
« Gepost op: 2011/01/15, 15:31:20 »
Beste Mensen,  :)

Ik ben redelijk nieuw met het gebruik van Linux, ik heb al wel naar verschillende distro's bekeken zoals:
Ubuntu, Backtrack, Chaox.  8)


Ik probeer een PCMCIA kaart (Ascom Voo:doo) werkend te krijgen via een PCI-PCMCIA kaart in mijn desktop pc.
Echter als ik "Dmesg" in een terminal/shell invul krijg ik de foutmelding: "PCMCIA_socket0 cs: unable to apply power"
Zowel op Backtrack als Chaox, ik heb al internet gekeken echter vind ik geen oplossing.
Ik maak gebruik van deze twee distro's omdat zij specifieke drivers en software (dect) ingebakken hebben die ik nodig heb, voor testen van mijn huisphone. Helaas heeft mijn laptop alleen een Expresscard slot waar dus geen PCMCIA kaart in past, en ik dus mijn PC moet gebruiken :(

Ik hoop dat iemand mij verder kan helpen.
Bvd.


Offline Gijsbert

  • Lid
  • Steunpunt: Ja
« Laatst bewerkt op: 2011/01/15, 19:44:19 door Gijsbert »
In der Beschränkung zeigt sich der Meister.

Offline Joris Donders

  • Lid
  • Steunpunt: Ja
Re: PCI - PCMCIA slot werkt niet op verschillende distro's
« Reactie #2 Gepost op: 2011/01/16, 00:19:54 »
Ik denk als Ubuntu werkt voor je huisphone, dat je het best je hardware eens test.
Ik gebruik zelf PCMCIA op mijn laptop en het is out of the box ! (Wifi card)
Mogelijk is er geen driver in Ubuntu die jouw cardbuskaart ondersteunt.

Kan je online geraken en via Systeem -- Beheer -- Stuurprogramma's geen extra driver downloaden ?

Misschien ook eens een andere CardBuskaart proberen ...

En vergeet OpenSuse niet; een zéér compleet systeem ! Misschien dat dat wel werkt.
Post je resultaten maar ! Succes !!
Gubuntu 17.04 wegens verdwijnen Unity binnenkort

Offline TheCrow01

  • Lid
  • Steunpunt: Nee
Re: PCI - PCMCIA slot werkt niet op verschillende distro's
« Reactie #3 Gepost op: 2011/01/17, 08:34:37 »
Bedankt voor je reactie, Ik heb Ubuntu nog niet geprobeerd maar wel de 2 andere genoemde distro's, waarbij ik dezelfde foutmelding krijg. De PCMCIA-PCI kaart die ik gebruik heeft de volgende chipset:  Ricoh R5C475 II.
Ik weet niet of het een driver issue is aangezien hij wel het PCMCIA slot ziet.

Ik denk als Ubuntu werkt voor je huisphone, dat je het best je hardware eens test.
Ik gebruik zelf PCMCIA op mijn laptop en het is out of the box ! (Wifi card)
Mogelijk is er geen driver in Ubuntu die jouw cardbuskaart ondersteunt.

Kan je online geraken en via Systeem -- Beheer -- Stuurprogramma's geen extra driver downloaden ?

Misschien ook eens een andere CardBuskaart proberen ...

En vergeet OpenSuse niet; een zéér compleet systeem ! Misschien dat dat wel werkt.
Post je resultaten maar ! Succes !!

Offline Joris Donders

  • Lid
  • Steunpunt: Ja
Re: PCI - PCMCIA slot werkt niet op verschillende distro's
« Reactie #4 Gepost op: 2011/01/17, 11:58:40 »
Met Ubuntu heb je wel de hele rits drivers te pakken voor CardBussen.
Die andere distro's heb ik zo mijn twijfels over (Ubuntu is volgens mij veel beter onderbouwd op dat vlak); ik ken ze eigenlijk niet....XD

Maar ik zou een "uitproberen van Ubuntu" toch overwegen; dus booten via de LiveCD en je systeem uitproberen ! Dat is ook een voordeel van Ubuntu dat je die functionaliteit hebt.
De progjes waar je over spreekt zullen 9/10 ook wel draaien in Ubuntu.

Gebruik de 10.04 LTS -versie, daarvan wéét ik dat die draait met alle CardBussen die ik heb.
Volgens mij is de chipset van je CardBus wél ondersteund bij Ubuntu (de lijst van de Wiki is helaas wel héél lang ...).

Zo kan je op een simpele manier je CardBus uittesten.
Zorg voor een internetverbinding (geen  WiFi maar bedraad) ! Zo kan je zien of er een extra driver te downloaden en installeren is.

Ik zou zeggen: baat het niet schaadt het niet ! (dat uitproberen)
Gubuntu 17.04 wegens verdwijnen Unity binnenkort

Offline TheCrow01

  • Lid
  • Steunpunt: Nee
Re: PCI - PCMCIA slot werkt niet op verschillende distro's
« Reactie #5 Gepost op: 2011/01/17, 16:21:02 »
Als ik me niet vergis maakt Backtrack gebruik van Ubuntu, ze hebben er volgens mij alleen een schil omheengebouwd. Maar inderdaad ik kan het altijd even proberen.  Ik laat het wel ff weten of het werkt of niet.
Iniedergeval bedankt voor het meedenken.

Met Ubuntu heb je wel de hele rits drivers te pakken voor CardBussen.
Die andere distro's heb ik zo mijn twijfels over (Ubuntu is volgens mij veel beter onderbouwd op dat vlak); ik ken ze eigenlijk niet....XD

Maar ik zou een "uitproberen van Ubuntu" toch overwegen; dus booten via de LiveCD en je systeem uitproberen ! Dat is ook een voordeel van Ubuntu dat je die functionaliteit hebt.
De progjes waar je over spreekt zullen 9/10 ook wel draaien in Ubuntu.

Gebruik de 10.04 LTS -versie, daarvan wéét ik dat die draait met alle CardBussen die ik heb.
Volgens mij is de chipset van je CardBus wél ondersteund bij Ubuntu (de lijst van de Wiki is helaas wel héél lang ...).

Zo kan je op een simpele manier je CardBus uittesten.
Zorg voor een internetverbinding (geen  WiFi maar bedraad) ! Zo kan je zien of er een extra driver te downloaden en installeren is.

Ik zou zeggen: baat het niet schaadt het niet ! (dat uitproberen)

Offline TheCrow01

  • Lid
  • Steunpunt: Nee
Re: PCI - PCMCIA slot werkt niet op verschillende distro's
« Reactie #6 Gepost op: 2011/01/17, 18:42:02 »
Ik heb de ubuntu live cd geprobeerd. Ik heb eerst de PCMCIA kaart uit me pc gehaald en toen DMESG gedaan. Vervolgens heb ik de PCMCIA kaart in mijn adapter geschoven en vervolgens nog een keer DMESG gedaan.
Ik heb deze twee teksten in 1 tekst bestand gegooit, ik heb de twee tekst bestanden gescheiden met de regel: Foutmelding met kaart.

De download link van het tekst bestand:

http://www.2shared.com/document/QUs465CE/ubuntu.html

Ik hoop dat iemand hier iets uit op kan maken.
bvd

Offline TheCrow01

  • Lid
  • Steunpunt: Nee
Re: PCI - PCMCIA slot werkt niet op verschillende distro's
« Reactie #7 Gepost op: 2011/01/19, 13:20:23 »
Is er niemand die mij verder kan helpen  ???

Offline Joris Donders

  • Lid
  • Steunpunt: Ja
Re: PCI - PCMCIA slot werkt niet op verschillende distro's
« Reactie #8 Gepost op: 2011/01/19, 17:13:32 »
Kan je een output van lspci geven ? Desnoods via een USB-stick en deze dan posten.

En passant geef eens de output van ifconfig ?

Ik heb wel al gevonden dat voor jouw CardBus er mogelijk geen driver is in Ubuntu !

Probeer ook de PCMCIA packages eens te gebruiken:

emerge sync && emerge wireless-tools

Zorg voor bedraad internet !!!

Heb je, bij wijze van test, al eens een andere CardBus geprobeerd ?
« Laatst bewerkt op: 2011/01/19, 17:16:15 door Joris Donders »
Gubuntu 17.04 wegens verdwijnen Unity binnenkort

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: PCI - PCMCIA slot werkt niet op verschillende distro's
« Reactie #9 Gepost op: 2011/01/19, 17:17:09 »
Het is een probleem in de kernel, dus welke distro je ook probeert, de fout blijft. pcmcia_socket pcmcia_socket0: cs: unable to apply power
Lees deze wat oudere, al eerder gegeven link door http://www.kernel.org/pub/linux/utils/kernel/pcmcia/powerbugs.html
En anders zelf nog even zoeken op Ubuntu pcmcia_socket pcmcia_socket0: cs: unable to apply power in www.google.nl/linux
In der Beschränkung zeigt sich der Meister.

Offline TheCrow01

  • Lid
  • Steunpunt: Nee
Re: PCI - PCMCIA slot werkt niet op verschillende distro's
« Reactie #10 Gepost op: 2011/01/20, 17:47:40 »
Joris & Gijbert, tnx for the replys.  ;)

Ik heb Ubuntu nu geinstalleerd op mijn pc, en ik heb wired internet.
Onderstaand is mijn LSPCI.
Ik heb geen andere PCI/PCMCIA (cardbus) adapter geprobeerd omdat ik die helaas niet heb.

En betreft die link: http://www.kernel.org/pub/linux/utils/kernel/pcmcia/powerbugs.html heb ik al een paar keer gezien, echter wordt ik daar niks wijzer van en dat gaat ook over een TI1225-based PCI adapter.

Ik kreeg ook de tip om de volgende command in mijn shell te plaatsen:
sudo apt-get install pcmcia-cs

echter krijg ik dan de volgende melding:
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
De status informatie wordt gelezen... Klaar
Pakket pcmcia-cs is niet beschikbaar, hoewel er naar verwezen wordt door
een ander pakket. Mogelijk betekent dit dat het pakket ontbreekt,
verouderd is, of enkel beschikbaar is van een andere bron
E: Pakket pcmcia-cs heeft geen installeerbare kandidaat

LSPCI:
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 746 Host (rev 02)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SG86C202
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS963 [MuTIOL Media IO] (rev 25)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 90)
00:0b.0 CardBus bridge: Ricoh Co Ltd RL5c475 (rev 80)
01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200 SE] (rev 01)
01:00.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200 SE] (Secondary) (rev 01)


Kan je een output van lspci geven ? Desnoods via een USB-stick en deze dan posten.

En passant geef eens de output van ifconfig ?

Ik heb wel al gevonden dat voor jouw CardBus er mogelijk geen driver is in Ubuntu !

Probeer ook de PCMCIA packages eens te gebruiken:

emerge sync && emerge wireless-tools

Zorg voor bedraad internet !!!

Heb je, bij wijze van test, al eens een andere CardBus geprobeerd ?

« Laatst bewerkt op: 2011/01/20, 17:51:51 door TheCrow01 »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: PCI - PCMCIA slot werkt niet op verschillende distro's
« Reactie #11 Gepost op: 2011/01/20, 22:02:13 »
TheCrow01, het gaat niet om de TI1225, maar om de powerbug in de kernel. :)
In der Beschränkung zeigt sich der Meister.

Offline TheCrow01

  • Lid
  • Steunpunt: Nee
Re: PCI - PCMCIA slot werkt niet op verschillende distro's
« Reactie #12 Gepost op: 2011/01/21, 08:26:40 »
TheCrow01, het gaat niet om de TI1225, maar om de powerbug in de kernel. :)

Wat mij opvalt is dat ik de melding: " unable to apply power" krijg op het moment dat ik de PCMCIA kaart in de computer stop, en vervolgens DMESG doe.

Maar wat in die Link staat kan ik altijd proberen ik weet alleen niet welke code ik moet invoeren,  :|
in het voorbeeld staat:

In order to do this, use setpci, eg:

   # setpci -s 0a.0 0x80.l
   0044b060
   # setpci -s 0a.0 0x80.l=0x0844b060
   
Alleen er staat ook bij: " Do NOT copy the number in this example verbatim."
Dus blijkbaar moet ik andere combinatie/cijfers invoeren, echter weet ik niet welke cijfers ik moet invoeren in de terminal.
Weet iemand hoe ik hierachter kom?
« Laatst bewerkt op: 2011/01/21, 11:00:35 door TheCrow01 »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: PCI - PCMCIA slot werkt niet op verschillende distro's
« Reactie #13 Gepost op: 2011/01/21, 18:45:24 »
Nog even terug komend op pcmcia-cs . Dit is de oude naam, je moet nu het pakket pcmciautils hebben.
In de terminal sudo apt-get install pcmciautils

This package provides PCMCIA initialisation tools for Linux 2.6.13-rc1 or
later, replacing the old pcmcia-cs tools used with earlier kernel versions.
PCMCIA cards are commonly used in laptops to provide expanded capabilities
such as network connections, modems, increased memory, etc.

To use PCMCIA you need to have kernel modules available to support
it. These are included in the stock Debian 2.6 kernel packages. You
will most likely also need udev, although it isn't always required.

The wireless-tools package is required by many wireless network adapters.

Canonical levert kritieke updates voor pcmciautils tot april 2013.

Mocht het hier ook niet mee lukken:
Open een terminal en type dit lspci -vv kan je de uitkomst plaatsen?
De nummers in het voorbeeld moet je niet overnemen, daarom eerst het bovenstaande commando om uit te zoeken welk adres de PCMCIA heeft.
« Laatst bewerkt op: 2011/01/21, 18:53:40 door Gijsbert »
In der Beschränkung zeigt sich der Meister.

Offline TheCrow01

  • Lid
  • Steunpunt: Nee
Re: PCI - PCMCIA slot werkt niet op verschillende distro's
« Reactie #14 Gepost op: 2011/01/21, 19:05:58 »
Volgens mij zit pcmciautils al standaard in Ubuntu hij geeft namelijk de melding:

sudo apt-get install pcmciautils
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
De status informatie wordt gelezen... Klaar
pcmciautils is reeds de nieuwste versie.
0 pakketten opgewaardeerd, 0 pakketten nieuw geïnstalleerd, 0 te verwijderen en 202 niet opgewaardeerd.
----------
Vervolgens command geprobeerd:
lspci -vv

En dit is volgende mij de belangrijkste Ouput:
-------------

00:0b.0 CardBus bridge: Ricoh Co Ltd RL5c475 (rev 80)
Subsystem: CARRY Computer ENG. CO Ltd Device 0101
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 168
Interrupt: pin A routed to IRQ 19
Region 0: Memory at 58020000 (32-bit, non-prefetchable) [size=4K]
Bus: primary=00, secondary=03, subordinate=06, sec-latency=176
Memory window 0: 50000000-53fff000 (prefetchable)
Memory window 1: 54000000-57fff000
I/O window 0: 00001000-000010ff
I/O window 1: 00001400-000014ff
BridgeCtl: Parity- SERR- ISA- VGA- MAbort- >Reset- 16bInt+ PostWrite+
16-bit legacy interface ports at 0001
Kernel driver in use: yenta_cardbus
Kernel modules: yenta_socket
------------
[b][i]Volledige Output:[/i][/b]
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 746 Host (rev 02)
Subsystem: ASRock Incorporation Device 0746
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ >SERR- <PERR- INTx-
Latency: 0
Region 0: Memory at d0000000 (32-bit, non-prefetchable) [size=64M]
Capabilities: <access denied>
Kernel driver in use: agpgart-sis
Kernel modules: sis-agp

00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SG86C202
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 248
Bus: primary=00, secondary=01, subordinate=02, sec-latency=248
I/O behind bridge: 0000b000-0000bfff
Memory behind bridge: cfd00000-cfefffff
Prefetchable memory behind bridge: afa00000-cfbfffff
Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
BridgeCtl: Parity- SERR+ NoISA- VGA+ MAbort- >Reset- FastB2B-
PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
Kernel modules: shpchp

00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS963 [MuTIOL Media IO] (rev 25)
Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0

00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Interrupt: pin B routed to IRQ 0
Region 4: I/O ports at 0c00 [size=32]
Kernel modules: i2c-sis96x

00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (prog-if 80 [Master])
Subsystem: ASRock Incorporation Device 5513
Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 128
Region 0: [virtual] Memory at 000001f0 (32-bit, non-prefetchable) [disabled] [size=8]
Region 1: [virtual] Memory at 000003f0 (type 3, non-prefetchable) [disabled] [size=1]
Region 2: [virtual] Memory at 00000170 (32-bit, non-prefetchable) [disabled] [size=8]
Region 3: [virtual] Memory at 00000370 (type 3, non-prefetchable) [disabled] [size=1]
Region 4: I/O ports at ff00 [size=16]
Kernel driver in use: pata_sis

00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
Subsystem: ASRock Incorporation Device 7012
Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 248 (13000ns min, 2750ns max)
Interrupt: pin C routed to IRQ 18
Region 0: I/O ports at dc00 [size=256]
Region 1: I/O ports at d800 [size=128]
Capabilities: <access denied>
Kernel driver in use: Intel ICH
Kernel modules: snd-intel8x0

00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f) (prog-if 10)
Subsystem: ASRock Incorporation Device 7001
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 248 (20000ns max), Cache Line Size: 32 bytes
Interrupt: pin A routed to IRQ 20
Region 0: Memory at cfffe000 (32-bit, non-prefetchable) [size=4K]
Kernel driver in use: ohci_hcd

00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f) (prog-if 10)
Subsystem: ASRock Incorporation Device 7001
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 248 (20000ns max), Cache Line Size: 32 bytes
Interrupt: pin B routed to IRQ 21
Region 0: Memory at cffff000 (32-bit, non-prefetchable) [size=4K]
Kernel driver in use: ohci_hcd

00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 90)
Subsystem: ASRock Incorporation Device 8201
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 248 (13000ns min, 2750ns max)
Interrupt: pin A routed to IRQ 19
Region 0: I/O ports at d400 [size=256]
Region 1: Memory at cfffd000 (32-bit, non-prefetchable) [size=4K]
Expansion ROM at 58000000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: sis900
Kernel modules: sis900

00:0b.0 CardBus bridge: Ricoh Co Ltd RL5c475 (rev 80)
Subsystem: CARRY Computer ENG. CO Ltd Device 0101
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 168
Interrupt: pin A routed to IRQ 19
Region 0: Memory at 58020000 (32-bit, non-prefetchable) [size=4K]
Bus: primary=00, secondary=03, subordinate=06, sec-latency=176
Memory window 0: 50000000-53fff000 (prefetchable)
Memory window 1: 54000000-57fff000
I/O window 0: 00001000-000010ff
I/O window 1: 00001400-000014ff
BridgeCtl: Parity- SERR- ISA- VGA- MAbort- >Reset- 16bInt+ PostWrite+
16-bit legacy interface ports at 0001
Kernel driver in use: yenta_cardbus
Kernel modules: yenta_socket

01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200 SE] (rev 01)
Subsystem: Hightech Information System Ltd. Device 5964
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 248 (2000ns min), Cache Line Size: 32 bytes
Interrupt: pin A routed to IRQ 16
Region 0: Memory at c0000000 (32-bit, prefetchable) [size=128M]
Region 1: I/O ports at b800 [size=256]
Region 2: Memory at cfef0000 (32-bit, non-prefetchable) [size=64K]
Expansion ROM at cfec0000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: radeon
Kernel modules: radeonfb, radeon

01:00.1 Display controller: ATI Technologies Inc RV280 [Radeon 9200 SE] (Secondary) (rev 01)
Subsystem: Hightech Information System Ltd. Device 5965
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 248 (2000ns min), Cache Line Size: 32 bytes
Region 0: Memory at b8000000 (32-bit, prefetchable) [size=128M]
Region 1: Memory at cfee0000 (32-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>



Nog even terug komend op pcmcia-cs . Dit is de oude naam, je moet nu het pakket pcmciautils hebben.
In de terminal sudo apt-get install pcmciautils

This package provides PCMCIA initialisation tools for Linux 2.6.13-rc1 or
later, replacing the old pcmcia-cs tools used with earlier kernel versions.
PCMCIA cards are commonly used in laptops to provide expanded capabilities
such as network connections, modems, increased memory, etc.

To use PCMCIA you need to have kernel modules available to support
it. These are included in the stock Debian 2.6 kernel packages. You
will most likely also need udev, although it isn't always required.

The wireless-tools package is required by many wireless network adapters.

Canonical levert kritieke updates voor pcmciautils tot april 2013.

Mocht het hier ook niet mee lukken:
Open een terminal en type dit lspci -vv kan je de uitkomst plaatsen?
De nummers in het voorbeeld moet je niet overnemen, daarom eerst het bovenstaande commando om uit te zoeken welk adres de PCMCIA heeft.

[Mod edit: code tags geplaatst]
« Laatst bewerkt op: 2011/01/21, 20:06:19 door asphyxia »

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: PCI - PCMCIA slot werkt niet op verschillende distro's
« Reactie #15 Gepost op: 2011/01/21, 20:01:58 »
Het pakketje is standaard geinstalleerd, bij mij ook. Ik heb gen pcmcia kaart, daarom krijg ik niks te zien bij het eerste commando:
gijs@gijs-desktop:~$ lspcmcia
gijs@gijs-desktop:~$ pccardctl
pcmciautils 014
Copyright (C) 2004-2005 Dominik Brodowski, (C) 1999 David A. Hinds
Report errors and bugs to <linux-pcmcia@lists.infradead.org>, please.
invalid or unknown argument
Usage: pccardctl COMMAND
Supported commands are:
ls
insert
eject
suspend
resume
reset
info
status
config
ident
Type in de terminal info pcmciautils voor meer informatie of in kijk in de map /usr/share/doc/pcmciautils

In der Beschränkung zeigt sich der Meister.

Offline TheCrow01

  • Lid
  • Steunpunt: Nee
Re: PCI - PCMCIA slot werkt niet op verschillende distro's
« Reactie #16 Gepost op: 2011/01/21, 21:11:23 »
Als ik in de terminal: info pcmciautils type krijg ik alle commands die er beschikbaar zijn. En in die documentatie staat hoe ik pcmciautils kan installen, echter is hij toch al geinstalld?? of zie ik dat verkeerd?
Ik kom hier helaas nog niet echt ver mee :(

Het pakketje is standaard geinstalleerd, bij mij ook. Ik heb gen pcmcia kaart, daarom krijg ik niks te zien bij het eerste commando:
gijs@gijs-desktop:~$ lspcmcia
gijs@gijs-desktop:~$ pccardctl
pcmciautils 014
Copyright (C) 2004-2005 Dominik Brodowski, (C) 1999 David A. Hinds
Report errors and bugs to <linux-pcmcia@lists.infradead.org>, please.
invalid or unknown argument
Usage: pccardctl COMMAND
Supported commands are:
ls
insert
eject
suspend
resume
reset
info
status
config
ident
Type in de terminal info pcmciautils voor meer informatie of in kijk in de map /usr/share/doc/pcmciautils



Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: PCI - PCMCIA slot werkt niet op verschillende distro's
« Reactie #17 Gepost op: 2011/01/21, 22:14:06 »
Dit commando lspcmcia geeft informatie over pcmcia apparaten, net zo als lsusb informatie geeft over usb apparaten.
Het tweede commando pccardctl moet worden gevolg door een optie, bijv. pccardctl info
In de mini howto staat vanaf punt 3 Hoe pccardctl te gebruiken.
In der Beschränkung zeigt sich der Meister.

Offline TheCrow01

  • Lid
  • Steunpunt: Nee
Re: PCI - PCMCIA slot werkt niet op verschillende distro's
« Reactie #18 Gepost op: 2011/01/22, 10:09:31 »
ALs ik lspcmcia type krijg ik:
Socket 0 Bridge:      [yenta_cardbus]    (bus ID: 0000:00:0b.0)

en
pccardctl info
PRODID_1=""
PRODID_2=""
PRODID_3=""
PRODID_4=""
MANFID=0000,0000
FUNCID=255


in die Howto staat ook:
Plug the cards in, watch them appear in /sys/bus/pcmcia/devices/ echter zie ik in die map niks verschijnen.
Moet ik niet eerst nog iets activeren of installeren? of is pcmciautils al helemaal geïnstalleerd?



Dit commando lspcmcia geeft informatie over pcmcia apparaten, net zo als lsusb informatie geeft over usb apparaten.
Het tweede commando pccardctl moet worden gevolg door een optie, bijv. pccardctl info
In de mini howto staat vanaf punt 3 Hoe pccardctl te gebruiken.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: PCI - PCMCIA slot werkt niet op verschillende distro's
« Reactie #19 Gepost op: 2011/01/22, 17:49:59 »
Dat je niet veel info krijgt komt, doordat er wat configuratie files aangepast moeten worden.
Lees eens deze link door http://www.kernel.org/pub/linux/utils/kernel/pcmcia/cardmgr-to-pcmciautils.html je hoeft niet opnieuw te installeren maar er staat wel informatie over de configuratie scripts. De PCMCIA kaart wordt rechtstreeks bediend door de kernel via de I/O bus, dus geen driver.
In der Beschränkung zeigt sich der Meister.

Offline TheCrow01

  • Lid
  • Steunpunt: Nee
Re: PCI - PCMCIA slot werkt niet op verschillende distro's
« Reactie #20 Gepost op: 2011/01/23, 15:41:15 »
Ik heb je gegeven link een aantal keer gelezen, echter snap ik niet precies wat ik nu moet doet.
dat script wat er wordt beschreven zorgt ervoor dat de cardmgr niet gestart wordt??


Dat je niet veel info krijgt komt, doordat er wat configuratie files aangepast moeten worden.
Lees eens deze link door http://www.kernel.org/pub/linux/utils/kernel/pcmcia/cardmgr-to-pcmciautils.html je hoeft niet opnieuw te installeren maar er staat wel informatie over de configuratie scripts. De PCMCIA kaart wordt rechtstreeks bediend door de kernel via de I/O bus, dus geen driver.

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: PCI - PCMCIA slot werkt niet op verschillende distro's
« Reactie #21 Gepost op: 2011/01/23, 17:33:21 »
Het eerste script wat in /etc/init.d/pcmcia  moet komen, zorgt er inderdaad voor dat de cardmgr niet gestart wordt.
Het tweede script wat in /etc/init.d/pcmcia-new moet komen, zorgt dat je de kaart er gewoon in en uit kan halen tijdens het gebruik van de computer. (hotplug)
In der Beschränkung zeigt sich der Meister.

Offline TheCrow01

  • Lid
  • Steunpunt: Nee
Re: PCI - PCMCIA slot werkt niet op verschillende distro's
« Reactie #22 Gepost op: 2011/01/23, 18:33:19 »
He gijsbert
ik heb die file "pcmcia" niet, in het pad: "/etc/init.d/" wel heb ik de /etc/init.d/pcmciautils
en /etc/init.d/pcmcia-new bestaat ook niet.. Houd dat in dat ik deze gewoon aan moet maken of??


Het eerste script wat in /etc/init.d/pcmcia  moet komen, zorgt er inderdaad voor dat de cardmgr niet gestart wordt.
Het tweede script wat in /etc/init.d/pcmcia-new moet komen, zorgt dat je de kaart er gewoon in en uit kan halen tijdens het gebruik van de computer. (hotplug)

Offline Gijsbert

  • Lid
  • Steunpunt: Ja
Re: PCI - PCMCIA slot werkt niet op verschillende distro's
« Reactie #23 Gepost op: 2011/01/23, 22:05:35 »
Vreemd dat pcmcia er niet instaat, gezien in de foutmelding pcmcia-cs staat vermeldt. De file pcmcia-new kan je wel aanmaken. Wel de computer opnieuw opstarten, hierna kijken of de kaart wel gezien wordt als je deze erin steekt.
In der Beschränkung zeigt sich der Meister.