Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu niet zichtbaar in MSHOME  (gelezen 1855 keer)

Offline Erick678

  • Lid
  • Steunpunt: Nee
Ubuntu niet zichtbaar in MSHOME
« Gepost op: 2011/01/11, 21:01:41 »
Goedenavond,

Ik ben al een tijdje aan het klooien met Ubuntu Server, vind het erg leuk om het te doen. Maar ik zit met een probleem.
Ik wil de server gaan gebruiken voor thuisgebruik. De server moet dus worden gedeeld met netwerkschijven. Het delen en de users aanmaken etc is allemaal geen probleem. Maar, ik zie de Ubuntu server niet op een Windows machine. Ik kan de server wel bereiken via filezilla o.i.d. maar zodra ik 'm in een werkgroep wil laden zie ik 'm niet.
Kan iemand mij hiermee helpen?

Het ip adres van mijn windows machine:
192.168.2.12

Het ip adres van mijn ubuntu server:
192.168.2.6

Bedankt alvast voor jullie hulp:)
Hieronder de config
[global]
netbios name = Samba24
server string = Samba file and print server
workgroup = MSHOME
security = user
hosts allow = 127. 192.168.2.
interfaces = 127.0.0.1/8 192.168.2.0/24
bind interfaces only = yes
remote announce = 192.168.0.255
remote browse sync = 192.168.0.255
printcap name = cups
load printers = yes
cups options = raw
printing = cups
guest account = smbguest
log file = /var/log/samba/samba.log
max log size = 1000
null passwords = no
username level = 6
password level = 6
encrypt passwords = yes
unix password sync = yes
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
local master = no
domain master = no
preferred master = no
domain logons = no
os level = 33
logon drive = m:
logon home = \\%L\homes\%u
logon path = \\%L\profiles\%u
logon script = %G.bat
time server = no
name resolve order = wins lmhosts bcast
wins support = no
wins proxy = no
dns proxy = no
preserve case = yes
short preserve case = yes
client use spnego = no
client signing = no
client schannel = no
server signing = no
server schannel = no
nt pipe support = yes
nt status support = yes
allow trusted domains = no
obey pam restrictions = yes
enable spoolss = yes
client plaintext auth = no
disable netbios = no
follow symlinks = no
update encrypted = yes
pam password change = no
passwd chat timeout = 120
hostname lookups = no
username map = /etc/samba/smbusers
passdb backend = tdbsam
passwd program = /usr/bin/passwd '%u'
passwd chat = *New*password* %n\n *ReType*new*password* %n\n *passwd*changed*\n
add user script = /usr/sbin/useradd -d /dev/null -c 'Samba User Account' -s /dev/null '%u'
add user to group script = /usr/sbin/useradd -d /dev/null -c 'Samba User Account' -s /dev/null -g '%g' '%u'
add group script = /usr/sbin/groupadd '%g'
delete user script = /usr/sbin/userdel '%u'
delete user from group script = /usr/sbin/userdel '%u' '%g'
delete group script = /usr/sbin/groupdel '%g'
add machine script = /usr/sbin/useradd -d /dev/null -g sambamachines -c 'Samba Machine Account' -s /dev/null -M '%u'
machine password timeout = 120
idmap uid = 16777216-33554431
idmap gid = 16777216-33554431
template shell = /dev/null
winbind use default domain = yes
winbind separator = @
winbind cache time = 360
winbind trusted domains only = yes
winbind nested groups = no
winbind nss info = no
winbind refresh tickets = no
winbind offline logon = no

[homes]
comment = Home Directories
path = /home
read only = no
available = yes
browseable = yes
writable = yes
guest ok = no
public = no
printable = no
locking = no
strict locking = no

[netlogon]
comment = Network Logon Service
path = /home/netlogon
read only = no
available = yes
browseable = yes
writable = no
guest ok = no
public = no
printable = no
locking = no
strict locking = no

[profiles]
comment = User Profiles
path = /var/samba/profiles
read only = no
available = yes
browseable = no
writable = yes
guest ok = no
public = no
printable = no
create mode = 0600
directory mask = 0700
locking = no
strict locking = no

[printers]
comment = All Printers
path = /var/spool/samba
browseable = yes
writable = no
guest ok = no
public = no
printable = yes
locking = no
strict locking = no

[pdf-documents]
path = /home/pdf-documents
comment = Converted PDF Documents
available = yes
browseable = yes
writeable = yes
guest ok = yes
locking = no
strict locking = no

[pdf-printer]
path = /tmp
comment = PDF Printer Service
printable = yes
guest ok = yes
use client driver = yes
printing = bsd
print command = /usr/bin/gadmin-samba-pdf %s %u
lpq command =
lprm command =


[Moderator-Edit:
Even de tekst tussen code-tags gezet]
« Laatst bewerkt op: 2011/01/14, 18:46:35 door heir4c »

Offline Gymnasiast

  • Lid
  • Steunpunt: Nee
Re: Ubuntu niet zichtbaar in MSHOME
« Reactie #1 Gepost op: 2011/01/14, 09:54:04 »
Staat de firewall aan? Dan moeten er daar wat poorten geopend worden.

Citaat van: http://www.samba.org/samba/docs/server_security.html
Using a firewall

Many people use a firewall to deny access to services that they don't want exposed outside their network. This can be a very good idea, although I would recommend using it in conjunction with the above methods so that you are protected even if your firewall is not active for some reason.

If you are setting up a firewall then you need to know what TCP and UDP ports to allow and block. Samba uses the following:

    UDP/137    - used by nmbd
    UDP/138    - used by nmbd
    TCP/139    - used by smbd
    TCP/445    - used by smbd

The last one is important as many older firewall setups may not be aware of it, given that this port was only added to the protocol in recent years.

Er staat nog meer op de pagina over veiligheid. Het kopje 'Host based protection' kan van pas komen bij het beter beveiligen van de server, omdat gedeelde mappen een zeker risico met zich meebrengen.
NOBODY expects the Spanish Inquisition!

Offline softbart

  • Lid
  • Steunpunt: Nee
Re: Ubuntu niet zichtbaar in MSHOME
« Reactie #2 Gepost op: 2011/01/14, 12:22:11 »
Zijn de workgroup van samba en de win-machine gelijk?
Volgens je conf is dit MSHOME.

groet,

Theo

Offline dropl

  • Lid
  • Steunpunt: Nee
Re: Ubuntu niet zichtbaar in MSHOME
« Reactie #3 Gepost op: 2011/01/14, 22:24:29 »
Oeps foutje bedankt
Ge wit dit oit noit nie

Offline Erick678

  • Lid
  • Steunpunt: Nee
Re: Ubuntu niet zichtbaar in MSHOME
« Reactie #4 Gepost op: 2011/01/15, 17:11:52 »
Mannen,

Bedankt voor jullie reacties. Ik ben er inmiddels al uitgekomen:)
Ik heb hetvolgende in mijn config gezet en toen werkte het wel:

netbios name = Servername

En de volgende regel aangepast:
# security = user naar security = share